Autor Tema: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22  (Leído 362906 veces)

0 Usuarios y 5 Visitantes están viendo este tema.

espeltron

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #160 en: 25-03-2014, 20:50 (Martes) »
Otro router VRX288 (experimental):

Investigando ...
Pongo un script de inicio "dsl" de un aparato con el VRX288:
Código: [Seleccionar]
#!/bin/sh
# vim: set ts=2 sw=2 et:
# /etc/bewan/lib/dsl

# specific vendor functions used by dsl scripts
# setparam must be included

# Working variables
# $modulation
# $DSLD

# Needed because libdti_agent.so is in /usr/lib
export LD_LIBRARY_PATH=/usr/lib:/lib

if [ ${DSL_LIB_LOADED:-0} -eq 1 ]; then
  return
fi

check_vendor_dsl() {
  # Lantiq binaries not installed ?
  test -d /opt/lantiq/bin || return 1
  # Driver started, restart unimplemented
  test -d $DSLD && return 1
  return 0
}

start_vendor_dsl() {

  local bindir='/opt/lantiq/bin'

  local platform=''
  local xDSL_Mgmt_Mode=''
  local xTM_Mgmt_Mode=''
  local wanphy_phymode=''
  local filename=''

  # Determine platform variables
  if [ "$(find /lib/firmware -name dsl_ar9_firmware*.bin)" != '' ]; then
    platform='ARX188'
    xDSL_Mgmt_Mode='ADSL'
    xTM_Mgmt_Mode='ATM'
    wanphy_phymode='0'

  elif [ "$(find /lib/firmware -name dsl_vr9_firmware*.bin)" != '' ]; then
    platform='VRX288'

    # Load xDSL negotiation accross reboot state machine environment
    Next_xDSL_Mode=$WANDSLInterfaceConfig_NextxDSLMode
    Next_xTM_Mode=$WANDSLInterfaceConfig_NextxTMMode
    xDSL_ADSL_Sub_Prefix=$WANDSLInterfaceConfig_ADSLSubPrefix
    xDSL_SW_Forced_Reboot=$WANDSLInterfaceConfig_ForcedReboot

    # Default values
    [ "$xDSL_ADSL_Sub_Prefix" = '' ] && xDSL_ADSL_Sub_Prefix='0'
    [ "$xDSL_SW_Forced_Reboot" = '' ] && xDSL_SW_Forced_Reboot='0'

    # Full VDSL/ADSL negotiation
    if [ "$modulation" = 'xDSL_multi' ]; then
      xDSL_Mgmt_Mode='Auto'
      xTM_Mgmt_Mode='Auto'
      # Default values
      [ "$Next_xDSL_Mode" = '' ] && Next_xDSL_Mode='2'
      [ "$Next_xTM_Mode" = '' ] && Next_xTM_Mode='PTM'

    # VDSL mode only
    elif [ "$modulation" = 'VDSL' ]; then
      xDSL_Mgmt_Mode='VDSL'
      xTM_Mgmt_Mode='PTM'
      Next_xDSL_Mode='2'
      Next_xTM_Mode='PTM'
      xDSL_SW_Forced_Reboot='0'

    # ADSL mode only
    else
      xDSL_Mgmt_Mode='ADSL'
      xTM_Mgmt_Mode='ATM'
      Next_xDSL_Mode='1'
      Next_xTM_Mode='ATM'
      xDSL_SW_Forced_Reboot='0'
    fi

    echo $xTM_Mgmt_Mode >$DSLD/status_xTM_Mgmt_Mode
    if [ "$Next_xDSL_Mode" = 1 ]; then
      echo 'ADSL' >$DSLD/status_Next_xDSL_Mode
    elif [ "$Next_xDSL_Mode" = 2 ]; then
      echo 'VDSL' >$DSLD/status_Next_xDSL_Mode
    fi
    echo $Next_xTM_Mode >$DSLD/status_Next_xTM_Mode
    echo $xDSL_ADSL_Sub_Prefix >$DSLD/status_xDSL_ADSL_Sub_Prefix
    echo $xDSL_SW_Forced_Reboot >$DSLD/status_xDSL_SW_Forced_Reboot

    # TODO phymode
    wanphy_phymode='0'
  else
    base_log 'TODO: unknown xDSL platform'
  fi

  # load kernel DSL driver
  (
    export wanphy_phymode
    local debug_mode=0
    cd $bindir; $bindir/inst_drv_cpe_api.sh $debug_mode
  )

  # Set modulation parameter (build the string of 0s and 1s according to the following specification)
  # G.992.1-A, G.992.2, G.992.3-A, G.992.5-A, T1.413, G.992.3-L, G.992.3-I, G.992.5-I, G.992.3-M, G.992.5-M, G.992.1-B, G.992.3-B, G.992.5-B, G.992.3-J, G.992.5-J
  local mode=""
  case "$modulation" in
  ADSL_ANSI_T1.413) mode='Annex_0_0_0_0_1_0_0_0_0_0_0_0_0_0_0';; # Need to set also G.992.1
  ADSL_multi)       mode='Annex_1_1_1_1_1_1_1_1_0_0_1_1_1_1_1';;
  ADSL_multi_AM)    mode='Annex_1_1_1_1_1_1_1_1_1_1_1_1_1_1_1';;
  ADSL_G.dmt)       mode='Annex_1_0_0_0_0_0_0_0_0_0_1_0_0_0_0';;
  ADSL_G.lite)      mode='Annex_0_1_0_0_0_0_0_0_0_0_0_0_0_0_0';; # Need to set also G.992.1
  ADSL_G.dmt.bis)   mode='Annex_0_0_1_0_0_1_1_0_1_0_0_1_0_1_0';;
  ADSL_2plus)       mode='Annex_0_0_0_1_0_0_0_1_0_1_0_0_1_0_1';;
  xDSL_multi)       mode='Annex_1_0_1_1_1_1_0_0_0_0_0_0_0_0_0';;
  VDSL)             mode='Annex_0_0_0_0_0_0_0_0_0_0_0_0_0_0_0';;
  *)                mode='Annex_1_1_1_1_1_1_1_1_1_1_1_1_1_1_1';;
  esac

  # load control daemon
  (
    local ADSL_MODE=$mode
    . /etc/init.d/ifx_cpe_control_init.sh
    start
  )
}

stop_vendor_dsl() {
  base_log 'TODO: stop_vendor_dsl unimplemented' debug
}

DSL_LIB_LOADED=1

En la configuracion ADSL se utiliza el modo ATM, mientras que en la VDSL el modo PTM.

Lo que interesa es llegar a poner:
"Full VDSL/ADSL negotiation"

En concreto, en este router se que se utiliza el:
drv_dsl_cpe_api-4.11.4

Saludos
espeltron


« Última modificación: 30-03-2014, 18:15 (Domingo) por espeltron »

GLaDOS

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #161 en: 25-03-2014, 21:38 (Martes) »
Ojalá tuviéramos ADSL/VDSL... Seria genial, espeltron. >:( >:( >:(

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #162 en: 25-03-2014, 21:40 (Martes) »
Ademas de las pruebas indicadas, hay una muy importante:
Código: [Seleccionar]
vdsl_cpe_control --version
dsl_cpe_control --version

Ya que hay 2 versiones:
Driver danube:
http://mirror2.openwrt.org/sources/drv_dsl_cpe_api_danube-3.24.4.4.tar.gz
http://mirror.opf.slu.cz/openwrt/sources/drv_dsl_cpe_api_danube-3.24.4.4.tar.gz

Driver vrx, que no esta en el repositorio oficial mirror2:
http://mirror.opf.slu.cz/openwrt/sources/drv_dsl_cpe_api_vrx-4.11.4.tar.gz

Saludos
espeltron

Respuesta del router:
Código: [Seleccionar]
root@OpenWrt:~# vdsl_cpe_control --version
DSL_CPE: DSL CPE Control Application V4.11.4
root@OpenWrt:~# dsl_cpe_control --version
-ash: dsl_cpe_control: not found

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #163 en: 25-03-2014, 21:44 (Martes) »
Hay comprobar que servicio estas utilizando, en teoria tiene que ser "/sbin/vdsl_cpe_control", y que la configuracion sea la adecuada.

Practicamente no debe de haber muchas diferencias entre dsl_cpe_control y vdsl_cpe_control.

Para saber si se carga correctamente la configuracion y si es la correcta hay que ver los fuentes:
 
https://dev.openwrt.org/browser/trunk/package/network/config/ltq-vdsl-app/files/dsl_control?rev=37198
https://dev.openwrt.org/browser/trunk/package/network/config/ltq-adsl-app/files/dsl_control?rev=37198

https://dev.openwrt.org/export/37198/trunk/package/network/config/ltq-vdsl-app/files/dsl_control
https://dev.openwrt.org/export/37198/trunk/package/network/config/ltq-adsl-app/files/dsl_control

Practicamente no hay diferencias entre ellos.

Ahora, para terminar de verificar la configuracion haz lo siguiente:

cat /etc/init.d/dsl_control > /tmp/dsl_control
O tambien vale:
cp /etc/init.d/dsl_control /tmp/dsl_control

Copia tambien los archivos ejecutables que hubiera:
/sbin/vdsl_cpe_control
/sbin/dsl_cpe_control

Sube todo esto dentro de un archivo comprimido, para comprobar si los parametros de configuracion de /etc/config/network son los adecuados:
Código: [Seleccionar]
config adsl-device 'adsl'
option fwannex 'a2p'
option annex 'a2p'

Los que hay definidos son los siguientes:
Citar
annex_b=10_00_10_00_00_04_00_00
annex_bdmt=10_00_00_00_00_00_00_00
annex_b2=00_00_10_00_00_00_00_00
annex_b2p=00_00_00_00_00_04_00_00
annex_a=04_01_04_00_00_01_00_00
annex_at1=01_00_00_00_00_00_00_00
annex_alite=00_01_00_00_00_00_00_00
annex_admt=04_00_00_00_00_00_00_00
annex_a2=00_00_04_00_00_00_00_00
annex_a2p=00_00_00_00_00_01_00_00
annex_l=00_00_00_00_04_00_00_00
annex_m=00_00_00_00_40_00_04_00
annex_m2=00_00_00_00_40_00_00_00
annex_m2p=00_00_00_00_00_00_04_00

Como obtener los 64 bits del anexo:
ADSL2 (pag. 26-27): https://tools.ietf.org/html/rfc4706
VDSL2 (pag. 27-28): https://tools.ietf.org/html/rfc5650

Bits diferentes (añadidos en VDSL2):
Código: [Seleccionar]
          Bit 52-55: Reserved
          Bit 56 : G.993.2 Annex A
          Bit 57 : G.993.2 Annex B
          Bit 58 : G.993.2 Annex C
          Bit 59-63: Reserved"

Hay otras cosas que no son tan parecidas:
Código: [Seleccionar]
- ADSL operation mode description
- xDSL operation mode description

Y en las pruebas deja varios minutos para que se sincronice, a veces no es inmediato.

Yo tengo tambien pepephone, y le he metido routers con VCI y VPI diferentes y consigue sincronizacion, aunque no haya conexion.
El VPI/VCI estan bien, es 0 y 33 respectivamente.

Pienso que el router intenta usar el modo VDSL por defecto, en vez del ADSL, pero se estan consiguiendo avances.  :D

Lo importante, como OpenWrt carga el firmware e inicia la conexion esta aqui:
Citar
   # start CPE dsl daemon in the background
   service_start /sbin/vdsl_cpe_control -i${xtu} \
         -n /sbin/dsl_notify.sh \
         -f /lib/firmware/${firmware}

La variable ${firmware}  es vdsl.bin, eso ya esta bien.
Ahora hay que comprobar que la variable "${xtu}" sea la adecuada.

Tambien puedes hacer 5 pruebas:

Prueba 1:
Código: [Seleccionar]
/etc/init.d/dsl_control stop
/etc/init.d/dsl_control start
/etc/init.d/dsl_control status
Esperar 2 minutos.

Prueba 2 (a2p):
Código: [Seleccionar]
/etc/init.d/dsl_control stop
service_start /sbin/vdsl_cpe_control -i00_00_00_00_00_01_00_00 -n /sbin/dsl_notify.sh -f /lib/firmware/vdsl.bin
/etc/init.d/dsl_control status
Esperar 2 minutos.

Prueba 3 (a):
Código: [Seleccionar]
/etc/init.d/dsl_control stop
service_start /sbin/vdsl_cpe_control -i04_01_04_00_00_01_00_00 -n /sbin/dsl_notify.sh -f /lib/firmware/vdsl.bin
/etc/init.d/dsl_control status
Esperar 2 minutos.

Prueba 4 (con -i sola):
Código: [Seleccionar]
/etc/init.d/dsl_control stop
service_start /sbin/vdsl_cpe_control -i -n /sbin/dsl_notify.sh -f /lib/firmware/vdsl.bin
/etc/init.d/dsl_control status
Esperar 2 minutos.

Prueba 5 (sin -i):
Código: [Seleccionar]
/etc/init.d/dsl_control stop
service_start /sbin/vdsl_cpe_control -n /sbin/dsl_notify.sh -f /lib/firmware/vdsl.bin
/etc/init.d/dsl_control status
Esperar 2 minutos.

Aqui se ve como se mandan los xtu bits:
https://lists.openwrt.org/pipermail/openwrt-devel/2012-May/015418.html
Supongo que es la forma correcta.

Saludos
espeltron

A ver, de aquí no me ha quedado muy claro...

cat /etc/init.d/dsl_control > /tmp/dsl_control lo tengo y lo puedo subir
Pero de aquí:

/sbin/vdsl_cpe_control lo tengo y lo puedo subir
/sbin/dsl_cpe_control NO lo tengo y NO lo puedo subir

Lo siguiente sería probar las pruebas desde la 1 hasta la 5, pero

service_start

me devuelve

root@OpenWrt:/sbin# service_start
-ash: service_start: not found

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #164 en: 25-03-2014, 21:52 (Martes) »
BRUTAL ESPELTON

root@OpenWrt:/lib/firmware# /etc/init.d/dsl_control status
Chipset:      Lantiq-VRx Unknown
Line State:      UP [0x801: showtime_tc_sync]
Data Rate:      16.800 Mb/s / 880 Kb/s
Line Attenuation:   21.7dB / 9.8dB
Noise Margin:      9.1dB / 9.0dB
Line Uptime:      1s

 >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:(

Estoy respondiendo desde el ASTORIA!!!

Gracias se que queda corto!!!

Donde mando las cervezas???

Otro router VRX288 (experimental):

Investigando ...
Pongo un script de inicio "dsl" de un aparato con el VRX288:
Código: [Seleccionar]
#!/bin/sh
# vim: set ts=2 sw=2 et:
# /etc/bewan/lib/dsl

# specific vendor functions used by dsl scripts
# setparam must be included

# Working variables
# $modulation
# $DSLD

# Needed because libdti_agent.so is in /usr/lib
export LD_LIBRARY_PATH=/usr/lib:/lib

if [ ${DSL_LIB_LOADED:-0} -eq 1 ]; then
  return
fi

check_vendor_dsl() {
  # Lantiq binaries not installed ?
  test -d /opt/lantiq/bin || return 1
  # Driver started, restart unimplemented
  test -d $DSLD && return 1
  return 0
}

start_vendor_dsl() {

  local bindir='/opt/lantiq/bin'

  local platform=''
  local xDSL_Mgmt_Mode=''
  local xTM_Mgmt_Mode=''
  local wanphy_phymode=''
  local filename=''

  # Determine platform variables
  if [ "$(find /lib/firmware -name dsl_ar9_firmware*.bin)" != '' ]; then
    platform='ARX188'
    xDSL_Mgmt_Mode='ADSL'
    xTM_Mgmt_Mode='ATM'
    wanphy_phymode='0'

  elif [ "$(find /lib/firmware -name dsl_vr9_firmware*.bin)" != '' ]; then
    platform='VRX288'

    # Load xDSL negotiation accross reboot state machine environment
    Next_xDSL_Mode=$WANDSLInterfaceConfig_NextxDSLMode
    Next_xTM_Mode=$WANDSLInterfaceConfig_NextxTMMode
    xDSL_ADSL_Sub_Prefix=$WANDSLInterfaceConfig_ADSLSubPrefix
    xDSL_SW_Forced_Reboot=$WANDSLInterfaceConfig_ForcedReboot

    # Default values
    [ "$xDSL_ADSL_Sub_Prefix" = '' ] && xDSL_ADSL_Sub_Prefix='0'
    [ "$xDSL_SW_Forced_Reboot" = '' ] && xDSL_SW_Forced_Reboot='0'

    # Full VDSL/ADSL negotiation
    if [ "$modulation" = 'xDSL_multi' ]; then
      xDSL_Mgmt_Mode='Auto'
      xTM_Mgmt_Mode='Auto'
      # Default values
      [ "$Next_xDSL_Mode" = '' ] && Next_xDSL_Mode='2'
      [ "$Next_xTM_Mode" = '' ] && Next_xTM_Mode='PTM'

    # VDSL mode only
    elif [ "$modulation" = 'VDSL' ]; then
      xDSL_Mgmt_Mode='VDSL'
      xTM_Mgmt_Mode='PTM'
      Next_xDSL_Mode='2'
      Next_xTM_Mode='PTM'
      xDSL_SW_Forced_Reboot='0'

    # ADSL mode only
    else
      xDSL_Mgmt_Mode='ADSL'
      xTM_Mgmt_Mode='ATM'
      Next_xDSL_Mode='1'
      Next_xTM_Mode='ATM'
      xDSL_SW_Forced_Reboot='0'
    fi

    echo $xTM_Mgmt_Mode >$DSLD/status_xTM_Mgmt_Mode
    if [ "$Next_xDSL_Mode" = 1 ]; then
      echo 'ADSL' >$DSLD/status_Next_xDSL_Mode
    elif [ "$Next_xDSL_Mode" = 2 ]; then
      echo 'VDSL' >$DSLD/status_Next_xDSL_Mode
    fi
    echo $Next_xTM_Mode >$DSLD/status_Next_xTM_Mode
    echo $xDSL_ADSL_Sub_Prefix >$DSLD/status_xDSL_ADSL_Sub_Prefix
    echo $xDSL_SW_Forced_Reboot >$DSLD/status_xDSL_SW_Forced_Reboot

    # TODO phymode
    wanphy_phymode='0'
  else
    base_log 'TODO: unknown xDSL platform'
  fi

  # load kernel DSL driver
  (
    export wanphy_phymode
    local debug_mode=0
    cd $bindir; $bindir/inst_drv_cpe_api.sh $debug_mode
  )

  # Set modulation parameter (build the string of 0s and 1s according to the following specification)
  # G.992.1-A, G.992.2, G.992.3-A, G.992.5-A, T1.413, G.992.3-L, G.992.3-I, G.992.5-I, G.992.3-M, G.992.5-M, G.992.1-B, G.992.3-B, G.992.5-B, G.992.3-J, G.992.5-J
  local mode=""
  case "$modulation" in
  ADSL_ANSI_T1.413) mode='Annex_0_0_0_0_1_0_0_0_0_0_0_0_0_0_0';; # Need to set also G.992.1
  ADSL_multi)       mode='Annex_1_1_1_1_1_1_1_1_0_0_1_1_1_1_1';;
  ADSL_multi_AM)    mode='Annex_1_1_1_1_1_1_1_1_1_1_1_1_1_1_1';;
  ADSL_G.dmt)       mode='Annex_1_0_0_0_0_0_0_0_0_0_1_0_0_0_0';;
  ADSL_G.lite)      mode='Annex_0_1_0_0_0_0_0_0_0_0_0_0_0_0_0';; # Need to set also G.992.1
  ADSL_G.dmt.bis)   mode='Annex_0_0_1_0_0_1_1_0_1_0_0_1_0_1_0';;
  ADSL_2plus)       mode='Annex_0_0_0_1_0_0_0_1_0_1_0_0_1_0_1';;
  xDSL_multi)       mode='Annex_1_0_1_1_1_1_0_0_0_0_0_0_0_0_0';;
  VDSL)             mode='Annex_0_0_0_0_0_0_0_0_0_0_0_0_0_0_0';;
  *)                mode='Annex_1_1_1_1_1_1_1_1_1_1_1_1_1_1_1';;
  esac

  # load control daemon
  (
    local ADSL_MODE=$mode
    . /etc/init.d/ifx_cpe_control_init.sh
    start
  )
}

stop_vendor_dsl() {
  base_log 'TODO: stop_vendor_dsl unimplemented' debug
}

DSL_LIB_LOADED=1

En la configuracion ADSL se utiliza el modo ATM, mientras que en la VDSL el modo PTM.

Lo que interesa es llegar a poner:
"Full VDSL/ADSL negotiation"

En concreto, en este router se que se utiliza el:
drv_dsl_cpe_api-4.11.4

Firmware ADSL de este router VRX288 (experimental):
http://www.mediafire.com/download/gyhg0lf958ehc5e/dsl_vr9_firmware_xdsl-05.04.08.00.00.06_05.04.04.04.00.01.zip

Este es el firmware ADSL mas reciente que he encontrado.

jmcabgam si pudieras probarlo y comentar los resultados ...

Con un poco de suerte puede que por defecto tenga el modo ADSL habilitado.

Saludos
espeltron

espeltron

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #165 en: 25-03-2014, 22:54 (Martes) »
BRUTAL ESPELTON

root@OpenWrt:/lib/firmware# /etc/init.d/dsl_control status
Chipset:      Lantiq-VRx Unknown
Line State:      UP [0x801: showtime_tc_sync]
Data Rate:      16.800 Mb/s / 880 Kb/s
Line Attenuation:   21.7dB / 9.8dB
Noise Margin:      9.1dB / 9.0dB
Line Uptime:      1s

 >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:(

Estoy respondiendo desde el ASTORIA!!!

Gracias se que queda corto!!!

Donde mando las cervezas???

A mi casa, por favor.  :D

Ahora que habia encontrado la informacion en polaco ...
http://openrouter.info/forum/viewtopic.php?f=18&t=2727&start=20
Que lo explicaban todo claramente para el TP-LINK TD-W8970.
http://pliki.gru.one.pl/11-2013/vr9.7z
http://rpc.one.pl/pliki/openwrt/TD-8970v1/openwrt-lantiq-xrx200-TDW8970-sysupgrade.image.tar.bz2

De "ifx_cpe_control_init.sh" he obtenido en claro:
Código: [Seleccionar]
get_fw_type() {
   if [ -r /etc/rc.d/config.sh ]; then
      . /etc/rc.d/config.sh 2> /dev/null
      platform=${CONFIG_IFX_MODEL_NAME%%_*}
   fi

   # The last digit of the xDSL firmware version specifies the Annex type
   # 1 - ADSL Annex A
   # 2 - ADSL Annex B
   # 6 - VDSL

   # Determine the type of the ADSL Firmware which is mounted
   if [ "$platform" = "VRX288" ]; then
      # For VRX platform there is always a combined VDSL/ADSL firmware binary used.
      # Therefore two what strings (version numbers) are included within binary.
      # The format of the extracted what strings has to have to following format
      # /firmware/xcpe_hw.bin : @(#)V_5.3.1.A.1.6 @(#)5.3.3.0.1.1
      #                               +---------+     +---------+
      #                              VDSL FW Vers.    ADSL FW Vers.
      FW_TYPE=`${BIN_DIR}/what.sh ${FW_DIR}/${FW_FILENAME} | cut -d'@' -f3 | cut -d'.' -f6`
   else
      # For ADSL only platforms (Danube, Amazon-SE, ARX100) there is only one
      # what string (version number) included.
      # The format of the extracted what strings has to have to following format
      # /firmware/dsl_firmware_a.bin : @(#)4.4.7.B.0.1
      #                                    +---------+
      #                                   ADSL FW Vers.
      FW_TYPE=`${BIN_DIR}/what.sh ${FW_DIR}/${FW_FILENAME} | cut -d'.' -f7`
   fi
}
¡YA SE QUE SIGNIFICAN LOS NUMEROS!

Y recordar, hay que mirar "drv_dsl_cpe_api_vrx-4.11.4.tar.gz", ya que es que utiliza la imagen que le ha funcionado a jmcabgam.
Sobre todo:
drv_dsl_cpe_api-4.11.4/src/include/drv_dsl_cpe_api_g997.h
Para ver la tabla con los diferentes modos xTU.

En cuanto a "vdsl_cpe_control" esta el siguiente comando:
Citar
vdsl_cpe_control --help

Obtenido de la pagina polaca:
Código: [Seleccionar]
root@OpenWrt:/tmp# vdsl_cpe_control --help
DSL_CPE: Welcome to DSL CPI API control application
DSL_CPE: usage: [options]
DSL_CPE: following options are available:
DSL_CPE:  --help        (-h)    - help screen
DSL_CPE:  --version     (-v)    - display version
DSL_CPE:  --init        (-i)    - init device w/ <xtu> Bits seperated by underscore (e.g. -i05_01_04_00_04_01_00_00)
DSL_CPE:  --low_cfg     (-l)    - low level configuration file
DSL_CPE:  --console     (-c)    - start console
DSL_CPE:  --event_cnf   (-e)    - configure instance activation handling <enable/disable>[_mask] (e.g. -e1_1)
DSL_CPE:  --msg_dump    (-m)    - enable message dump
DSL_CPE:  --auto_scr_1  (-a)    - autoboot start script for ADSL (empty by default)
DSL_CPE:  --auto_scr_2  (-A)    - autoboot start script for VDSL (empty by default)
DSL_CPE:  --firmware1   (-f)    - firmware file, default /opt/ifx/firmware/xcpe_hw.bin
DSL_CPE:  --notif       (-n)    - notification script name, default ./xdslrc.sh
DSL_CPE:  --tcpmsg      (-t)    - enable dbgtool, listen only on <ipaddr> (optional, e.g. -t0.0.0.0)
DSL_CPE:  --multimode   (-M)    - set multimode config -M<NextMode>[_<AdslSubPref>] (e.g. -M1_1 or -M1)
DSL_CPE:  --tc-layer    (-T)    - set TC-Layer options -T<TcLayer>_<TcConfigUs>_<TcConfigDs> (e.g. -T2_0x3_0x1)
DSL_CPE:  --sequence    (-S)    - set activation sequence -S<Sequence>_<Mode> (e.g. -M0_0)
DSL_CPE:  --debug_drv   (-g)    -
DSL_CPE:  --debug_app   (-G)    -

Y hay mas informacion por ahi, pero por hoy es suficiente.

Tengo tambien el firmware de la VoIP;D

¿Seguimos?
 ^-^ ^-^ ^-^ ^-^ ^-^

Saludos
espeltron

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #166 en: 25-03-2014, 23:03 (Martes) »
...

Tengo tambien el firmware de la VoIP;D

¿Seguimos?
 ^-^ ^-^ ^-^ ^-^ ^-^

Saludos
espeltron


espelton, eres un fuera de serie!!! Anda que no tenias razón cuando comentaste en tu primer post en este hilo que atábamos algo perdidos y liados...

Que si seguimos? Pues claro!!! Dime por donde quiere que sigamos!!!

Vamos, que queda la wifi, puertos ethernet (con vlans) 10 % y la VoIp, creo que no me dejo nada...

Lo de la wifi está complicado, no...? No hay posibilidad de nada... ???

espeltron

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #167 en: 25-03-2014, 23:28 (Martes) »
Bueno, antes de nada...

Los polacos tiene una imagen ADSL mas reciente (segun los codigos de numeracion VDSL y ADSL Anexo A):
dsl_vr9_firmware_xdsl-05.06.00.08.01.06_05.05.02.00.01.01.bin
Por si quieres ver si mejora en algo la conexion ADSL.

Ademas tienen imagenes con OpenWrt, asi que pongo los enlaces:
http://pliki.gru.one.pl/11-2013/vr9.7z
http://rpc.one.pl/pliki/openwrt/TD-8970v1/openwrt-lantiq-xrx200-TDW8970-sysupgrade.image.tar.bz2
http://ecco.selfip.net/trunk/lantiq/openwrt-lantiq-xrx200-TDW8970-sysupgrade.image

He visto que tu linea llega hasta 16.8Mb. ¿Cuanto tenias antes?

En cuanto a la Wifi, lo otros dias ayude con los drivers de un Ralink RT3070, que utiliza el driver "rt2870.bin".
Resulta que este archivo lo he visto ya en alguna compilacion de OpenWrt para el ARV7519, asi que van por el buen camino.

Creo que lleva el RT3062F, asi que al ser del mismo fabricante se cargara de forma similar.

Ralink mete "el firmware" de cada dispositivo en la inicializacion de este, da igual que sea USB, PCI, PCI-E, etc, .. todos se mandan como archivo binario ya compilado para ese chip Ralink.
El caso es que las imagenes "binarias" son las mismas para linux, windows, i386 o mips, son archivos de muy pocos KB.

Asi que voy a subir las imagenes firmware mas actualizadas del wifi para el RT3062F, que tambien se colocan en:
/lib/firmware/


Saludos
espeltron
« Última modificación: 25-03-2014, 23:48 (Martes) por espeltron »

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #168 en: 25-03-2014, 23:59 (Martes) »
Espelton, te comento que con este bin también me ha funcionado y no veo diferencias entre ambos en cuanto a los datos, te copio: (el 1 es el primero y el 2 el del segundo post)
Código: [Seleccionar]
1
root@OpenWrt:/lib/firmware# /etc/init.d/dsl_control status
Chipset: Lantiq-VRx Unknown
Line State: UP [0x801: showtime_tc_sync]
Data Rate: 16.704 Mb/s / 880 Kb/s
Line Attenuation: 21.7dB / 9.4dB
Noise Margin: 9.0dB / 9.0dB
Line Uptime: 1m 52s
root@OpenWrt:/lib/firmware# /etc/init.d/dsl_control status
Chipset: Lantiq-VRx Unknown
Line State: DOWN [0x380: full_init]
Data Rate: 16.708 Mb/s / 884 Kb/s
Line Attenuation: 21.7dB / 9.8dB
Noise Margin: 9.1dB / 10.7dB
Line Uptime: 1m 35s

2
root@OpenWrt:/lib/firmware# /etc/init.d/dsl_control status
Chipset: Lantiq-VRx Unknown
Line State: UP [0x801: showtime_tc_sync]
Data Rate: 16.880 Mb/s / 880 Kb/s
Line Attenuation: 21.7dB / 9.4dB
Noise Margin: 9.0dB / 9.0dB
Line Uptime: 2m 11s
root@OpenWrt:/lib/firmware# /etc/init.d/dsl_control status
Chipset: Lantiq-VRx Unknown
Line State: UP [0x801: showtime_tc_sync]
Data Rate: 16.788 Mb/s / 884 Kb/s
Line Attenuation: 21.7dB / 9.4dB
Noise Margin: 9.0dB / 10.3dB
Line Uptime: 6s

Y con el tema de la wifi, lo espero como agua de mayo!!! Te agradezco el soporte que nos estas dando.

Citar
En cuanto a la Wifi, lo otros dias ayude con los drivers de un Ralink RT3070, que utiliza el driver "rt2870.bin".
Resulta que este archivo lo he visto ya en alguna compilacion de OpenWrt para el ARV7519, asi que van por el buen camino.

Creo que lleva el RT3062F, asi que al ser del mismo fabricante se cargara de forma similar.

Ralink mete "el firmware" de cada dispositivo en la inicializacion de este, da igual que sea USB, PCI, PCI-E, etc, .. todos se mandan como archivo binario ya compilado para ese chip Ralink.
El caso es que las imagenes "binarias" son las mismas para linux, windows, i386 o mips, son archivos de muy pocos KB.

Asi que voy a subir las imagenes firmware mas actualizadas del wifi para el RT3062F, que tambien se colocan en:
/lib/firmware/

Uff, esos techones me dan mala espina... que pasa?

Saludos
« Última modificación: 26-03-2014, 00:02 (Miércoles) por jmcabgam »

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #169 en: 26-03-2014, 00:04 (Miércoles) »
Espelton, te comento que con este bin también me ha funcionado y no veo diferencias entre ambos en cuanto a los datos, te copio: (el 1 es el primero y el 2 el del segundo post)
Código: [Seleccionar]
1
root@OpenWrt:/lib/firmware# /etc/init.d/dsl_control status
Chipset: Lantiq-VRx Unknown
Line State: UP [0x801: showtime_tc_sync]
Data Rate: 16.704 Mb/s / 880 Kb/s
Line Attenuation: 21.7dB / 9.4dB
Noise Margin: 9.0dB / 9.0dB
Line Uptime: 1m 52s
root@OpenWrt:/lib/firmware# /etc/init.d/dsl_control status
Chipset: Lantiq-VRx Unknown
Line State: DOWN [0x380: full_init]
Data Rate: 16.708 Mb/s / 884 Kb/s
Line Attenuation: 21.7dB / 9.8dB
Noise Margin: 9.1dB / 10.7dB
Line Uptime: 1m 35s

2
root@OpenWrt:/lib/firmware# /etc/init.d/dsl_control status
Chipset: Lantiq-VRx Unknown
Line State: UP [0x801: showtime_tc_sync]
Data Rate: 16.880 Mb/s / 880 Kb/s
Line Attenuation: 21.7dB / 9.4dB
Noise Margin: 9.0dB / 9.0dB
Line Uptime: 2m 11s
root@OpenWrt:/lib/firmware# /etc/init.d/dsl_control status
Chipset: Lantiq-VRx Unknown
Line State: UP [0x801: showtime_tc_sync]
Data Rate: 16.788 Mb/s / 884 Kb/s
Line Attenuation: 21.7dB / 9.4dB
Noise Margin: 9.0dB / 10.3dB
Line Uptime: 6s

Antes tenía lo mismo, sobre 16,5...

Y con el tema de la wifi, lo espero como agua de mayo!!! Te agradezco el soporte que nos estas dando.

Citar
En cuanto a la Wifi, lo otros dias ayude con los drivers de un Ralink RT3070, que utiliza el driver "rt2870.bin".
Resulta que este archivo lo he visto ya en alguna compilacion de OpenWrt para el ARV7519, asi que van por el buen camino.

Creo que lleva el RT3062F, asi que al ser del mismo fabricante se cargara de forma similar.

Ralink mete "el firmware" de cada dispositivo en la inicializacion de este, da igual que sea USB, PCI, PCI-E, etc, .. todos se mandan como archivo binario ya compilado para ese chip Ralink.
El caso es que las imagenes "binarias" son las mismas para linux, windows, i386 o mips, son archivos de muy pocos KB.

Asi que voy a subir las imagenes firmware mas actualizadas del wifi para el RT3062F, que tambien se colocan en:
/lib/firmware/

Uff, esos techones me dan mala espina... que pasa?

Saludos

espeltron

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #170 en: 26-03-2014, 00:12 (Miércoles) »
WIFI:

Es un METALINK DRIVER

Si veis el log del foro inicial:
https://foro.seguridadwireless.net/openwrt/astoria-networks-arv7519-de-ya-com-ahora-orange/msg256139/#msg256139
Aparecen los archivos:
ap_upper.bin
contr_lm.bin

Segun esto es la version: "version number: FW_3.1.0_Customers_r5058 MIPS"

Pues esos archivos y el resto que van junto a ellos hay que meterlos a....:
/lib/firmware/

Una pagina en donde tratan este driver:
http://wireless80211.wordpress.com/2010/04/03/metalink-driver-3-1-0-6-on-405ex/

Y otra pagina:
https://dev.openwrt.org/ticket/14488
Y el driver para el FW 3.1.0:
https://www.dropbox.com/s/0tg0krp4rwt8e7g/lq-wave-300-03.01.00.12.31.09.58ada131737d.src.tar.gz

Como punto de partida esta bien.

Saludos
espeltron
« Última modificación: 30-03-2014, 18:13 (Domingo) por espeltron »

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #171 en: 26-03-2014, 00:26 (Miércoles) »
He metido estos:

Código: [Seleccionar]
Aqui estan, una version mas reciente:
http://www.mediafire.com/download/283c4z5aba7r3b8/Metalink_Driver_FW_3.2.1_r5437.zip
version number: FW_3.2.1_r5437 MIPS

Y esto es lo que hay:

Código: [Seleccionar]
root@OpenWrt:/lib/firmware# ls -lh
-rw-r--r--    1 root     root       46.9K Dec 11 11:59 ProgModel_A_CB.bin
-rw-r--r--    1 root     root        7.8K Dec 11 11:59 ProgModel_A_CB_3D_RevB.bin
-rw-r--r--    1 root     root       46.9K Dec 11 11:59 ProgModel_A_nCB.bin
-rw-r--r--    1 root     root        7.8K Dec 11 11:59 ProgModel_A_nCB_3D_RevB.bin
-rw-r--r--    1 root     root       46.9K Dec 11 11:59 ProgModel_BG_CB.bin
-rw-r--r--    1 root     root        7.8K Dec 11 11:59 ProgModel_BG_CB_3D_RevB.bin
-rw-r--r--    1 root     root       46.9K Dec 11 11:59 ProgModel_BG_nCB.bin
-rw-r--r--    1 root     root        7.8K Dec 11 11:59 ProgModel_BG_nCB_3D_RevB.bin
-rw-r--r--    1 root     root      157.3K Dec 11 11:59 ap_upper.bin
-rw-r--r--    1 root     root       83.4K Dec 11 11:59 contr_lm.bin
-rw-r--r--    1 root     root      864.8K Mar 25 23:44 ltq-dsl-fw-a-vr9.bin
-rw-r--r--    1 root     root        8.0K Feb 11 22:02 rt2870.bin
lrwxrwxrwx    1 root     root          34 Mar 25 14:28 vdsl.bin -> /lib/firmware/ltq-dsl-fw-a-vr9.bin

Como puedo saber si funciona...

ifconfig:

Código: [Seleccionar]
root@OpenWrt:/lib/firmware# ifconfig
br-lan    Link encap:Ethernet  HWaddr xxx 
          inet addr:192.168.8.5  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr:xxScope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:500 errors:0 dropped:0 overruns:0 frame:0
          TX packets:363 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:57122 (55.7 KiB)  TX bytes:183932 (179.6 KiB)

eth0      Link encap:Ethernet  HWaddr xxx
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:509 errors:0 dropped:0 overruns:0 frame:0
          TX packets:363 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:68806 (67.1 KiB)  TX bytes:185528 (181.1 KiB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:400 (400.0 B)  TX bytes:400 (400.0 B)

nas0      Link encap:Ethernet  HWaddr xxx
          inet6 addr: fe80::869c:a6ff:fec0:b829/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:79 errors:79 dropped:0 overruns:79 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:6474 (6.3 KiB)

barriteleves

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #172 en: 26-03-2014, 00:32 (Miércoles) »
hola compañero, simplemete grs, aunque me gustaria probar y claro no se que hacer esto esta claro que me supera o estoy como bien decias perdido pero estupendo >:( >:( >:( por lo menos deme donde van las cervecas a casa.....'''donde buen una pregunta.

Pues esos archivos y el resto que van junto a ellos hay que meterlos a....:
/lib/firmware/

esto como lo realizo con winscp sin mas supongo que descomprimido ??
me gustara intentar colaborar por su puesto

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #173 en: 26-03-2014, 00:37 (Miércoles) »
Hasta donde yo sé el driver tiene algunos problemas para funcionar con openwrt, y el principal es que usa WEXT (wireless extensions), que es la API antigua, en vez de nl80211, además de que da algunos errores al compilar con kernels recientes.
http://wireless.kernel.org/en/developers/Documentation/nl80211
https://forum.openwrt.org/viewtopic.php?id=45047

doblecero

  • Visitante
Re:
« Respuesta #174 en: 26-03-2014, 22:58 (Miércoles) »
Que gran noticia!!! Gracias por la currada espeltron y jmcabgam!!!

Estoy deseando probarlo y comprobar la estabilidad de la conexión...

Saludos

Enviado desde mi GT-I9300 mediante Tapatalk
« Última modificación: 26-03-2014, 23:11 (Miércoles) por doblecero »

jmcabgam

  • Visitante
Re:
« Respuesta #175 en: 26-03-2014, 23:51 (Miércoles) »
Que gran noticia!!! Gracias por la currada espeltron y jmcabgam!!!

Estoy deseando probarlo y comprobar la estabilidad de la conexión...

Saludos

Enviado desde mi GT-I9300 mediante Tapatalk

Yo sólo me he limitado a seguir las maravillosas instrucciones de espeltron, todo el mérito es suyo.

Cuando queráis seguimos con el wifi...  ;)

espeltron

  • Visitante
Re:
« Respuesta #176 en: 27-03-2014, 01:13 (Jueves) »
Cuando queráis seguimos con el wifi...  ;)

El wifi es complicado, es necesario:
- crear toolchains, seguramente con versiones de gcc especificas
- hacer compilaciones cruzadas
- posiblemente parchear codigo

De momento yo no tengo tiempo para preparar las herramientas necesarias para esto y mi experiencia en compilaciones es limitada.
Asi que el wifi tendra que esperar, a menos que haya algun figura que sea capaz de sacarle punta a los drivers Metalink, que como bien dice Pteridium utilizan las obsoletas "wireless extension" (WEXT) y puede que sean incompatibles con los nuevos kernels.

Si alguien quiere hacer una prueba experimental, que se me ha ocurrido, por si las moscas:

Arcadyan anteriormente hacia dispositivos USB wireless wifi N, con el nombre comercial Accton, es posible que hayan "reetiquetado el chip" o "tenga un modo de funcionar" compatible con los driver USB actuales (con el VID y el PID cambiados).
Digo esto porque en ciertos backups originales no aparecen los "firmwares" tipicos de Metalink, como el "ap_upper.bin" o el "contr_lm.bin".

Mis sospechas van dirigidas al driver "cuasi-generico" de Ralink "rt2870.bin" para USB:
https://wiki.debian.org/rt2870sta
Buscar Arcadyan y Accton.
El firmware "rt2870.bin" es el mismo para diversos chips, como el de las antenas de 1W con chip RT3070.

O puede que usen algun otro para PCI (en un modelo de router similar, el ARV7519 usaban el RT3062F):
http://wiki.openwrt.org/arv7519
O puede que usaran otro firmware de carga similar al modo de funcionamiento de Ralink, como el de Atheros o los de Realtek.

Primeras pruebas:
1.- Identificar dispositivos USB y PCI (dmesg, lsusb, lspci, etc)
2.- Comprobar con un adaptador USB Wifi de Ralink si se han instalado correctamente los drivers en el OpenWrt.
3.- Quitar este adaptador USB wifi y reiniciar el openwrt, utilizando diferentes drivers para ver si alguno funcionara, introduciendo los identificadores VID, PID de los USB, PCI, etc. encontrados anteriormente y "sospechosos" de tener una segunda funcionalidad.

Saludos
espeltron
« Última modificación: 27-03-2014, 01:17 (Jueves) por espeltron »

barriteleves

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #177 en: 27-03-2014, 11:35 (Jueves) »
hola compañero dice:


Citar
1.- Identificar dispositivos USB y PCI (dmesg, lsusb, lspci, etc)
2.- Comprobar con un adaptador USB Wifi de Ralink si se han instalado correctamente los drivers en el OpenWrt.
3.- Quitar este adaptador USB wifi y reiniciar el openwrt, utilizando diferentes drivers para ver si alguno funcionara, introduciendo los identificadores VID, PID de los USB, PCI, etc. encontrados anteriormente y "sospechosos" de tener una segunda funcionalidad.

mira no se si esto es lo que comentas lo tienes el la pagina 7 si hay que hacer algo mas precisamente soy bastante novato pero si lo esplica paso a paso aunque te cueste igual lo realizo::

Citar
pues yo aun estoy muy novato trasteando con la imagen, y para ver si vale o no le he metido en los dos usb que tiene un usb wifi 150n chips

[quote[   17.852000] br-lan: port 1(eth0) entered forwarding state
[  191.856000] usb 1-1: USB disconnect, device number 2
[  217.700000] usb 2-1: new high-speed USB device number 2 using ifxusb_hcd
[  218.084000] usb 2-1: reset high-speed USB device number 2 using ifxusb_hcd
[  218.284000] ieee80211 phy1: rt2x00_set_rt: Info - RT chipset 5390, rev 0502 detected
[  218.376000] ieee80211 phy1: rt2x00_set_rf: Info - RF chipset 5370 detected
]

esto ha sido cuando lo he cambiado de ubicacion al otro usb latera, pero tambien lo reconoce en el que esta ubicado en la parte posterior , no se si funcionara bien configurado ya que ahora lo tengo para otro menester, pero si consiguo hacerlo funcionar metiendo luci tratare de hacerlo funcionar ya comentare saludos[/quote]

neubauten

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #178 en: 27-03-2014, 13:05 (Jueves) »
Hola a todos,

estoy intentando compilar a partir del git que hay enlazado en el post de gmtii. Hay uno de los parches que me da un error que no he conseguido solucionar:
Citar
YYY@XXXX:/move/livebox_2.1/openwrt-arv7519rw$ make V=99
make[1]: Entering directory `/move/livebox_2.1/openwrt-arv7519rw'
make[2]: Entering directory `/move/livebox_2.1/openwrt-arv7519rw'
make[3]: Entering directory `/move/livebox_2.1/openwrt-arv7519rw/target/linux'
make[4]: Entering directory `/move/livebox_2.1/openwrt-arv7519rw/target/linux/lantiq'
if [ -s "/move/livebox_2.1/openwrt-arv7519rw/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/linux-3.10.32/patches/series" ]; then (cd "/move/livebox_2.1/openwrt-arv7519rw/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/linux-3.10.32"; if quilt --quiltrc=- next >/dev/null 2>&1; then quilt --quiltrc=- push -a; else quilt --quiltrc=- top >/dev/null 2>&1; fi ); fi
Applying patch platform/0008-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
patching file drivers/net/phy/Kconfig
patching file drivers/net/phy/Makefile
patching file drivers/net/phy/lantiq.c
patch: **** unexpected end of file in patch
Patch platform/0008-NET-PHY-adds-driver-for-lantiq-PHY11G.patch does not apply (enforce with -f)
make[4]: *** [/move/livebox_2.1/openwrt-arv7519rw/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/linux-3.10.32/.quilt_checked] Error 1
make[4]: Leaving directory `/move/livebox_2.1/openwrt-arv7519rw/target/linux/lantiq'
make[3]: *** [compile] Error 2
make[3]: Leaving directory `/move/livebox_2.1/openwrt-arv7519rw/target/linux'
make[2]: *** [target/linux/compile] Error 2
make[2]: Leaving directory `/move/livebox_2.1/openwrt-arv7519rw'
make[1]: *** [/move/livebox_2.1/openwrt-arv7519rw/staging_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/stamp/.target_compile] Error 2
make[1]: Leaving directory `/move/livebox_2.1/openwrt-arv7519rw'
make: *** [world] Error 2
YYY@XXXX:/move/livebox_2.1/openwrt-arv7519rw$

¿Alguien más lo ha intentado? ¿Cómo lo habéis solucionado?

Eliminando ese parche consigo compilar pero no funcionan los puertos ethernet del router. Quiero compilar el firmware para añadir soporte para un módem 3g y un conversor de puerto serie-usb, desde la versión que hay publicada no es posible hacerlo a través de opkg.

Gracias!

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #179 en: 27-03-2014, 17:08 (Jueves) »
Quizá sea hora de hacer una rama lantiq en el repositorio de openwrt-es.  >:D

//FINAL Y MÁS DOS RESPUESTAS