Autor Tema: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22  (Leído 327774 veces)

0 Usuarios y 3 Visitantes están viendo este tema.

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #140 en: 21-03-2014, 19:05 (Viernes) »
Pues de momento se me han acabado las ideas...  ???



espeltron

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #141 en: 22-03-2014, 19:14 (Sábado) »
 :D
Estais un poco perdidos y liados.
Este mismo problema, pero con otro aspecto surgio anteriormente en el ARV7518 con el ADSL, que se conectaba y no sincronizaba.
Todo era problema del archivo "ltq-dsl-fw-a-danube.bin" (= "dsl-fw-a.bin", ="adsl.bin"), que no existia, solo existia el "b".

https://foro.seguridadwireless.net/openwrt/voip-en-routers-de-yacom-arv4518-y-arv7518/msg286157/#msg286157

Este archivo se localiza en la ruta:
/lib/firmware/

Pero en las imagenes subidas en este foro solo aparece el archivo:
rt2870.bin

Este archivo pertenece a los drivers "wireless" de Ralink.

En esta misma carpeta deberian de situarse, ademas del fichero del firmware ADSL, el fichero de la VoIP:
danube_firmware.bin
ifx_firmware.bin

Todos los nombres dados estan basados en diversas revisiones del ARV7518, un modelo mas antiguo de Lantiq, en esta version pueden diferir, segun los drivers openwrt implementados.

Hay que saber qomo actua la configuracion del:
/etc/config/network

Y los "alias" que pudieran tener los nombres de los archivos o los link que hubiera.
config adsl-device 'adsl'
   option fwannex 'a'
   option annex 'a'

Para obtener los archivos de los diferentes firmwares de los perifericos ADSL y VoIP es necesario descomprimir "backups" originales de este router o de routers que tengan los mismos componentes.

En el modelo ARV7518 se obtuvieron de paginas de actualizacion de firmwares de modelos alemanes, de modelos similares, como el Easybox 803A, ARV752DPW22.
http://www.vodafone.de/business/hilfe-support/support-firmware-easybox-803-dsl-modem.html
https://forum.vodafone.de/t5/LTE-Hardware/Neue-Firmware-f%C3%BCr-EasyBox-803-Tur*****x-verf%C3%BCgbar/td-p/218812

Si me facilitais nombres de routers, backups de firmwares originales de este router y otras imagenes de routers compatibles, podre desempaquetar las imagenes de los firmwares, para agregarlas a:
/lib/firmware/

Tanto los archivos de ADSL como las de VoIP.

Esto solucionaria parte del problema, luego hay que ver como funciona internamente el OpenWrt y como se comunica con estos perifericos.

Saludos
espeltron

doblecero

  • Visitante
Re:
« Respuesta #142 en: 25-03-2014, 00:15 (Martes) »
Gracias por el apunte espeltron!
He intentado buscar una imagen original de este router pero no la he encontrado. Yo no saqué un dump del mio así que no puedo restaurar para trastear.

No obstante, he visto que el kpn xperia Box (VGV7519) monta el mismo VRX288.

En la wiki de openwrt para este router: http://wiki.openwrt.org/toh/arcadyan/vgv7519
 he encontrado este enlace a lo que parecen los drivers de varias cosas de ese modelo, entre ellas el de la adsl:
http://dev.phrozen.org/ltq-mirror/

Meterlo en /lib/firmware/ creando los enlaces oportunos funcionará (suponiendo que sea el driver y que sirva)?

Si no es así habria que instalarlo de alguna forma especial o compilar una versión incluyendo este fichero?


Gracias.

Enviado desde mi GT-I9300 mediante Tapatalk

espeltron

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #143 en: 25-03-2014, 12:12 (Martes) »
Hola doblecero

Ya sabia que el VGV7519 monta tambien el VRX288, pero  gracias por la informacion.

Citar
http://dev.phrozen.org/ltq-mirror/
El enlace que has puesto es el de un ARV7518, no el de un ARV7519.
Te digo esto porque las imagenes de los firmware ADSL "ltq-dsl-fw-a-xxx.bin" ocupan solo unos 300KB, como en el modelo ARV7518.
Segun mis descubrimientos en otros routers VRX288, las imagenes de los firmware ADSL del ARV7519 deben de ocupar algo mas de unos 700KB.

Citar
Meterlo en /lib/firmware/ creando los enlaces oportunos funcionará (suponiendo que sea el driver y que sirva)?
Desconozco como han creado los drivers ADSL de openwrt en este router, en principio, si mantienen la misma estructura y compatibilidad con el ARV7518, los modulos del nucleo xxxx.ko deberian cargar el firmware con los mismos "nombres .bin".
De momento habra que dejar varias copias o links hasta averiguar cual es el que carga exactamente.

Citar
Si no es así habria que instalarlo de alguna forma especial o compilar una versión incluyendo este fichero?
En el ARV7518, para cambiar de anexo B a anexo A solo tenia que reemplazar el archivo binario, sin hacer ninguna compilacion.
Si el problema del ARV7519 con el ADSL solo se debe a la imagen del firmware, solo habra que añadirla "con el nombre .bin adecuado" a:
/lib/firmware/
Si hay mas problemas, con los drivers o codigo que no este implementado, o correctamente implementado, habra que ir descubriendolo.

Saludos
espeltron
« Última modificación: 25-03-2014, 12:19 (Martes) por espeltron »

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #144 en: 25-03-2014, 12:22 (Martes) »
:D
Estais un poco perdidos y liados.
Este mismo problema, pero con otro aspecto surgio anteriormente en el ARV7518 con el ADSL, que se conectaba y no sincronizaba.
Todo era problema del archivo "ltq-dsl-fw-a-danube.bin" (= "dsl-fw-a.bin", ="adsl.bin"), que no existia, solo existia el "b".

https://foro.seguridadwireless.net/openwrt/voip-en-routers-de-yacom-arv4518-y-arv7518/msg286157/#msg286157

Este archivo se localiza en la ruta:
/lib/firmware/

Pero en las imagenes subidas en este foro solo aparece el archivo:
rt2870.bin

Este archivo pertenece a los drivers "wireless" de Ralink.

En esta misma carpeta deberian de situarse, ademas del fichero del firmware ADSL, el fichero de la VoIP:
danube_firmware.bin
ifx_firmware.bin

Todos los nombres dados estan basados en diversas revisiones del ARV7518, un modelo mas antiguo de Lantiq, en esta version pueden diferir, segun los drivers openwrt implementados.

Hay que saber qomo actua la configuracion del:
/etc/config/network

Y los "alias" que pudieran tener los nombres de los archivos o los link que hubiera.
config adsl-device 'adsl'
   option fwannex 'a'
   option annex 'a'

Para obtener los archivos de los diferentes firmwares de los perifericos ADSL y VoIP es necesario descomprimir "backups" originales de este router o de routers que tengan los mismos componentes.

En el modelo ARV7518 se obtuvieron de paginas de actualizacion de firmwares de modelos alemanes, de modelos similares, como el Easybox 803A, ARV752DPW22.
http://www.vodafone.de/business/hilfe-support/support-firmware-easybox-803-dsl-modem.html
https://forum.vodafone.de/t5/LTE-Hardware/Neue-Firmware-f%C3%BCr-EasyBox-803-Tur*****x-verf%C3%BCgbar/td-p/218812

Si me facilitais nombres de routers, backups de firmwares originales de este router y otras imagenes de routers compatibles, podre desempaquetar las imagenes de los firmwares, para agregarlas a:
/lib/firmware/

Tanto los archivos de ADSL como las de VoIP.

Esto solucionaria parte del problema, luego hay que ver como funciona internamente el OpenWrt y como se comunica con estos perifericos.

Saludos
espeltron

Espeltron, lo que necesitarías, según indica gtmii en su primer post para hacer una copia de seguridad, son esos datos?
Código: [Seleccionar]
Hacemos el corto.
Accedemos al bootloader original.
Arrancamos Openwrt de serie con 0 y luego J.
Luego mediante dd if=/dev/mtdX of=backup.bin o cat /dev/mtdX > backup.bin hacemos copia de las particiones. La última será la interesante (supertask_bootcfg).

Si es así, dispongo de esa info.

Si me lo confirmas te lo subo.

Saludos

espeltron

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #145 en: 25-03-2014, 12:55 (Martes) »
Hola jmcabgam

Lo que necesito son los numeros que van a salir en la Euromillonaria,  :D, pero si me subes el "backup.bin" lo tratare con cariño y me dara "backup-fw-adsl-a.bin".

Este archivo lo subire para que hagas experimentos con el.

Nota:
Citar
La última será la interesante (supertask_bootcfg).

Me vale cualquiera de estos archivos:
01.- la imagen completa "Flash Image" de 32MB (33.554.432 bytes)
02.- "Image 0" de 6144K
03.- "Image 1" de 6144K

Saludos
espeltron
« Última modificación: 25-03-2014, 13:10 (Martes) por espeltron »

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #146 en: 25-03-2014, 13:00 (Martes) »
OK espeltron, te mando el link con "todo" lo que saqué del router antes de toquetearlo... espero que sea lo que necesitas

https://dl.dropboxusercontent.com/u/77629730/849ca6c0b828.zip

Los números de la Euromillonaria te los mando por privado, porque de lo contrario, todo el mundo se va a apuntar y vamos a caber a un par de euros por cabeza... >:D

Muchas gracias por tu soporte.

Saludos

PD: Admins, no sé si publicar esta info al completo de mi router es contraproducente en algún aspecto o no... algún problema?

espeltron

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #147 en: 25-03-2014, 13:29 (Martes) »
Hola jmcabgam

Del mtd5.bin (11.534.336 bytes) y del mtd7.bin (6.291.456 bytes) he obtenido el siguiente archivo:
dsl_vr9_firmware_xdsl.bin

Saludos
espeltron
« Última modificación: 30-03-2014, 18:19 (Domingo) por espeltron »

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #148 en: 25-03-2014, 13:31 (Martes) »
Hola jmcabgam

Del mtd5.bin (11.534.336 bytes) y del mtd7.bin (6.291.456 bytes) he obtenido el siguiente archivo:
http://www.mediafire.com/download/8q9gt91a381i7r8/dsl_vr9_firmware_xdsl-05.03.02.08.01.06_05.04.01.0A.01.01.zip

El nombre que le he puesto ha sido uno que lo identifica con la version interna del VDSL/ADSL, o al menos eso creo.

Saludos
espeltron

Perdona mi torpeza, pero qué se supone que hay que hacer con ese fichero?

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #149 en: 25-03-2014, 13:49 (Martes) »
Grabarlo en la flash del router, pero no recuerdo la ruta ni el nombre que hay que ponerle.  :-[

espeltron

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #150 en: 25-03-2014, 14:24 (Martes) »
Perdona mi torpeza, pero qué se supone que hay que hacer con ese fichero?

Primero hay que ver los distintos modelos y familias de Lantiq, para evitar confusiones:
http://wiki.openwrt.org/doc/hardware/soc/soc.lantiq
La "danube" era la del ARV7518, despues esta la AR9 de otros similares y la de este ARV7519 es la "VR9", del VRX288.

Como la rama utilizada actualmente es la "trunk", ya que esta en desarrollo, tenemos los siguientes paquetes:
http://downloads.openwrt.org/snapshots/trunk/lantiq/packages/kmod-ltq-adsl-danube-fw-a_0.1-1_lantiq.ipk
http://downloads.openwrt.org/snapshots/trunk/lantiq/packages/kmod-ltq-adsl-ar9-fw-a_0.1-1_lantiq.ipk

De estos paquetes se obtienen:
/lib/firmware/ltq-dsl-fw-a-danube.bin
/lib/firmware/ltq-dsl-fw-a-ar9.bin
/lib/firmware/adsl.bin

adsl.bin es un enlace al "ltq-dsl-fw-a-xxx.bin" correspondiente.

Para hacerlo de forma correcta:

Renombrar el archivo de la imagen backup "dsl_vr9_firmware_xdsl-05.03.02.08.01.06_05.04.01.0A.01.01.bin" a:
/lib/firmware/ltq-dsl-fw-a-vr9.bin

Ya que es un VR9 por ser un VRX288.

Crear los siguientes enlaces directos a ese archivo ("por no saber" que archivo es el que carga el modulo del kernel que se esta utilizando actualmente):
/lib/firmware/ltq-dsl-fw-a-danube.bin  --> enlace al ltq-dsl-fw-a-vr9.bin
/lib/firmware/ltq-dsl-fw-a-ar9.bin  --> enlace al ltq-dsl-fw-a-vr9.bin
/lib/firmware/adsl.bin  --> enlace al ltq-dsl-fw-a-vr9.bin
Borrando previamente algun archivo ".bin" con el mismo nombre que pudiera haber (no creo que sirvan los firmwares del ar9 o de danube).

Si no se quieren crear enlaces simbolicos con "ln -s" se pueden hacer multiples copias del archivo.

Saludos
espeltron
« Última modificación: 25-03-2014, 15:04 (Martes) por espeltron »

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #151 en: 25-03-2014, 14:47 (Martes) »
espeltron, magnífica explicación.  >:( >:( >:(
Lo curioso es que en openwrt esté el firm para los ar9 pero no para los vr9.
« Última modificación: 25-03-2014, 14:47 (Martes) por Pteridium »

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #152 en: 25-03-2014, 14:54 (Martes) »
Os cuento lo que he hecho, sin resultado satisfactorio  :'( (a ver si me he equivocado en algo...)

Copio el fichero de espeltron (dsl_vr9_firmware_xdsl-05.03.02.08.01.06_05.04.01.0A.01.01.zip) descomprimido y lo renombro a ltq-dsl-fw-a-vr9.bin, creo los enlaces simbolicos y esto es lo que hay en /lib/firmware

Código: [Seleccionar]
root@OpenWrt:/lib/firmware# ls -lh
lrwxrwxrwx    1 root     root          34 Mar 25 14:28 adsl.bin -> /lib/firmware/ltq-dsl-fw-a-vr9.bin
lrwxrwxrwx    1 root     root          34 Mar 25 14:29 ltq-dsl-fw-a-ar9.bin -> /lib/firmware/ltq-dsl-fw-a-vr9.bin
lrwxrwxrwx    1 root     root          34 Mar 25 14:29 ltq-dsl-fw-a-danube.bin -> /lib/firmware/ltq-dsl-fw-a-vr9.bin
-rw-r--r--    1 root     root      757.4K Mar 25 14:11 ltq-dsl-fw-a-vr9.bin
-rw-r--r--    1 root     root        8.0K Feb 11 22:02 rt2870.bin

Y el log me da:

Código: [Seleccionar]
Tue Mar 25 14:37:22 2014 daemon.info pppd[801]: Plugin rp-pppoe.so loaded.
Tue Mar 25 14:37:22 2014 daemon.info pppd[801]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Tue Mar 25 14:37:22 2014 daemon.notice pppd[801]: pppd 2.4.5 started by root, uid 0
Tue Mar 25 14:37:37 2014 daemon.warn pppd[801]: Timeout waiting for PADO packets
Tue Mar 25 14:37:37 2014 daemon.err pppd[801]: Unable to complete PPPoE Discovery
Tue Mar 25 14:37:37 2014 daemon.info pppd[801]: Exit.

Esta prueba la he hecho cambiando /etc/config/network
Código: [Seleccionar]
config adsl-device 'adsl'
        option fwannex 'a'
        option annex 'a2p'

Con todas las posibilidades en fwannex, annex en 'a' y 'a2p', incluso comentando la linea annex y probando fwannex con ambos valores, sin resultado...

 ??? ??? ???

He hecho algo mal, alguna indicación adicional?

Muchas gracias!!!
« Última modificación: 25-03-2014, 15:07 (Martes) por jmcabgam »

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #153 en: 25-03-2014, 15:07 (Martes) »
Código: [Seleccionar]
root@OpenWrt:/lib/firmware# ls -lh
lrwxrwxrwx    1 root     root          34 Mar 25 14:28 adsl.bin -> /lib/firmware/ltq-dsl-fw-a-vr9.bin
lrwxrwxrwx    1 root     root          34 Mar 25 14:29 ltq-dsl-fw-a-ar9.bin -> /lib/firmware/ltq-dsl-fw-a-vr9.bin
lrwxrwxrwx    1 root     root          34 Mar 25 14:29 ltq-dsl-fw-a-danube.bin -> /lib/firmware/ltq-dsl-fw-a-vr9.bin
-rw-r--r--    1 root     root      757.4K Mar 25 14:11 ltq-dsl-fw-a-vr9.bin
-rw-r--r--    1 root     root        8.0K Feb 11 22:02 rt2870.bin

He hecho algo mal, alguna indicación adicional?

Muchas gracias!!!

PD: Espeltro, entiendo que cuando pones /etc/firmware/ quieres decir /lib/firmware/
Te sobran 2 firmwares: ltq-dsl-fw-a-danube.bin y ltq-dsl-fw-a-ar9.bin. Para un router con chip VR9 no valen más que para incordiar.
Según las indicaciones de espeltron copias ltq-dsl-fw-a-vr9.bin y lo enlazas con adsl.bin con ln -s
Para ver si sincroniza: /etc/init.d/dsl_control status

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #154 en: 25-03-2014, 15:09 (Martes) »
Código: [Seleccionar]
root@OpenWrt:/lib/firmware# ls -lh
lrwxrwxrwx    1 root     root          34 Mar 25 14:28 adsl.bin -> /lib/firmware/ltq-dsl-fw-a-vr9.bin
lrwxrwxrwx    1 root     root          34 Mar 25 14:29 ltq-dsl-fw-a-ar9.bin -> /lib/firmware/ltq-dsl-fw-a-vr9.bin
lrwxrwxrwx    1 root     root          34 Mar 25 14:29 ltq-dsl-fw-a-danube.bin -> /lib/firmware/ltq-dsl-fw-a-vr9.bin
-rw-r--r--    1 root     root      757.4K Mar 25 14:11 ltq-dsl-fw-a-vr9.bin
-rw-r--r--    1 root     root        8.0K Feb 11 22:02 rt2870.bin

He hecho algo mal, alguna indicación adicional?

Muchas gracias!!!

PD: Espeltro, entiendo que cuando pones /etc/firmware/ quieres decir /lib/firmware/
Te sobran 2 firmwares: ltq-dsl-fw-a-danube.bin y ltq-dsl-fw-a-ar9.bin. Para un router con chip VR9 no valen más que para incordiar.
Según las indicaciones de espeltron copias ltq-dsl-fw-a-vr9.bin y lo enlazas con adsl.bin con ln -s
Para ver si sincroniza: /etc/init.d/dsl_control status

OK, pruebo y comento...

Nada, igual... no funciona...

Código: [Seleccionar]
root@OpenWrt:~# ls -lh /lib/firmware/
lrwxrwxrwx    1 root     root          34 Mar 25 14:28 adsl.bin -> /lib/firmware/ltq-dsl-fw-a-vr9.bin
-rw-r--r--    1 root     root      757.4K Mar 25 14:11 ltq-dsl-fw-a-vr9.bin
-rw-r--r--    1 root     root        8.0K Feb 11 22:02 rt2870.bin

Código: [Seleccionar]
root@OpenWrt:~# /etc/init.d/dsl_control status
Chipset: Lantiq-VRx n
Line State: DOWN [0x0: not initialized]
Data Rate: 0 b/s / 0 b/s
Line Attenuation: 0.0dB / 0.0dB
Noise Margin: 0.0dB / 0.0dB
Line Uptime: down

Y con todas las combinaciones en /etc/config/network para fwannex y annex, a y a2p

« Última modificación: 25-03-2014, 15:26 (Martes) por jmcabgam »

espeltron

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #155 en: 25-03-2014, 15:39 (Martes) »
No es adsl.bin, es vdsl.bin

https://dev.openwrt.org/browser/trunk/package/kernel/lantiq/ltq-vdsl-fw/src/vdsl_fw_install.sh?rev=37007
https://gitlab.labs.nic.cz/turris/openwrt/blob/a024efd187f91c8ec1b21877fbf94b0e2669dc3a/package/platform/lantiq/ltq-vdsl-fw/src/vdsl_fw_install.sh

Código: [Seleccionar]
...
cp ${FW_TAPI} ${FW_DSL} /lib/firmware/

ln -s /lib/firmware/vr9_dsl_fw_annex_b.bin /lib/firmware/vdsl.bin

En nuestro caso seria:
Citar
cp ltq-dsl-fw-a-vr9.bin /lib/firmware/
ln -s /lib/firmware/ltq-dsl-fw-a-vr9.bin /lib/firmware/vdsl.bin

Supongo que el resto de paquetes (drivers y modulos del kernel) se instalan correctamente.

Suerte..

Saludos
espeltron

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #156 en: 25-03-2014, 16:11 (Martes) »
Bueno, un pasito mas...

Parece que ya está el driver "en su sitio y con su nombre correcto", pero no consigo adsl...

Código: [Seleccionar]
Tue Mar 25 15:44:35 2014 daemon.info pppd[9169]: Plugin rp-pppoe.so loaded.
Tue Mar 25 15:44:35 2014 daemon.info pppd[9169]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Tue Mar 25 15:44:35 2014 daemon.notice pppd[9169]: pppd 2.4.5 started by root, uid 0
Tue Mar 25 15:44:36 2014 user.notice root: Found no matching interface for DSL notification (HANDSHAKE)
Tue Mar 25 15:44:38 2014 user.notice root: Found no matching interface for DSL notification (DOWN)
Tue Mar 25 15:44:42 2014 user.notice root: Found no matching interface for DSL notification (READY)
Tue Mar 25 15:44:50 2014 daemon.warn pppd[9169]: Timeout waiting for PADO packets
Tue Mar 25 15:44:50 2014 daemon.err pppd[9169]: Unable to complete PPPoE Discovery
Tue Mar 25 15:44:50 2014 daemon.info pppd[9169]: Exit.

Código: [Seleccionar]
root@OpenWrt:~# /etc/init.d/dsl_control status
Chipset: Lantiq-VRx Unknown
Line State: DOWN [0x300: handshake]
Data Rate: 0 b/s / 0 b/s
Line Attenuation: 0.0dB / 0.0dB
Noise Margin: 0.0dB / 0.0dB
Line Uptime: down

root@OpenWrt:~# /etc/init.d/dsl_control status
Chipset: Lantiq-VRx Unknown
Line State: DOWN [0x1: exception]
Data Rate: 0 b/s / 0 b/s
Line Attenuation: 0.0dB / 0.0dB
Noise Margin: 0.0dB / 0.0dB
Line Uptime: down

root@OpenWrt:~# /etc/init.d/dsl_control status
Chipset: Lantiq-VRx Unknown
Line State: DOWN [0x200: silent]
Data Rate: 0 b/s / 0 b/s
Line Attenuation: 0.0dB / 0.0dB
Noise Margin: 0.0dB / 0.0dB
Line Uptime: down

Yo tengo adsl con pepephone, y esto es una copia de mi /etc/config/network

Código: [Seleccionar]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd7e:d830:c95c::/48'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.8.5'
option dns '8.8.8.8'
option netmask '255.255.255.0'
# option ip6assign '60'
option macaddr 'XX:XX:XX:XX:XX:XX' borrado para el foro

config adsl-device 'adsl'
option fwannex 'a2p'
option annex 'a2p'

config atm-bridge 'atm'
option encaps 'llc'
option vci '33'
option vpi '0'
option payload 'bridged'
option unit '0'
# option atmdev '0'

config interface 'wan'
option ifname 'nas0'
option proto 'pppoe'
option username 'pepephone@pepephone'
option password 'pepephone'
# option ipv6 '1'
option macaddr 'XX:XX:XX:XX:XX:XX' borrado para el foro

#config interface 'wan6'
# option ifname '@wan'
# option proto 'dhcpv6'


He probado variar la lineas en rojo con valores a y a2p, todas las combinaciones y nada...
Código: [Seleccionar]
option fwannex 'a2p'
option annex 'a2p'
« Última modificación: 25-03-2014, 16:13 (Martes) por jmcabgam »

espeltron

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #157 en: 25-03-2014, 17:06 (Martes) »
Hay comprobar que servicio estas utilizando, en teoria tiene que ser "/sbin/vdsl_cpe_control", y que la configuracion sea la adecuada.

Practicamente no debe de haber muchas diferencias entre dsl_cpe_control y vdsl_cpe_control.

Para saber si se carga correctamente la configuracion y si es la correcta hay que ver los fuentes:
 
https://dev.openwrt.org/browser/trunk/package/network/config/ltq-vdsl-app/files/dsl_control?rev=37198
https://dev.openwrt.org/browser/trunk/package/network/config/ltq-adsl-app/files/dsl_control?rev=37198

https://dev.openwrt.org/export/37198/trunk/package/network/config/ltq-vdsl-app/files/dsl_control
https://dev.openwrt.org/export/37198/trunk/package/network/config/ltq-adsl-app/files/dsl_control

Practicamente no hay diferencias entre ellos.

Ahora, para terminar de verificar la configuracion haz lo siguiente:

cat /etc/init.d/dsl_control > /tmp/dsl_control
O tambien vale:
cp /etc/init.d/dsl_control /tmp/dsl_control

Copia tambien los archivos ejecutables que hubiera:
/sbin/vdsl_cpe_control
/sbin/dsl_cpe_control

Sube todo esto dentro de un archivo comprimido, para comprobar si los parametros de configuracion de /etc/config/network son los adecuados:
Código: [Seleccionar]
config adsl-device 'adsl'
option fwannex 'a2p'
option annex 'a2p'

Los que hay definidos son los siguientes:
Citar
annex_b=10_00_10_00_00_04_00_00
annex_bdmt=10_00_00_00_00_00_00_00
annex_b2=00_00_10_00_00_00_00_00
annex_b2p=00_00_00_00_00_04_00_00
annex_a=04_01_04_00_00_01_00_00
annex_at1=01_00_00_00_00_00_00_00
annex_alite=00_01_00_00_00_00_00_00
annex_admt=04_00_00_00_00_00_00_00
annex_a2=00_00_04_00_00_00_00_00
annex_a2p=00_00_00_00_00_01_00_00
annex_l=00_00_00_00_04_00_00_00
annex_m=00_00_00_00_40_00_04_00
annex_m2=00_00_00_00_40_00_00_00
annex_m2p=00_00_00_00_00_00_04_00

Como obtener los 64 bits del anexo:
ADSL2 (pag. 26-27): https://tools.ietf.org/html/rfc4706
VDSL2 (pag. 27-28): https://tools.ietf.org/html/rfc5650

Bits diferentes (añadidos en VDSL2):
Código: [Seleccionar]
          Bit 52-55: Reserved
          Bit 56 : G.993.2 Annex A
          Bit 57 : G.993.2 Annex B
          Bit 58 : G.993.2 Annex C
          Bit 59-63: Reserved"

Hay otras cosas que no son tan parecidas:
Código: [Seleccionar]
- ADSL operation mode description
- xDSL operation mode description

Y en las pruebas deja varios minutos para que se sincronice, a veces no es inmediato.

Yo tengo tambien pepephone, y le he metido routers con VCI y VPI diferentes y consigue sincronizacion, aunque no haya conexion.
El VPI/VCI estan bien, es 0 y 33 respectivamente.

Pienso que el router intenta usar el modo VDSL por defecto, en vez del ADSL, pero se estan consiguiendo avances.  :D

Lo importante, como OpenWrt carga el firmware e inicia la conexion esta aqui:
Citar
   # start CPE dsl daemon in the background
   service_start /sbin/vdsl_cpe_control -i${xtu} \
         -n /sbin/dsl_notify.sh \
         -f /lib/firmware/${firmware}

La variable ${firmware}  es vdsl.bin, eso ya esta bien.
Ahora hay que comprobar que la variable "${xtu}" sea la adecuada.

Tambien puedes hacer 5 pruebas:

Prueba 1:
Código: [Seleccionar]
/etc/init.d/dsl_control stop
/etc/init.d/dsl_control start
/etc/init.d/dsl_control status
Esperar 2 minutos.

Prueba 2 (a2p):
Código: [Seleccionar]
/etc/init.d/dsl_control stop
service_start /sbin/vdsl_cpe_control -i00_00_00_00_00_01_00_00 -n /sbin/dsl_notify.sh -f /lib/firmware/vdsl.bin
/etc/init.d/dsl_control status
Esperar 2 minutos.

Prueba 3 (a):
Código: [Seleccionar]
/etc/init.d/dsl_control stop
service_start /sbin/vdsl_cpe_control -i04_01_04_00_00_01_00_00 -n /sbin/dsl_notify.sh -f /lib/firmware/vdsl.bin
/etc/init.d/dsl_control status
Esperar 2 minutos.

Prueba 4 (con -i sola):
Código: [Seleccionar]
/etc/init.d/dsl_control stop
service_start /sbin/vdsl_cpe_control -i -n /sbin/dsl_notify.sh -f /lib/firmware/vdsl.bin
/etc/init.d/dsl_control status
Esperar 2 minutos.

Prueba 5 (sin -i):
Código: [Seleccionar]
/etc/init.d/dsl_control stop
service_start /sbin/vdsl_cpe_control -n /sbin/dsl_notify.sh -f /lib/firmware/vdsl.bin
/etc/init.d/dsl_control status
Esperar 2 minutos.

Aqui se ve como se mandan los xtu bits:
https://lists.openwrt.org/pipermail/openwrt-devel/2012-May/015418.html
Supongo que es la forma correcta.

Saludos
espeltron
« Última modificación: 25-03-2014, 18:37 (Martes) por espeltron »

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #158 en: 25-03-2014, 17:18 (Martes) »
Código: [Seleccionar]
config adsl-device 'adsl'
option fwannex 'a'
option annex 'a2p'
En fwannex, si mal no recuerdo, hay que poner 'a' a secas, y es en annex donde se puede jugar con los parámetros simplemente comentar o eliminar esa línea para que autodetecte.

espeltron

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #159 en: 25-03-2014, 19:45 (Martes) »
Ademas de las pruebas indicadas, hay una muy importante:
Código: [Seleccionar]
vdsl_cpe_control --version
dsl_cpe_control --version

Ya que hay 2 versiones:
Driver danube:
http://mirror2.openwrt.org/sources/drv_dsl_cpe_api_danube-3.24.4.4.tar.gz
http://mirror.opf.slu.cz/openwrt/sources/drv_dsl_cpe_api_danube-3.24.4.4.tar.gz

Driver vrx, que no esta en el repositorio oficial mirror2:
http://mirror.opf.slu.cz/openwrt/sources/drv_dsl_cpe_api_vrx-4.11.4.tar.gz

Saludos
espeltron
« Última modificación: 25-03-2014, 21:35 (Martes) por espeltron »