Autor Tema: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22  (Leído 322827 veces)

0 Usuarios y 1 Visitante están viendo este tema.

barriteleves

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #120 en: 13-03-2014, 22:36 (Jueves) »
hola jmcabgam se agradece la ayuda siempre se puede aprende un poco cada dia por su puesto esto de ser novato cuesta , pero a todo se llega grs a los maestros  que hay por aqui e icluso a los novatos que posteando su errores evitan que otros los comenta. y seguro que mucho de lo que has posteado me sirve para realizarlo mejo  y no dar la bara a los demas un saludo


« Última modificación: 13-03-2014, 23:10 (Jueves) por barriteleves »

jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #121 en: 13-03-2014, 23:14 (Jueves) »
hola jmcabgam se agradece la ayuda siempre se puede apheende un poco cada dia por su puesto esto de ser novato cuesta , pero a todo se llega gras a los maestros  que hay por aqui e icluso a los novatos que posteando su errores evitan que otros los comenta. y seguro que mucho de lo que has posteado me sirve para realizarlo mejo  y no dar la bara a los demas un saludo

Eeeeeiiiiii!!!! que yo soy un novatón!!! Pero bueno, leyendo, entendiendo, probando, releyendo, reprobando, rerere.... se llega a buen puerto.

Pero por aquí estoy para echar una mano hasta donde llegue!!!

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #122 en: 13-03-2014, 23:45 (Jueves) »
Del tema del ADSL estoy como doblecero

No consigo echar a andar la adsl... :(

Mi configuración (lógicamente user y pwd bien puestos), es la misma que tengo en otro router con openwrt y la adsl andando:

Código: [Seleccionar]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'


config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.10'
option netmask '255.255.255.0'


config adsl-device 'adsl'
option fwannex 'a'
option annex 'a'


config interface 'wan'
option ifname 'nas0'
option proto 'pppoe'
option username 'XXXXXXXXXXXXXXXX'
option password 'XXXXXXXXXXXXXXXX'


config atm-bridge 'atm'
option unit '0'
option encaps 'vc'
option payload 'bridged'
option vci '35'
option vpi '8'

Prueba a cambiar 'a' por 'a2p' en annex o directamente borrar "option annex 'a'". Con los de yacom funcionaba probando con una de las dos soluciones.

gmtii

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #123 en: 14-03-2014, 00:06 (Viernes) »
Añadido GIT con parches aplicados en el primer post para que el que quiera pueda compilar su firmware.

Saludos.


jmcabgam

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #124 en: 14-03-2014, 00:26 (Viernes) »
Prueba a cambiar 'a' por 'a2p' en annex o directamente borrar "option annex 'a'". Con los de yacom funcionaba probando con una de las dos soluciones.

Pues nada, he probado

Código: [Seleccionar]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7e:d830:c95c::/48'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.8.5'
        option netmask '255.255.255.0'
        option macaddr '84:9c:a6:XX:XX:XX'

config adsl-device 'adsl'
        option fwannex 'a' 
        option annex 'a2p'

config atm-bridge 'atm'
        option encaps 'vc'
        option vci '33'
        option vpi '0'
        option payload 'bridged'
        option unit '0'

config interface 'wan'
        option ifname 'nas0'
        option proto 'pppoe'
        option username 'XXX@XXX'
        option password 'XXX'
        option macaddr '84:9c:a6:XX:XX:XX'

Incluso he probado varias configuraciones
Código: [Seleccionar]
config adsl-device 'adsl'
        option fwannex 'a' 
        option annex 'a2p'
Código: [Seleccionar]
config adsl-device 'adsl'
        option fwannex 'a' 
#       option annex 'a2p'
Código: [Seleccionar]
config adsl-device 'adsl'
        option fwannex 'a2p' 
       option annex 'a2p'

y todas las combinaciones posibles, habilitando/deshabilitando y cambiando los valores entre a y a2p, incluso anulando ambas líneas y en cada reinicio siempre me decía lo mismo...

Sin el cable ADSL, me dice lo mismo  ??? ??? ???

Código: [Seleccionar]
...
Fri Mar 14 00:12:23 2014 daemon.info pppd[857]: Exit.
Fri Mar 14 00:12:23 2014 daemon.notice netifd: Interface 'wan' is now down
Fri Mar 14 00:12:23 2014 daemon.info pppd[872]: Plugin rp-pppoe.so loaded.
Fri Mar 14 00:12:23 2014 daemon.info pppd[872]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Fri Mar 14 00:12:23 2014 daemon.notice pppd[872]: pppd 2.4.5 started by root, uid 0
Fri Mar 14 00:12:38 2014 daemon.warn pppd[872]: Timeout waiting for PADO packets
Fri Mar 14 00:12:38 2014 daemon.err pppd[872]: Unable to complete PPPoE Discovery
Fri Mar 14 00:12:38 2014 daemon.info pppd[872]: Exit.
Fri Mar 14 00:12:38 2014 daemon.notice netifd: Interface 'wan' is now down
Fri Mar 14 00:12:38 2014 daemon.info pppd[887]: Plugin rp-pppoe.so loaded.
Fri Mar 14 00:12:38 2014 daemon.info pppd[887]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Fri Mar 14 00:12:38 2014 daemon.notice pppd[887]: pppd 2.4.5 started by root, uid 0
...

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #125 en: 14-03-2014, 13:48 (Viernes) »
Pues nada, he probado

Incluso he probado varias configuraciones
Código: [Seleccionar]
config adsl-device 'adsl'
        option fwannex 'a' 
        option annex 'a2p'
Código: [Seleccionar]
config adsl-device 'adsl'
        option fwannex 'a' 
#       option annex 'a2p'
Código: [Seleccionar]
config adsl-device 'adsl'
        option fwannex 'a2p' 
       option annex 'a2p'

y todas las combinaciones posibles, habilitando/deshabilitando y cambiando los valores entre a y a2p, incluso anulando ambas líneas y en cada reinicio siempre me decía lo mismo...

Sin el cable ADSL, me dice lo mismo  ??? ??? ???

Código: [Seleccionar]
...
Fri Mar 14 00:12:23 2014 daemon.info pppd[857]: Exit.
Fri Mar 14 00:12:23 2014 daemon.notice netifd: Interface 'wan' is now down
Fri Mar 14 00:12:23 2014 daemon.info pppd[872]: Plugin rp-pppoe.so loaded.
Fri Mar 14 00:12:23 2014 daemon.info pppd[872]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Fri Mar 14 00:12:23 2014 daemon.notice pppd[872]: pppd 2.4.5 started by root, uid 0
Fri Mar 14 00:12:38 2014 daemon.warn pppd[872]: Timeout waiting for PADO packets
Fri Mar 14 00:12:38 2014 daemon.err pppd[872]: Unable to complete PPPoE Discovery
Fri Mar 14 00:12:38 2014 daemon.info pppd[872]: Exit.
Fri Mar 14 00:12:38 2014 daemon.notice netifd: Interface 'wan' is now down
Fri Mar 14 00:12:38 2014 daemon.info pppd[887]: Plugin rp-pppoe.so loaded.
Fri Mar 14 00:12:38 2014 daemon.info pppd[887]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Fri Mar 14 00:12:38 2014 daemon.notice pppd[887]: pppd 2.4.5 started by root, uid 0
...
Échale un ojo a este hilo: https://foro.seguridadwireless.net/openwrt/arv7518-no-consigo-que-el-adsl-funcione/
Hay que tener en cuenta que una cosa es que sincronice con la central y otra cosa es que se autentique. Por los logs que has puesto no se autentica, pero no sabes si tiene sincronismo o no.
El caso más común de que haya sincronismo pero no internet es que algún detalle de la configuración esté mal puesto. Revisa usuario, contraseña, vpi, vci, encapsulación (llc o vc-mux) y si es pppoe o pppoa.

barriteleves

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #126 en: 14-03-2014, 15:05 (Viernes) »
hola jmcabgam leeo que tienes problemas de conexion adsl o autentificacion y como ayuda por si te vale permiteme decirte que revises las o la dns haber si es eso, ya si es la que as posteado igual hasta que no tengas puesta la que le corresponde a tu proveedor de intenet no te funciona. suerte

manuelacantasaetas

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #127 en: 14-03-2014, 16:16 (Viernes) »
>:( >:(

Vaiss  a obrar algún milagro con el tema del wifi?
Imposible: habría que reescribir el driver de cabo a rabo.
https://forum.openwrt.org/viewtopic.php?id=45047

Una pena.  :-[

barriteleves

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #128 en: 14-03-2014, 19:08 (Viernes) »
hola compañero dice:

>:( >:(

Vaiss  a obrar algún milagro con el tema del wifi?
Imposible: habría que reescribir el driver de cabo a rabo.
https://forum.openwrt.org/viewtopic.php?id=45047

Una pena.  :-[

pues yo aun estoy muy novato trasteando con la imagen, y para ver si vale o no le he metido en los dos usb que tiene un usb wifi 150n chips

[quote[   17.852000] br-lan: port 1(eth0) entered forwarding state
[  191.856000] usb 1-1: USB disconnect, device number 2
[  217.700000] usb 2-1: new high-speed USB device number 2 using ifxusb_hcd
[  218.084000] usb 2-1: reset high-speed USB device number 2 using ifxusb_hcd
[  218.284000] ieee80211 phy1: rt2x00_set_rt: Info - RT chipset 5390, rev 0502 detected
[  218.376000] ieee80211 phy1: rt2x00_set_rf: Info - RF chipset 5370 detected
][/quote]

esto ha sido cuando lo he cambiado de ubicacion al otro usb latera, pero tambien lo reconoce en el que esta ubicado en la parte posterior , no se si funcionara bien configurado ya que ahora lo tengo para otro menester, pero si consiguo hacerlo funcionar metiendo luci tratare de hacerlo funcionar ya comentare saludos

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #129 en: 17-03-2014, 17:12 (Lunes) »
Leyendo un par de cosas sueltas resulta que hay un firm para que el switch interno funcione como fast ethernet (vr9_phy22f_a1x.bin) y otro para que funcione como gigabit ethernet (vr9_phy11g_a1x.bin).
Puedo estar perfectamente equivocado, pero me da que si se pasa el firm vr9_phy22f en vez del vr9_phy11g deberían funcionar los cuatro puertos fast ethernet del router, pero seguramente el puerto wan se quedará con una velocidad máxima de 100mbps.
Si alguien pudiera echarle un ojo y comentar los resultados...
Los cambios habría que hacerlos en los ficheros ARV7519RWV11.dts y ARV7519RWV12.dts al final de todo. Ejemplo:
Código: [Seleccionar]
/dts-v1/;


/include/ "ARV7519RW.dtsi"

/ {
fpi@10000000 {
localbus@0 {
nor-boot@0 {
compatible = "lantiq,nor";
bank-width = <2>;
reg = <0 0x0 0x2000000>, <1 0x2000000 0x2000000>;
#address-cells = <1>;
#size-cells = <1>;

partition@0 {
label = "uboot";
reg = <0x000000000000 0x00060000>;
read-only;
};

partition@60000 {
label = "uboot_cfg";
reg = <0x000000060000 0x00020000>;
read-only;
};

partition@80000 {
label = "firmware";
reg = <0x000000080000 0x01f00000>;
};

partition@1f80000 {
label = "boardconfig";
reg = <0x000001f80000 0x00080000>;
read-only;

};



};
};
};
gphy-xrx200 {
compatible = "lantiq,phy-xrx200";
firmware = "lantiq/vr9_phy22f_a1x.bin";  /*VR9 1.1*/
phys = [ 00 01 ];
};
};

gmtii

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #130 en: 18-03-2014, 00:20 (Martes) »
muy buenas,

buen detalle... al ppio. probé todas las combinaciones y con este siempre se colgaba al hacer la carga de fw o daba error

[    0.276000] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[    0.280000] ifx_pcie_bios_map_irq port 0 dev 0000:00:00.0 slot 0 pin 1
[    0.284000] ifx_pcie_bios_map_irq dev 0000:00:00.0 irq 144 assigned
[    0.288000] ifx_pcie_bios_map_irq port 0 dev 0000:01:00.0 slot 0 pin 1
[    0.292000] ifx_pcie_bios_map_irq dev 0000:01:00.0 irq 144 assigned
[    0.296000] Switching to clocksource MIPS
[    0.304000] NET: Registered protocol family 2
[    0.308000] TCP established hash table entries: 1024 (order: 1, 8192 bytes)
[    0.312000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.320000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.328000] TCP: reno registered
[    0.332000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.336000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.344000] NET: Registered protocol family 1
[    0.348000] gptu: totally 6 16-bit timers/counters
[    0.352000] gptu: misc_register on minor 63
[    0.356000] gptu: succeeded to request irq 126
[    0.360000] gptu: succeeded to request irq 127
[    0.364000] gptu: succeeded to request irq 128
[    0.368000] gptu: succeeded to request irq 129
[    0.376000] gptu: succeeded to request irq 130
[    0.380000] gptu: succeeded to request irq 131
[    0.376000] gptu: succeeded to request irq 130
[    0.380000] gptu: succeeded to request irq 131
[    0.384000] phy-xrx200 gphy-xrx200.8: requesting lantiq/vr9_phy22f_a2x.bin

aquí se queda pensando un buen rato

[   60.512000] phy-xrx200 gphy-xrx200.8: failed to load firmware: lantiq/vr9_phy22f_a2x.bin
[   60.520000] phy-xrx200: probe of gphy-xrx200.8 failed with error -22

y el fichero está en ./target/linux/lantiq/files/firmware/lantiq/vr9_phy22f_a2x.bin

Saludos.


« Última modificación: 18-03-2014, 00:22 (Martes) por gmtii »

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #131 en: 18-03-2014, 12:07 (Martes) »
muy buenas,

buen detalle... al ppio. probé todas las combinaciones y con este siempre se colgaba al hacer la carga de fw o daba error
No dejas nada al azar.  ;)

barriteleves

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #132 en: 18-03-2014, 18:18 (Martes) »
hola buenas, haber si podeis aconsejarme algo sobre conectar con mi proveerdo de adsl 10mb telefonica. he provado todo el fin de semana partiendo de este ejemplo.

Citar
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'


config interface 'lan'
   option ifname 'eth0'
   option type 'bridge'
   option proto 'static'
   option ipaddr '192.168.1.10'
   option netmask '255.255.255.0'


config adsl-device 'adsl'
   option fwannex 'a'
   option annex 'a'


config interface 'wan'
   option ifname 'nas0'
   option proto 'pppoe'
   option username 'XXXXXXXXXXXXXXXX'
   option password 'XXXXXXXXXXXXXXXX'

   
config atm-bridge 'atm'
   option unit '0'
   option encaps 'vc'
   option payload 'bridged'
   option vci '35'
   option vpi '8'


con winscp conectado y editado el fichero de configuracion network y salvandolo .

realizando las modificaciones que creia conveniente como vpi 8, vci 32, el modulo de adsl realizando todos los cambios posibles y nada no conecta algun consejor para poder realizar la prueba, tambien decir que los dos rj 45 wl un y tres creo me funcionan bien no he notado cortes. venga un saludo y grs

comentar que no he podido actualizar luci quizas a pesar de conectar este router al principal con rj 45 y si me da salidad a adsl el pc pero no hay forma alguna otra manera de realizarlo se pueden bajar los paquetesy meterlos directamente como una imagen se actualizaria ???

Citar
« Última modificación: 18-03-2014, 18:27 (Martes) por barriteleves »

doblecero

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #133 en: 19-03-2014, 18:20 (Miércoles) »
Hola barriteleves,
Hasta donde se nadie ha sido capaz de echar a andar el modem de este router con la adsl. Yo mismo estuve haciendo bastantes pruebas ayer y sigo teniendo el mismo problema de "daemon.err pppd[872]: Unable to complete PPPoE Discovery". He leido un poco y hay una forma de especificar el nombre del PPoE de la siguiente forma (aunque otra cosa es conseguir que tu ISP te lo proporcione, cosa que dudo):

Código: [Seleccionar]
option 'pppd_options' 'rp_pppoe_service lan1'
Por otro lado, no creo que este sea el problema puesto que con la configuracion que todos hemos indicado yo tengo funcionando sin problemas la adsl en otros routers con chip lantiq.


Sobre los puertos ethernet... ya sabemos que dos de ellos no funcionan (alternamente, creo que el 1 y el 3, no estoy seguro de si son estos dos u otros).

Yo he conseguido instalar paquetes correctamente con opkg. Como lo estás haciendo? Es posible que tengas un probelma de dns y no te resuelva el nombre del repositorio de paquetes?


barriteleves

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #134 en: 19-03-2014, 18:51 (Miércoles) »
hola doblecero grs por tu respuesta. pues no se si sera problema de dns, es posible pongo la que corresponde la proveedor de adsl 80-58-61-250 lo pongo junto con el cambio de ip inicial de 192.168.1.1 a por ejemplo 192.168.1.2 o 192.168.2.1 he probado con estas en el fichero network editado con winscp y salvado normalmente.

doblecero

  • Visitante
Re:
« Respuesta #135 en: 19-03-2014, 21:07 (Miércoles) »
Puedes ponernos aquí tu fichero de /etc/config/network (borra cualquier dato de tu acceso adsl)?

Enviado desde mi GT-I9300 mediante Tapatalk

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #136 en: 20-03-2014, 14:05 (Jueves) »
¿Habéis comprobado si sincroniza?
Código: [Seleccionar]
/etc/init.d/dsl_control statusEn caso de que sincronice saldrá algo parecido a esto:
Código: [Seleccionar]
root@OpenWrt:/etc/config# /etc/init.d/dsl_control status
Chipset:                Ifx-Danube 1.3
Line State:             UP [0x801: showtime_tc_sync]
Data Rate:              7.864 Mb/s / 667 Kb/s
Line Attenuation:       15.5dB / 8.7dB
Noise Margin:           8.8dB / 8.7dB
Line Uptime:            1m 9s

doblecero

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #137 en: 20-03-2014, 17:09 (Jueves) »
No sincroniza...
Sale todo a 0.

Estoy empezando a tener dudas de que el puerto adsl funcione.... es posible?
alguien sabe alguna forma de comprobar que el puerto funcione?


barriteleves

  • Visitante
Re:
« Respuesta #138 en: 20-03-2014, 23:32 (Jueves) »
hola doblecero dice:

Puedes ponernos aquí tu fichero de /etc/config/network (borra cualquier dato de tu acceso adsl)?

Enviado desde mi GT-I9300 mediante Tapatalk

pues aqui pongo copia del fichero /etc/config/network


Citar
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fd19:742e:8fb4::/48'

config interface 'lan'
   option ifname 'eth0'
   option type 'bridge'
   option proto 'static'
   option ipaddr '192.168.1.1'
   option netmask '255.255.255.0'
   option ip6assign '60'
   option macaddr 'xxxxxxxxxxxxxxxxx'
   option gateway '192.168.1.2'
   option dns '80.58.61.250'

config atm-bridge 'atm'
   option vpi '8'
   option vci '32'
   option encaps 'llc'
   option payload 'bridged'

config interface 'wan'
   option ifname 'nas0'
   option proto 'pppoe'
   option username 'adsl@telefonicanetpa'
   option password 'adslppp'
   option ipv6 '1'
   option macaddr 'xxxxxxxxxxxxxx'

config interface 'wan6'
   option ifname '@wan'
   option proto 'dhcpv6'


este es el ultimo que lo he intentado guardando algo de loque hay original cuando gravas la imagen por primera vez, tambien he probado a cambiar todo y dejar como en los ejemplos posteados anteriormente. y no he conseguido que conectara.


Pteridium, en cuanto tenga un rato libre el adsl lo pruebo y compruebo lo que me has comentado grs
« Última modificación: 21-03-2014, 02:09 (Viernes) por barriteleves »

barriteleves

  • Visitante
Re: [Desarrollo] OpenWrt en ASTORIA ARV7519RW22 - Livebox 2.1
« Respuesta #139 en: 21-03-2014, 09:09 (Viernes) »
bueno Pteridium aqui pongo el estado de dsl:

Citar
root@OpenWrt:~# /etc/init.d/dsl_control status
Chipset:                Lantiq-VRx n
Line State:             DOWN [0x0: not initialized]
Data Rate:              0 b/s / 0 b/s
Line Attenuation:       0.0dB / 0.0dB
Noise Margin:           0.0dB / 0.0dB
Line Uptime:            down
root@OpenWrt:~#

un saludo