Autor Tema: has detectado una version nueva , ...avisanos.  (Leído 221269 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: has detectado una version nueva , ...avisanos.
« Respuesta #180 en: 12-11-2014, 22:08 (Miércoles) »
@USUARIONUEVO

Seria interesante tener el siguiente script en la distro.

slpkg 2.0.4

Utility for easy management packages in Slackware

Salu2

te la concedo ,por que ocupa solo 14 kas  ;)

la incluire esta noche en iso desarrollo.



Garcad

  • Visitante
Re: has detectado una version nueva , ...avisanos.
« Respuesta #181 en: 13-11-2014, 20:56 (Jueves) »
@USUARIONUEVO

A la función de buscar dependencias le falta la base de datos.

wifislax ~ # slackyd -u
Repository: slackware [www.slackware.at]
`- Downloading FILELIST.TXT [Already update]            

wifislax ~ #

Sin la base de datos da error.

Salu2
« Última modificación: 13-11-2014, 20:57 (Jueves) por Garcad »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: has detectado una version nueva , ...avisanos.
« Respuesta #182 en: 15-11-2014, 05:18 (Sábado) »
@USUARIONUEVO

A la función de buscar dependencias le falta la base de datos.

wifislax ~ # slackyd -u
Repository: slackware [www.slackware.at]
`- Downloading FILELIST.TXT [Already update]            

wifislax ~ #

Sin la base de datos da error.

Salu2

no entiendo lo que dices.

slackyd -d

que es para buscar dependencias , no me da ningun error.

Garcad

  • Visitante
Re: has detectado una version nueva , ...avisanos.
« Respuesta #183 en: 15-11-2014, 19:46 (Sábado) »
@USUARIONUEVO

Cuando busca las dependencias rotas recién instalado el S.O. en el hdd no da opción a repararlas ya que no contiene el directorio y archivos que acompañan a la acción #slackyd -u

En el directorio /var/slackyd/slackware/ le faltan archivos que necesita para permitirte instalar el paquete que cree necesario para reparar la dependencia rota.

Código: [Seleccionar]
.:
total 46432
-rw-r--r-- 1 root root       77 nov 15 19:30 backup.7z
-rw-r--r-- 1 root root   793199 nov 15 19:31 CHECKSUMS.md5
-rw-r--r-- 1 root root        0 nov 15 19:31 contenido.txt
drwxrwxrwx 2 root root     4096 nov 15 19:31 extra
-rw-r--r-- 1 root root  1051290 nov 15 19:31 FILELIST.TXT
-rw-r--r-- 1 root root 42130920 nov 15 19:31 MANIFEST
-rw-r--r-- 1 root root  2889186 nov 15 19:31 MANIFEST.bz2
-rw-r--r-- 1 root root   663145 nov 15 19:31 PACKAGES.TXT
drwxrwxrwx 2 root root     4096 nov 15 19:31 patches

./extra:
total 0

./patches:
total 220
-rw-r--r-- 1 root root 192512 nov 15 19:31 MANIFEST.bz2.part
-rw-r--r-- 1 root root  30371 nov 15 19:31 PACKAGES.TXT

wifislax ~ # slackyd -d

Checking... compruebo todos paquetes instalados.

Cuando termina intenta buscar una librería x y da el error siguiente.

Searching libkdeui.so.4:

Error, no MANIFEST files found.
Try to update or fix your slackyd.conf.


wifislax ~ #

MODIFICADO

wifislax ~ # slackyd -u

Repository: slackware [www.slackware.at]
`- Downloading FILELIST.TXT [100 % @ 196.6 KB/s]    
`- Downloading CHECKSUMS.md5 [100 % @ 188.3 KB/s]    
`- Downloading PACKAGES.TXT [100 % @ 189.6 KB/s]    
`- Downloading MANIFEST.bz2 [100 % @ 203.4 KB/s]    
>> Uncompressing MANIFEST.bz2: done.
`- Downloading patches PACKAGES.TXT [100 % @ 56.8 KB/s]    
`- Downloading patches MANIFEST.bz2 [100 % @ 206.6 KB/s]    
>> Uncompressing patches MANIFEST.bz2: done.
`- Downloading extra PACKAGES.TXT [100 % @ 95.9 KB/s]    
`- Downloading extra MANIFEST.bz2 [100 % @ 87.8 KB/s]    
>> Uncompressing extra MANIFEST.bz2: done.

wifislax ~ #

wifislax ~ # slackyd -d

Checking... compruebo todos paquetes instalados.

Cuando termina.

Found 12 missing dependencies:

Searching libkdeui.so.4: nothing found.
Searching libkdecore.so.4: nothing found.
Searching libqt-mt.so.3: nothing found.
Searching libkio.so.4: nothing found.
Searching libjawt.so: found 1 package.
Searching libkabc.so.1: nothing found.
Searching libavcodec.so.56: nothing found.
Searching libavutil.so.54: nothing found.
Searching libavformat.so.56: nothing found.
Searching libavdevice.so.56: nothing found.
Searching libswscale.so.3: nothing found.
Searching libx264.so.142: nothing found.

Download gcc-java-4.8.2-i486-1.txz [from slackware] ? [y/N] n

Nothing was choosed

Parche temporal.

wifislax / # ln -s /usr/lib/libkdeui.so.5 /usr/lib/libkdeui.so.4
wifislax / # ln -s /usr/lib/libkdecore.so.5 /usr/lib/libkdecore.so.5
wifislax / # ln -s /usr/lib/libkdecore.so.5 /usr/lib/libkdecore.so.4
wifislax / # ln -s /usr/lib/libkabc.so.4 /usr/lib/libkabc.so.1
wifislax / # ln -s /usr/lib/libavcodec.so.55 /usr/lib/libavcodec.so.56
wifislax / # ln -s /usr/lib/libavutil.so.52 /usr/lib/libavutil.so.54
wifislax / # ln -s /usr/lib/libavformat.so.55 /usr/lib/libavformat.so.56
wifislax / # ln -s /usr/lib/libavdevice.so.55 /usr/lib/libavdevice.so.56
wifislax / # ln -s /usr/lib/libswscale.so.2 /usr/lib/libswscale.so.3
wifislax / # ln -s /usr/lib/libx264.so.138 /usr/lib/libx264.so.142
wifislax / #

Salu2
« Última modificación: 15-11-2014, 20:19 (Sábado) por Garcad »

Garcad

  • Visitante
Re: has detectado una version nueva , ...avisanos.
« Respuesta #184 en: 15-11-2014, 19:52 (Sábado) »
@USUARIONUEVO

La ultima versión de desarrollo de Wifislax me da error, una vez instalado el S.O. y el grub al iniciar desde el hdd no encuentra x archivo del grub.

Testado instalación kde normal, y kde pae.

wifislax-4.9-13112014.iso
md5 : f41e2de3bfae8d6543a295c4744cf80b
sha256 : 4ec0dbf737512435f325ab25161608ba7b22f17be4cc3be06dd5a9f899473a51

Echo en falta la posibilidad de comprobar que el archivo descargado esta bien descargado.

Salu2

sol666

  • Visitante
Re: has detectado una version nueva , ...avisanos.
« Respuesta #185 en: 15-11-2014, 20:00 (Sábado) »
@USUARIONUEVO

Seria interesante tener el siguiente script en la distro.

slpkg 2.0.4

Utility for easy management packages in Slackware

Salu2

te la concedo ,por que ocupa solo 14 kas  ;)

la incluire esta noche en iso desarrollo.
e estado probando el slpkg segun el manual con
slpkg -s sbo brasero me da error,con slpkg -s sbo dvdstyler tambien al intentar compilar ffmpeg,¿eso es porque los slackbuilds estan mal?
tambien he probado con
~ # slpkg -s slack brasero --current
                                                                              
Packages with name matching [ brasero ]                                      
                                                                              
Reading package lists .............................Done

No such package brasero: No matching

~ # slpkg -s slack dvdstyler

Packages with name matching [ dvdstyler ]

Reading package lists .............................Done

No such package dvdstyler: No matching
slpkg -s slacky dvdstyler

NEWS in ChangeLog.txt
slpkg ...initialization
Files re-created ...Done

Packages with name matching [ dvdstyler ]

Reading package lists ...Done
Resolving dependencies ......Done

No such package dvdstyler: No matching

slpkg -s rlw dvdstyler

Packages with name matching [ dvdstyler ]

Reading package lists ...Done
Resolving dependencies .....Done

No such package dvdstyler: No matching

esto significa que no esta en ninguno de los repositorios o hay que configurar algo?


Garcad

  • Visitante
Re: has detectado una version nueva , ...avisanos.
« Respuesta #186 en: 15-11-2014, 20:23 (Sábado) »
esto significa que no esta en ninguno de los repositorios o hay que configurar algo?

Los comandos no son los correctos.

Para actualizar slpkg

# slpkg -s sbo slpkg
 
Repositorios disponibles en la versión 2.0.4

      Slackware = slack '--current'
      Alien = alien '--current'
      SlackBuilds = sbo
      Slacky = slacky
      Robby's = rlw

slpkg -s slack [package...]
slpkg -s alien [package...]
slpkg -s sbo [package...]
slpkg -s slacky [package...]
slpkg -s rlw [package...]

Para brasero necesita tener instaldo gtk-doc

# wget -c https://download.gnome.org/sources/gtk-doc/1.21/gtk-doc-1.21.tar.xz
# tar -Jxf gtk-doc-1.21.tar.xz
# cd gtk-doc-1.21
# ./configure
# make
# make install


wifislax / # slpkg -s sbo brasero
Reading package lists ........Done

The following packages will be automatically installed or upgraded
with new version:

+==============================================
| Package                              Version          Arch         Repository
+==============================================
Installing:
 brasero                                 3.11.3           i486         SBo
Installing for dependencies:
 orc                                        0.4.22           i486         SBo
 gstreamer1                           1.4.1             i486         SBo
 gst1-plugins-base                 1.4.1             i486         SBo
 gst1-plugins-bad                   1.4.1             i486         SBo
 libunique                               1.1.6             i486         SBo

Installing summary
==============================================
Total 6 packages.
4 packages will be installed, 1 allready installed and 1 package
will be upgraded.

Do you want to continue [Y/n]? n
wifislax / #

Verde: Instalada la misma versión que en el repositorio.
Rojo: Paquete no instalado.
Naranja: Instalado pero es una versión diferente.

'--current' Se refiere a la versión actual.

Si a la pregunta ... Do you want to continue [Y/n]? le contestamos con Y e INTRO.

Descarga todas las dependencias y paquetes que necesite inclusive las que están en naranja.

Si no queremos que nos desinstale cualquier paquete en naranja lo podemos añadir a la lista negra.

wifislax / # slapt-get -search libunique
libunique-3.0.2-i486-1sw [inst=sí]: (null)
wifislax / #

# slpkg -b libunique --add

En este caso opto por no quitar libunique del sistema y veremos si da error o no luego el brasero.

Iniciamos la instalacion del brasero

wifislax / # slpkg -s sbo brasero
Do you want to continue [Y/n]? Y e INTRO

Para dvdstyler

wifislax / # slpkg -s sbo dvdstyler


Salu2
« Última modificación: 15-11-2014, 21:13 (Sábado) por Garcad »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: has detectado una version nueva , ...avisanos.
« Respuesta #187 en: 15-11-2014, 21:00 (Sábado) »
dejarse d emariconadas, hay un updater para brasero ...en SU ULTIMA VERSION ,...


si usais ese tipo de gestores, vais a morir a la version que haya en el repositorio ,que siempre dista mucho de ser la mas nueva.



Garcad

  • Visitante
Re: has detectado una version nueva , ...avisanos.
« Respuesta #188 en: 15-11-2014, 21:11 (Sábado) »
dejarse d emariconadas, hay un updater para brasero ...en SU ULTIMA VERSION ,...


si usais ese tipo de gestores, vais a morir a la version que haya en el repositorio ,que siempre dista mucho de ser la mas nueva.


Te ahorra mucho trabajo, ahora que tengo lives 2.2.2 instalado ya puedo compilar la ultima versión 2.2.6 sabiendo que no me faltaran muchas dependencias

Lo mismo con OpenShot

Salu2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: has detectado una version nueva , ...avisanos.
« Respuesta #189 en: 15-11-2014, 23:52 (Sábado) »
ACABO DE INSTALAR LA ISO , sin problemas de ningun tipo al hdd

y zero dependencias rotas.

as que , no se...   ???

Garcad

  • Visitante
Re:
« Respuesta #190 en: 16-11-2014, 00:31 (Domingo) »
¿Hay md5 de la iso para verificar que se descargo bien?

Enviado desde mi HM NOTE 1W mediante Tapatalk


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re:
« Respuesta #191 en: 16-11-2014, 00:31 (Domingo) »
¿Hay md5 de la iso para verificar que se descargo bien?

Enviado desde mi HM NOTE 1W mediante Tapatalk



No estoy en casa ....

mañana subire otra.

Garcad

  • Visitante
Re:
« Respuesta #192 en: 16-11-2014, 00:33 (Domingo) »
Hay nuevo kernel. ¿Has comprobado si compila bien?

Salu2

Enviado desde mi HM NOTE 1W mediante Tapatalk


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re:
« Respuesta #193 en: 16-11-2014, 00:42 (Domingo) »
Hay nuevo kernel. ¿Has comprobado si compila bien?

Salu2

Enviado desde mi HM NOTE 1W mediante Tapatalk



¿donde hay nuevo kernel?  ...

la iso ya lleva el ultimo desde hace dias

longterm:    3.12.32    2014-11-05


Vas ultradesfasado ...  lo de las dependencias que decias rotas igual , eso es de hace ya por lo menos una semana.
« Última modificación: 16-11-2014, 00:44 (Domingo) por USUARIONUEVO »

Garcad

  • Visitante
Re:
« Respuesta #194 en: 16-11-2014, 00:49 (Domingo) »
Hay nuevo kernel. ¿Has comprobado si compila bien?

Salu2

Enviado desde mi HM NOTE 1W mediante Tapatalk



¿donde hay nuevo kernel?  ...

la iso ya lleva el ultimo desde hace dias

longterm:    3.12.32    2014-11-05


Vas ultradesfasado ...  lo de las dependencias que decias rotas igual , eso es de hace ya por lo menos una semana.

Yo creo que no lo estoy.

wifislax ~ # uname -a
Linux wifislax 3.12.32-wifislax #1 SMP PREEMPT Wed Nov 5 23:17:13 CET 2014 i686 Intel(R) Atom(TM) CPU N450   @ 1.66GHz GenuineIntel GNU/Linux
wifislax ~ #


Salu2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: has detectado una version nueva , ...avisanos.
« Respuesta #195 en: 16-11-2014, 01:18 (Domingo) »
entonces que dices de nuevo kernel ??

 ;D

Garcad

  • Visitante
Re: has detectado una version nueva , ...avisanos.
« Respuesta #196 en: 16-11-2014, 01:21 (Domingo) »
No me di cuenta que ya estábamos con el ultimo kernel.

El conocimiento no ocupa lugar y el desconocimiento lo deja vació.

Salu2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: has detectado una version nueva , ...avisanos.
« Respuesta #197 en: 16-11-2014, 01:26 (Domingo) »
No me di cuenta que ya estábamos con el ultimo kernel.

El conocimiento no ocupa lugar y el desconocimiento lo deja vació.

Salu2


yo buscando el 3.12.33  ...   ;D ;D ;D ;D

sol666

  • Visitante
Re: has detectado una version nueva , ...avisanos.
« Respuesta #198 en: 16-11-2014, 02:56 (Domingo) »
 ??? ??? ??? una cosita que no se si con los updaters pasara o por lo menos avisara,al actualizar dvdstyler con slpkg se ve que a actualizado alguna libreria creo que la x264 y ahora no me va el vlc,se oye pero no se ve
« Última modificación: 16-11-2014, 03:01 (Domingo) por sol666 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14489
Re: has detectado una version nueva , ...avisanos.
« Respuesta #199 en: 16-11-2014, 03:54 (Domingo) »
??? ??? ??? una cosita que no se si con los updaters pasara o por lo menos avisara,al actualizar dvdstyler con slpkg se ve que a actualizado alguna libreria creo que la x264 y ahora no me va el vlc,se oye pero no se ve

por que te habra "desactualizado"  x264

lo estoy avisando.

aora te toca volver a compilar vlc ...  ;D

//FINAL Y MÁS DOS RESPUESTAS