Autor Tema: [Tutorial] Receptor de radio Wi-Fi con OpenWrt  (Leído 174631 veces)

0 Usuarios y 1 Visitante están viendo este tema.

mojopicon

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #240 en: 07-11-2013, 12:36 (Jueves) »
Código: [Seleccionar]
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-audio:
 * kernel (= 3.10.18-1-8d035f231ca216c7f05cb7440630ceca) * kernel (= 3.10.18-1-8d035f231ca216c7f05cb7440630ceca) *
 * opkg_install_cmd: Cannot install package kmod-usb-audio.


El paquete te está pidiendo una versión del kernel distinta a la que tienes. Puedes intentar pasar por alto la advertencia y forzar la instalación con:
Código: [Seleccionar]
opkg install -force-depends kmod-usb-audio

Probablemente te lo instale sin mayor problema, de todas formas si vas a seguir instalando paquetes a mano, lo más seguro es que te siga dando la lata con lo mismo. La mejor opción sin duda es compilarte el firmware de entrada con todos los paquetes que necesites.


« Última modificación: 07-11-2013, 12:37 (Jueves) por mojopicon »

pikomule

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #241 en: 07-11-2013, 12:47 (Jueves) »
ya lo he instalado como indicas.

No me detecta la tarjeta, me indica esto:

root@OpenWrt:~# ls /dev/a*
ls: /dev/a*: No such file or directory

mojopicon

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #242 en: 07-11-2013, 12:54 (Jueves) »
ya lo he instalado como indicas.

No me detecta la tarjeta, me indica esto:

root@OpenWrt:~# ls /dev/a*
ls: /dev/a*: No such file or directory

¿Has instalado todos los paquetes necesarios para el soporte usb (kmod-usb-core, kmod-usb-ohci,  kmod-usb2)?
Asegúrate de que el puerto está funcionando, a mi el 5387-un me ha dado bastantes problemas para que me funcione el usb correctamente. Haz un lsusb y si ahi no aparece listada la tarjeta, vuelve a pincharla y haz un dmesg a ver que dice.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4583
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #243 en: 07-11-2013, 12:58 (Jueves) »
pikomule, el tema de las dependencias del kernel se ha repetido ya muchísimas veces. Lo tienes explicado en el hilo de las FAQ.
Valoraciones positivas en compra/venta:
125 en Htcmania
158 en Har2mano
20 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

pikomule

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #244 en: 07-11-2013, 13:03 (Jueves) »
root@OpenWrt:~# lsusb
-ash: lsusb: not found

Gracias jar229, ya lo he leido.

No entiendo por que no reconoce el puerto USB

mojopicon

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #245 en: 07-11-2013, 13:06 (Jueves) »
root@OpenWrt:~# lsusb
-ash: lsusb: not found

Gracias jar229, ya lo he leido.

No entiendo por que no reconoce el puerto USB

Lo que te está diciendo no es que no reconozca el puerto, sino que no tienes instalado el comando lsusb (es otro paquete, instalable con opkg). Si te parece seguimos en el hilo del Ar-5387-un
https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-ar5387un/

pikomule

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #246 en: 07-11-2013, 13:24 (Jueves) »
creo que intentare compilar un firmware a ver si lo consigo, por que me da error al instalar cualquier dependencia.

segun dmesg si esta reconocido la tarjeta usb por usb-platform

ruloalg

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #247 en: 09-11-2013, 18:06 (Sábado) »
Hola de nuevo, tengo un problema al hacer funcionar la radio, estoy usando un h556a ver.a con el firmware Backport de danitool a la versión Attitude Adjustment ( uso esta para no tener problemas con las dependecias y funciona todo bien, el wifi, paquetes etc). En principio todo los pasos del tutorial sin ningún problema hasta reproducir que me dice "ERROR: problems opening audio device":
root@OpenWrt:~#  mpc play
http://giss.tv:8000/radiogodella98fm.mp3
[paused]  #1/1   0:00/0:00 (0%)
volume:100%   repeat: off   random: off   single: off   consume: off
ERROR: problems opening audio device

con otras fuentes pasa =.
la tarjeta (supongo que ahí estará el problema es una ds4201 audio dac estereo analógico que ya lleva altavoces que tenía abandonada, y debe ser mala con ganas eso si) la detecta tanto al poner  ls /dev/a* como el lsusb aunque a veces hay que volver a enchufarla o reiniciar sobretodo si tengo puesto otro usb.
 Bueno de momento creo voy a pedir esta http://onogal.com/electronica-e-informatica/tarjeta-de-sonido-7.1-externa-adaptador-audio-por-usb-2.0-cd-drivers-dj-pen-2186
que parece similar a la que poneís por aqui y debería funcionar ¿no?

raphik

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #248 en: 10-11-2013, 20:37 (Domingo) »
Hola ruloalg.

¿Estás seguro que la URL http://giss.tv:8000/radiogodella98fm.mp3 está activa? No consigo hacerla sonar con Winamp.
¿También te da el mismo error con otras emisoras?

En cuanto a las tarjetas de sonido USB, no todas son iguales. Yo he tenido mala experiencia con una comprada en DX (SKU 22475) a la que al poco tiempo dejó de funcionarle uno de los canales. Gratuitamente me enviaron otra exactamente igual, sólo que dejó de funcionar completamente. Actualmente estoy probando un modelo que trae unos pulsadores extra.

La que has elegido seguro que va a funcionar. Lo único: mira precios, que con la emoción compramos a cualquier precio y luego se nos queda la cara que se nos queda cuando la vemos más barata en otro sitio. Te lo digo por propia experiencia.
En tinydeal la tienes la misma por 3'25€, en DX por 2'52€ y en buyincoins por 1'35€
http://www.tinydeal.com/es/71-channel-sound-adapter-p-2509.html
http://dx.com/es/p/usb-virtual-7-1-channel-external-sound-card-adapter-101281
http://www.buyincoins.com/item/87.html

¡Suerte!

ruloalg

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #249 en: 11-11-2013, 19:48 (Lunes) »
 Buenas, si raphik creo este finde semana no estaba emitiendo, sería cosa de giss.tv que a veces no va o se colgaría el servidor y hasta el lunes no lo pone en marcha, no hay presupuesto para más.
 De todas formas al final probe enchufando la tarjeta de sonido/altavoces a un hub alimentado y ya que suena  >:(  ;D  si lo pongo directo o no suena o sale ese mensaje.
 Pues no ahora me he dado cuenta de que directamente también va, me debo haber hecho un lio con las fuentes el otro día, aunque también veo que me sale un mensaje en el registro: 
 amixer: Mixer default load error: Invalid argument 

 Pero en fin que funcionar funciona, creo voy a ponerlo todo desde cero de nuevo por si he empastrado algo poniendo paquetes y tal

 Gracias por los enlaces, en pprincipio elegí esa por no pagar por paypal y que llegaba rápido, ahora que ya veo que funciona la cosa no se si la pillaré lo miraré más e igual una de "marca" aunque más cara.

pUes nada gracias again y ahora a seguir probando cosas y mirar lo de los controles pero el paso importante ya esta hecho

teck

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #250 en: 13-11-2013, 23:03 (Miércoles) »
yo lo tengo funcionando en un Tplink MR3220 todo bien tuve que añadir estas lineas al config del mpd ya que no me agregaba los mp3 de una unidad externa.

Código: [Seleccionar]
log_level            "verbose"
auto_update    "yes"
auto_update_depth "3"
follow_outside_symlinks    "yes"
follow_inside_symlinks        "yes"

Se podrá equalizar el audio? o al menos escoger equalizaciones preestablecidas
« Última modificación: 13-11-2013, 23:06 (Miércoles) por teck »

raphik

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #251 en: 14-11-2013, 14:22 (Jueves) »
... Se podrá equalizar el audio? o al menos escoger equalizaciones preestablecidas

Por lo que parece, se puede. Yo nunca lo he intentado. Supongo que habría que incluir el plugin alsaequal en la compilación de OpenWrt.

https://patrick-nagel.net/blog/archives/180
http://www.thedigitalmachine.net/alsaequal.html

Un saludo.

raphik

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #252 en: 12-12-2013, 23:34 (Jueves) »
... Esta es la version disponible en ese repositorio "0.15.8-2", hay otro mas actual que soporte AAC? ...

Aunque el tema salió hace un par de meses, no he parado de darle vueltas. Estoy convencido de que mpd-full soporta flujos de audio AAC+ siempre que instalemos el paquete libfaad2 (y sospecho que también libffmpeg-full). El problema es que el HG553 no es lo bastante potente como para mover el códec en tiempo real: empieza a decodificar correctamente los dos primeros segundos hasta que se satura la CPU y luego empieza a "dar saltitos". Lo he comprobado instalando la utilidad cpusage y visualizando las cargas. Los porcentajes típicos de uso de CPU son del 18 % para mp3 y ¡¡del 100% para aac+!!
Libfaad2 utiliza FPU pero como el router no tiene, la emula por software y eso chupa mucha CPU.
Existe una versión de libfaad2 que no utiliza FPU. Me gustaría probarla a ver qué tal va, pero no soy capaz de compilarla.

Saludos.

danitool

  • Visitante
Re: [Tutorial] Receptor de radio Wi-Fi con OpenWrt
« Respuesta #253 en: 13-02-2014, 22:47 (Jueves) »
Hace tiempo que tenía cierto problema con triggerhappy. No siempre pero la mayoría de veces me repetía los comandos dos veces. No sé si soy el único ****** que tiene este problema porque no vi que nadie se quejase de ello. Ultimamente veo muchas chapuzas con lo relacionado a OpenWrt.

El caso es que creo uqe lo solucioné. El script de inicio parece estar mal. A continuacion pongo el script corregido.

/etc/init.d/triggerhappy
Código: [Seleccionar]
#!/bin/sh /etc/rc.common
START=93

start() {
/usr/sbin/thd --socket /tmp/triggerhappy.socket --triggers /etc/triggerhappy/triggers.d/ --daemon
}

stop() {
/usr/sbin/th-cmd --socket /tmp/triggerhappy.socket --quit
}



Sobre la versión de libfaad2 que no utiliza FPU, eso donde se puede encontrar?, o es una versión compilada con ciertos flags?

Saludos


Pteridium

  • Visitante
Re: [Tutorial] Radio Wi-Fi con OpenWrt
« Respuesta #254 en: 14-02-2014, 12:50 (Viernes) »
... Esta es la version disponible en ese repositorio "0.15.8-2", hay otro mas actual que soporte AAC? ...

Aunque el tema salió hace un par de meses, no he parado de darle vueltas. Estoy convencido de que mpd-full soporta flujos de audio AAC+ siempre que instalemos el paquete libfaad2 (y sospecho que también libffmpeg-full). El problema es que el HG553 no es lo bastante potente como para mover el códec en tiempo real: empieza a decodificar correctamente los dos primeros segundos hasta que se satura la CPU y luego empieza a "dar saltitos". Lo he comprobado instalando la utilidad cpusage y visualizando las cargas. Los porcentajes típicos de uso de CPU son del 18 % para mp3 y ¡¡del 100% para aac+!!
Libfaad2 utiliza FPU pero como el router no tiene, la emula por software y eso chupa mucha CPU.
Existe una versión de libfaad2 que no utiliza FPU. Me gustaría probarla a ver qué tal va, pero no soy capaz de compilarla.

Saludos.
Pues da la impresión que has llegado al límite de la cpu, aunque no indicas cuánto consume de memoria, pero no creo que sea el caso.
El BCM6358 es un SoC obsoleto con una cpu BMIPS4500 bastante "vieja", aunque en la mayoría de las cosas sigue haciendo su función. Sería interesante probar cómo va la descompresión de AAC+ en un BCM6328 ya que su cpu es más moderna, y si aun así se queda corto, en algún otro router que tenga un SoC con aceleración dsp como el Lantiq Danube o el Ralink RT3052 (los cores mips 24KEc, 34Kc y posteriores tienen unas extensiones, llamadas dsp y dspr2 parecidas a las MMX, para acelerar algunos cálculos).
También se puede probar, si el problema no es la memoria, a cambiar la flag del compilador -Os por -O2, además de probar con otras versiones superiores de GCC o con eglibc en vez de uclibc.
En resumen: has llegado al tope del HG553.  ;)

raphik

  • Visitante
Re: [Tutorial] Receptor de radio Wi-Fi con OpenWrt
« Respuesta #255 en: 11-03-2014, 13:20 (Martes) »
... Sobre la versión de libfaad2 que no utiliza FPU, eso donde se puede encontrar?, o es una versión compilada con ciertos flags?
...

Échale un vistazo a este post: https://forum.openwrt.org/viewtopic.php?pid=205026#p205026

La parte interesante es la que dice:

Código: [Seleccionar]
If you want to play aac radio streams smoothly you should create the following patch with subdir (https://dev.openwrt.org/ticket/9645):
mkdir package/feeds/packages/faad2/patches/package/feeds/packages/faad2/patches/100-define-fixed-point.patch:

Index: faad2-2.7/libfaad/common.h
===================================================================
--- faad2-2.7.orig/libfaad/common.h     2009-02-05 03:51:03.000000000 +0300
+++ faad2-2.7/libfaad/common.h  2013-06-19 13:02:09.447526662 +0400
@@ -65,7 +65,7 @@
 /* use double precision */
 /* #define USE_DOUBLE_PRECISION */
 /* use fixed point reals */
-//#define FIXED_POINT
+#define FIXED_POINT
 //#define BIG_IQ_TABLE

 /* Use if target platform has address generators with autoincrement */

then recompile faad2 and install new package on your openwrt. Now aac playing takes approximately 60% CPU (was 100%)
Or you can use latest faad2 Makefile: https://dev.openwrt.org/changeset/34527

Saludos.



danitool

  • Visitante
Re: [Tutorial] Receptor de radio Wi-Fi con OpenWrt
« Respuesta #256 en: 11-03-2014, 19:38 (Martes) »
No parece complicado portar eso a versiones anteriores que no lo tengan. Precisamente hace poco monté una wifi radio con un AR5381u (bcm6328) y los flujos aac iban muy fluidos, creo que no sobrepasaba el 60% de consumo de CPU, pero en una versión en la que ya está incluido ese fix.

En mi opinión creo que el hg556 tal vez pueda con aac, pero no lo probé. Lo que sí probé en ese router fue archivos flac pesados de alta calidad, e iba como la seda, eso sí usando la tasa de muestreo cutre de la tarjeta 16bit/44100 kHz.

¿Ahora mismo que versión estás usando para la wifi-radio?.

Sobre lo de lirc audio-alsa tengo un apaño que funciona, para las versiones recientes que resultaba que iba cuando le venia en gana. El tema lo comenté en un par de sitios:
http://permalink.gmane.org/gmane.comp.embedded.openwrt.devel/23111
https://forum.openwrt.org/viewtopic.php?pid=226923#p226923

Aunque curiosamente recientemente cambié de Backfire a AA-12.03 en mi viejo livebox1, con una compilación personalizada (en la que quité gran cantidad de cosas ya que solo tiene 16 RAM) y no registré el problema con lirc, va tan perfecto que asusta, hasta poniéndole un calcetín en encima del módulo IR funciona  >:D


raphik

  • Visitante
Re: [Tutorial] Receptor de radio Wi-Fi con OpenWrt
« Respuesta #257 en: 12-03-2014, 08:29 (Miércoles) »
¿Ahora mismo que versión estás usando para la wifi-radio?.

La AA12.09 en un HG553.
« Última modificación: 12-03-2014, 08:31 (Miércoles) por raphik »

raphik

  • Visitante
Re: [Tutorial] Receptor de radio Wi-Fi con OpenWrt
« Respuesta #258 en: 13-03-2014, 12:48 (Jueves) »
Tras compilar OpenWRT BBr39908 para el Comtrend AR5387-un, me he llevado la gran sorpresa de que reproduce flujos AAC "sin saltitos" de audio.

Saludos.
« Última modificación: 23-03-2014, 20:26 (Domingo) por raphik »

raphik

  • Visitante
Re: [Tutorial] Receptor de radio Wi-Fi con OpenWrt
« Respuesta #259 en: 21-03-2014, 14:45 (Viernes) »
¡Sorpresa! Ahora, con la última versión del trunk, el hg553 reproduce AAC sin saltos.
Compilación BB r40006 para radio wifi con mpc, mpd, relayd y algunas cosillas más.
Saludos.
« Última modificación: 23-03-2014, 22:26 (Domingo) por raphik »