Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 616978 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado jmarcet

  • **
  • Mensajes: 2
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1280 en: 10-06-2019, 15:11 (Lunes) »
El proceso es algo complicado, tienes que compilar tu propio OpenWRT para el router que uses.

Podría compartir el build para el que uso yo, un Netgear R7800, si le puede interesar a alguien. Sólo me falta incluir el tvheadend para que sea completo al 100%.

O, si me dices que modelo de router tienes, en cuanto tenga un rato puedo hacer un build para él.



Desconectado yonoesio

  • **
  • Mensajes: 9
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1281 en: 12-06-2019, 06:52 (Miércoles) »
Es un linksys WRT1900AC V1.

Gracias!

Desconectado ppfdez

  • **
  • Mensajes: 6
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1282 en: 18-06-2019, 21:31 (Martes) »
X jmarcet

Tengo los conocimientos básicos para compilar. Hace un par de años lo hice para el Observa Telecom VH4032N cuando no tenía soporte.
No tengo ni idea, ni siquiera en teoria, de como aplicar parches. ¿Podrías indicarnos los principios básicos o algun tutorial completo donde se trate su aplicación?

Gracias.
« Última modificación: 25-06-2019, 12:39 (Martes) por ppfdez »

Desconectado Foguet

  • **
  • Mensajes: 2
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1283 en: 30-07-2019, 15:02 (Martes) »
Hola,
No se si le pasa a alguien más pero con la configuración que realiza el script (no me modificado nada) en las últimas 2 semanas al ver la tele a los 20 segundos se para la emisión. Me pasa en todas las cadenas con el deco oficial.

Tengo un router Turris Omnia con la versión 15.05 de openwrt.

¿Como puedo hacer pruebas de depuración? Imagino que alguna ruta se perderá

Desconectado yonoesio

  • **
  • Mensajes: 9
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1284 en: 30-07-2019, 19:17 (Martes) »
Hace unos días me pasó lo mismo en una instalación limpia (18.06.4) en un WRT1900 v1. Si cambiaba de canal funcionaba 20 segundos y volvía a congelarse. Reiniciando varias veces router y deco al final dejo de fallar.

Desconectado Foguet

  • **
  • Mensajes: 2
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1285 en: 31-07-2019, 10:59 (Miércoles) »
Hace unos días me pasó lo mismo en una instalación limpia (18.06.4) en un WRT1900 v1. Si cambiaba de canal funcionaba 20 segundos y volvía a congelarse. Reiniciando varias veces router y deco al final dejo de fallar.
Exacto! Eso mismo tengo que hacer reiniciar y no una sino varias veces hasta que funciona lo cual es bastante coñazo... más cuando casi toda mi casa depende de la wifi  ;D

Por cierto tenemos el mismo router WRT1900 v1 pero ese ahora está en casa de mis padres... la de peleas que me dió en su día  :-\

Desconectado yonoesio

  • **
  • Mensajes: 9
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1286 en: 25-08-2019, 08:40 (Domingo) »
Hace un par de días cambié el WRT1900AC V1 por un WRT3200ACM.
El el WRT1900AC si quería VOD tenia que desactivar el Flow Offloading, con lo que no alcanzaba los 600/600. En ocasiones, la imagen de la tele se pixelaba, saltaba el sonido. Eran muy pocas veces pero molestaba.

Con el WRT3200ACM me funciona "casi" todo sin hacer nada raro (de hecho traspasé la mayor parte de la config del 1900AC). Lo que sigue sin funcionar es el control del directo.

Hice instalación nueva, por si acaso, con la imagen de davidc502 y el script de Noltari, pero todo funciona igual.

Espero que algún día encuentren el por qué no funcionan los controles del directo. Por mi parte no le doy mas vueltas.

Saludos!

Desconectado ppfdez

  • **
  • Mensajes: 6
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1287 en: 27-09-2019, 21:49 (Viernes) »
Por fin lo tenemos. Tengo el antiguo imagenio funcionando sobre el actual snapshot (OpenWrt SNAPSHOT, r11119-442ecce761) con todas sus funcionalidades, incluidos por suspuesto los controles del directo.

Para ello hay que compilar. Esto es relativamente sencillo disponiendo de una máquina real o virtual con una distribución de linux reciente. Con Debian 7 Wheezy no va, a mi me funcionó con Debian 10 buster y con este da un error al compilar desde root, hay que hacerlo desde un usuario o como yo hice desde root, tecleando "export FORCE_UNSAFE_CONFIGURE = 1". Con el manual de la wiki de OpenWRT se puede llegar a conseguirlo.

Hay que instalar lo consabido sobradamente siguiendo el hilo con la nueva casuistica a partir de las ediciones 18 de OpenWRT de bird1-ipv4 en vez de bird, la ausencia de kmod-bridge que ya no hace falta, la variable net.netfilter.nf_conntrack_helper = 1 y el problemón para mi, de parchear (GRACIAS Luispa y JMarcet -ver pagina anterior del hilo-) kmod-ipt-nathelper-rtsp , en realidad parchear conntrack_rtsp.c . En este punto habría que seguir el manual malo referente al parcheo de la wiki. IMPOSIBLE..IMPOSIBLE para mi.

Desesperado, decido parchear a mano porque se ve que es poco. Buscando mucho observo en el build kit de openwrt que  "nf_conntrack_rtsp.c" esta en la ruta (compilo para una configuración orange pi zero plus + un switch programable de 8 bocas a Gbit):

./build_dir/target-aarch64_cortex-a53_musl/linux-sunxi_cortexa53/xtables-addons-3.3/extensions/rtsp/nf_conntrack_rtsp.c

que se crea, gran descubrimiento viendo un ejemplo de parche, a partir de un parche "100-add-rtsp-conntrack.patch" que no parchea nada sino que crea unos pocos de ficheros de la nada, que no existían, lo que se podría decir que es un parcheo más que total, totalísimo, asombrado me quedé. Este parche esta en la ruta:

./feeds/packages/net/xtables-addons/patches/100-add-rtsp-conntrack.patch

Así que habría que "parchear un parche" y por eso a lo mejor todos los cabezazos con el manual de la wiki sobre el tema.

Se me ocurre entonces aplicar el parche editando el archivo 100-add-rtsp-conntrack.patch con las 2 modificaciones de sustituir
+-                                nf_ct_l3num(ct), &srvaddr,
por
++                                nf_ct_l3num(ct), NULL, //&srvaddr
en las 2 ocasiones que aparece.


A partir de ahí make j5 V=s y vualá el nf_conntrack_rtsp.c parcheado esperando que el módulo de la imagen tambien.

Quemo la SD, y al nuevo sistema le meto la configuración totalmente funcional LEDE 17.04 sobre banana pi. Pruebo y maravilla, por fin: Imagenio con todas sus funcionalidades incluidas la pausa, el play, el rebobinado y el ver desde el incio, para las transmisiones en directo. Como Nadal me sentí cuando se tira a la pista de tierra batida, de espaldas al suelo, mirando al cielo.
« Última modificación: 27-09-2019, 21:58 (Viernes) por ppfdez »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4586
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1288 en: 29-09-2019, 20:11 (Domingo) »
Como Nadal me sentí cuando se tira a la pista de tierra batida, de espaldas al suelo, mirando al cielo.

 >:( >:( >:(
Valoraciones positivas en compra/venta:
130 en Htcmania
174 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

Desconectado yonoesio

  • **
  • Mensajes: 9
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1289 en: 30-09-2019, 14:09 (Lunes) »
Lo comenté con davidc502 y parece que lo va a incluir en sus próximas versiones para los routers WRT

Desconectado apocalypse

  • **
  • Mensajes: 7
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1290 en: 01-10-2019, 04:24 (Martes) »
Buenas. Voy a hacerme con Edgerouter X en breve y tengo varias dudas con el tema del VOD/TimeShift (Pausar, Rebobinar, etc el directo).

¿Es necesario parchear nf_conntrack_rtsp.c también para OpenWRT 17.01.x o sólo para la 18.06.x?
¿El timeshift no funciona en la 18.06 ni parcheando rtsp si se activa el hardware offload (MT7621)?

Otra cosa, por defecto tendré todo el tráfico input y forward de la vlan2 rechazado (soy un poco maniático con la seguridad), con dos reglas permisivas: IGMP entrante, y forwarding del tráfico multicast desde 172.16.0.0/12 a 224.0.0.0/4 en la LAN. Así lo tenía en el HG556a con chaos calmer y funcionaba perfectamente VLC y el addon de MovistarTV de Kodi, incluído el EPG. Mi duda es si para el deco hará falta alguna regla más para el tema del VOD.
« Última modificación: 01-10-2019, 04:39 (Martes) por apocalypse »

Desconectado ppfdez

  • **
  • Mensajes: 6
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1291 en: 01-10-2019, 23:09 (Martes) »
X apocalypse

¿Es necesario parchear nf_conntrack_rtsp.c también para OpenWRT 17.01.x o sólo para la 18.06.x?

Solo para los 18.06.X. Yo lo he tenido funcionando meses sin problemas con un LEDE 17.01.4 sobre una banana pi con todas las funcionalidades del Imagenio incluidos los controles del directo y por supuesto sin parche alguno.

¿El timeshift no funciona en la 18.06 ni parcheando rtsp si se activa el hardware offload (MT7621)?

No te puedo decir ya que si lo activo en modo software, en la orange pi zero plus no hay switch, pierdo la navegación por internet y no he seguido probando. Tiene 4 nucleos ARM 64 bits a 1 GHz y no hace falta activarlo para tener un alto throughput

Otra cosa, por defecto tendré todo el tráfico input y forward de la vlan2 rechazado (soy un poco maniático con la seguridad), con dos reglas permisivas: IGMP entrante, y forwarding del tráfico multicast desde 172.16.0.0/12 a 224.0.0.0/4 en la LAN. Así lo tenía en el HG556a con chaos calmer y funcionaba perfectamente VLC y el addon de MovistarTV de Kodi, incluído el EPG. Mi duda es si para el deco hará falta alguna regla más para el tema del VOD.

No te puedo decir. Échalo a andar primero y preocúpate después de "cerrar puertas".
« Última modificación: 02-10-2019, 22:52 (Miércoles) por ppfdez »

Desconectado apocalypse

  • **
  • Mensajes: 7
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1292 en: 02-10-2019, 01:17 (Miércoles) »
Gracias ppfdez. Como tengo 100Mbps simétricos creo que le pondré la 17.01.7 a pesar de no soportar nat offloading. Más adelante compilaré una 18.06.2 (la 18.06.4 he leído que causa reinicios al cabo de varios dias con el HW NAT offloading) con el parche y probaré a ver si funciona o no.

Desconectado apocalypse

  • **
  • Mensajes: 7
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1293 en: 18-10-2019, 04:39 (Viernes) »
De momento estoy con la 17.01.7 que compilé con un parche de NAT offloading (Fast Path o SFE de Qualcomm). La TV funciona al 100% con el módulo kmod-ipt-nathelper-rtsp sin parchear. Las reglas del firewall como comenté. Muy contento de momento con el ER-X en OpenWRT. Con el parche no usa ni 8% de CPU con la conexión a tope.

Lo que tengo es un problema con las VLAN y un Switch gestionable que comentaré en otro tema.

Desconectado yonoesio

  • **
  • Mensajes: 9
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1294 en: 09-11-2019, 10:50 (Sábado) »
Pues al final me he decidido a compilar una versión a medida para mi router. Por fin me funciona el timeshift.
Si tienes un poco de idea de linux y alguna vez has compilado un kernel, tampoco es tan dificil.

Desconectado apocalypse

  • **
  • Mensajes: 7
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1295 en: 11-11-2019, 08:15 (Lunes) »
Estoy probando la última snapshot de OpenWRT 19.07 y funciona tanto los contenidos VOD como el control del directo sin tener que parchear. Además funciona también con el SW/HW Flow Offload activado.
« Última modificación: 11-11-2019, 10:16 (Lunes) por apocalypse »

Desconectado yonoesio

  • **
  • Mensajes: 9
Re:[Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
« Respuesta #1296 en: 13-11-2019, 19:35 (Miércoles) »
Abrí un PR en Git para que modificasen el parche para tener timeshift. No he tenido tiempo para hacerlo correctamente, pero otro usuario vió la apertura de la issue y el PR y lo ha lanzado él.
Parece que lo van a incluir.