Autor Tema: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt  (Leído 316379 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #40 en: 08-10-2012, 17:20 (Lunes) »
Del astoria, ni idea ... ???

Enviado desde mi U30GT-H usando Tapatalk 2


Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

elmasvital

  • Visitante
Re: Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #41 en: 08-10-2012, 18:23 (Lunes) »
Del astoria, ni idea ... ???

Enviado desde mi U30GT-H usando Tapatalk 2

WAUUUU acabo de hacerlo funcionar ACTIVANDO el firewall o_O en el astoria arv7518pw

PD: Voy a irme a dar una vuelta me afectado un poco :-D

Edito: Lo confimo. Si se inicia el router con el demonio firewall activado funciona el modo cliente wifi hacia el ethernt. Si lo enciendo con el firewall apagado no funciona hasta que se activa. Si se ha arrancado con el demonio activado y se detiene sigue funcionando sin problemas. Alguna idea del por qué de este comportamiento?
« Última modificación: 08-10-2012, 20:09 (Lunes) por elmasvital »

jbconpepsi

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #42 en: 10-10-2012, 13:31 (Miércoles) »
Hola a todos, ¿Sabéis si puedo conectar mediante WDS un comtrend ar5387un y un HG556a con openwrt y chipset atheros con seguridad wpa o al no tener el mismo chip me olvido del tema?
Lo he intentado como dice el compañero Elnef pero en modo cliente me pilla señal y en modo ap se queda sin señal.

¿Alguna idea?

Gracias y saludos.

Noltari

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #43 en: 10-10-2012, 14:49 (Miércoles) »
Hola a todos, ¿Sabéis si puedo conectar mediante WDS un comtrend ar5387un y un HG556a con openwrt y chipset atheros con seguridad wpa o al no tener el mismo chip me olvido del tema?
Lo he intentado como dice el compañero Elnef pero en modo cliente me pilla señal y en modo ap se queda sin señal.

¿Alguna idea?

Gracias y saludos.
La respuesta está en el primer post del Comtrend ar5387un.
Hay que mirar si la información que pedimos ya está disponible...

Miguelez

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #44 en: 10-10-2012, 20:34 (Miércoles) »
Hola a todo el equipazo

Funcionan tanto el Modo cliente enrutado (por Interfaz de Comandos) como el Modo repetidor (por Interfaz "WEB GUI") enhorabuena!!!!  ;D

En el caso del Modo repetidor parece que si le pongo la señal encriptada por wep me dice conectividad limitada o nula y no consigo nunca acceso a internet ni por ethernet ni por wifi, ¿Será que tengo forzosamente que poner la red repetida sin encriptacion? Ya que si le pongo sin encriptacion si que funciona.

¿El HG556a puede repetir mas de una señal wifi al mismo tiempo?

Voy a probar meterle mas funciones hasta que reviente!!!! jajaja





Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #45 en: 10-10-2012, 21:01 (Miércoles) »
Si estás usando una compilación antigua y quieres repetir una señal con cifrado WEP, tienes que configurar la wifi del hg556a en modo 'g'.
Y por cierto, que esto ya está comentado en el hilo de cómo configurarlo en modo repetidor  >:(

Enviado desde mi U30GT-H usando Tapatalk 2
« Última modificación: 10-10-2012, 21:04 (Miércoles) por jar229 »
Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

jbconpepsi

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #46 en: 18-10-2012, 10:29 (Jueves) »
Hola a todos, ¿Sabéis si puedo conectar mediante WDS un comtrend ar5387un y un HG556a con openwrt y chipset atheros con seguridad wpa o al no tener el mismo chip me olvido del tema?
Lo he intentado como dice el compañero Elnef pero en modo cliente me pilla señal y en modo ap se queda sin señal.

¿Alguna idea?

Gracias y saludos.
La respuesta está en el primer post del Comtrend ar5387un.
Hay que mirar si la información que pedimos ya está disponible...

El ar5387un tiene el firmware original de jazztel (no tiene openwrt) y está conectado a la línea de telefono. ¿Sería posible conectarlo al HG556a por wds? Me he leído el post entero que me citas y no he visto respuesta a mi consulta. Ya se que si el 5387 tiene openwrt no se puede.

Saludos.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #47 en: 18-10-2012, 11:31 (Jueves) »
No, no podrás usar WDS.
Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

jbconpepsi

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #48 en: 18-10-2012, 11:49 (Jueves) »
Gracias, me lo temía. En modo cliente normal no he tenido ningún problema y los equipos que conecto por cable funcionan de lujo pero en modo cliente wds se conecta pero no van los equipos que conecto por cable ni por wifi. Sin embargo, dos ar5387 ambos con firmware de jazztel si se conectan con wds y wpa sin problemas (debe ser porque llevan el mismo chip).

Saludos.

GXY

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #49 en: 24-10-2012, 02:24 (Miércoles) »
Hola a todos!

Mi primer mensaje aquí y ya estoy pidiendo algo..  :-[ pero en fin, llevo ya unas cuantas horas peleandome con configuraciones y buscando en foros y tutoriales, y ya ni veo...

La cuestión: Estoy intentando configurar un router comtrend CT-5361 de telefonica como CLIENTE para conectar por WIFI a otro router (con ADSL) y así compartir la ADSL a los dispositivos conectados al comtrend.

En el comtrend instale OpenWRT 96348GW-11-squashfs-bc300-cfe que por cierto funcionando a la primera y estupendamente. para las pruebas estoy intentando conectar a un router Zyxel 660HW-D1 de telefonica actualizado firmware a v.3.40 oficial.

He seguido básicamente las instrucciones del propio wiki de openWRT, aquí

http://wiki.openwrt.org/doc/recipes/routedclient

y tambien las del primer post de este hilo y otros foros como por ejemplo...

http://www.adslzone.net/postt308556.html
http://www.auditoriaswireless.net/index.php/topic,3245.0.html
http://www.pumawifi.org/?q=node/98

etc...

y el asunto es que lo tengo a medias. He conseguido que los routers se "vean" entre si, el "cliente" (el comtrend) aparece en la lista de dispositivos conectados del "servidor" (el zyxel). si hago un ping desde sesión SSH en el comtrend el zyxel responde... y hasta ahí.

de navegar, 0. los dispositivos conectados en el comtrend no ven al zyxel. le he dado la vuelta a los archivos de configuración una docena de veces (empece usando el LuCI, y ahora ya voy directamente a los archivos editando en la sesión SSH.. hace AÑOS que no usaba vi)

y nada. no se si estoy haciendo algo mal o es que estoy intentando hacer algo que no se puede hacer... en fin. un poquito de ayuda plzz :)

antes de que lo preguntéis, algunas cosas sobre la configuración que estoy haciendo.

- he tenido en cuenta configurar dos redes independientes en el comtrend, una que es la que se conecta como cliente y otra para los dispositivos que se conectan a el. desde el PC conectado hago el SSH al comtrend y como comente mas arriba, el comtrend hace ping al zyxel así que en principio esa parte debería estar bien.

- la red wifi del zyxel tiene seguridad WPA PSK. he probado muchas cosas pero una de ellas no ha sido desconectar la seguridad. en primer lugar porque la configuración definitiva si no tiene un nivel de seguridad aceptable no me servirá de mucho.

si necesitáis que pegue el contenido de los archivos de configuración, no problem... pero ahora estoy escribiendo este tocho desde el tablet y desde aquí no me puedo conectar al router para copiar los archivos :/

muchas gracias por anticipado :)

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #50 en: 24-10-2012, 08:02 (Miércoles) »
Pon por aquí los ficheros: network, wireless, dhcp y firewall
Qué rango de ip's usas en la red principal ?
Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

GXY

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #51 en: 24-10-2012, 13:12 (Miércoles) »
en unos minutos pego el contenido de los archivos. :)

el rango de IPs del principal es 192.168.0.x y del secundario es 192.168.1.x

EDIT. los archivos.

Citar
# FILE network

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'ifname' 'eth1'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.1'
        option 'netmask' '255.255.255.0'
        option 'nat' '1'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'type' 'bridge'

config 'interface' 'wan'
        option 'ifname' 'wlan0'
        option 'ipaddr' '192.168.0.55'
        option 'netmask' '255.255.255.0'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'dns' '192.168.0.1'
        option 'gateway' '192.168.0.1'
        option 'proto' 'static'

Citar
# FILE wireless


config 'wifi-device' 'wlan0'
        option 'type' 'mac80211'
        option 'macaddr' '00:16:38:cb:7d:b5'
        option 'hwmode' '11g'
        option 'channel' '4'

config 'wifi-iface'
        option 'device' 'wlan0'
        option 'network' 'wan'
        option 'mode' 'sta'
        option 'ssid' 'ssiddelwifi'
        option 'hostname' 'FUN.2'
        option 'encryption' 'psk'
        option 'key' 'clavedelwifi'
        option 'rts' '2346'
        option 'frag' '2346'


Citar
# FILE firewall


config 'defaults'
        option 'syn_flood' '1'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'

config 'zone'
        option 'name' 'lan'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'

config 'zone'
        option 'name' 'wan'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'
        option 'masq' '1'
        option 'masq_dest' '!192.168.0.0/24'

config 'forwarding'
        option 'src' 'wan'
        option 'dest' 'lan'

config 'rule'
        option 'src' 'wan'
        option 'proto' 'udp'
        option 'dest_port' '68'
        option 'target' 'ACCEPT'

config 'rule'
        option 'src' 'wan'
        option 'proto' 'icmp'
        option 'icmp_type' 'echo-request'
        option 'target' 'ACCEPT'

config 'include'
        option 'path' '/etc/firewall.user'


Citar
# FILE dhcp

config dnsmasq
        option domainneeded     1
        option boguspriv        1
        option filterwin2k      '0'  #enable for dial on demand
        option localise_queries 1
        option local    '/lan/'
        option domain   'lan'
        option expandhosts      1
        option nonegcache       0
        option authoritative    1
        option readethers       1
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
        #list server            '/mycompany.local/1.2.3.4'
        #option nonwildcard     1
        #list interface         br-lan
        #list notinterface      lo

config dhcp lan
        option interface        lan
        option start    100
        option limit    150
        option leasetime        12h

config dhcp wan
        option interface        wan
        option ignore   1
« Última modificación: 24-10-2012, 13:31 (Miércoles) por GXY »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #52 en: 24-10-2012, 14:42 (Miércoles) »
en unos minutos pego el contenido de los archivos. :)

el rango de IPs del principal es 192.168.0.x y del secundario es 192.168.1.x

EDIT. los archivos.


Antes de darte más indicaciones ...  y cómo me imagino que te resultará más cómodo que todos los equipos estén la misma subred, mírate este post: https://foro.seguridadwireless.net/openwrt/instalando-openwrt-en-comtrend/msg214309/#msg214309
Ponle al comtrend la compilación de RollerDk: rev. 28208 - broadcom con Luci
Con el driver propietario de broadcom, se consigue un 'cliente puente transparente' sin ningún problema.
Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

GXY

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #53 en: 28-10-2012, 23:10 (Domingo) »
Gracias!

bajare y probare ese firmware a ver que tal  :D

cuando haya hecho algunas pruebas pasare de nuevo por aqui. :)

EDIT. done! funcionando!  ;D

ahora hay otra cosilla que intento hacer y no me sale. me llevo la preguntilla al otro hilo, ya que este es especificamente para el modo cliente

muchas gracias!  >:(
« Última modificación: 29-10-2012, 02:34 (Lunes) por GXY »

jesus1997

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #54 en: 05-11-2012, 14:38 (Lunes) »
hola soy nuevo en este blog esque el otro dia fuy al baul de los recuerdos y encontre un comtrend ct-5361 el caso esque aunque lo e intentao poner en modo repetido no consigo que me transmita interner por los puertos la 1 y lan2  alos cuales queria conectar un dlink para q me hiciese de generador wifi . conectado a la linea telefonica(de movistar) tengo el nuevo amper asl-26555

alguien me puede ayudar???? ;D
gracias de antemano

jesus1997

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #55 en: 05-11-2012, 14:40 (Lunes) »
porcierto se me olvidava en el comtrend tengo openwrt

Noltari

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #56 en: 05-11-2012, 14:41 (Lunes) »
hola soy nuevo en este blog esque el otro dia fuy al baul de los recuerdos y encontre un comtrend ct-5361 el caso esque aunque lo e intentao poner en modo repetido no consigo que me transmita interner por los puertos la 1 y lan2  alos cuales queria conectar un dlink para q me hiciese de generador wifi . conectado a la linea telefonica(de movistar) tengo el nuevo amper asl-26555

alguien me puede ayudar???? ;D
gracias de antemano
Lo siento, pero he muerto ahogado en el intento de leer tu respuesta. Intenta explicar tu problema de nuevo, pero utilizando signos de puntuación.

Saludos.
« Última modificación: 05-11-2012, 14:43 (Lunes) por Noltari »

jesus1997

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #57 en: 06-11-2012, 14:13 (Martes) »
Hola soy nuevo en este blog.  El otro día fui al baúl de los recuerdos y encontré un comtrend ct-5361m, el caso es ,que aunque lo he intentado poner en modo repetidor, no consigo que me transmita Internet por los puertos lan 1 y lan 2  a los cuales quería  conectar un dlink para que  me hiciese de generador wifi, es decir , como AP .El comtrend, estaría conectado(por wifi),a un Amper asl-26555 que es el nuevo que da movistar.

Noltari

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #58 en: 06-11-2012, 15:04 (Martes) »
Hola soy nuevo en este blog.  El otro día fui al baúl de los recuerdos y encontré un comtrend ct-5361m, el caso es ,que aunque lo he intentado poner en modo repetidor, no consigo que me transmita Internet por los puertos lan 1 y lan 2  a los cuales quería  conectar un dlink para que  me hiciese de generador wifi, es decir , como AP .El comtrend, estaría conectado(por wifi),a un Amper asl-26555 que es el nuevo que da movistar.
Con el CT5361 no puedes repetir la señal; sólo puedes conectarte como cliente. Esto es debido al Hardware que lleva (Broadcom 4318 para el wifi).
Si sigues el tutorial del modo cliente tal y como está descrito en el primer post no deberías tener ningún problema en configurarlo para tal fin.

Recuerda que según el tutorial, la subred del router con openwrt es 192.168.2.0/24, por lo que el D-Link debería estar configurado en "modo bridge" y con una IP en la interfaz LAN de dicha subred (por ejemplo 192.168.2.2, asignándole como puerta de enlace la 192.168.2.1). Sin embargo, también puedes configurarlo en modo cliente DHCP, de tal forma que no tengas que fijar la IP manualmente.

Saludos!

jesus1997

  • Visitante
Re: [Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
« Respuesta #59 en: 07-11-2012, 14:55 (Miércoles) »
muchas gracias por responderme pero  tengo un problema, según el router, en la pagina de luci, el router esta enviando y recibiendo paquetes pero no tengo Internet por ninguno de los puertos lan del comtrend.
Alguien podría ayudarme. gracias