?>/script>'; } ?> [Desarrollo] OpenWrt en Huawei HG556a Widgets Magazine

Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 2126586 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: OpenWRT en Huawei hg556a
« Respuesta #780 en: 04-10-2012, 11:35 (Jueves) »

Son sólo paquetes custom, tampoco es que se vaya a cargar el router xD. Tú ponla en el primer post, con que te funcione a ti es suficiente xD.
Además, más pruebas haces que yo, que no tengo ni la mitad de los routers para los que hago compilaciones :$.

El otro día tenía un rato para hacer el proceso de parcheo en el tutorial de compilación de openwrt, pero como los servidores de openwrt están modo troll, no pude hacer mucho xDDD.

Saludos!

Añadida al post inicial  ;)

A ver si sacas tiempo y actualizas el tuto de la compilación. Los servidores de OpenWrt ya parecen funcionar correctamente ^-^

Por cierto, el fix de los usb está incluido en la última versión de tu parche ?

a qui esta desde hace 2 meses, https://dev.openwrt.org/attachment/ticket/10741/hw556_svn_all.2.patch, solo quiero saber si es peligroso compilar con el?, porque es algo diferente a la versión del primer post.

gracias

Pues espera a ver que comenta Noltari  ;)


Noltari

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #781 en: 04-10-2012, 11:44 (Jueves) »
a qui esta desde hace 2 meses, https://dev.openwrt.org/attachment/ticket/10741/hw556_svn_all.2.patch, solo quiero saber si es peligroso compilar con el?, porque es algo diferente a la versión del primer post.

gracias
No utilices esa versión porque es antigua.
Los parches SVN del primer post siempre son actualizados a las últimas versiones.

Saludos.


emeryth

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #782 en: 04-10-2012, 11:52 (Jueves) »
ok gracias por tu pronta respuesta.  ;D


Noltari

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #783 en: 04-10-2012, 12:04 (Jueves) »

Son sólo paquetes custom, tampoco es que se vaya a cargar el router xD. Tú ponla en el primer post, con que te funcione a ti es suficiente xD.
Además, más pruebas haces que yo, que no tengo ni la mitad de los routers para los que hago compilaciones :$.

El otro día tenía un rato para hacer el proceso de parcheo en el tutorial de compilación de openwrt, pero como los servidores de openwrt están modo troll, no pude hacer mucho xDDD.

Saludos!

Añadida al post inicial  ;)

A ver si sacas tiempo y actualizas el tuto de la compilación. Los servidores de OpenWrt ya parecen funcionar correctamente ^-^

Por cierto, el fix de los usb está incluido en la última versión de tu parche ?
Desde la versión 33275 está incluido. De hecho, está indicado al lado de los paquetes que incluye el firmware, y también lo avisé (creo :P).

Saludos!


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: OpenWRT en Huawei hg556a
« Respuesta #784 en: 04-10-2012, 14:19 (Jueves) »
Desde la versión 33275 está incluido. De hecho, está indicado al lado de los paquetes que incluye el firmware, y también lo avisé (creo :P).

Saludos!

Sí, que el fix está incluído en el firmware lo tengo claro (que yo sí leo  ;D).
Lo que no tenía claro, es sí el fix de los usb estaba incluido en el parche que está en el primer post.
Vamos que si para compilar había que aplicar 2 parches en lugar de uno.


eq7mavala

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #785 en: 05-10-2012, 14:57 (Viernes) »
Soy el unico al que no le funciona el programita de DDNS en esta ultima compilacion?

Con NO-IP no funciona y me quedo sin opciones...


krapula_1

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #786 en: 06-10-2012, 15:42 (Sábado) »
Hola, estoy probando la versión (r33275) he conseguido ponerlo en modo repetir no gracias a mi sino a los manuales que están super currados, gracias por compartirlo con nosotros de verdad gran trabajo.

Pues bien después de montar un pendrive me han surgido varias dudas. Yo por las noches apago los routers (una mania) y claro los desconecto de la luz. Al tener montado un disco duro esto no es una buena practica.

Existe alguna manera de hacer un shutdown al router de manera que desmonte el disco y pare los servicios? Se podría configurar el botón de restart para ello?

En definitiva, ¿De que manera hay que apagar el router para no romper nada?

Salu2


Noltari

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #787 en: 06-10-2012, 16:02 (Sábado) »
Hola, estoy probando la versión (r33275) he conseguido ponerlo en modo repetir no gracias a mi sino a los manuales que están super currados, gracias por compartirlo con nosotros de verdad gran trabajo.

Pues bien después de montar un pendrive me han surgido varias dudas. Yo por las noches apago los routers (una mania) y claro los desconecto de la luz. Al tener montado un disco duro esto no es una buena practica.

Existe alguna manera de hacer un shutdown al router de manera que desmonte el disco y pare los servicios? Se podría configurar el botón de restart para ello?

En definitiva, ¿De que manera hay que apagar el router para no romper nada?

Salu2
Edita el fichero /etc/config system, añadiendo esto al final:
Código: [Seleccionar]
config button
        option button 'restart'
        option action 'pressed'
        option handler 'umount /mnt/usb'

Después descarga este script hotplug para los botones:
Código: [Seleccionar]
mkdir /etc/hotplug.d/button
cd /etc/hotplug.d/button
wget https://dev.openwrt.org/export/33629/trunk/target/linux/atheros/base-files/etc/hotplug.d/button/00-button

Reinicia el router y cuando pulses el botón si todo está bien, los usb deberían desmontarse.

Saludos.


Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2378
  • Prácticas precisas precisan práctica
Re: OpenWRT en Huawei hg556a
« Respuesta #788 en: 06-10-2012, 16:27 (Sábado) »
Soy el unico al que no le funciona el programita de DDNS en esta ultima compilacion?

Con NO-IP no funciona y me quedo sin opciones...

Por si te sirve de consuelo, a mi tampoco me funciona...  ;)


flumenhaggen

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #789 en: 06-10-2012, 21:18 (Sábado) »
con la versión atheros el multiessid va sin ningún problema, pero

¿alguien ha conseguido multiessid con la versión con chipset ralink?

¿es imposible o vale la pena pelearse?


eq7mavala

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #790 en: 07-10-2012, 13:02 (Domingo) »
Soy el unico al que no le funciona el programita de DDNS en esta ultima compilacion?

Con NO-IP no funciona y me quedo sin opciones...

Por si te sirve de consuelo, a mi tampoco me funciona...  ;)

Despues de varias pruebas, la conclusion es la siguiente:

El script funciona, decir ejecuto el:

sh /usr/lib/ddns/dynamic_dns_updater.sh myddns

Y la IP se actualiza, pero solo forzando manualmente la actualizacion


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: OpenWRT en Huawei hg556a
« Respuesta #791 en: 07-10-2012, 15:00 (Domingo) »
Habrán cambiado algo en LuCi que hace que no 'llame' de forma correctamente al script.
Intenta localizarlo ... mira a ver si está en /etc/config  ^-^


eq7mavala

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #792 en: 07-10-2012, 16:33 (Domingo) »
A los que quieran configurar el DDNS:

Lo configurais tal cual con luci y luego desde terminal ejecutais esta linea:


sh /usr/lib/ddns/dynamic_dns_updater.sh myddns &

luego cerrais el terminal y ya teneis el script funcionando, asumo que lo que hace luci es arrancar este subproceso...

Cada vez que el router se apague o reinicie tendreis que volver a iniciarlo...


excrma

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #793 en: 07-10-2012, 20:24 (Domingo) »
Alguien puede explicar como hacer que funcione el botón de activar-descativar el wifi. Estaría bien que al pulsarlo se activara y se encendier el led de wifi y al volberlo a pulsar se desactivara y se apagara dicho led.

Saludos.


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: OpenWRT en Huawei hg556a
« Respuesta #794 en: 08-10-2012, 08:04 (Lunes) »
Aquí tienes info sobre el tema de los botones: http://wiki.openwrt.org/doc/howto/hardware.button


Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2378
  • Prácticas precisas precisan práctica
Re: OpenWRT en Huawei hg556a
« Respuesta #795 en: 08-10-2012, 11:33 (Lunes) »
A los que quieran configurar el DDNS:

Lo configurais tal cual con luci y luego desde terminal ejecutais esta linea:


sh /usr/lib/ddns/dynamic_dns_updater.sh myddns &

luego cerrais el terminal y ya teneis el script funcionando, asumo que lo que hace luci es arrancar este subproceso...

Cada vez que el router se apague o reinicie tendreis que volver a iniciarlo...


Yo la verdad es que no me he comido mucho la cabeza, cuando vi que con openwrt daba problemas configuré el no-ip en en Livebox2 y me va bien.

Pero gracias por la info  ;)


eq7mavala

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #796 en: 09-10-2012, 11:24 (Martes) »
Haces bien en comerte el tarro lo justo y necesario, yo no tengo ningún otro dispositivo que permita cuenta de NO-IP, solo funcionan con TZO y dynds y son de pago...


gmtii

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #797 en: 09-10-2012, 13:12 (Martes) »
han probado el yaddns (opkg install yaddns) y configurando el /etc/config/ddns? a mi me sigue funcionando con no-ip....

Haces bien en comerte el tarro lo justo y necesario, yo no tengo ningún otro dispositivo que permita cuenta de NO-IP, solo funcionan con TZO y dynds y son de pago...


peterpunk

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #798 en: 11-10-2012, 11:16 (Jueves) »
Hola
O no entiendo como cofigurar el router para que sea cliente transparente con rellayd, o estoy haciendo algo mal. Cuento toda la historia.

Tengo configurado el Router como cliente transparente.
Estos son los ficheros de configuración, por si hay algo mal.

[spoiler]root@OpenWrt:/etc/config# cat dhcp
config dnsmasq
        option domainneeded     1
        option boguspriv        1
        option filterwin2k      0  # enable for dial on demand
        option localise_queries 1
        option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
        option rebind_localhost 1  # enable for RBL checking and similar services
        #list rebind_domain example.lan  # whitelist RFC1918 responses for domains
        option local    '/lan/'
        option domain   'lan'
        option expandhosts      1
        option nonegcache       0
        option authoritative    1
        option readethers       1
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
        #list server            '/mycompany.local/1.2.3.4'
        #option nonwildcard     1
        #list interface         br-lan
        #list notinterface      lo
        #list bogusnxdomain     '64.94.110.11'

config dhcp lan
        option interface        lan
        option start    100
        option limit    150
        option leasetime        12h
        option ignore   1

config dhcp wan
        option interface        wan
        option ignore   1
root@OpenWrt:/etc/config# cat firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option network 'lan wwan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        option output 'REJECT'
        option input 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.20'
        option netmask '255.255.255.0'
        option gateway '192.168.2.1'
        option dns '8.8.8.8'

config interface 'wwan'
        option proto 'dhcp'

config interface 'stabridge'
        option proto 'relay'
        option 'network' 'lan wwan'
        option ipaddr '192.168.2.20'

root@OpenWrt:/etc/config# cat wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option macaddr '64:16:f0:08:86:fe'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '0'
        option txpower '27'
        option country 'US'

config wifi-iface
        option network 'wwan'
        option bssid '88:25:2C:8B:27:34'
        option ssid 'peterpunk'
        option encryption 'wep-open'
        option device 'radio0'
        option mode 'sta'
        option key1 'aabbccddeeff01020304050607'
        option key '1'
[/spoiler]

En teoria esta como el esquema.
          
                <                          >        
Router Adsl |                           |Router OpenWRT                   PC  
                |_____                   |_____                           _____
                |_____|                  |_____|-----------------|_____|
      192.168.2.1          192.168.2.101  192.168.1.20     192.168.2.103    
          
Esta es la configuración del PC que esta al final de la red.
Con dhcp
C:\Documents and Settings\MFG>ipconfig
Configuración IP de Windows

Adaptador Ethernet Network Connect Adapter          :
        Estado de los medios. . . .: medios desconectados

Adaptador Ethernet Conexión de área local          :
         Sufijo de conexión específica DNS :
        Dirección IP. . . . . . . . . . . : 192.168.2.103
        Máscara de subred . . . . . . . . : 255.255.255.0
        Puerta de enlace predeterminada   : 192.168.2.1

Pues con esta configuración el pc no puede acceder al router, aunque si salir a internet.
Necesito que el pc pueda acceder a un disco duro montado en el usb del router.

ifconfig del router
[spoiler]root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 64:16:F0:08:86:FD
          inet addr:192.168.1.20  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2881 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13216 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:471117 (460.0 KiB)  TX bytes:5247557 (5.0 MiB)

eth0      Link encap:Ethernet  HWaddr 64:16:F0:08:86:FD
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2881 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13221 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:511451 (499.4 KiB)  TX bytes:5252772 (5.0 MiB)
          Interrupt:14

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:154 errors:0 dropped:0 overruns:0 frame:0
          TX packets:154 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:12898 (12.5 KiB)  TX bytes:12898 (12.5 KiB)

wlan0     Link encap:Ethernet  HWaddr 64:16:F0:08:86:FE
          inet addr:192.168.2.101  Bcast:192.168.2.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:138608 errors:0 dropped:23 overruns:0 frame:0
          TX packets:96057 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:30493968 (29.0 MiB)  TX bytes:27063999 (25.8 MiB)          
[/spoiler]

Si cambio a esta configuración poniedo una ip fija al pc al final de la red este puede acceder al disco duro del router. Pero cualquier otro PC que se conecte al wifi principal no puede acceder al PC detras del router, que tambien es necesario ya que en este hay montado otros servicios.

                <                          >        
Router Adsl |                           |Router OpenWRT                   PC  
                |_____                   |_____                           _____
                |_____|                  |_____|-----------------|_____|
      192.168.2.1          192.168.2.101  192.168.1.20     192.168.21.30    

C:\Documents and Settings\MFG>ipconfig
Configuración IP de Windows

Adaptador Ethernet Network Connect Adapter          :
        Estado de los medios. . . .: medios desconectados

Adaptador Ethernet Conexión de área local          :
        Sufijo de conexión específica DNS :
        Dirección IP. . . . . . . . . . . : 192.168.1.30
        Máscara de subred . . . . . . . . : 255.255.255.0
        Puerta de enlace predeterminada   : 192.168.2.1

¿Como se configura el openwrt para que el pc al final de la red pueda acceder al router y salir a internet y desde el wifi se pueda acceder al pc?

« Última modificación: 16-10-2012, 12:18 (Martes) por peterpunk »

Miguelez

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #799 en: 11-10-2012, 13:51 (Jueves) »
Buenos dias repasando la respuestas al tema de este foro veo que no se habla mucho del editor VI para el putty siendo indispensable su conocimiento pues daré algunas nociones muy basicas para que no se despiste nadie.  >:(

Una vez que pongamos el nombre de usuario y la clave aparece la presentacion de putty.

Para acceder a la lectura/escritura de un fichero en putty debemos escribir el siguiente comando "vi"

vi /etc/config/network

En este momento, ya se nos está mostrando el contenido del fichero "network"

Estamos en estado de "modo lectura", podeis moveros con el cursor por el texto pero si intentais poner una letra, no lo escribe.

Para pasar a "modo escritura" debemos presionar la "i". Al presionar esta tecla vemos que nos aparece una "I" en la parte inferior de la pantalla.

Para volver a "modo lectura" presionamos "ESC", vemos que la "I" desaparece. Volvemos a "modo escritura" presionando "i".

Una vez hechas la modificaciones en el fichero, queremos salir y que queden guardadas pues mantenemos presionadas las teclas "Shift" o mayusculas + z. Si antes no se salió del "modo escritura" no se guardaran los datos. Si hemos dado al capslock o mayusculas fijas y pulsamos shift + z no saldrá hasta que no desactivemos el capslock.

Como ya dije es una explicacion muy basica pero suficiente para editar los ficheros del router mediante el putty.

Espero haber ayudado en algo ya que no solo pregunto dudas sino que tambien aporto soluciones.  ;D

De nada.