?>/script>'; } ?> [Desarrollo] OpenWrt en Huawei HG556a Widgets Magazine

Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 2169497 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

rgbravo

  • Visitante
Re: Re: OpenWRT en Huawei hg556a
« Respuesta #720 en: 16-09-2012, 22:20 (Domingo) »
Entiendo perfectamente tu postura, incluso tu enfado.
Ahora ponte tú en el lugar de los que andamos por el foro intentando ayudar a los demás (tú incluido, por supuesto). Damos una serie de indicaciones a seguir, algunas de lo más básicas, os dirigimos a los hilo fijos (que ya es lo primero que se debería leer). Cuando todo este fallo, os pedimos más detalles de los problemas y ... parece que nunca es suficiente ...
Insisto, y repito: es imposible que este router se quede colgado por el mero hecho de parar el firewal.
Te puedo dar mil indicaciones, decirte que te leas montones de páginas, pero si no comprendes lo que haces, o al menos lo intentas ...
Cómo averiguaste que el problemas de velocidad que tenías con el router no era de este sino del pc ?
Si tienes problemas y/o dudas concretos explicalos, que intentaremos solucionarlos. Pero al menos a mi, no me pidas que te enseñe a usar putty. El aprendizaje de ciertas cosas, es cosa tuya.


Enviado desde mi CUBE U30GT-H usando Tapatalk 2


Yo también entiendo tu postura :resuelvo las dudas y los problemas de compañeros de trabajo a nivel informático( hasta dónde sé y puedo). Precisamente por eso entiendo que hay que plantear bien el problema e intento ser claro y preciso (y creo que intento serlo) Pero también se ( al menos es mi postura no ya con mis compañeros sino que yo diría en general el la vida) que hay gente que no puede, o incluso, no quiere, llegar a dominar una cuestión a nivel "moderador" de un foro, pero que también merece ser ayudada.
La cuestión de la velocidad de la conexión es toda mérito tuyo (aunque no sabemos si es una cuestion de hardware o de software lo que impide alcanzar más velocidad y lo hemos dejado aparcado)
Se que ahora mismo mi pc se encuentra en una red distinta (generada por el router) a la de mi impresora. Se que intentamos generar un "puente" que permita conectar ambas redes y que así mi impresora "vea" al resto de equipos de la red principal y pueda comunicarse con ellos. Se que eso requiere activar un módulo del firmware instalado en el router(humildemente creo que se que queremos hacer)

pero DESCONOZCO (y no me duelen prendas en reconocerlo) el código o las instrucciones necesarias para poder hacer eso: y aquí es dónde pido ayuda.
Sino puedo aprender "todo el codigo necesario" y no aparece la pantalla Advanced Settings en la pestaña de Wifi cuando entro el el router a través de Lucy sinceramente...... no se como seguir.


aguera-competicion

  • Visitante
Re: Re: OpenWRT en Huawei hg556a
« Respuesta #721 en: 16-09-2012, 22:37 (Domingo) »
Entiendo perfectamente tu postura, incluso tu enfado.
Ahora ponte tú en el lugar de los que andamos por el foro intentando ayudar a los demás (tú incluido, por supuesto). Damos una serie de indicaciones a seguir, algunas de lo más básicas, os dirigimos a los hilo fijos (que ya es lo primero que se debería leer). Cuando todo este fallo, os pedimos más detalles de los problemas y ... parece que nunca es suficiente ...
Insisto, y repito: es imposible que este router se quede colgado por el mero hecho de parar el firewal.
Te puedo dar mil indicaciones, decirte que te leas montones de páginas, pero si no comprendes lo que haces, o al menos lo intentas ...
Cómo averiguaste que el problemas de velocidad que tenías con el router no era de este sino del pc ?
Si tienes problemas y/o dudas concretos explicalos, que intentaremos solucionarlos. Pero al menos a mi, no me pidas que te enseñe a usar putty. El aprendizaje de ciertas cosas, es cosa tuya.


Enviado desde mi CUBE U30GT-H usando Tapatalk 2


Yo también entiendo tu postura :resuelvo las dudas y los problemas de compañeros de trabajo a nivel informático( hasta dónde sé y puedo). Precisamente por eso entiendo que hay que plantear bien el problema e intento ser claro y preciso (y creo que intento serlo) Pero también se ( al menos es mi postura no ya con mis compañeros sino que yo diría en general el la vida) que hay gente que no puede, o incluso, no quiere, llegar a dominar una cuestión a nivel "moderador" de un foro, pero que también merece ser ayudada.
La cuestión de la velocidad de la conexión es toda mérito tuyo (aunque no sabemos si es una cuestion de hardware o de software lo que impide alcanzar más velocidad y lo hemos dejado aparcado)
Se que ahora mismo mi pc se encuentra en una red distinta (generada por el router) a la de mi impresora. Se que intentamos generar un "puente" que permita conectar ambas redes y que así mi impresora "vea" al resto de equipos de la red principal y pueda comunicarse con ellos. Se que eso requiere activar un módulo del firmware instalado en el router(humildemente creo que se que queremos hacer)

pero DESCONOZCO (y no me duelen prendas en reconocerlo) el código o las instrucciones necesarias para poder hacer eso: y aquí es dónde pido ayuda.
Sino puedo aprender "todo el codigo necesario" y no aparece la pantalla Advanced Settings en la pestaña de Wifi cuando entro el el router a través de Lucy sinceramente...... no se como seguir.


Hola en el firewall no te exlicare porque en OpenWrt no he tocado nada, pero... algunas cosas básicas si.

sabes tocar el putty?
sabes modificar archivos con el VI?
Dices que se bloquea la conexión telnet?
accedes a telnet al router por la parte wan o lan?

Poco a poco.


rgbravo

  • Visitante
Re: Re: OpenWRT en Huawei hg556a
« Respuesta #722 en: 16-09-2012, 23:54 (Domingo) »
sabes tocar el putty?
La verdad no.Ayer aprendí lo que era mirando la wikipedia e instalé a través de la pagina oficial de PUTTY la version 0.62
sabes modificar archivos con el VI?
No se que es VI
Dices que se bloquea la conexión telnet?
Se me bloqueó la conexión a internet y el acceso al router. Fue justo al llegar al momento en el que debía cambiar la zona horaria para dejar abiertos los canales 12 y 13.
accedes a telnet al router por la parte wan o lan?
Yo diría que por lan puesto que Putty está instalado en el pc y éste está conectado al router por lan

Además de esto:

ACLARACIÓN ANTES DE EMPEZAR: siempre que a partir de ahora digo router quiero decir que a través de Lucy veo dentro del router todas las pestañas y subpestañas de las que hablo

llevo cacharreando en Lucy todo este tiempo y al mismo tiempo mirando el foro  específico al que me remitió jar229 y he seguido intentando cosas:
1.- he intentado instalar el firmware que se sugiere al principio del foro (openwrt-HW553-squashfs-cfe.bin ) pero me dice la imagen no es válida y no lo puedo poner en el router. Luego he visto que la última compilación puesta por jar229 es r33074 y dado que yo tengo r33275 supongo que contiene lo necesario para poder trabajar

2.-El primer paso del proceso según el foro es instalar relayd.  Cacharreando en el router en la pestaña System, subpestaña Software veo esto en Installed Packages
relayd 2011-10-24-4e8f1fa4ca2b176500362843a9e57ea5abd4b7a3
significa que está instalado relayd y operativo en el router?

3.-El siguiente paso el firewal una pregunta:
Puedo desactivarlo accediendo a la subpestaña Firewall de la pestaña Network desde el router o hay que hacerlo a través de Putty?
4.-Supongamos que a través de putty consigo desactivar el firewall; el siguiente paso en el proceso sería cambiar la zona horaria; puedo hacer eso desde la pestaña System en el apartado  TimeZone? Si es asi supongo que elijo la opción Europe/madrid ¿?

5.- Siguiendo el proceso me pierdo en el apartado vi /etc/config/network
Porque sinceramente, no entiendo del todo esta frase: En el interface lan, la opción ipaddr es la importante. Deberá estar en una subred distinta a la que tenéis actualmente. En mi caso ha pasado de ser 10.0.0.94 a 10.0.1.94
Y en el inteface stabridge, opción ipaddr podremos la que teníamos hasta ahora (10.0.0.94 para mí).
La subred del router es 192.168.0.1 y la red principal, la de casa, es 192.168.1.1 asi que.... qué debería poner yo?
Una ultima cuestión, si todo esto que pregunto no debería ir aqui sino el hilo correspondiente decidlo y dejo de preguntar cosas dónde no debo.
Un saludo y gracias de verdad a todos y en especial a aguera= competición y por supuesto a jar229


Elnef

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #723 en: 17-09-2012, 07:19 (Lunes) »
Voy a intentar ayudarte también en lo que pueda.

2- Significa que está instalado pero eso no quiere decir que se esté ejecutando. Para asegurarte entra con el Putty y escribe:

/etc/init.d/relayd enable

Así se arracará siempre con el router

4- Creo que lo de la zona horaria no es necesario, es sólo opcional si quieres utilizar los canales 12 y 13. Dicho sea de paso a mí esto bnunca me ha funcionado en el HG556a.

5- Estás haciendo lo correcto. Si tu red principal es  del tipo 192.168.1.1, la 192.168.0.1. es una subred. De todas formas, y personalmente, no me gusta usar la subred 192.168.0.1 porque es una dirección Ip muy frecuente en los modos de recuperación de distintos routers. Y aunque no te debería dar problemas, personalmente prefiero usar la 192.168.2.1, por ejemplo. 


aguera-competicion

  • Visitante
Re: Re: OpenWRT en Huawei hg556a
« Respuesta #724 en: 17-09-2012, 12:38 (Lunes) »
sabes tocar el putty?
La verdad no.Ayer aprendí lo que era mirando la wikipedia e instalé a través de la pagina oficial de PUTTY la version 0.62




sabes modificar archivos con el VI?

No se que es VI



Dices que se bloquea la conexión telnet?
Se me bloqueó la conexión a internet y el acceso al router. Fue justo al llegar al momento en el que debía cambiar la zona horaria para dejar abiertos los canales 12 y 13.



accedes a telnet al router por la parte wan o lan?
Yo diría que por lan puesto que Putty está instalado en el pc y éste está conectado al router por lan

Además de esto:

ACLARACIÓN ANTES DE EMPEZAR: siempre que a partir de ahora digo router quiero decir que a través de Lucy veo dentro del router todas las pestañas y subpestañas de las que hablo

llevo cacharreando en Lucy todo este tiempo y al mismo tiempo mirando el foro  específico al que me remitió jar229 y he seguido intentando cosas:
1.- he intentado instalar el firmware que se sugiere al principio del foro (openwrt-HW553-squashfs-cfe.bin ) pero me dice la imagen no es válida y no lo puedo poner en el router. Luego he visto que la última compilación puesta por jar229 es r33074 y dado que yo tengo r33275 supongo que contiene lo necesario para poder trabajar



2.-El primer paso del proceso según el foro es instalar relayd.  Cacharreando en el router en la pestaña System, subpestaña Software veo esto en Installed Packages
relayd 2011-10-24-4e8f1fa4ca2b176500362843a9e57ea5abd4b7a3
significa que está instalado relayd y operativo en el router?

3.-El siguiente paso el firewal una pregunta:
Puedo desactivarlo accediendo a la subpestaña Firewall de la pestaña Network desde el router o hay que hacerlo a través de Putty?
4.-Supongamos que a través de putty consigo desactivar el firewall; el siguiente paso en el proceso sería cambiar la zona horaria; puedo hacer eso desde la pestaña System en el apartado  TimeZone? Si es asi supongo que elijo la opción Europe/madrid ¿?

5.- Siguiendo el proceso me pierdo en el apartado vi /etc/config/network
Porque sinceramente, no entiendo del todo esta frase: En el interface lan, la opción ipaddr es la importante. Deberá estar en una subred distinta a la que tenéis actualmente. En mi caso ha pasado de ser 10.0.0.94 a 10.0.1.94
Y en el inteface stabridge, opción ipaddr podremos la que teníamos hasta ahora (10.0.0.94 para mí).
La subred del router es 192.168.0.1 y la red principal, la de casa, es 192.168.1.1 asi que.... qué debería poner yo?
Una ultima cuestión, si todo esto que pregunto no debería ir aqui sino el hilo correspondiente decidlo y dejo de preguntar cosas dónde no debo.
Un saludo y gracias de verdad a todos y en especial a aguera= competición y por supuesto a jar229

Si tienes windows imagino que sabras que en tu pc tienes la consola CMD (ventana negra) para hacer comandos que ya apenas se utiliza ya que se hace casi todo de modo grafico. Linux también tiene esa consola de comandos, y el firmware que as metido al router imagino que sabrás que es un sistema linux. pues bien, para entrar en la consola de comandos de tu router lo aras de manera remota mediante ese programa putty. básicamente para conectarte haz lo siguiente:
Host name (or ip adress) introduce la ip del router
tica la casilla Telnet
tica en open
Apartir de ahora te saldrá el logo deOpenWrt, y estarás remotamente conectado al router donde podrás ver crear o modificar carpetas.
Esto es para usuarios con experiencia o expertos por lo que para hacer cosas aquí es bastante o muy difícil para alguien que no sabe lo que es el putty. Esto es una alternativa a LUCI mas potente porque lo puedes hacer todo pero solo es aconsejable para usuarios experimentados. Apartir de aquí el siguiente paso es saber de comandos.
Ahora tu decides si sigues por aquí o por LUCI >:(

VI es un editor de textos como podría ser Wordpad de windows pero mucho mas dificil de usar. Con esto editaras los archivos de configuración atravez del putty.

para asegurarte de donde proceden esos cortes, haz una cosa, realiza un ping continuo hacia el router que te sirva de sonda para cuando tengas esos cortes poder ver si llegas al router  o es otra cosa. Para realizar un ping continuo en windows --> ping 192.168.1.1 -t

r33275 creo que es la ultima versión, si quieres instalar otra versión deves hacerlo mediante el proceso de la primera pagina de este mismo post, si lo haces mediante LUCI creo que no funciona

El fiewall nunca lo he tocado no obstante para desactivarlo seguro que por consola se puede, por LUCI no lo se, aquí no te puedo ayudar tanto.


vi /etc/config/network
Esta frase por asi decirlo quiere decir algo como :

abrir con el editor de texto VI el archivo network que esta en la ruta etc/config/

El problema lo tendrás para modificar el archivo ya que es un poco difícil y no es solo escribir letras y borrar. Esto si tendrías que dar una vuelta por internet y ver tutoriales de como modificar archivos con VI

Te voy a dar una sugerencia o facilidad, si te ves imposible con el VI.
Planteate utilizar WINSCP, para que me entiendas básicamente es un putty que te conecta remotamente a un dispositivo pero te presenta una consola gráfica y no de comando, de esta manera veras las carpetas y archivos del dispositivo remoto (router)en forma de árbol como si te metes en el disco c: de tu windows


El tema del firewall y de la aplicación relayd no te puedo ayudar porque no la he utilizado.

« Última modificación: 17-09-2012, 12:51 (Lunes) por aguera-competicion »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: OpenWRT en Huawei hg556a
« Respuesta #725 en: 18-09-2012, 11:27 (Martes) »
Volvemos con el tema, a ver si conseguimos solucionarlo entre todos ;)
rgbravo: el problema de impresión que tienes, exactamente, cual es ?
Igual que probaste a conectar por cable usando el portatil, se te ocurrió imprimir a ver si el problema se presentaba también ?
Me da en la nariz, que pudiera ser un tema del firewal del equipo (pc) ...  :-X


rgbravo

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #726 en: 18-09-2012, 20:04 (Martes) »
Volvemos con el tema, a ver si conseguimos solucionarlo entre todos ;)
rgbravo: el problema de impresión que tienes, exactamente, cual es ?
Igual que probaste a conectar por cable usando el portatil, se te ocurrió imprimir a ver si el problema se presentaba también ?
Me da en la nariz, que pudiera ser un tema del firewal del equipo (pc) ...  :-X
Hola a todos y DE VERDAD GRACIAS  A TODOS por los aportes para solucionar el problema con la impresora.
Jar229 después del problema con la velocidad y el pc, lo primero que probé fue si era posible imprimir con alguno de los portátiles conectados al router.... pero no funcionó (creo que es un problema con el propio rotuer y el hecho de que se encuentre en una subred diferente a la de la impresora, que es la principal)
De todas maneras hay una cosa que,quiza es básica, pero que no termino de entender:
en el proceso necesario para configurar el router como cliente, el primer paso el abrir la ventana de la conexión LAN y cambiar varios parámetros : el primero es introducir una IP que sea distinta a la de la red principal.
Mis preguntas son:
¿por qué tiene que ser una IP distinta a la de la red principal?
¿podría ser una ip cuyo rango estuviera dentro de la red principal? (por ejemplo en mi caso la red principal es 192.168.1.1, podría ponerle al rotuer 192.168.1.2 por ejemplo)
¿si esto es posible, al tener el rotuer una IP dentro del rango de la red principal estaría el pc también dentro de la red principal y por lo tanto vería al resto de los equipos o esto que digo es una solemne tontería?
P.D. He visto todos los mensajes anteriores pero mi situacion personal (niña de 3años + mujer convaleciente) no me permiten probar todo lo que sugerís. lo intentaré ahora mismo. Aun así gracias de nuevo
ME EDITO A MI MISMO PORQUE HE PODIDO EMPEZAR A HACER ALGO PERO NECESITO SABER SI VOY BIEN ENCAMINADO ANTES DE SEGUIR (perdón por el "reposteo"

Si tienes windows imagino que sabras que en tu pc tienes la consola CMD (ventana negra) para hacer comandos que ya apenas se utiliza ya que se hace casi todo de modo grafico. Linux también tiene esa consola de comandos, y el firmware que as metido al router imagino que sabrás que es un sistema linux. pues bien, para entrar en la consola de comandos de tu router lo aras de manera remota mediante ese programa putty. básicamente para conectarte haz lo siguiente:
Host name (or ip adress) introduce la ip del router
tica la casilla Telnet
tica en open
Apartir de ahora te saldrá el logo deOpenWrt, y estarás remotamente conectado al router donde podrás ver crear o modificar carpetas.
Esto es para usuarios con experiencia o expertos por lo que para hacer cosas aquí es bastante o muy difícil para alguien que no sabe lo que es el putty. Esto es una alternativa a LUCI mas potente porque lo puedes hacer todo pero solo es aconsejable para usuarios experimentados. Apartir de aquí el siguiente paso es saber de comandos.
Ahora tu decides si sigues por aquí o por LUCI >:(
He empezado con el proceso de cacharreo. Lo primero que me ocurre es que si abro putty y  clicko en la opcion  TELNET durante una décima de segundo sale una minipantalla en negro (como cmd en windows) luego desaparece y.... nada más
Si dejo la opción que viene en putty por defecto (SSH) me sale un mensaje en inglés que dice que el sever host key (perdonad per no se cual sería la traducción al español del termino informatico pero supongo que basicamente hace referencia a la dirección que pones) no está en el registro y que no existe garantía de que el aparato al que quiero conectarme sea realmente el que yo creo que es y me dice que si quiero continuar o no( yo siempre he dicho que si) luego cambia la pantalla de putty,arriba sale el logo de Openwrt  y puedo escribir código si quiero. Yo he seguido introduciendo todo el código ahi (pero la verdad no se si lo estoy haciendo en el router o no, yo creo que si)

PD: agradecería que me dijerais si los pasos a seguir que os dije son correctos o no.
Por ejemplo alguien me decía que lo de cambiar la zona horaria no es necesario ¿es verdad? (pero entonces lo de los canales 12 y 13) Yo crei que precisamente a través de uno de esos canales ibamos a establecer el bridge con la red principal (es asi o me estoy columpiando¿?)
Si me lo puedo saltar..... voy al siguiente paso y configuro el archivo donde debo introducir las IP correspondientes en cada sitiio?... si hago esto lo hago a través de VI o lo puedo hacer también con Putty llegando con el cursor hasta la línea correspondiente y cambiándola?

« Última modificación: 18-09-2012, 20:33 (Martes) por rgbravo »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: OpenWRT en Huawei hg556a
« Respuesta #727 en: 18-09-2012, 21:01 (Martes) »
Olvídate de todo lo comentado y volvamos a intentarlo usando WinSCP (como te había recomendado aguera-competicion).
Bájalo e instálalo desde aquí: http://www.winscp.org/ (tienes traducción al español).
Una vez instalado, configúralo para que se conecte a la IP del hg556a con el usuario: root y password: el que hayas puesto (el puerto dejas el 22). Importante, en protocolo selecciona SCP. Guardas y conectas.
Te dará 2 mensajes de error, ignóralos sin más.
Ahora, si pinchas sobre /raiz estarás viendo la estructura de directorios del router. Te vas hasta /etc/config y señalas el fichero network, con el botón derecho le das a editar.
Copias y pegas aquí el contenido.
Haces lo mismo con firewall y wireless.
Una vez vea los ficheros, te digo lo que tienes que modificar.
La IP de tu router principal es 192.168.1.1 ? Y la del resto de equipos ?

Mientras tanto, vamos a asegurarnos de que el firewall no está causando problemas, así que lo vamos a desactivar.
Desde Luci: /Sistema/Startup pincha sobre una sóla vez en la línea de firewall donde pone activado (cambiará tras unos segundos a desactivar). Vuelve a repetir el proceso (en la línea de firewall), pero dónde pone Stop.
Si lo has hecho correctamente, primero habrás deshabilitado el firewall al inicio (así cuando se reinicie el router no volverá a ponerse en marcha) y segundo, lo habrás detenido (ya que casi seguro que estaba en ejecución).

Ahora, verificamos si la línea que hace referencia a relayd está activada (en verde), si no lo está, actívala.



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: OpenWRT en Huawei hg556a
« Respuesta #728 en: 19-09-2012, 10:07 (Miércoles) »
Por si a alguien le es útil  ;)

He compilado una nueva versión (r33456) con las siguientes características/paquetes:
LuCi + traducción al español, relayd, FPU emulation, htop (administrador gráfico de procesos), soporte para usb 2.0,  kmod-fs-ext4 (soporte de formato de disco ext2-ext4), ntfs-3g (soporte de formato de disco ntfs), kmod-vfat (soporte de formato de disco fat32), servidor de impresion (p910nd), servidor de ficheros (samba), servidor de ftp (pure-ftpd), transmission (versión 2.61.1), statistics (estadísticas para el control del router), wavemon (visor del nivel de señal/calidad del enlace wifi), swaputils, wget.

http://www.mediafire.com/download.php?h15dydv32uyvxka

Ahora mismo lo tengo conectado y funcionando como ' puente repetidor' (con relayd)  >:(

Aviso, por si alguien usa el servidor de impresión, que viene mal configurado. Trae la ruta por defecto de la impresora como "/dev/lp0" y ahora es detectada en "/dev/usb/lp0" (hay que cambiarlo en /etc/config/p910nd o desde LuCi)

Cuando la haya testeado un par de días más, la pondré en el post principal  ;)

rgbravo: lo del firewall, si no lo has hecho aún, olvídalo. Primero probamos con el en marcha.


aguera-competicion

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #729 en: 19-09-2012, 12:47 (Miércoles) »
Por si a alguien le es útil  ;)

He compilado una nueva versión (r33456) con las siguientes características/paquetes:
LuCi + traducción al español, relayd, FPU emulation, htop (administrador gráfico de procesos), soporte para usb 2.0,  kmod-fs-ext4 (soporte de formato de disco ext2-ext4), ntfs-3g (soporte de formato de disco ntfs), kmod-vfat (soporte de formato de disco fat32), servidor de impresion (p910nd), servidor de ficheros (samba), servidor de ftp (pure-ftpd), transmission (versión 2.61.1), statistics (estadísticas para el control del router), wavemon (visor del nivel de señal/calidad del enlace wifi), swaputils, wget.

http://www.mediafire.com/download.php?h15dydv32uyvxka

Ahora mismo lo tengo conectado y funcionando como ' puente repetidor' (con relayd)  >:(

Aviso, por si alguien usa el servidor de impresión, que viene mal configurado. Trae la ruta por defecto de la impresora como "/dev/lp0" y ahora es detectada en "/dev/usb/lp0" (hay que cambiarlo en /etc/config/p910nd o desde LuCi)

Cuando la haya testeado un par de días más, la pondré en el post principal  ;)

rgbravo: lo del firewall, si no lo has hecho aún, olvídalo. Primero probamos con el en marcha.

Hola, sabes si hay por el foro algún post sobre como compilar esto mismo que as echo tu? me gustaría practicar esto mismo que as echo tu.
Gracias.


chicuno

  • Visitante
Re: Re: OpenWRT en Huawei hg556a
« Respuesta #730 en: 19-09-2012, 13:04 (Miércoles) »
Jar229 deseando llegar a casa para probar tu ultima creacion...:)

Enviado desde mi HTC Wildfire S A510e usando Tapatalk 2


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: OpenWRT en Huawei hg556a
« Respuesta #731 en: 19-09-2012, 14:14 (Miércoles) »

Hola, sabes si hay por el foro algún post sobre como compilar esto mismo que as echo tu? me gustaría practicar esto mismo que as echo tu.
Gracias.

No, no hay ningún hilo con información detallada de cómo compilar.
Pero puedes mirar los siguientes enlaces:
http://wiki.openwrt.org/doc/howto/buildroot.exigence
http://wiki.openwrt.org/doc/howto/build
https://foro.seguridadwireless.net/openwrt/openwrt-en-huaweig-hg556a/msg251807/#msg251807

Si te 'atrancas' en algo, avisa  ;)

Jar229 deseando llegar a casa para probar tu ultima creacion...:)

Enviado desde mi HTC Wildfire S A510e usando Tapatalk 2

Ya contarás ...  ^-^


rgbravo

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #732 en: 19-09-2012, 16:12 (Miércoles) »
Copias y pegas aquí el contenido.
Haces lo mismo con firewall y wireless.
Una vez vea los ficheros, te digo lo que tienes que modificar.
CONTENIDO CONFIG:
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config interface 'lan'
   option ifname 'eth0'
   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option dns '8.8.8.8'
   option accept_ra '1'
   option ipaddr '192.168.2.1'

config interface 'laprimer'
   option proto 'dhcp'

CONTENIDO FIREWALL:
config defaults
   option syn_flood '1'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'REJECT'

config zone
   option name 'lan'
   option network 'lan'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'REJECT'

config zone
   option name 'wan'
   option input 'REJECT'
   option output 'ACCEPT'
   option forward 'REJECT'
   option masq '1'
   option mtu_fix '1'
   option network 'wan wwan laprimer'

config forwarding
   option src 'lan'
   option dest 'wan'

config rule
   option name 'Allow-DHCP-Renew'
   option src 'wan'
   option proto 'udp'
   option dest_port '68'
   option target 'ACCEPT'
   option family 'ipv4'

config rule
   option name 'Allow-Ping'
   option src 'wan'
   option proto 'icmp'
   option icmp_type 'echo-request'
   option family 'ipv4'
   option target 'ACCEPT'

config rule
   option name 'Allow-DHCPv6'
   option src 'wan'
   option proto 'udp'
   option src_ip 'fe80::/10'
   option src_port '547'
   option dest_ip 'fe80::/10'
   option dest_port '546'
   option family 'ipv6'
   option target 'ACCEPT'

config rule
   option name 'Allow-ICMPv6-Input'
   option src 'wan'
   option proto 'icmp'
   list icmp_type 'echo-request'
   list icmp_type 'echo-reply'
   list icmp_type 'destination-unreachable'
   list icmp_type 'packet-too-big'
   list icmp_type 'time-exceeded'
   list icmp_type 'bad-header'
   list icmp_type 'unknown-header-type'
   list icmp_type 'router-solicitation'
   list icmp_type 'neighbour-solicitation'
   list icmp_type 'router-advertisement'
   list icmp_type 'neighbour-advertisement'
   option limit '1000/sec'
   option family 'ipv6'
   option target 'ACCEPT'

config rule
   option name 'Allow-ICMPv6-Forward'
   option src 'wan'
   option dest '*'
   option proto 'icmp'
   list icmp_type 'echo-request'
   list icmp_type 'echo-reply'
   list icmp_type 'destination-unreachable'
   list icmp_type 'packet-too-big'
   list icmp_type 'time-exceeded'
   list icmp_type 'bad-header'
   list icmp_type 'unknown-header-type'
   option limit '1000/sec'
   option family 'ipv6'
   option target 'ACCEPT'

config include
   option path '/etc/firewall.user'

CONTENIDO WIRELESS:
config wifi-device 'radio0'
   option type 'mac80211'
   option macaddr '5c:4c:a9:71:04:f5'
   option hwmode '11ng'
   option htmode 'HT20'
   list ht_capab 'SHORT-GI-40'
   list ht_capab 'TX-STBC'
   list ht_capab 'RX-STBC1'
   list ht_capab 'DSSS_CCK-40'
   option disabled '0'
   option channel '7'
   option txpower '27'
   option country 'US'

config wifi-iface
   option network 'laprimer'
   option ssid 'Rohan'
   option encryption 'psk2'
   option device 'radio0'
   option mode 'sta'
   option bssid '2C:B0:5D:F3:A7:CC'
   option key '''??????????????????'

La IP de tu router principal es 192.168.1.1 ? Y la del resto de equipos ?
El resto de los equipos no tiene asignada IP fija: la obtienen de manera automática.

Ahora, verificamos si la línea que hace referencia a relayd está activada (en verde), si no lo está, actívala.
Si introduczo el comando /Sistema/Startup la respuesta es
-ash: /Sistema/Startup not found
He probado por System en lugar de sistema, he probado a poner espacios antes y después de las barras (por si era algo relacionado por la manera de teclearlo) pero ha habido tu tía.
No se si tiene que ver pero como os comenté  la conexión de Putty no puede ser por Telnet sino por SSH


Elnef

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #733 en: 19-09-2012, 17:28 (Miércoles) »
Por si a alguien le es útil  ;)

He compilado una nueva versión (r33456) con las siguientes características/paquetes:
LuCi + traducción al español, relayd, FPU emulation, htop (administrador gráfico de procesos), soporte para usb 2.0,  kmod-fs-ext4 (soporte de formato de disco ext2-ext4), ntfs-3g (soporte de formato de disco ntfs), kmod-vfat (soporte de formato de disco fat32), servidor de impresion (p910nd), servidor de ficheros (samba), servidor de ftp (pure-ftpd), transmission (versión 2.61.1), statistics (estadísticas para el control del router), wavemon (visor del nivel de señal/calidad del enlace wifi), swaputils, wget.

http://www.mediafire.com/download.php?h15dydv32uyvxka

Ahora mismo lo tengo conectado y funcionando como ' puente repetidor' (con relayd)  >:(

Aviso, por si alguien usa el servidor de impresión, que viene mal configurado. Trae la ruta por defecto de la impresora como "/dev/lp0" y ahora es detectada en "/dev/usb/lp0" (hay que cambiarlo en /etc/config/p910nd o desde LuCi)

Cuando la haya testeado un par de días más, la pondré en el post principal  ;)

rgbravo: lo del firewall, si no lo has hecho aún, olvídalo. Primero probamos con el en marcha.

Instalada en mis dos hg556a conectados por WDS y funcionando todo perfecto.

Muchas gracias por el enorme curros que os pegáis.


chicuno

  • Visitante
Re: Re: OpenWRT en Huawei hg556a
« Respuesta #734 en: 19-09-2012, 17:47 (Miércoles) »
Lo poco q me ha dado tiempo a probar me ha gustado mucho...conectado como cliente, punto de acceso y accediendo a la red y al router por wifi :)

Yo sigo con mi guerra particular montando un pen Ntfs.  Lo he intentado y no me lo ha cogido... aunq he tenido poco tiempo y lo he hecho todo muy rapido.  Ntfs-3g viene instalado y  funciona perfectamente a ejecutarlo.  Tendre q revisar los comandos.

Por cierto hay algun tuto para añadir la interface de montado de unidades como en el hg553?

Jar229 gracias por la compilacion , gran trabajo.;D

Un saludo.

Enviado desde mi HTC Wildfire l A510e usando Tapatalk 2


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: OpenWRT en Huawei hg556a
« Respuesta #735 en: 20-09-2012, 08:43 (Jueves) »

Ahora, verificamos si la línea que hace referencia a relayd está activada (en verde), si no lo está, actívala.
Si introduczo el comando /Sistema/Startup la respuesta es
-ash: /Sistema/Startup not found
He probado por System en lugar de sistema, he probado a poner espacios antes y después de las barras (por si era algo relacionado por la manera de teclearlo) pero ha habido tu tía.
No se si tiene que ver pero como os comenté  la conexión de Putty no puede ser por Telnet sino por SSH

Te dije que lo hicieras desde LuCi (el interfaz web).

Es imprescindible que te asegures que relayd está habilitado.

Desde putty (si te atreves), conectado por ssh (el telnet se deshabilita, en cuanto pones password al router) escribes (después de logearte):

Código: [Seleccionar]
/etc/init.d/relayd enable
Si te suelta un error, no continúes.
Si todo ha ido bien, usando WinSCP, sustituye el contenido de tus ficheros por estos:

network
Código: [Seleccionar]

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.2.100'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '8.8.8.8'

config interface 'wwan'
option proto 'dhcp'

config 'interface' 'stabridge'
option proto 'relay'
option network 'lan wwan'
option ipaddr '192.168.1.100'

firewall
Código: [Seleccionar]

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option network 'lan wwan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
option network 'wan wwan'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

dhcp
Código: [Seleccionar]
config dnsmasq
option domainneeded 1
option boguspriv 1
option filterwin2k 0  # enable for dial on demand
option localise_queries 1
option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
option rebind_localhost 1  # enable for RBL checking and similar services
#list rebind_domain example.lan  # whitelist RFC1918 responses for domains
option local '/lan/'
option domain 'lan'
option expandhosts 1
option nonegcache 0
option authoritative 1
option readethers 1
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
#list server '/mycompany.local/1.2.3.4'
#option nonwildcard 1
#list interface br-lan
#list notinterface lo
#list bogusnxdomain     '64.94.110.11'

config dhcp lan
option interface lan
option start 100
option limit 150
option leasetime 12h
option ignore 1

config dhcp wan
option interface wan
option ignore 1

wireless
Código: [Seleccionar]

config wifi-device 'radio0'
option type 'mac80211'
option macaddr '5c:4c:a9:71:04:f5'
option hwmode '11ng'
option htmode 'HT20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option channel '7'
option txpower '20'
option country 'US'

config wifi-iface
option network 'wwan'
option ssid 'Rohan'
option encryption 'psk2'
option device 'radio0'
option mode 'sta'
option bssid '2C:B0:5D:F3:A7:CC'
option key 'TU_CLAVE_WPA2'

La primera vez que le des a guardar un fichero desde WinSCP te dará dos avisos de error, ignóralos.

Reinicia el router, y si lo has hecho todo correctamente, ya tendrás todos los equipos en la misma subred.
El hg556a tiene la ip 192.168.1.100. Si en algún momento no te respodiera, inténtalo con la 192.168.2.100
Es posible, que debas asignar desde el router adsl una ip fija para el hg556a. Mira en el apartado LAN a ver si tienes la opción.


rgbravo

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #736 en: 20-09-2012, 17:58 (Jueves) »
Te dije que lo hicieras desde LuCi (el interfaz web).
Te falto decir SO ZOPENCO porque tienes toda la razón del mundo. No se porqué pero me obcequé
en que Lucy= a PUTTY y estuve como un imbecil intentando hacer lo que no se podía hacer

Es imprescindible que te asegures que relayd está habilitado.
Está conectado (comprobado desde Lucy todo en verde en la línea correspondiente)

Voy a explicaros lo que me ocurre ahora:
he hecho todo según los pasos: no me dio ningún error al guardar ningún archivo en WINSCP(lo digo por si esto es sintomático de algo)
Después de acabar todo el proceso reinicié el router.
Ahora funciona el router y el ordenador se conecta a internet pero la impresora sigue sin funcionar(he probado a desconcetar el firewall de windows por si acaso pero no hay tu tía)
Le he asignado al router una ip fija (la 100)
Pero ahora no consigo entrar en el router (pruebo todas las ips que se me ocurre que pueden funcionar 192.168.1.100/192.168.2.100/192.168.2.1,que es la que tenía antes de realizar todo el proceso,y 192.168.01, que es la que tenía antes de que la cambiara por la anterior como me sugeristeis)siempre obtengo el mismo mensaje en el navegador : problema al cargar la página

Seguro que es otra perogrullada pero no consigo dar con ella
Una última curiosidad:
la mac que aparece en la pegatina que tenía el router cuando lo entregó Vodafone es: 5c4ca97104f4 sin embargo la que aparece en la lista de conexión de router principal cuando uno se concecta al otro es : 5c4ca97104f5 ... por qué cambia el último número?

« Última modificación: 20-09-2012, 18:02 (Jueves) por rgbravo »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: Re: OpenWRT en Huawei hg556a
« Respuesta #737 en: 20-09-2012, 19:23 (Jueves) »
La segunda MAC es la wifi, y es la que tienes que reservar (indicando que quiere asignarle la IP 192.168.1.100) en el router principal.
Por cierto qué marca y modelo es ?
Después de hacerlo, reinicia el hg556a.
Explica con todo el detalle que puedas, el problema que tienes al intentar imprimir.


Enviado desde mi CUBE U30GT-H usando Tapatalk 2


aguera-competicion

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #738 en: 21-09-2012, 11:35 (Viernes) »
y digo yo.......... ¿es posible hacer un ping a la impresora desde donde no es posible imprimir?
lo primero es llegar y luego imprimir!!!

Si te responde al ping, y sigues sin poder imprimir, desinstala del PC problemática el software de la impresora y reinicia el equipo.
Después de poner en marcha de nuevo el equipo, usa el CD de configuración/asistente de los drivers.
jar229 El router que tiene  el compañero configurado en bridge realiza nat  nat o no?


flumenhaggen

  • Visitante
Re: OpenWRT en Huawei hg556a
« Respuesta #739 en: 21-09-2012, 18:10 (Viernes) »
puede que sea un poco off-topic, si eso me decís y creo otra entrada en el foro.

pero es que no sé si tendrá que ver con este firmware en particular.

no logro hacer funcionar nfs con el hg556a y el último trunk. Es un firmware compilado por mi.

Código: [Seleccionar]
root@OpenWrt:~# opkg list-installed |grep nfs
kmod-fs-nfs - 3.3.8-1
kmod-fs-nfs-common - 3.3.8-1
kmod-fs-nfsd - 3.3.8-1
nfs-kernel-server - 1.2.6-1

Código: [Seleccionar]
root@OpenWrt:~# cat /etc/exports
/mnt/wd    192.168.2.0/24(rw,root_squash,sync)
/mnt/tt    192.168.2.0/24(rw,root_squash,sync)
root@OpenWrt:~# exportfs
/mnt/wd       192.168.2.0/24
/mnt/tt       192.168.2.0/24

wd tiene un vfat montado. tt es un directorio sin nada, para hacer pruebas por si tiene que ver con eso.

El cliente lo tengo en la misma red 192.168.2.231, contectado al router por cable (nada de wifi todavía):

Código: [Seleccionar]
flumen@tomato:~$ rpcinfo  -p 192.168.2.1
   program vers proto   port  service
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100005    1   udp    973  mountd
    100005    2   udp    973  mountd
    100005    1   tcp    976  mountd
    100005    2   tcp    976  mountd
    100003    2   udp   2049  nfs
    100003    2   tcp   2049  nfs

flumen@tomato:~$ sudo mount -t nfs -v 192.168.2.1:/mnt/wd/ mounts/router
[sudo] password for flumen:
mount.nfs: timeout set for Fri Sep 21 18:03:55 2012
mount.nfs: trying text-based options 'vers=4,addr=192.168.2.1,clientaddr=192.168.2.231'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'addr=192.168.2.1'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 192.168.2.1 prog 100003 vers 3 prot TCP port 2049
mount.nfs: portmap query retrying: RPC: Program/version mismatch
mount.nfs: prog 100003, trying vers=3, prot=17
mount.nfs: trying 192.168.2.1 prog 100003 vers 3 prot UDP port 2049
mount.nfs: portmap query failed: RPC: Program/version mismatch
mount.nfs: prog 100003, trying vers=2, prot=6
mount.nfs: trying 192.168.2.1 prog 100003 vers 2 prot TCP port 2049
mount.nfs: prog 100005, trying vers=1, prot=17
mount.nfs: trying 192.168.2.1 prog 100005 vers 1 prot UDP port 973
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: trying text-based options 'vers=4,addr=192.168.2.1,clientaddr=192.168.2.231'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'addr=192.168.2.1'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 192.168.2.1 prog 100003 vers 3 prot TCP port 2049
mount.nfs: portmap query retrying: RPC: Program/version mismatch
mount.nfs: prog 100003, trying vers=3, prot=17
mount.nfs: trying 192.168.2.1 prog 100003 vers 3 prot UDP port 2049
mount.nfs: portmap query failed: RPC: Program/version mismatch
mount.nfs: prog 100003, trying vers=2, prot=6
mount.nfs: trying 192.168.2.1 prog 100003 vers 2 prot TCP port 2049
mount.nfs: prog 100005, trying vers=1, prot=17
mount.nfs: trying 192.168.2.1 prog 100005 vers 1 prot UDP port 973
mount.nfs: mount(2): Stale NFS file handle
mount.nfs: trying text-based options 'vers=4,addr=192.168.2.1,clientaddr=192.168.2.231'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'addr=192.168.2.1'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 192.168.2.1 prog 100003 vers 3 prot TCP port 2049
mount.nfs: portmap query retrying: RPC: Program/version mismatch
mount.nfs: prog 100003, trying vers=3, prot=17
mount.nfs: trying 192.168.2.1 prog 100003 vers 3 prot UDP port 2049
...


y así hasta que da timeout. Mientras, el router muestra en el log

Código: [Seleccionar]

Sep 21 16:02:52 OpenWrt daemon.notice mountd[2492]: /mnt/wd has been mounted by 192.168.2.231
Sep 21 16:03:02 OpenWrt daemon.notice mountd[2492]: NFS mount of /mnt/wd attempted from 192.168.2.231
Sep 21 16:03:02 OpenWrt daemon.notice mountd[2492]: /mnt/wd has been mounted by 192.168.2.231
Sep 21 16:03:12 OpenWrt daemon.notice mountd[2492]: NFS mount of /mnt/wd attempted from 192.168.2.231
Sep 21 16:03:12 OpenWrt daemon.notice mountd[2492]: /mnt/wd has been mounted by 192.168.2.231

...

y sigue hasta que el cliente da tiemout.

No entiendo lo del stale "Stale NFS file handle", nadie está utilizando o modificando ficheros del disco duro. Con el directorio 'tt', tampoco funciona.

Por lo de "RPC: Program/version mismatch" he probado a montarlo como nfs4:

Código: [Seleccionar]
flumen@tomato:~$ sudo mount -t nfs4 -v 192.168.2.1:/mnt/tt mounts/router
mount.nfs4: timeout set for Fri Sep 21 18:10:05 2012
mount.nfs4: trying text-based options 'addr=192.168.2.1,clientaddr=192.168.2.231'
mount.nfs4: mount(2): Protocol not supported
mount.nfs4: Protocol not supported

también he probado con el firewall apagado, pero nada.


alguna idea?

« Última modificación: 21-09-2012, 18:11 (Viernes) por flumenhaggen »