Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 1987335 veces)

0 Usuarios y 1 Visitante están viendo este tema.

DJROCKER

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2500 en: 24-05-2015, 21:13 (Domingo) »
Bueno akabo de ponerme y decir que estoy cerca cerca de la desesperación....Hice todo como me indicas pero cuando intento configurar los MODOS del router y del adaptador Luci o alguien hace lo que le sale de los cojines......  :( :(:(

- En el router selecciono "Access Point" y cuando guardo y aplico se pone en "Client"

- Y en el adaptador USB selecciono "Client" y al guardar y aplicar se pone en "Unknow"

Menudo negocio.....inserto unas capturas xa que se vea bien claro.....

Configuración Router

https://lh6.googleusercontent.com/-6FXdkCg2gfQ/VWH9Gd7b8GI/AAAAAAAAB9M/aQordTQ6Skg/w1001-h549-no/ROUTER.PNG

Configuración del Adaptador USB

https://lh4.googleusercontent.com/-9PCaEeOF0xA/VWH9GQ143QI/AAAAAAAAB9M/67-u8ncggbo/w844-h549-no/Captura%2BAdaptador.PNG

Y después de guardar y aplicar me keda esta fiesta....

https://lh5.googleusercontent.com/-E8lydMlsJJk/VWH9GWN4RtI/AAAAAAAAB9M/EviUjdNYXTQ/w1042-h431-no/Captura%2BTotal.PNG

Espero vuestra ayuda y en especial la tuya DjRocker, crack!

Saludos a todos!



Mira, vamos a empezar de 0
Ves a sistema y en sistema te vas a backups en esa pagina dale a resetear de fabrica y espera sin tocar nada unos 3 minutos y lo restablecera de nuevo el router con luci, cuando estes me avisas



pintxeti

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2501 en: 27-05-2015, 17:08 (Miércoles) »
¿hay alguna forma de saber por numero de serie y tal si nuestro router es atheros o no?

Me ofrecen un par de routers de este modelo y deseo comprar el que tiene atheros para poder hacerlo repetidor pero claro me interesa saber si tiene ahteros o no?

COmo lo puedo saber? SI abrirlo claro...

Lafucillo

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2502 en: 27-05-2015, 17:13 (Miércoles) »
En el siguiente enlace lo indica.

http://wiki.openwrt.org/toh/huawei/hg556a

Lafu

¿hay alguna forma de saber por numero de serie y tal si nuestro router es atheros o no?

Me ofrecen un par de routers de este modelo y deseo comprar el que tiene atheros para poder hacerlo repetidor pero claro me interesa saber si tiene ahteros o no?

COmo lo puedo saber? SI abrirlo claro...

Mohican

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2503 en: 30-05-2015, 14:22 (Sábado) »
Bueno gente, pues tengo el gusto de comentar q he conseguido instalar Openwrt en mi Hg...y lo más importante, hacerlo funcionar!  ;D
Mi agradecimiento a todos por este gran foro y especialmente dar las gracias al forero DjRocker por su inestimable ayuda.   >:( >:(

Salu2

luismi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2504 en: 31-05-2015, 18:25 (Domingo) »
Buenas tardes, hay algun Firmware compilado con Asterisk por defecto? es que estoy intentando instalarlo y me da este error durante la instalación

Collected errors:
 * pkg_run_script: package "libpopt" postinst script returned status 127.
 * opkg_configure: libpopt.postinst returned 127.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2221
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2505 en: 31-05-2015, 19:17 (Domingo) »
Buenas tardes, hay algun Firmware compilado con Asterisk por defecto? es que estoy intentando instalarlo y me da este error durante la instalación

Collected errors:
 * pkg_run_script: package "libpopt" postinst script returned status 127.
 * opkg_configure: libpopt.postinst returned 127.

¿Qué versión de openwrt estás utilizando?
¿Y cuál es el contenido del fichero /etc/opkg.conf?

luismi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2506 en: 31-05-2015, 19:20 (Domingo) »
Buenas tardes, hay algun Firmware compilado con Asterisk por defecto? es que estoy intentando instalarlo y me da este error durante la instalación

Collected errors:
 * pkg_run_script: package "libpopt" postinst script returned status 127.
 * opkg_configure: libpopt.postinst returned 127.

¿Qué versión de openwrt estás utilizando?
¿Y cuál es el contenido del fichero /etc/opkg.conf?


Buenas tardes, muchas gracias por contestar Tiki2000
La versión es:
OpenWrt Barrier Breaker r37937

La configuración del opkg es:
src/gz packages http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/luci
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay

Muchas gracias Crack!

Mohican

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2507 en: 11-06-2015, 11:54 (Jueves) »
Buenas compañeros!! Sabéis de algún firmware para Hg556 versión C(Atheros) con drivers para adaptador USB Atheros??

Saludos!!

Altair64

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2508 en: 11-06-2015, 13:06 (Jueves) »
Buenas tardes, hay algun Firmware compilado con Asterisk por defecto? es que estoy intentando instalarlo y me da este error durante la instalación

Collected errors:
 * pkg_run_script: package "libpopt" postinst script returned status 127.
 * opkg_configure: libpopt.postinst returned 127.

¿Qué versión de openwrt estás utilizando?
¿Y cuál es el contenido del fichero /etc/opkg.conf?


Buenas tardes, muchas gracias por contestar Tiki2000
La versión es:
OpenWrt Barrier Breaker r37937

La configuración del opkg es:
src/gz packages http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/luci
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay

Muchas gracias Crack!

Algo cambió en los repositorios de OpenWRT, la URL o algo, con firmwares precompilados de antes de ese cambio siempre toca cambiar las direcciones. No sé si lo que hago yo es lo correcto, pero siempre me voy desde aquí (esta url en el caso de este router):
http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/
y si te fijas hay varias secciones, pues añado todas. No sé si es lo correcto, pero por si quieres intentarlo, puedes probar con esto, quita la línea
src/gz packages http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/luci
y reemplázala por todo esto:

src/gz packages_base http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/base
src/gz packages_luci http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/luci
src/gz packages_management http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/management
src/gz packages_packages http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages
/packages
src/gz packages_routing http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages
/routing
src/gz packages_telephony http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages
/telephony

Lo digo porque yo con ahora con los AR5387un y los HG556a siempre tuve problemas recientemente con ese supuesto cambio de direcciones en los repositorios. Eso sí, si te sigue dando prueba a borrar los paquetes que el opkg intenta configurar, y luego vuelves a instalarlos. Recuerda hacer un opkg update antes.

Si sigue sin irte puede que tengas que cambiar más cosas de la dirección... yo tuive que hacerlo. Creo que para empezar la parte que llega hasta http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx está mal porque el CPU del router no es un ar71xx sino un bc6358, por tanto,
http://downloads.openwrt.org/barrier_breaker/14.07/brcm63xx/
es otra cosa que puedes probar a cambiar, el ar71xx por brcm63xx

Spantapajaros

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2509 en: 14-06-2015, 20:44 (Domingo) »
Gracias noentiendero.

Estoy volviendo a retomar el tema de Openwrt y esto me estaba volviendo loco, ahora ya me aparecen los paquetes.

Lo que ahora me esta pasando es que para instalar el luci-app-ddns o ddns-scripts me esta pidiendo un paquete que se llama libc, y esto antes no me pasaba.

Y ya que he dejado caer mi duda dejo aqui mi fichero conf del opkg para el que le pueda ayudar de un HG556

Código: [Seleccionar]
src/gz packages_base http://downloads.openwrt.org/barrier_breaker/14.07/brcm63xx/generic/packages/base/
src/gz packages_luci http://downloads.openwrt.org/barrier_breaker/14.07/brcm63xx/generic/packages/luci/
src/gz packages_management http://downloads.openwrt.org/barrier_breaker/14.07/brcm63xx/generic/packages/management/
src/gz packages_packages http://downloads.openwrt.org/barrier_breaker/14.07/brcm63xx/generic/packages/packages/
src/gz packages_routing http://downloads.openwrt.org/barrier_breaker/14.07/brcm63xx/generic/packages/routing/
src/gz packages_telephony http://downloads.openwrt.org/barrier_breaker/14.07/brcm63xx/generic/packages/telephony/
src/gz packages_oldpackages http://downloads.openwrt.org/barrier_breaker/14.07/brcm63xx/generic/packages/oldpackages/
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay

Durruti

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2510 en: 14-06-2015, 22:52 (Domingo) »
Hola, me gustaría saber si es posible conectar este router directamente a la ONT de fibra.

ONT fibra movistar --cable-- Router HG556A -- dar internet por cable y wifi a todos mis cacharros

Decidme si estoy perdiendo el tiempo intentándolo, porque no lo consigo.

He usado la última compilación de este hilo y seguido este tutorial:
Convertir nuestro router con OpenWrt en un router neutro [puerto LAN como WAN]
https://foro.seguridadwireless.net/openwrt/luci-configurar-puerto-lan-como-wan/

Spantapajaros

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2511 en: 14-06-2015, 23:59 (Domingo) »
Si, así lo tengo yo y use el tutorial que hay que aquí, que creo que es el mismo que has usado tu. A mi el único problema que me dio, fue no tener en otro router (el de ono en tu caso) en el puerto 1 del hg556.

Si tu ordenador no navega y crees que lo tienes bien, prueba a hacer un ping desde el hg556 y así vas descartando cosas.

Durruti

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2512 en: 15-06-2015, 00:17 (Lunes) »
Si, así lo tengo yo y use el tutorial que hay que aquí, que creo que es el mismo que has usado tu. A mi el único problema que me dio, fue no tener en otro router (el de ono en tu caso) en el puerto 1 del hg556.

Si tu ordenador no navega y crees que lo tienes bien, prueba a hacer un ping desde el hg556 y así vas descartando cosas.

Ok muchas gracias por responder, entonces seguiré intentándolo

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2513 en: 15-06-2015, 09:46 (Lunes) »
Ojo que la Fibra de movistar no es lo mismo que el cable de Ono. Ya hay un tema tratando esto por el foro ...  ^-^

darKknight

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2514 en: 17-06-2015, 14:52 (Miércoles) »
La conexión es PPPoE y el tráfico va etiquetado en la VLAN ID 6.

El puerto Ethernet que asignes a la WAN y conectes a la ONT, tienes que ponerlo en la VLAN 6 y Tagged.
« Última modificación: 17-06-2015, 14:55 (Miércoles) por darKknight »

Mohican

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2515 en: 22-06-2015, 22:44 (Lunes) »
Buenas a todos! Vuelvo por aki a ver si alguno de vosotros me echa una mano con el siguiente problema que me ha surgido.
El tema es que he instalado el firmware r39304usb lo configuro para repetir señal y todo bien hasta que apago el router. Al volver a encenderlo me pierde la configuración y ya no trabaja. ¿Q me aconsejais que haga? He estado leyendo por el foro y no sé si la solución a mi posible problema tiene que ver con esto que he encontrado en preguntas frecuentes sobre OpenWrt. Copio y pego....Espero me ayudeis por favor.

Acabo de actualizar el firmware de mi router y ahora, cuando lo reinicio (o apago) no me guarda los cambios
Código:
jffs2_scan_eraseblock(): End of filesystem marker found at 0x?????
jffs2: Cowardly refusing to erase blocks on filesystem with no valid JFFS2 nodes
jffs2: empty_blocks ??, bad_blocks ?, c->nr_blocks ??
Ejecutar el siguiente comando (si no es posible acceder por telnet/ssh hay que acceder al modo failsafe):
Código:
mtd erase -r rootfs_data

Cuando el router se haya reiniciado ya no debería aparecer el error.

Spantapajaros

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2516 en: 23-06-2015, 01:56 (Martes) »
Yo creo que lo que tienes que hacer es conectarte por putty y después de logearte ejecutar el comando.

Mohican

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2517 en: 23-06-2015, 02:54 (Martes) »
Ok, gracias por contestarme y tan rapido Spantapajaros! Entiendo que solo tengo que ejecutar este comando si??

(mtd erase -r rootfs_data)

¿Alguna otra opinión? 
« Última modificación: 23-06-2015, 03:08 (Martes) por Mohican »

pintxeti

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2518 en: 23-06-2015, 17:22 (Martes) »
Tengo un HG556 version C, es decir el del chip atheros.
Mi unica intención es usar el router a modo de repetidor de un livebox de orange.
¿Que versión me aconsejais?

Por le momento solo quiero repetidor...luego cuando me haga mas a fondo con el router ya cacharreare con mas cosas.

Un saludo

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2519 en: 24-06-2015, 09:00 (Miércoles) »
Tengo un HG556 version C, es decir el del chip atheros.
Mi unica intención es usar el router a modo de repetidor de un livebox de orange.
¿Que versión me aconsejais?

Por le momento solo quiero repetidor...luego cuando me haga mas a fondo con el router ya cacharreare con mas cosas.

Un saludo

Para el modo repetidor, te vale cualquiera.

Si quieres probar la última versión, usa la RC2 de Chaos Chalmer.