Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 2040132 veces)

0 Usuarios y 3 Visitantes están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2440 en: 05-04-2015, 19:12 (Domingo) »
El segundo repetidor está conectado por wifi al primer repetidor ?

Si la respuesta es sí, puedes enlazarlos usando WDS, ambos equipos estarían en la misma subred y deberías deshabilitar el servidor DHCP del segundo repetidor.

Para el enlace WDS, mira el tutorial Modo Cliente/Repetidor/WDS con OpenWrt



gito75

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2441 en: 05-04-2015, 20:31 (Domingo) »
Hola a  todos. En primer lugar daros las gracias por el trabajo que realizais desinteresadamente para que los "pardillos" como yo seamos capaces de darle uso a los trastos que la parienta intenta tirar a la basura desde hace años.

Este ha sido el caso de este router Huawei (desde hoy ya tengo algo bueno para recordar) que acabo de ponerlo a funcionar en modo repetidor.

Solo he tenido problemas con el firm r38342 que no enlazaba correctamente con el WIFI de casa se cortaba y conectaba intermitentemente. Instale el 39304 y perfecto, señal estable e incluso me gano varios dB´s.

Os leido mucho pero evidentemente no he sido capaz de leerme las ciento y pico paginas por lo que no se si se habrá hablado de un problema que me ha surgido y que paso a contar por si a alguien le sucede lo mismo:

Tras instalar el firm y escanear para conectarme a mi red WIFI de casa me aparecian todas menos esta. He escaneado mil veces, reseteado el router, vuelta a escanear y nada. Cambie el nombre de la red y tampoco. Estaba transmitiendo en el canal 12 de mi comtrend....pues ese era el problema, lo he bajado y me lo ha reconocido perfecto. Al parecer el Huawei tiene menos margen de frecuencias y creo que el más alto es el 11.

Saludos para todos y muchas gracias una vez mas

Edito: Lo tengo ya funcionando y no me fío de cortarlo para probar porque seguro que he tenido un golpe de suerte al salirme a la primera  ^-^ . Una pregunta, ¿El firm 39304 que es el que tengo puesto tambien pierde la configuración al resetearse? ¿Si se produce un corte de luz tengo que volver a configurarlo?? Decideme que no por lo que que más querais!!!
« Última modificación: 05-04-2015, 20:34 (Domingo) por gito75 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re:
« Respuesta #2442 en: 05-04-2015, 23:07 (Domingo) »
La configuración no debería perderse, salvo error.
De todas formas, puedes hacer una copia de la misma desde LuCi (el interfaz web de OpenWrt): Sistema/Backup.

Enviado desde uno de mis 'cacharros' usando Tapatalk

gito75

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2443 en: 06-04-2015, 08:58 (Lunes) »
Gracias jar229.
Probe anoche y efectivamente no pierde configuración (no se donde leería ese problema). Aún así gracias por avisarme de que se puede hacer backup, muy util, lo haré.

s79

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2444 en: 07-04-2015, 11:12 (Martes) »
Hola a todos

He visto que el software soporta tvheadend  pero no encuentro el paquete v4l para las capturadoras de video.

Me gustaría instalar newcam y poder gestionar la capturadora de vídeo.
Podéis orientarme un poco, voy liado con los paquetes

gracias

gito75

  • Visitante
Re:
« Respuesta #2445 en: 08-04-2015, 20:17 (Miércoles) »
La configuración no debería perderse, salvo error.
De todas formas, puedes hacer una copia de la misma desde LuCi (el interfaz web de OpenWrt): Sistema/Backup.

Enviado desde uno de mis 'cacharros' usando Tapatalk

Perdona Jar229....era demasiado bonito para ser verdad esto de que todo me saliese bien a la primera sin necesitar molestaros  :-[

Al poner el router en modo repetidor hay una cosa que no entiendo, y es que funcionaba perfectamente con la misma IP que el router que da el ADSL a casa (los dos con 192.168.1.1) ¿como es eso posible? perdona mi ignorancia.
Que tengan la misma IP (a pesar de que me extrañaba) no me molestaba porque la red ya cubria todo el piso y esa era mi intencion, pero al pinchar un disco duro en el router principal veo que solo puedo acceder a él cuando estoy conectado a traves de su wifi, cuando estoy a traves del wifi del repetidor (Huawei con openwrt) no me conecta.

En un principio pensé que era logico porque la ruta del disco duro es la 192.168.1.1\usb1_1 y cuando pongo esa ruta conectado al wifi del repe como tiene la misma IP pues me falla.

He intentado cambiar la IP al repetidor poniendole la 192.168.1.2 (en interfaces  - LAN - Direccion IPv4 y tras pelearme un poco con el repe (se ha tomado mucho tiempo para dejarme conectarme a él) ya vuelve a funcionar en modo repe pero sigo con el mismo problema, no tengo conexion con el router principal. No hace ping por lo que sigo sin tener acceso al disco duro

Disculpa que te moleste para esto que seguro ser una tonteria pero llevo dos dias buscando información por no molestar pero ya estoy rendido.

Seguro que estoy mezclando churras con merinas porque pensándolo bien son dos redes distintas ¿verdad? ¿Es posible hacer lo que busco?...partiendo de la base de que soy bastante torpe claro.

Perdona las molestias y gracias una vez más

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2446 en: 08-04-2015, 20:31 (Miércoles) »
Para que los equipos puedan "verse", debes usar relayd.

Lee estos hilos y si tienes dudas, preguntas.


Modo repetidor con y sin relayd (HG556a)

Relayd sin traumas (configuración gráfica desde LuCi)

gito75

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2447 en: 08-04-2015, 23:37 (Miércoles) »
Para que los equipos puedan "verse", debes usar relayd.

Lee estos hilos y si tienes dudas, preguntas.


Modo repetidor con y sin relayd (HG556a)

Relayd sin traumas (configuración gráfica desde LuCi)

Voy a hincar los codos a ver si soy capaz de coger conceptos.
Muchas gracias una vez mas por tu tiempo.
« Última modificación: 08-04-2015, 23:39 (Miércoles) por gito75 »

Sekmeth

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2448 en: 11-04-2015, 13:36 (Sábado) »
Hola


Quería preguntaros una cosa a los poseedores del HG556a (yo tengo la versión con wifi Atheros).
Resulta que cuando lo compré no traía la fuente de alimentación original (12Voltios//2Amperios), sino una de 12 Voltios//1Amperio.

El router funcionar, funciona.
Lo que pasa es que el led de power no deja de parpadear como si tuviese actividad.
Le he puesto una clave alfanumérica WPA2-PSK-AES, con un SSID nuevo (y oculto), el canal wifi lo he dejado fijo, y en la web de admin. del router no aparecen clientes wifi asociados. He cambiado varias veces de firmware, tanto al oficial como al Irlandés con idéntico resultado, y lo único que me queda por pensar el el tema de la fuente de alimentación.


Mi pregunta es: ¿alguien que tenga una fuente de alimentación de menos amperaje ha notado comportamiento raro o inusual en este router como yo?

Muchas gracias y perdonar el off topic.  :-\

edudi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2449 en: 11-04-2015, 15:38 (Sábado) »
Hola


Quería preguntaros una cosa a los poseedores del HG556a (yo tengo la versión con wifi Atheros).
Resulta que cuando lo compré no traía la fuente de alimentación original (12Voltios//2Amperios), sino una de 12 Voltios//1Amperio.

El router funcionar, funciona.
Lo que pasa es que el led de power no deja de parpadear como si tuviese actividad.
Le he puesto una clave alfanumérica WPA2-PSK-AES, con un SSID nuevo (y oculto), el canal wifi lo he dejado fijo, y en la web de admin. del router no aparecen clientes wifi asociados. He cambiado varias veces de firmware, tanto al oficial como al Irlandés con idéntico resultado, y lo único que me queda por pensar el el tema de la fuente de alimentación.


Mi pregunta es: ¿alguien que tenga una fuente de alimentación de menos amperaje ha notado comportamiento raro o inusual en este router como yo?

Muchas gracias y perdonar el off topic.  :-\

Buenas caballero, este router en concreto Atheros lo he tenido en pruebas de consumo (W) durante un largo período de tiempo.

El transformador original de 12v 2A dá como máximo 24 W (a los cuales es muy dificil de llegar por mucho que le pinchemos por los 3 USB, ya que está para bien sobredimensionado su transformador).

Te voy a poner una tabla mía de consumos de este router Atheros haciendo únicamente de repetidor WiFi con los siguientes datos: W Máx (Watios Máximos alcanzados) y W mín (Wattios mínimos alcanzados).




Conclusión: Con OpenWRT firmware r39xxxUSB de jar229, en este router por lo que mi watímetro marca no pasa de 10,9 W como máximo y como mínimo ha dado 8,5 W, así que aunque estés demasiado justo con tu transformador (12v x 1A = 12 W máximos) en principio ese no es tu problema, parece que tienes que tener algo mal configurado, porque si entras por ethernet al router y puedes configurar tu red WiFi, dudo mucho que el WiFi lo tengas cascado.


Un saludo
« Última modificación: 15-05-2015, 01:01 (Viernes) por edudi »

wifino

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2450 en: 13-04-2015, 14:20 (Lunes) »
He compilado un firmware directamente del repositorio de OpenWrt con ciertas modificaciones:
  • He incorporado el parche para que la MAC del WiFi de los Ralink sea la correcta: http://patchwork.openwrt.org/patch/2947/
  • He incorporado el parche para que se pueda hacer sysupgrade sin problemas: http://patchwork.openwrt.org/patch/3092/
  • He habilitado la opción ATH_USER_REGD en la configuración (.config) porque desactiva la restricción del regdomain de la EEPROM. De esta forma se pueden utilizar todos los canales del WiFi sin parchear los datos de calibración. Para ello basta con editar a mano el fichero .config y cambiar la línea "# CONFIGATH_USER_REGD  is not set" por "CONFIG_ATH_USER_REGD=y"
Como podréis comprobar en la lista de paquetes, he compilado el firmware con soporte para WiFis USB, tanto Ralink (rt2800-usb) como Realtek (rtl8187).

Yo prefiero Coca-Cola ®. Es que soy abstemio  ^-^

En cualquier caso, felicidades  >:(
Yo tampoco bebo alcohol porque no me gusta nada el sabor, era por hacer la tontería de turno xD.

Saludos!

Hola, respecto a este tema tengo un hg556a con chip ralink con la compilación r39304usb. Está configurado como ap me muestra la mac de la wifi y corresponde a la ralink, como puedo cambiarla o que salga la correcta, no se si lleva incluido el parche en la compilacion r39304usb y no se que hacer. Cual es el motivo por el que muestra la mac ralink y porque no deja modificarla como las mac de wwan y lan. Gracias y un saludo

viru

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2451 en: 14-04-2015, 05:38 (Martes) »
¿Necesita ayuda para configurating hg556a ... tengo un módem WiMAX con 192.168.2.1 IP y hg556 con 192.168.124.254 ip he conectado wimax a hg556 través lan cable..on puerto primero lan de hg556 ... al conectar wifi soy conseguir ip para todos los clientes a través de módem WiMAX es decir 192.168.2.33, 34 ... im podido acceder a mi página hg556 y no obtener ip de hg556 dhcp ... plz dime ajuste correcto. de modo que pueda acceder tanto wimax y la página del router

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2452 en: 14-04-2015, 08:45 (Martes) »
¿Necesita ayuda para configurating hg556a ... tengo un módem WiMAX con 192.168.2.1 IP y hg556 con 192.168.124.254 ip he conectado wimax a hg556 través lan cable..on puerto primero lan de hg556 ... al conectar wifi soy conseguir ip para todos los clientes a través de módem WiMAX es decir 192.168.2.33, 34 ... im podido acceder a mi página hg556 y no obtener ip de hg556 dhcp ... plz dime ajuste correcto. de modo que pueda acceder tanto wimax y la página del router

No entiendo nada  ???

viru

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2453 en: 14-04-2015, 16:21 (Martes) »
¿Necesita ayuda para configurating hg556a ... tengo un módem WiMAX con 192.168.2.1 IP y hg556 con 192.168.124.254 ip he conectado wimax a hg556 través lan cable..on puerto primero lan de hg556 ... al conectar wifi soy conseguir ip para todos los clientes a través de módem WiMAX es decir 192.168.2.33, 34 ... im podido acceder a mi página hg556 y no obtener ip de hg556 dhcp ... plz dime ajuste correcto. de modo que pueda acceder tanto wimax y la página del router

No entiendo nada  ???

lo siento ... tengo la siguiente configuración

    Wimax
          .
          .
    Wimax módem
          . WAN = IP a través de ISP,
          . LAN = 192.168.2.1 estático
          . Servidor DHCP,
          . DNS a través de ISP
          .
          .
   Enrutador HG556a inalámbrica (WAN = dinámica a través de Wimax módem DHCP [192.168.2.x], conectarse a través de cable LAN en el puerto 1
          . LAN = 192.168.124.254 estática
          . Servidor DHCP,
          . .
          . Ahora las com****doras portátiles inalámbricas de problemas se conectan en este punto (que consigue portátil IP a través de Wimax DHCP (192.168.2.33) insted de conseguir ip del router inalámbrico DHCP [192.168.124.x])

capaz de acess página wimax módem ... pero la página no enrutador

lo siento por mi español
« Última modificación: 14-04-2015, 16:26 (Martes) por viru »

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2454 en: 18-04-2015, 20:46 (Sábado) »
Parece que alguien ha desarrollado drivers para la parte de VoIP

https://github.com/pgid69/bcm63xx-phone

Aunque son más bien drivers específicos para el HG553, supongo que en el HG556a deberían funcionar, con algún cambio menor. No tengo pensado meterme en este tema ya que la voz por IP no es algo que use. Seguramente alguien esté interesado así que ahí dejo ese link.

Más posibilidades para este router (por sino tenía ya pocas)  >:D

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2235
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2455 en: 19-04-2015, 13:01 (Domingo) »
Parece que alguien ha desarrollado drivers para la parte de VoIP

https://github.com/pgid69/bcm63xx-phone

Aunque son más bien drivers específicos para el HG553, supongo que en el HG556a deberían funcionar, con algún cambio menor. No tengo pensado meterme en este tema ya que la voz por IP no es algo que use. Seguramente alguien esté interesado así que ahí dejo ese link.

Más posibilidades para este router (por sino tenía ya pocas)  >:D

Esto sí que es bueno. A ver si alguien lo prueba y comenta.

wifino

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2456 en: 26-04-2015, 23:53 (Domingo) »
Hola, una cuestión sobre el hg556a: al cambiar mi adaptador wifi de posición usb en el router, se me ha creado en el apartado wifi un "radio2" que no he podido configurar. Es posible eliminar por completo "radio2" y "radio1" por completo para que al reiniciar no vuelva a salir y empezar a configurar desde cero? Gracias y saludos!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2457 en: 27-04-2015, 08:52 (Lunes) »
Hola, una cuestión sobre el hg556a: al cambiar mi adaptador wifi de posición usb en el router, se me ha creado en el apartado wifi un "radio2" que no he podido configurar. Es posible eliminar por completo "radio2" y "radio1" por completo para que al reiniciar no vuelva a salir y empezar a configurar desde cero? Gracias y saludos!

Desde una conexión ssh escribe:

Código: [Seleccionar]
rm /etc/config/wireless
Luego reinicia el router.

wifino

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2458 en: 27-04-2015, 15:59 (Lunes) »
Hola, una cuestión sobre el hg556a: al cambiar mi adaptador wifi de posición usb en el router, se me ha creado en el apartado wifi un "radio2" que no he podido configurar. Es posible eliminar por completo "radio2" y "radio1" por completo para que al reiniciar no vuelva a salir y empezar a configurar desde cero? Gracias y saludos!

Desde una conexión ssh escribe:

Código: [Seleccionar]
rm /etc/config/wireless
Luego reinicia el router.
Muchas gracias por tu rápida contestación y ayuda, tb aprobecho para hacerlo extensivo a todos los moderadores del foro...
Me podrías decir si se puede cambiar la dirección mac publica que muestra el router cuando se configura como "master". La wwan y la lan si que pude cambiarlas desde "interfaces". Saludos!

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2235
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2459 en: 27-04-2015, 18:23 (Lunes) »
Hola, una cuestión sobre el hg556a: al cambiar mi adaptador wifi de posición usb en el router, se me ha creado en el apartado wifi un "radio2" que no he podido configurar. Es posible eliminar por completo "radio2" y "radio1" por completo para que al reiniciar no vuelva a salir y empezar a configurar desde cero? Gracias y saludos!

Desde una conexión ssh escribe:

Código: [Seleccionar]
rm /etc/config/wireless
Luego reinicia el router.
Muchas gracias por tu rápida contestación y ayuda, tb aprobecho para hacerlo extensivo a todos los moderadores del foro...
Me podrías decir si se puede cambiar la dirección mac publica que muestra el router cuando se configura como "master". La wwan y la lan si que pude cambiarlas desde "interfaces". Saludos!

option macaddr 'AA:BB:CC:DD:EE:FF' en la sección config wifi-iface en /etc/config/wireless