Autor Tema: [Desarrollo] OpenWrt en Comtrend WAP-5813n  (Leído 313425 veces)

0 Usuarios y 1 Visitante están viendo este tema.

pelonbcn

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #80 en: 16-12-2012, 11:49 (Domingo) »
Buenas,

No encuentro para descargar el firmware WAP-5813n-CFE-P401-402TLF-C02_R35.BIN, ¿dónde lo podría conseguir?

Gracias,

Carlos



Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #81 en: 16-12-2012, 12:09 (Domingo) »
Buenas,

No encuentro para descargar el firmware WAP-5813n-CFE-P401-402TLF-C02_R35.BIN, ¿dónde lo podría conseguir?

Gracias,

Carlos
Hola,

ya he arreglado los enlaces del primer post. Si no has cambiado el bootloader (sólo has instalado OpenWrt) instala el que no lleva CFE.

Saludos.

pelonbcn

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #82 en: 17-12-2012, 11:26 (Lunes) »
Hola,

Muchas gracias, ya los estoy bajando. Sólo tengo una duda, el router está de fábrica con el firmware oficial de Movistar (CFE v1.0.37-102.1-5), en ese caso tengo que instalar el que tiene CFE?

Gracias,

Carlos

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #83 en: 17-12-2012, 11:36 (Lunes) »
Se ha mejorado algo el tema de la perdida de paquetes?

Gracias

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #84 en: 17-12-2012, 11:45 (Lunes) »
Se ha mejorado algo el tema de la perdida de paquetes?

Gracias
Tengo este tema a la espera de que jogo dé señales de vida, que no aparece desde hace 20 días...

Hola,

Muchas gracias, ya los estoy bajando. Sólo tengo una duda, el router está de fábrica con el firmware oficial de Movistar (CFE v1.0.37-102.1-5), en ese caso tengo que instalar el que tiene CFE?

Gracias,

Carlos
¿Entonces para qué quieres volver a poner el firmware oficial? Uno de los dos se ha perdido aquí, o tú o yo xD.

pelonbcn

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #85 en: 17-12-2012, 20:25 (Lunes) »
Buenas,

Creonque me he liado yo, pensaba que era el fimware de openwrt para el ct5813n...

Carlos

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #86 en: 29-12-2012, 00:39 (Sábado) »
Hoy he conseguido hacer funcionar el USB. Lo he estado probando (copias de ficheros, transmission, dlna) y la verdad es que no da mal rendimiento.

Cuando saque algo de tiempo hago un tutorial de cómo añadirle el USB.
Tengo que coger un router sin modificar y hacer fotos con una cámara buena.

Saludos!

aguera-competicion

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #87 en: 30-12-2012, 10:18 (Domingo) »
Gracias por esta info, en breve modificare el mio también.

Pteridium

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #88 en: 30-12-2012, 13:10 (Domingo) »
Hoy he conseguido hacer funcionar el USB. Lo he estado probando (copias de ficheros, transmission, dlna) y la verdad es que no da mal rendimiento.

¿No da mal rendimiento? Debería ser, de entre los routers que entregan los proveedores, el más rápido con casi cualquier cosa que se le pida.
http://wiki.openwrt.org/inbox/benchmark.openssl

Por cierto, ¿qué tipo de core MIPS es el que usa el BCM6369? Lo único que he encontrado es que puede ser un 4kc, pero no termino de tenerlo claro.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #89 en: 30-12-2012, 18:28 (Domingo) »
Hoy he conseguido hacer funcionar el USB. Lo he estado probando (copias de ficheros, transmission, dlna) y la verdad es que no da mal rendimiento.

¿No da mal rendimiento? Debería ser, de entre los routers que entregan los proveedores, el más rápido con casi cualquier cosa que se le pida.
http://wiki.openwrt.org/inbox/benchmark.openssl

Por cierto, ¿qué tipo de core MIPS es el que usa el BCM6369? Lo único que he encontrado es que puede ser un 4kc, pero no termino de tenerlo claro.
Creo que todos los bcm63xx son 4kc. De todas formas, el 6369 es idéntico al 6368, a excepción de que no lleva dsl.

He obtenido 4MB/s en lectura desde un pendrive formateado en NTFS, pero con ext4 el rendimiento es superior.

krasny

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #90 en: 02-01-2013, 20:07 (Miércoles) »
Que crack eres noltari!

Una pregunta, ese transistor se calienta mucho? al no estar disipando calor por ningún sitio quizá sería conveniente ponerle el típico disipador para transistor en la parte de atrás no? o quizá no haga falta...

Pues cuando pueda configurar las VLANs con Openwrt haré este mod, hasta entonces estoy limitado por la mierda del firmware de TEO :(

Muchas gracias por tu trabajo!

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #91 en: 02-01-2013, 20:15 (Miércoles) »
Que crack eres noltari!

Una pregunta, ese transistor se calienta mucho? al no estar disipando calor por ningún sitio quizá sería conveniente ponerle el típico disipador para transistor en la parte de atrás no? o quizá no haga falta...

Pues cuando pueda configurar las VLANs con Openwrt haré este mod, hasta entonces estoy limitado por la mierda del firmware de TEO :(

Muchas gracias por tu trabajo!
Si te refieres al regulador de voltaje (LM-7805) no se calienta demasiado si conectas pendrives.

Sin embargo, he probado a conectar un disco duro de 2.5'' sin alimentación externa (tiene dos puertos USB, uno para datos y otro para alimentación) y la verdad es que se puso a bastante temperatura, así que igual sí era conveniente disipar el calor de alguna forma.

No he probado con discos duros externos alimentados por fuentes externas.

Gracias por el reconocimiento y un saludo ;)

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #92 en: 08-01-2013, 18:11 (Martes) »
Por favor, leed este post entero antes de flashear nada.

Bueno, pues aquí os traigo el primer firmware con VLANs para BRCM6368:
https://dl.dropbox.com/u/4708147/openwrt/ct5813/openwrt-CT5813n-squashfs-cfe_r35052.bin

Tened en cuenta que siempre podéis volver al firmware oficial si algo va mal (disponible en el primer post).

No voy a facilitar los parches necesarios porque el driver b53 (necesario para hacer funcionar las VLANs) es de jogo, no mío.
Se supone que a lo largo de esta semana, cuando terminemos de "debuguearlo" jogo integrará los parches del b53 en el repositorio oficial de OpenWrt.

El firmware incorpora los siguiente paquetes: kmod-usb2 + kmod-usb-storage + kmod-fs-ext4 + swconfig + bird4 + luci + brcm-wl + luci-app-upnp + luci-app-ddns.
He de advertir que la estabilidad del driver b53 no está 100% garantizada.
Uno de los problemas que he identificado es que no hay comunicación con el router tras reiniciarlo por shell/luci (no ocurre el 100% de las veces, pero sí bastantes). Sin embargo, este problema no sucede si apagamos y encendemos el router desde el interruptor.
He incluido un script en el firmware que autoconfigura el router en el primer inicio para la FTTH de Movistar (VOIP inluida).

P.D: Si no respondo es que estoy ocupado, que tengo mi primer examen el día 11.

Espero que lo disfrutéis. Saludos!

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #93 en: 09-01-2013, 12:58 (Miércoles) »
Con esta versión dejaremos de perder paquetes de manera misteriosa?

Gracias

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #94 en: 09-01-2013, 13:14 (Miércoles) »
Con esta versión dejaremos de perder paquetes de manera misteriosa?

Gracias
Yo lo he probado y desde luego es más estable, pero no te prometo nada, porque ahora mismo ando algo liado y no he tenido tiempo para probarla a fondo.
Te advierto que lo he preconfigurado para Movistar FTTH, por lo que si quieres usarlo como Cliente WiFi, tienes que adaptar las VLANs en caso de que necesites usar el puerto WAN, si no lo necesitas utiliza los otros cuatro con la interfaz eth0.1 para LAN.

Además, repito que el driver b53 está en fase de pruebas, y hay cosas que fallan. Menos da una piedra, porque por lo menos hay VLANs.
Cuando termine los exámenes probablemente quite el TP-Link WDR4300 unos días y lo cambie por el CT-5813n con OpenWrt para probar su "estabilidad". Además, imagino que el driver b53 ya estará integrado en OpenWrt y algo más "debugueado".

Saludos.

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #95 en: 10-01-2013, 23:50 (Jueves) »
Vale, probado, los paquetes ya no se pierden como antes, pero la conexión inalambrica asi como la alambrica tiende a quedarse pensando como lag, como si se fuera y volviera, sobretodoo en whatsapp, la tasa de transferencia es aceptable y de la perdida de paquetes nunca mas se supo...

Gracias por vuestro magnifico trabajo!!!!  >:(

krasny

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #96 en: 11-01-2013, 23:24 (Viernes) »
Gracias por vuestro curro!!!!

Ahora mismo no tengo el router puesto, pero en cuanto pueda pruebo esta versión. Entre esto y el USB va a resultar un pedacho de equipo!

gmtii

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #97 en: 14-01-2013, 14:28 (Lunes) »
vaya, me he perdido la fiesta, pensaba que estaba suscrito al hilo y no me he enterado de los progresos con el usb... esta tarde mismo saco el router del cajón  :-[ :-[ :-[ :-[

felicidades de nuevo a Noltari que parece que también tiene dominada la electrónica  ;D

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #98 en: 14-01-2013, 14:42 (Lunes) »
vaya, me he perdido la fiesta, pensaba que estaba suscrito al hilo y no me he enterado de los progresos con el usb... esta tarde mismo saco el router del cajón  :-[ :-[ :-[ :-[

felicidades de nuevo a Noltari que parece que también tiene dominada la electrónica  ;D
Yo diría que más bien fue "pura potra" xD.

De electrónica sigo teniendo los mismos conocimientos básicos, pero prefiero dejaros esos temas a vosotros, que lo domináis más que yo.
Se me da mejor hacer parches del kernel para añadir funcionalidades/arreglar cosas que esto, aunque he de admitir que entretiene bastante andar cacharreando :D.

Saludos y cuenta los progresos con el mod ^^.

gmtii

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #99 en: 14-01-2013, 21:18 (Lunes) »
Funcionando el USB, pero con resistencias de 4k7. Con las de 10k no hubo manera...

Gracias y saludos!