Autor Tema: [Desarrollo] OpenWrt en Comtrend WAP-5813n  (Leído 313401 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Noltari

  • Visitante
Re: Openwrt en Comtrend 5813n
« Respuesta #60 en: 26-08-2012, 15:14 (Domingo) »
Actualizados los parches SVN y añadido un firmware actualizado en el primer post.

No compilaba con versiones superiores a la 32921 debido a una serie de cambios introducidos por jogo.
https://dev.openwrt.org/changeset/32921/trunk/target/linux/brcm63xx

Saludos!



krasny

  • Visitante
Re: Openwrt en Comtrend 5813n
« Respuesta #61 en: 26-08-2012, 15:34 (Domingo) »
Nada interesante en lo que al 5813n respecta en estos cambios verdad noltari?

Noltari

  • Visitante
Re: Openwrt en Comtrend 5813n
« Respuesta #62 en: 26-08-2012, 16:43 (Domingo) »
Nada interesante en lo que al 5813n respecta en estos cambios verdad noltari?
No, simplemente una actualización de los parches para que no dé error al compilar.

cheke

  • Visitante
Re: Openwrt en Comtrend 5813n
« Respuesta #63 en: 26-08-2012, 18:33 (Domingo) »
yo para que pudiera compilar con la version de subversion mas moderna en el parche tube que eliminar la seccion .set external phy = 1 , por que segun la declarion de errores no era soportado, compilado funciona todo bien menos secciones de luci

gmtii

  • Visitante
Re: Openwrt en Comtrend 5813n
« Respuesta #64 en: 24-10-2012, 00:08 (Miércoles) »
hola

estoy mirando el puerto USB de este router, y yendo directas las líneas d+ y d- a la cpu, por algún lado están en corto a tierra.. sin esquemas ni pinout, ando mirando si localizo las resistencias para cambiarlas por unas de 15k... pero por más que he mirado no doy con ellas...

EDITO: probé otro pendrive, y las líneas tienen tensión de modo que en ppio eléctricamente parece correcto ¿? sin embargo en OpenWrt no hay señal de vida...

para el regulador de 12 a 5, tomé un camino fácil:



saludos.
« Última modificación: 24-10-2012, 00:17 (Miércoles) por gmtii »

Noltari

  • Visitante
Re: Openwrt en Comtrend 5813n
« Respuesta #65 en: 24-10-2012, 00:31 (Miércoles) »
hola

estoy mirando el puerto USB de este router, y yendo directas las líneas d+ y d- a la cpu, por algún lado están en corto a tierra.. sin esquemas ni pinout, ando mirando si localizo las resistencias para cambiarlas por unas de 15k... pero por más que he mirado no doy con ellas...

EDITO: probé otro pendrive, y las líneas tienen tensión de modo que en ppio eléctricamente parece correcto ¿? sin embargo en OpenWrt no hay señal de vida...

para el regulador de 12 a 5, tomé un camino fácil:



saludos.
Ánimo, a ver si consigues algo :D. Es que yo, lo que es el hardware xD...

Saludos!

gmtii

  • Visitante
Re: Openwrt en Comtrend 5813n
« Respuesta #66 en: 24-10-2012, 09:43 (Miércoles) »
buenas,

con dos pull down, los pendrive muestran actividad (se ve parpadeo de led y tal), pero el openwrt sigue sordo ... lo cierto es que, o bien este SOC tiene las R de pull down en d+ y d- integradas y seleccionables por software ( desconectado muestran R=0 ), o bien diseñaron el puerto sin esos componentes lo que me extrañaría muchísimo... a saber



hola

estoy mirando el puerto USB de este router, y yendo directas las líneas d+ y d- a la cpu, por algún lado están en corto a tierra.. sin esquemas ni pinout, ando mirando si localizo las resistencias para cambiarlas por unas de 15k... pero por más que he mirado no doy con ellas...

EDITO: probé otro pendrive, y las líneas tienen tensión de modo que en ppio eléctricamente parece correcto ¿? sin embargo en OpenWrt no hay señal de vida...

para el regulador de 12 a 5, tomé un camino fácil:



saludos.
Ánimo, a ver si consigues algo :D. Es que yo, lo que es el hardware xD...

Saludos!

Noltari

  • Visitante
Re: Openwrt en Comtrend 5813n
« Respuesta #67 en: 09-11-2012, 12:16 (Viernes) »
buenas,

con dos pull down, los pendrive muestran actividad (se ve parpadeo de led y tal), pero el openwrt sigue sordo ... lo cierto es que, o bien este SOC tiene las R de pull down en d+ y d- integradas y seleccionables por software ( desconectado muestran R=0 ), o bien diseñaron el puerto sin esos componentes lo que me extrañaría muchísimo... a saber


¿Algo nuevo con respecto al USB?
Cuando posteaste tus intentos de conseguir USB en este router me animaste a mi también, así que me compré reguladores LM7805 por ebay y el usb para soldar a placa por dealextreme. En cuanto me llegue el usb me pongo a hacer pruebas ^^ (ya tengo el LM7805 con 5V estables).
http://www.ebay.es/itm/250876654434?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649#ht_1528wt_1159
http://dx.com/p/diy-usb-4-pin-female-90-degree-side-inserted-socket-connector-silver-10-piece-pack-127640

Por cierto, para conseguir los 5V he seguido el esquema estándar para el LM7805, pero sin el condesador de 0.33uF, porque la placa ya lleva uno de 1uF justo donde cojo los 11.77V de entrada. Sí que le he puesto el de 0.1uF en la salida.
http://artefactos.leame.com/index.php?module=weblogmodule&action=view&id=17
http://artefactos.leame.com/files/esquema7805.jpg

Saludos!

Noltari

  • Visitante
Re: Openwrt en Comtrend 5813n
« Respuesta #68 en: 10-11-2012, 23:02 (Sábado) »
Añadido al primer post un build con el kernel 3.6 y los paquetes necesarios para probar el USB 2.0 en este router. Yo estoy a la espera de que me llegue el pedido de dealextreme para soldar el USB y ponerme a hacer pruebas.
Por cierto, este build no tiene wifi.

Saludos!

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #69 en: 21-11-2012, 23:53 (Miércoles) »
Buenas noches, no se que le pasa a este router, que en el momento en que conecto los cables se pierden entorno al 70 % de los paquetes por ethernet...

Con el firmware de casa no consigo poner los 5 puertos como switch siempre pierdo 1 boca y necesito las 5 y con openwrt pierdo los paquetes...

He probado con los 3 firmwares, solo cambiando la IP, la mascara, puerta de enlace y DNS

Incomprendible

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #70 en: 25-11-2012, 03:19 (Domingo) »
Actualizados los parches para el SVN del primer post.
Llevo un par de semanas MUY LIADO con la universidad, por lo que no tengo mucho tiempo...
Así que si alguien quiere compilar un firmware con los parches y subirlo se lo agradecería.

Buenas noches, no se que le pasa a este router, que en el momento en que conecto los cables se pierden entorno al 70 % de los paquetes por ethernet...

Con el firmware de casa no consigo poner los 5 puertos como switch siempre pierdo 1 boca y necesito las 5 y con openwrt pierdo los paquetes...

He probado con los 3 firmwares, solo cambiando la IP, la mascara, puerta de enlace y DNS

Incomprendible
Yo también he notado que bastantes de los paquetes se pierden :$. Debe ser porque el switch no está bien inicializado por el bootloader. No sé si habrá que esperar al driver b53 para que funcione bien (con el que también tendremos VLANs).

Saludos!

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #71 en: 26-11-2012, 23:41 (Lunes) »
Hay esperanzas de solución o me busco otro router con red giga???

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #72 en: 26-11-2012, 23:57 (Lunes) »
Hay esperanzas de solución o me busco otro router con red giga???
jogo ha hecho algún que otro progreso estos últimos días. Ha conseguido configurar VLANs en un router 6368 con un switch 53115 (igual que el CT-5813n).

Aun así, no puedo decirte si b53 estará implementado en openwrt dentro de 1 semana o dentro de un año. Estas cosas van muy lentas...

Saludos.

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #73 en: 28-11-2012, 13:19 (Miércoles) »
Acabo de comprar un WR1043ND, buena compra o me recomiendas uno como el tuyo? WDR4300

Grcias

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #74 en: 28-11-2012, 13:42 (Miércoles) »
Acabo de comprar un WR1043ND, buena compra o me recomiendas uno como el tuyo? WDR4300

Grcias
Hombre, el WR1043ND no es nada malo :P.
El tema es que yo me pillé el WDR4300 pensando en una posible y futura ampliación de velocidad por parte de Movistar. El WR1043ND no sé hasta qué velocidad puede soportar.
El WDR4300 debería poder tirar a 200Mbps sin despeinarse, porque tiene una CPU de 540 MHz, mientras que el CT-5813n y el WR1043ND tienen 400MHz.
Éste es otro de los motivos por el que compré el WDR4300, ya que quería algo que me durara a largo y plazo y fuera mejor que el CT-5813n.

Saludos!

srt8100

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #75 en: 03-12-2012, 22:15 (Lunes) »
Buenas!!

Yo creo que este router tiene potencial, openwrt  funciona bien, cuando se vayan puliendo detalles sera un buen router.
Como decis le pasa algo con los paquetes, yo lo tengo como cliente wifi y 2 clientes por cable... pues entre ellos y con salida a internet noto que le cuesta.

Esperemos que jogo avance con el tema del driver  ;D

En cuanto al usb tenemos algun avance? seria genial poder utilizar el puerto usb en este router.. como servidor de descargas seria un tiro

salu2

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #76 en: 04-12-2012, 11:46 (Martes) »
Buenas!!

Yo creo que este router tiene potencial, openwrt  funciona bien, cuando se vayan puliendo detalles sera un buen router.
Como decis le pasa algo con los paquetes, yo lo tengo como cliente wifi y 2 clientes por cable... pues entre ellos y con salida a internet noto que le cuesta.

Esperemos que jogo avance con el tema del driver  ;D

En cuanto al usb tenemos algun avance? seria genial poder utilizar el puerto usb en este router.. como servidor de descargas seria un tiro

salu2
Pues sí, tiene bastante potencial.

La verdad es que jogo está un poco ausente estos días y aún tiene pendiente integrar mis parches para el HG556a. Una vez estén integrados, mandaré los del BCMA para que el AR-5381u/Ar-5387un/P.DG A4001N tengan WiFi. Cuando los mande, subiré los parches actualizados para que se puedan compilar firmwares mientras son aceptados.

En cuanto al USB, esta tarde igual tengo novedades, porque esta mañana me han llegado los USB que pedí a dealextreme para soldar en la placa. Me gusta que las cosas queden guays y no quería soldarle un usb que tuviese que dejar colgando por ahí :P.
http://dx.com/p/diy-usb-4-pin-female-90-degree-side-inserted-socket-connector-silver-10-piece-pack-127640

Tampoco es que entienda mucho de electrónica, pero probaré un par de cosas a ver qué pasa :P.

Saludos!

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #77 en: 04-12-2012, 15:51 (Martes) »
Aunque ya lo comenté en otra parte por ahí. Por si acaso os recuerdo que el USB en la mayoría chipsets tienen un pin que digamos mal traducido es la "señal de fallo".

Me remito a mi experiencia con el bcm6348, este pin en el SoC sí que está localizado y es el USB_PWRFLT. Resulta que este pin ha de estar conectado con una resistencia pullup para que funcione el USB.

Para más pistas además este pin es una señal de entrada, la cual va conectada a una salida del integrado que no teneis soldado en la placa.
Código: [Seleccionar]
Fault Flag (Output): Active-low, open-drain output. Indicates overcurrent or
thermal shutdown conditions.
Habrá cientos de modelos de switchs de corriente de este tipo, con más o menos patillas, así que adivinar el pinout que tendría el integrado sin soldar es imposible. Para ejemplo un Texas Instruments de 6 patillas.
http://www.ti.com/product/tps2530

El integrado no es necesario en absoluto, solo es necesario que el pin como ya dije esté conectado a VCC(3.3V) mediante una resistencia que podría estar entre 3 y 10 Kohm.

Puede que sea necesario o no, vamos que no sé si está por defecto activado internamente en este SoC en particular, o bien puede que ya esté conectado a la resistencia pullup externamente.

Yo buscaría algún punto a 3.3 Voltios en el cual haya un componente sin soldar y que se intuya que sea esta resistencia porque además va al SoC. En caso de encontrarla pues eso, soldar esa resistencia. Yo le pondría una de 5kOhm.
« Última modificación: 04-12-2012, 15:54 (Martes) por danitool »

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #78 en: 05-12-2012, 01:01 (Miércoles) »
Aunque ya lo comenté en otra parte por ahí. Por si acaso os recuerdo que el USB en la mayoría chipsets tienen un pin que digamos mal traducido es la "señal de fallo".

Me remito a mi experiencia con el bcm6348, este pin en el SoC sí que está localizado y es el USB_PWRFLT. Resulta que este pin ha de estar conectado con una resistencia pullup para que funcione el USB.

Para más pistas además este pin es una señal de entrada, la cual va conectada a una salida del integrado que no teneis soldado en la placa.
Código: [Seleccionar]
Fault Flag (Output): Active-low, open-drain output. Indicates overcurrent or
thermal shutdown conditions.
Habrá cientos de modelos de switchs de corriente de este tipo, con más o menos patillas, así que adivinar el pinout que tendría el integrado sin soldar es imposible. Para ejemplo un Texas Instruments de 6 patillas.
http://www.ti.com/product/tps2530

El integrado no es necesario en absoluto, solo es necesario que el pin como ya dije esté conectado a VCC(3.3V) mediante una resistencia que podría estar entre 3 y 10 Kohm.

Puede que sea necesario o no, vamos que no sé si está por defecto activado internamente en este SoC en particular, o bien puede que ya esté conectado a la resistencia pullup externamente.

Yo buscaría algún punto a 3.3 Voltios en el cual haya un componente sin soldar y que se intuya que sea esta resistencia porque además va al SoC. En caso de encontrarla pues eso, soldar esa resistencia. Yo le pondría una de 5kOhm.
Gracias por la info :D.

Creo que he encontrado el pin que dice danitool


Ahora sí que aparecen mensajes en el kernel al conectar un pendrive, pero da los siguientes errores:
Código: [Seleccionar]
device descriptor read/64 error -71
device not accepting address X
A raíz de los errores danitool me ha sugerido soldar resistencias pullup y pulldown en D+ y D-, pero ha sucedido lo mismo que sin ellas.

Para obtener los 5V utilizo un LM7805, cogiendo como entrada 12V. Entre los 5V y GND he colocado un condensador de 0.1uF.

A ver si alguien más entendido que yo en electrónica le da un empujón. Lo siento chicos, pero lo mío es el software xD.

Saludos!
« Última modificación: 14-01-2013, 12:11 (Lunes) por Noltari »

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #79 en: 05-12-2012, 12:11 (Miércoles) »
Bien, no sé exactamente que esquema usas de alimentación, pero pienso que el USB, justo antes del conector debiera llevar un condensador electrolítico de bastante capacidad para amortiguar los cambios en la demanda de corriente, muy altos cuando por ejemplo se enchufa en caliente un pendrive.

No sé si influye, pero yo probaría con un condensador electrolítico de al menos 10 microfaradios (ojo con la polaridad). Para enchufado en caliente al menos sería necesario uno de 470 microfaradios, y esto último lo digo por experiencia.

Evidentemente el condensador electrolítico iría conectado con el pin positivo a 5V y el negativo a GND.