Autor Tema: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO  (Leído 211952 veces)

0 Usuarios y 1 Visitante están viendo este tema.

e_8

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #80 en: 16-11-2007, 16:04 (Viernes) »
quizas alguna carpeta no se copio bien, copia la carpeta al completo /sbin desde el modo live sea usb o cd al pusb donde esta completa.


a la tarde te creo el sda3

100 x 100 , buen olfato, existian errores en el file system , reinstale desde CD ( 3 veces + en 2 pc's )
Problematica la integridad de datos en copia a USB ?? o la lectura del CD ??) y USB funcionando.
SDA3 y SDB3 OK.

Ahora toca empezar con la auditoria .
Tienes un buen enlace para empezar con las Zydas.
Necesito instalar algo más en la 3.1 para las Zydas
Donde encuentro el wireshark ,para esta versión.

Muchas gracias.




Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17710
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #81 en: 16-11-2007, 18:10 (Viernes) »
Pues ya ta rulando el wifislax en el disco duro sata con carcasa USB, pues ya consegui que leyera el vmlinuz como te dije antes pero cuando arracaba na mas arracar se me reiniciaba el ordena, pues lo he solucionado poniendo el cheatcode acpi=off en el menu.lst.

Asi que nada gente seguir intentadolo merece mucho la pena MUCHAS GRACIAS POR TODO HWAGM

vale ok, no pense en eso, en micaso tambien debo usar ese cheatcode

me alegro que funcione, asi ya puedes actualizar los drivers de rt73 y los del rtl8187 si es que los necesita, y todo lo futuro que pueda salir


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17710
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #82 en: 16-11-2007, 18:13 (Viernes) »

100 x 100 , buen olfato, existian errores en el file system , reinstale desde CD ( 3 veces + en 2 pc's )

ok


Problematica la integridad de datos en copia a USB ?? o la lectura del CD ??) y USB funcionando.

ok

SDA3 y SDB3 OK.

perfecto


Ahora toca empezar con la auditoria .

 ;D

Tienes un buen enlace para empezar con las Zydas.

proceso general, no hace falta nada especial para las zydas


Necesito instalar algo más en la 3.1 para las Zydas

no

Donde encuentro el wireshark ,para esta versión.

teclealo directamente en una shell, tal cual


Muchas gracias.



los 3 ultimos puntos mejor fuera de este post, en sus secciones respectivas, asi dejamos solo este hilo para el tema de la instalacion-usb.

--------------

Estoy contento de que os funcione


GSÜS

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #83 en: 16-11-2007, 20:58 (Viernes) »
Hola!!!

Despues varios fracasos con el tuneo de la small,  decidi no perder mas el tiempo y comprarme un usb de 4 gb para realizar la instalacin completa que me recomendo el maestro Hwagm.

La stick me la reconoce el portatil como sdb1 asi que he bajado el vmlinuz y el initrd.gz correspondiente. Una vez recopilado todo lo necesario y habiendo formateado con qtparted ext3, me dispuse a instalar la Wifislax completa.

Despues de 1 hora se instalo correctamente (o eso creo  :P). Tal y como dice el compañero ieslajanda, el problema esta al realizar el segundo paso. Si lo hago mediante el instalador (modo grafico /mnt/sdb1), me dice que el no es una particion linux, y si desde la shell tecleo grub-install --root-directory=/mnt/sdb1 /dev/sdb me dice que no encuentra en dichoso stage1, aunque yo lo veo dentro del /boot/grub. He buscado tb sin exito el fichero menu.lst ¿donde andara?

Resultado en la media parte Maquina 1 GSÜS 0

Estoy un poco fustrado... :-\  pero confio en vosotros ;)

Saludos

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17710
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #84 en: 16-11-2007, 23:03 (Viernes) »
metamos de nuevo el grub con este paquete:

abrimos shell

wget http://telefonica.net/web2/wifislax/usb/grub-0.97-i486-3.tgz

pkgtool

selecionamos current y dira si queremos instalar el grub-0.97-i486-3.tgz,

luego hacemos de nuevo el:

paso 2 y el paso 3. Y repetimos lo del

grub-install --root-directory=/mnt/sdb1 /dev/sdb
aunque sea en modo live, pues el paquete es pequeño y se instala bien.

Tambien podemos entrar en el MBR de otra forma, creo que lo he explicado.

Tecleamos en la shell

grub

y se abre el editor de grub

root          (hdX,Y)
setup (hdX)
exit

eso mete el arranque en el MBR

fijaros como detecta vuestra USB, en micado era la hd1,0

pero despues del (

pulsar el tabulador y os saldra las posibles hd.

probarlo con la usb metida y sin ella ,asi podreis ver que hd es?

Es curioso que da mas problemas el grub que no lo demas

« Última modificación: 16-11-2007, 23:05 (Viernes) por Hwagm »


GSÜS

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #85 en: 16-11-2007, 23:52 (Viernes) »
mmm algo hago mal!

1 bajo el paquete

2 tecleo pkgtool

seleciono current y puff sale sin hacer nada... no lo he logrado instalar.
Tb he mirado el grub pero al insertar y extraer el usb no varia nada.

gracias perdona mi tozudez

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17710
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #86 en: 16-11-2007, 23:59 (Viernes) »
pues eso no es normal, el pkgtool detecta los paquetes en el mismo directorio

tambien puedes hacer:

https://foro.seguridadwireless.net/index.php/topic,2128.0.html

installpkg grub-0.97-i486-3.tgz


GSÜS

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #87 en: 17-11-2007, 00:28 (Sábado) »
En primer lugar darte las gracias por contestar tan rapido  ;)

installpkg grub-0.97-i486-3.tgz funciona a la perfeccion.La dificultad es doble cuando no se domina linux...

Mañana intentare empezar desde 0 y comento los resultados.

Gracias de nuevo

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17710
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #88 en: 17-11-2007, 03:33 (Sábado) »
Ya se lo que pasa, en una nueva reinstalación me ha pasado, por alguna razon el instalador pone el montaje de la USB como solo lectura.

Hacer estos (ejmeplo para sdb1)

umount /mnt/sdb1
mount /dev/sdb1 /mnt/sdb1
mkdir /mnt/sdb1/boot

ahora ya podeis usar el paso 2  y 3 del instlador grafico

o

grubconfig1.sh
grub-install --root-directory=/mnt/sdb1 /dev/sdb

o


grub
root    (hd1,0)
setup (hd1)
quit

----------------

Ahora meter dentro de boot el vmlinuz y el initrd.gz adecuados
y logicamente modificar el /mnt/sdb1/menu.lst

root (hd1,0) >>>>>>>>>>>>>> root (hd0,0), y añadir el cheatcode deseado

y sobre todo la linea
initrd /boot/splash.initrd por
initrd /boot/initrd.gz
o el initrd.gz que se neceita en funcion de si es sda1, sdb1, etc........


aunque esto se puede modificar luego en el arranque mediante tecla <escape> e para edit y b para botear.

------------------------

si lo haceis con el grafico pues saldra la pantalla de carga que creo hadrianweb, si lo haceis mediante los 2 ultimos comandos, pues el arranque sera en modo texto sin los logos.

Asi pues podeis desoues del grubconfig1.sh y antes del grub-install --root-directory=/mnt/sdb1 /dev/sdb lo siguiente:


cp /boot/grub/message.wifiway /mnt/sdb1/boot/grub



Nota: el paso 2 es similar a ejecutar grubconfig1.sh y es lo que crea la carpeta del grub con todos los ficheros necesarios.

En definitiva desmontar el pendrive, volverlo a montar y reejecutar los pasos  2 y 3 del instlador


-------------------------------

Es lo mismo ejecutar

grub-install --root-directory=/mnt/sdb1 /dev/sdb

o


grub
root    (hd1,0)
setup (hd1)
quit

pero claro esta hace falta el contenido de la carpeta /mnt/sdb1/boot/grub y eso se genera con la script grubconfig1.sh creada por hadrianweb que es lo mismo que el paso 2 del instlador grafico, cosa que no he mencionado antes y de hay los problemas, pero que vienen debido a que en el paso 1 en algun caso de las veces que se ha iejecutado pasa el pendrive a modo de lectura, capiche.


Asi pues no es problema del paquete grub instalado y no hace falta
reinstalar installpkg grub-0.97-i486-3.tgz, para la small si, pero no es el caso


Y un comentario, si no pongo mi cheatdoce necesitado, es decir el acpi=off, a mi no me reinicia el pc simplemente llegado a un punto se queda lapantalla en negro lo mismo que si no lo pongo en modo livecd, pero en un caso a vosotros si que se os reiniciaba, igual en su dia en las pruebas cuando me pasaba lo mismo con un vmlinuz que habia compilado antes de este ultimo me pasaba lo mismo y quizas fuese por lo mismo, aunque no lo se seguro, en todo caso con este vmlinuz el kernel monolitico esta ok para arrancar con el usb, sea pendrive o un disco duro externo por usb.

Lo que si me pasa es que igual que falla al crear la carpeta boot, falla algun fichero mas, y se tira un huevo en arrancar y salen que falta algun fichero, en ese caso copio algunas carpetas a pelo como vosotros habeis hecho y luego ya arranca a la primera, asi que si el arranque se queda colgado esperar un buen ratillo.
« Última modificación: 17-11-2007, 04:01 (Sábado) por Hwagm »


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17710
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #89 en: 17-11-2007, 04:23 (Sábado) »
tambien es bueno al final de todo y antes de arrancar de desmontar la usb, en mi caso sdb1

mount /mnt/sdb1

y

e2fsck /dev/sdb1


hacerlo 2 veces.

Os repara errores del pendrive y agiliza el arranque posterior


*dudux

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #90 en: 17-11-2007, 13:32 (Sábado) »
menudo caos esta montando esto de las usb............

yo acabo de instalar el grub pero veo que no me ha creao el menu.lst dentro del boot.........
lo edito como en el post haber.........

*dudux

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #91 en: 17-11-2007, 13:55 (Sábado) »
mi gozo en un pozo.............parece que mi laptop no arranca desde usb

solo arranca desde: hdd, cd/dvd , lan y fdd

 :'(

Bodescu

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #92 en: 17-11-2007, 14:59 (Sábado) »
Unos dos o tres (cientos) intentos despues, y tras varias comeduras de olla y blasfemias de marinero turco, tengo al fin el GRUB correctamente montado en el pdrive, y logro que comience el arranque del SO. Ha sido todo un logro, porque he montado una autentica pirueta para llegar hasta este punto, y eso que en el tute parecia relativamente sencillo...

Pero...

En plena carga del SO, tenemos que VFS: Cannot open root device "sdb1" or unknown block(0,0) lo que lleva inevitablemente a 'Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)"

Aqui es donde entrais vosotros... Ideas?

Gracias

Un saludo

Bodescu

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #93 en: 17-11-2007, 15:23 (Sábado) »
Vale, el problema del FS esta resuelto: Me faltaba la linea del initrd.gz LOL!

Pero un par de lineas mas adelante se vuelve a quedar el arranque: EXT3-fs: mounting filesystem with errors, running e2fsck is recommended

Asi que paro todo, arranco la livecd y paso el e2fsck, y... Como no es EXT2, pues no me lo toca...

Asi que... EIN?  ???

Un saludo

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17710
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #94 en: 17-11-2007, 18:57 (Sábado) »
 ;D ;D ;D

pues ahora a mi mismo, despues de hacerlo todo otra vez, para ver eso del vmlinuz que si se quedaba colgado por el cheatcode ono, pues curioso, me sale lo del error 2 en el grub que falta el paso stage1, creo recordar que esto ya le salia a un compañero, pero cuando lo ley pensaba que le salia con el comando

grub-install --root-directory=/mnt/sda1 /dev/sda

bueno, espero que no se haya jodido la usb , jejeje porque ya no me deja acceder en modo live, iba a probar el gparted.iso, pero he encontrado un remedio:

estaba de paseo por el carrefour y por 9,90 euros he comprado el PANZER 2 y me he liado a destrozar tanques jejejeje, aconsejo un poco de relax que nos vamos a quemar con esto, por lo menos en este fin de semana.

Luego cuando haya disparado algunas balas me pondre de nuevo, sino es un sin vivir.


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17710
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #95 en: 17-11-2007, 23:19 (Sábado) »
sigo jugando con el PANZER 2, ya lo dije, unos dias de descanso nos viene bien a todos


chinitiw

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #96 en: 18-11-2007, 12:34 (Domingo) »
si lo del relax por unos dias no es mala opción porque despues de "algunos intentos (caguen #&&&$!!!9) estoy ya pr4obando cosas  raras y con pocomsentio!!! 

Bodescu

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #97 en: 18-11-2007, 13:13 (Domingo) »
Vale, conseguido!

El problema era de sincronia: La live me decia que si, que habia metido todo en el pendrive, pero me mentia: Lo tenia guardado en buffer. Jodio Slax xDD

Asi que prepare la llave con EXT3 desde un Debian, y luego, con la live arrancada, le di la llave, inicie el paso 1, y aun habiendo dicho que habia acabado, lo deje un rato mas. No sabria decir cuanto rato hay que dejarle hasta que vuelca el buffer, porque me fui de vermout con los colegas, y tarde un par de horitas JUAS!

Al regresar, desmonte el usb, umount /dev/sdb1, instale el GRUB, grub-install --root-directory=/dev/sdb1 /dev/sdb por consola y ejecute el paso 3 a sdb1 y sdb respectivamente.

Una vez hecho, desmonte y monte el pdrive de nuevo, y copie los archivos initrd.gz y vmlinuz corespondientes a /boot

Una vez mas, desmonto la llave y... Halt!!

Asi si, y he de decir que va como la seda desde el pdrive JUAS!!!

Gracias por el trabajo bien hecho.

Habria que investigar, quien corresponda, el por que de esa falta de sincro al terminar el paso 1. Quiza se podria forzar el vaciado del buffer una vez termina la aplicacion de trabajar, y ya que se hace asi, talvez tambien forzar el umount, para que no de problemas el paso 2.

Apuntes que dejo por si pueden ser utiles, a quien corresponda.

Un saludo

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17710
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #98 en: 18-11-2007, 13:54 (Domingo) »
 ;)

perfecto.

En mi ultimo caso, acceso por gtparted y veo que este todo lleno, a saber lo que hice.

No pasa nada, se elimina la particion, se vuelve a formatear y a empezar de cero.


Citar
Asi si, y he de decir que va como la seda desde el pdrive JUAS!!!




ya ni tocarlo, ejejej, ahora a tunearlo, pero ya jamas tocar el grub, se instala las cosas desde el mismo, drivers aplicaciones, etc.

Citar
talvez tambien forzar el umount, para que no de problemas el paso 2.

bien observado, pero lo añadire mejor al inicio del paso 2.

POrque asi pasado en paso 1, podemos ver que se instalo todo.

Y lo mismo para la script de instalacion del wifiway  ;)

Lo de vaciar el buffer y del sincro, jejeje, no llego a tanto conocimiento del linux.


« Última modificación: 18-11-2007, 13:59 (Domingo) por Hwagm »


GSÜS

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #99 en: 18-11-2007, 14:58 (Domingo) »
Conseguido!!

Tras varios intentos por fin logre instalar de forma completa la WS.

He seguido todos los pasos que anteriormente se han mencionado (importante lo de modificar el menu.lst).

La primera vez que se inicio el SO desde el usb iba muy lento, y al intentar cargar el driver de mi tarjeta wireless dio un error y se quedo en estado de aletargo. Al reiniciar ya no me cargaba el entorno gráfico (startx petaba). Reinicie varias veces pero siempre con el mismo fallo, así que no quedo mas remedio que reinstalar. Dos horas después esty escribiendo este post.

He vuelto a cargar el driver sin problemas y ahora corre de lujo. Lo único que noto es que va un pelin lento. ¿Lo de copiar las carpetas a pelo agiliza realmente algo?

Una vez mas Hwagm darte las gracias, por animarnos, tu paciencia e interes, y a todos los compañeros que hacen posible lo que parece imposible.

Saludos