Autor Tema: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO  (Leído 211659 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Antarx

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #120 en: 04-01-2008, 01:33 (Viernes) »
Pues la iso que me he bajado tiene una carpeta que pone wifislax... supongo que sera esa  ;D

En realidad, no me habia fijado que habia fijado que habia otra otra opcion.

Y es cierto que no tengo mucha idea de linux, pero creo que probandolo es como se aprende, y si no se pueden guardar los cambios, dificilmente se puede evolucionar.
Igual tenia que haber empezado por aprenderme los comandos... no se, soy un poco raro  :D

*******************
Editado:

He conseguido realizar la instalacion en el usb con la opcion Lilo, pero aunque parece que lo instala bien, no  funciona.

Y he intentado buscar el archivo menu.lst, pero no esta... de hecho, en el directorio boot no me aparece ninguna carpeta.

Voy a intentar instalarlo otra vez, con el grub, a ver que pasa

**********************
Editado 2

Borré tod el USB y probé a instalar con grub en mnt/sdb1, y lo ha instalado.

Pero luego, el paso 2 me da un error raro, (cuando le pongo como destino mnt/sdb1, msnt/sdb, dev/sdb1 o dev/sdb se sale de la aplicacion y dice que deberia haber unos directorios en user/grub y en otra parte que ahora no recuerdo.

El paso 3 tampoco va... aparentemente, funciona (no da quejas), pero el usb sigue sin ser bootable

Y curiosamente, la carpeta boot no existe dentro del USB. He pensado en copiar la carpeta boot del LIVE cd, pero seria demasiado basto... no creo que funcione.

Otra cosa.
se me ocurrio a mi, que lo mismo, habia que transferirle sistema al USB, del mismo modo que se hacia con el LIVE USB.
Fale, pues la cosa es que el archivo .bat desde windows (perdon, prohibido decirlo) si funciona, pero el .sh, no se ejecuta, si no que me lo abre en el editor de texto.


« Última modificación: 04-01-2008, 17:13 (Viernes) por Antarx »

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17707
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #121 en: 06-01-2008, 01:57 (Domingo) »
Pues la iso que me he bajado tiene una carpeta que pone wifislax... supongo que sera esa  ;D

ok


En realidad, no me habia fijado que habia fijado que habia otra otra opcion.

Y es cierto que no tengo mucha idea de linux, pero creo que probandolo es como se aprende, y si no se pueden guardar los cambios, dificilmente se puede evolucionar.

tienes razon


Igual tenia que haber empezado por aprenderme los comandos... no se, soy un poco raro  :D

yo me ley un libro de unix, que me fue muy bien,


*******************
Editado:

He conseguido realizar la instalacion en el usb con la opcion Lilo, pero aunque parece que lo instala bien, no  funciona.

lilo no, mejor usa el grub


Y he intentado buscar el archivo menu.lst, pero no esta... de hecho, en el directorio boot no me aparece ninguna carpeta.

porque lo has hecho con lilo, y debes hacerlo con grub


Voy a intentar instalarlo otra vez, con el grub, a ver que pasa

exacto, esa es la buena


**********************
Editado 2

Borré tod el USB y probé a instalar con grub en mnt/sdb1, y lo ha instalado.

Pero luego, el paso 2 me da un error raro, (cuando le pongo como destino mnt/sdb1, msnt/sdb, dev/sdb1 o dev/sdb se sale de la aplicacion y dice que deberia haber unos directorios en user/grub y en otra parte que ahora no recuerdo.

El paso 3 tampoco va... aparentemente, funciona (no da quejas), pero el usb sigue sin ser bootable

Y curiosamente, la carpeta boot no existe dentro del USB. He pensado en copiar la carpeta boot del LIVE cd, pero seria demasiado basto... no creo que funcione.

Otra cosa.
se me ocurrio a mi, que lo mismo, habia que transferirle sistema al USB, del mismo modo que se hacia con el LIVE USB.
Fale, pues la cosa es que el archivo .bat desde windows (perdon, prohibido decirlo) si funciona, pero el .sh, no se ejecuta, si no que me lo abre en el editor de texto.

los comandos .sh no se ejecutan pinchando si no escribiendolos en la consola.

Se necesita el paso 2, porque es laa unica manera de que arranque por grub, centrate en ese punto.

la usb tiene que estar formateada con formato linux - ext3, eso es muy importnte.

Pero no tienes que ejecutar ningun bat ni sh, estan confundiendo las cosas, eso es para modo liveusb, que no es lo que quieres, sino que quieres instalarla completa en la usb para guardas cambios.

El paso 3 sino esta correcto el paso 2 no sirve para nada, de hecho casi con el paso 2 ya debe valer.

el paso 2 hace una llamada al grubconfig1.sh y te da ejemplos de lo que dbes poner.

tienes la usb formateda como ext3, porsino el grub no te la reconoce como linux.


Antarx

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #122 en: 07-01-2008, 18:27 (Lunes) »
LO CONSEGUI  ;D ;D ;D

Y ya se donde estaba el problema.

El paso 2 era incorrecto. Lo que ocurre, es que como nunca lo habia conseguido hacer bien, no sabia que me tenia que salir, y por lo tanto, no me daba cuenta de que estaba mal.

Al final, despues de desmontar y montar la unidad un monton de veces, el paso 2 funcionó.

Ea, ahora, a otra cosa

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17707
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #123 en: 07-01-2008, 19:21 (Lunes) »
 ;)

perfecto pues


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17707
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #124 en: 12-01-2008, 11:03 (Sábado) »
1ª actualizcion de kernel para los que usais este tipo de instalacion en el USB

https://foro.seguridadwireless.net/index.php/topic,8367.0.html

lleva kernel mas depurado, siempre se puede volver para atras porque no borro nada solo renombro.

Y es interesante para probar las ipw4965, porque ya se que nadie con una de esas se instala las lives en el hdd de un portatil nuevo, y no se puede estar creando cada semana una iso nueva para hacerla correr en livecd, ademas de que noes posible hacerla con este nuevo kernel por el tema de las linux-lives, asi que esta actualizacion es muy buena para los que usais habitualmente el modo usb de instalacion completa.

Y mas si tenemos iwp4965, se que son drivers que estan en sus inicios, pero podemos ir aprediendo elproceso de update, para cuando los drivers esten ok.


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17707
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #125 en: 13-01-2008, 02:52 (Domingo) »
va genial la wifiway en el pendrive con este nuevo kernel.

lastima del rollo del initrd.gz sino se podria perfectamente servir ya preparada  ;)

y no acabo de ver claro un super menu con todas las posibilidades, igual si seria interesante meterlas en la tienda pero bajo demanda de peticion de como reconoce nuestro equipo  el usb pendrive.

aunque el metodo es facil, 1 se botea la live con el cd, luego se actualiza en modo live, que te lo deja todo preparado, y luego se instala, luego se modifica el menu.lst y ya esta, aunque no se si habra problemas de memoria, creo que no.


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17707
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #126 en: 14-01-2008, 01:21 (Lunes) »
importante:

para no liar las cosas, es mejor instalar la actualizacion antes de liarse con la instalacion, y solo hara falta el correspondiente:

http://telefonica.net/web2/wifislax/usb/initrd.gz

http://telefonica.net/web2/wifislax/usb/initrdsda1.gz

http://telefonica.net/web2/wifislax/usb/initrdsda2.gz

http://telefonica.net/web2/wifislax/usb/initrdsda3.gz

el sdb1 corresponde a http://telefonica.net/web2/wifislax/usb/initrd.gz

http://telefonica.net/web2/wifislax/usb/initrdsdb2.gz

http://telefonica.net/web2/wifislax/usb/initrdsdb3.gz

http://telefonica.net/web2/wifislax/usb/initrdsdc1.gz

http://telefonica.net/web2/wifislax/usb/initrdsdc2.gz

http://telefonica.net/web2/wifislax/usb/initrdsdc3.gz

y modificar el menu.lst añadiendo

initrd /boot/initrd.gz

y ya sabemos que arrancada desde el pendrive en el root(x,Y) no debemos decirle sdaX,0 o sdbX,0 sino como un disco duro,

ejemplo

root (hd0,0) aunque con la livecd el hd0,0 fuera otro

aunque esto se puede editar en el proceso de arranque

« Última modificación: 14-01-2008, 01:25 (Lunes) por Hwagm »


bheart

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #127 en: 16-01-2008, 13:36 (Miércoles) »
Hola de nuevo gente, sigo peleandome con la instalacion, y empiezo a no tener claro si lo hago bien o no, por partes:

1 lo de hacer el pendrive arrancable no hace falta? es que si no ya encontramos el primer fallo que tenia

2 formateado en ext3, eso de momento parece que si lo tenemos dominado xD

3 como no hay raviolli a arrancar desde el cd y que me funcionen los usb como dios manda lo que he hecho es crear una maquina virtual en virtualbox y ahi  si me coje los pendrives, como el disco que tengo normalmente es sata en la maquina virtual monto primero un usb para que me ocupe el sda1  y luego monto el de 4 gigas donde intalare, asi por lo menos tenemos los mismos sistemas de arranque que en el ordenador real luego.

4 hago la instalacion  en sdb1

5 configuro e instalo grub en /dev/sdb sdb1 mediante el lanzador grafico que tiene wifiway 1.0 beta2

6 al arrancar me coje el arranque, sale grub pero llega un momento que no me coje vmlinuz durante el arranque diciendo que no existe la particion.

Despues de eso ya me puse a trastear y la arme aun más gorda, pero eso ya es otra cuestion, ando en el segundo intento completo desde 0 ya os diré, si veis el fallo decirme donde está please
« Última modificación: 16-01-2008, 13:59 (Miércoles) por bheart »

chinitiw

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #128 en: 16-01-2008, 15:09 (Miércoles) »
formateas el pen con el qtparted (wifislax) o lo haces con el gparted  (wifiway) , con el primero y por experiencia te diré que me dio la hos... de problemas , pero como tenia ubuntu instalado lo hice con el gparted y sin mayores problemas , pero si lo haces con wifiway y gparted entonces por ahí no creo que sea la cosa.
 

saludos

bheart

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #129 en: 16-01-2008, 23:05 (Miércoles) »
He utilizado el gparted de ubuntu, asi que por ahi no van los tiros, ahora que he vuelto del curro seguire por donde iba, a instalar grub toca

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17707
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #130 en: 16-01-2008, 23:17 (Miércoles) »
sabeis que wifislax y wifiway se puede arrancar ademas de modo livehdd, es decir tienes la ***********.iso en windows, en el directorio raiz, no se si has probado eso, si que hace falta el cd pero solo en la 1 parte

6 al arrancar me coje el arranque, sale grub pero llega un momento que no me coje vmlinuz durante el arranque diciendo que no existe la particion.
creo qu ehay esta el problema

dime como reconoce tu equipo el usb en linux , y postea el fichero menu.lst aqui mismo  ;)

si por lo menos arrancas con el, eso ya s mucho porque has entendido que el root (x,y)  corresponde a una unidad diferente de lo habitual con hdd.

te carga el vmlinuz, eso es bueno pero lo qu equeda me imagino el porque, respondeme  a esas 2 preguntas pro favor????

Citar
lo de hacer el pendrive arrancable no hace falta? es que si no ya encontramos el primer fallo que tenia

claro que hace falta, pero si ya has arrancaco con el usb y al menos carga el vmlinuz eso es que ya lo has subsanado
« Última modificación: 16-01-2008, 23:21 (Miércoles) por Hwagm »


kyocarlos

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #131 en: 17-01-2008, 10:15 (Jueves) »
hola a todos,

Conseguí por fin hacer una partición de 4GB en el pendrive de 8GB  a fuerza de pelearme.
Al final la cree con el qtparted del liveusb del wifislax.  Mi caso es sdb1
Hice los pasos. El segundo paso lo hice con el script (de hecho lo he llegado a probar también desde la forma gráfica y ya no sé que má probar) y me dice que correcto, que sdb1 es hd1. El tercer paso lo hago correctamente con la pantalla gráfica

/mnt/sdb1
y
/dev/sdb

copio el vmlinuz y el initrd.gz al directorio boot y modifico el menu.lst

hd1,0 por hd0,0
y añado la linea
initrd /boot/initrd.gz

El resto del menu.lst lo dejo tal cual.

Arranco y me pasa que mi laptop pasa del usb y arranca directamente windows sin dar ningún error ni nada.

Os pongo mi menu.lst:

# Archivos de configuracion del GRUB  '/boot/grub/menu.lst'.
# Creado por  by 'hadrianweb' a dia de  jue 17 ene 2008 00:56:38 CET
#
# Comienzo de la seccion global del GRUB
#timeout 30
#color light-gray/blue black/light-gray
# End GRUB global section
# Other bootable partition config begins
  title Windows on (/dev/sda2)
  map (hd0,0) (hd0,1)
  map (hd0,1) (hd0,0)
  rootnoverify (hd0,1)
  makeactive
  chainloader +1
# Other bootable partition config ends
# Other bootable partition config begins
  title Windows on (/dev/sda3)
  map (hd0,0) (hd0,2)
  map (hd0,2) (hd0,0)
  rootnoverify (hd0,2)
  makeactive
  chainloader +1
# Other bootable partition config ends
# Comienzo de la configuracion del grub para linux
  title Linux on (/dev/sdb1)
  root (hd0,0)
  initrd /boot/initrd.gz
  kernel /boot/vmlinuz root=/dev/sdb1 ro vga=normal
# Configuracion del grub para linux terminada
# Other bootable partition config begins
  title Windows on (/dev/sdc1)
  map (hd0) (hd4)
  map (hd4) (hd0)
  rootnoverify (hd4,0)
  makeactive
  chainloader +1
# Other bootable partition config ends


Como nota por lo que podeis ver aquí:

sdc1 es otro pendrive (en el que tengo un wifislax 3.1 modo liveusb) que tenía conectado cuando hice el proceso para copiar vmlinuz y el initrd.gz.
con este wifislax si que me arranca cuando quiero así que la configuración de la bios de arrancar usb está bien puesta

Mis preguntas son:

En el menu.lst veo que no esta eso de makeactive ni ningún map; cómo debería ser?.
Podría quitar la seccion de sdc1 (de hecho nunca arrancaré con los 2 pendrive puestos)
Por qué no me arranca, es que ni lo intenta, pasa a windows directamente.
Qué puedo haber hecho mal? Qué cosas puedo tocar para intentar arreglarlo?
Qué es eso del wifiway.message.

Si alguien me puede poner los pasos para sdb1 resumido y darme alguna pista se lo agradecería.

gracias.



yagor77

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #132 en: 17-01-2008, 13:18 (Jueves) »
Hola tengo un pendrive de 8GB me vale la pena crear una particion  SWAP ?
gracias

bheart

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #133 en: 17-01-2008, 15:24 (Jueves) »
dime como reconoce tu equipo el usb en linux , y postea el fichero menu.lst aqui mismo

El portatil me lo reconoce en principio como sdb si no meto más que este pendrive, y en el que monto en la maquina virtual tengo hda de disco, monto otro pendrive para ocupar el sda que tendria en linux para el disco principal del portatil, y luego monto el que voy a utilizar para que quede el esquema lo más parecido posible.

En el segundo intento hemos hechado pasos para atras, me fallos el config grub y volvi a tener inutilizable el pen, asi que otra vez a empezar de nuevo, si consigo llegar al punto anterior te posteo el archivo de arranque.

(añadido) Estoy ahora con el tercer intento y voy a intentar coger capturas de pantalla y consola de como lo voy haciendo, veremos que tal, y si no ya tengo más informacion para repasar fallos
« Última modificación: 17-01-2008, 16:20 (Jueves) por bheart »

kyocarlos

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #134 en: 17-01-2008, 22:20 (Jueves) »
Al final he borrado todo y he vuelto a empezar.

Estoy en el punto 2 y cuando ejecuto grubconfig1.sh desde el instalador gráfico o a mano llego a un punto que dice:

root (hd4,0) --> error 21 selected disk does not exist
setup (hd4,0) --> error 12 invalid device requested

Por que esta pillando hd4?


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17707
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #135 en: 17-01-2008, 22:57 (Jueves) »
posiblemente ese kernel el 2.6.21.5 y el vmlinuz para usb nos este dando problemas, creo que lo haceis bien y que el problemas es ese kernel, lastima que no pueda scar una live con el nuevo kernel que compile, me da rabia, pero hay un atajo

yo en modo liveCD, usaria el update1.sh asi luego al instlar en el usb, arrancariia con ese nuevo kernel.

title Linux on (/dev/sdb1)
  root (hd0,0)
  initrd /boot/initrd.gz

eso esta bien

---------------

Hay que analizar 2 partes importante, si al menos o llega arrancar y que os dice al rrancar, sino encuentra el grub, sino encuentra el vmlinuz, y si una arrancado se queda parado, porque a lo mejor no es el initrd.gz correcto, a lo mejor es otros, es importante que cada cual analice que es donde se el proceso no es correcto, recordar


1.- fallo en el boot nada mas arrancar y avisa sobre el grub
2. no da ese fallo, pero avisa que no encutra el vmlinux

3.- pasa todo lo demas, pero lleva un momento en que despues de sañir algunas lineas, pues se queda colgado

seguramenteteneis problemas diferentes, pero al estar los 2 casos postaedaos y de forma no sguida, sino entremezclados, pues no os sigo bien, igual si me mandais un im personal con el problema en cuestion, lo podemos tratar de forma inpte, y asi me aclaro mejor

pero recordar de avisar en que punto estais, si el 1 ,el 2 o el 3

« Última modificación: 17-01-2008, 22:59 (Jueves) por Hwagm »


yagor77

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #136 en: 19-01-2008, 00:56 (Sábado) »
Yo estoy atascado en el paso 2, por mas q monto y desmonto, cuando le doy la ruta "/dev/sda1" me dice q la unidad no es de linux, si le vuelvo a dar me acepta pero da el fallo de stage1. Cuando entro a ver las particiones me dice q la sda1 es particion de linux, asi q no se.

Un saludo

kyocarlos

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #137 en: 19-01-2008, 01:15 (Sábado) »
yagor77,

cuando desmontes desenchufa el pendrive y lo vuelves a enchufar. Luego montas.

kyocarlos

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #138 en: 20-01-2008, 01:43 (Domingo) »
Tengo una pregunta para todos aquellos que hayan podido instalar en el usb
el wifiway.

Llevo peleandome algun tiempo con la instalación de wifiway y quería que alguien me confirmara una cosa que  me pasa.

Cuando estoy en el paso 1 de instalar wifiway en el usb, empiezza a copiar y llega un momento que acaba (lo dice el instalador gráfico). Pero, yo miro el pendrive y sigue parpadeando como si estuviera todavía volcando datos. Lleva así al menos un par de horas (como cuando parpadea la luz de un disco duro cuando lee y escribe) y no se si es normal, si hasta que no deje de parpadear no puedo hacer los siguientes pasos o si tengo que hacer caso omiso a este parpadeo rápido y constante y continuar con los siguientes pasos.

Lo digo pq otras veces no me fijé y apenas el instalador gráfico me dijo que acabó, yo continué con los siguientes pasos y a ver si va a ser este el motivo por el que no me arranca bien diciendo que no encuentra algún fichero

(Tu, HWAgm ya sabes de que hablo ya que te comenté el asunto por mensajes personales)

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17707
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #139 en: 20-01-2008, 01:46 (Domingo) »
si me fije en el parpadeo y suele hacer eso, pero ya te dije, copialo todo de nuevo, pero hazlo con el propio konqueror copiar y pegar salvo la carpeta boot, pero asegura que la instalacion la has hecho en el miso equipo que va a funcionar la usb, porque creo que tu has metido el initrd.gz para el sdb1, pero apostaria que tu equipo ese pendrive lo reconoce como sda1