Autor Tema: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO  (Leído 212272 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Conectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #140 en: 20-01-2008, 01:48 (Domingo) »
Yo estoy atascado en el paso 2, por mas q monto y desmonto, cuando le doy la ruta "/dev/sda1" me dice q la unidad no es de linux, si le vuelvo a dar me acepta pero da el fallo de stage1. Cuando entro a ver las particiones me dice q la sda1 es particion de linux, asi q no se.

Un saludo

probar el paso 2 con el wifislax 3.1, pero solo el paso a ver si os dice exactamente lo mismo, espero que no se problema del grubconfig del wifiway-1.0 beta 2 y del soporte internacional, probar el paso 2 con wifislax 3.1 a ver que tal

Pd: cada vez estoy mas animado por suministrar usb con el wifiway y el wifislax ya instalado unos de los, pero de forma completa, previa petcion del intrd.gz, o meterlos todos y asi cad cual elije en el arranque.

Pero si yo he podido instarlo vosotros tambien, u y una vez conseguido ya no hara falta tocarlo mas, es decir la carpeta boot/grub, eso valdra para siempre, luego ya se podra instalar cuanquier linux que su kernel tenga soporte de eset tipo


« Última modificación: 20-01-2008, 01:51 (Domingo) por Hwagm »


kyocarlos

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #141 en: 20-01-2008, 01:54 (Domingo) »
HWagm,

Pero si monto el pendrive con /dev/sdb1 y puedo acceder a él es que realmente lo está reconociendo bien, no?

bheart

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #142 en: 20-01-2008, 12:03 (Domingo) »
Creo que ya voy encontrando los fallos poco a poco, he conseguido ya volver a conseguir que me arranque el pen aunque se quede a mitad, voy a meterme al nuevo intento y deberia ser definitivo, o casi.

Continua
Efectivamente ya solucione todo lo que tenia que ver con la instalacion del grub, todo fallos mios (Si es que uno ya no sabe ni leer) pero terminar de arrancar no termina, pero eso ya es por compatibilidad con usb me imagino, se me pelea un pelin.
Probare cuando pueda a hacer una instalacion en disco y cargar la actualización a ver si cuela, pero eso ya con más calma que en el portatil no tengo disco y el fijo lo tengo desmontado.
« Última modificación: 21-01-2008, 00:01 (Lunes) por bheart »

kyocarlos

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #143 en: 27-01-2008, 20:18 (Domingo) »
hola a todos,

Voy a dar una información que puede ayudar a los que se les corta la instalación en el usb.

El tema que se corta es debido a que el número de sectores que se transfiere en las ráfagas de copia en el pendrive es incompatible con el que soporta en el pendrive.

Para modificarlo, una vez montado el pendrive hay que editar el archivo siguiente (esto es para el caso sdb1)

/sys/block/sdb/device/max_sectors

a mí por defecto me coge 240. tiene que ser un valor multiplo de 8. Idlo bajando hasta que no se os corte. Más información en:

http://eliduc.berlios.de/index.php/Grabar_datos_en_un_pendrive

Espero que esto le sirva de ayuda a alguien.

Vayamos a mi problema:

Despues de conseguir que me acabara la instalación (copia de archivos desde menu gráfico)

cuando hago el paso 2 me dice que me ha generado el grub dentro del directorio boot , incluso el menu.lst pero miro dentro y no está.

Yo tenía uno de mis pruebas anteriores y lo copié pero al arrancar me sale el prompt del grub.

Qué estoy haciendo  mal?

Alguien me puede decir una vez acabada la instalacion y copia de archivos del paso 1 que tengo que hacer para que se genere correctamente lo del grub?

Por cierto, para saber si se han copiado todos los archivos alguien me puede decir cuánto le ocupa la instalación en el pendrive?

Se me ocurrió hacer hacer un e2fsck /dev/sdb1 y empezó a encontrar errores de inodos.
Supongo que el problema está aquí; voy a probar a particionar con la iso del gparted a ver si es que wifislax tiene algún problema al hacer las particiones con qtparted y ext3.

Mucho me huele que todos los que tienen problemas del paso 2 en adelante tienen que ver con que la información en disco no se ha grabado del todo correctamente. Y si no, probad e2fsck /dev/sdb1 con la unidad que os toque. Cuando pruebe lo del gparted, ya contaré mi experiencia.

Gracias.
« Última modificación: 28-01-2008, 11:41 (Lunes) por kyocarlos »

Jaimeber

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #144 en: 12-02-2008, 23:25 (Martes) »
Lo conseguí. instalacion completa en un usb 4GB.

Es interesante de cara a actualizaciones pero el wifislax small en modo live-usb en un pen de 512MB va echando leches. Me va mas rápido que con la instalacion completa. ¿Es normal?.
Uso una ipw3945 y con airoway va lentisimo con la instalacion completa en el pen de 4GB. Sin embargo el airoscript va ma rapidito. bueno, seguiremos cacharreando.

Gracias por estos fantasticos manuales

danielguchachi

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #145 en: 22-02-2008, 17:38 (Viernes) »
hola, necesito ayuda para poder ejecutar el wifislax desde memoria 2gb, he quemado ya mi cd wifislax 3.1 iso y booteo con el ingreso mis contraseñas, tambien copie las carpetas boot y wifislax a la memoria usb, asi que inicio con el cd wifislax3.1., posteriormente ingreso las contraseñas e inicio el entorno grafico, ....empero luego no se que mas debo hacer
 nota...soy un poco nahualt para estas cosas

Conectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #146 en: 23-02-2008, 00:24 (Sábado) »
Lo conseguí. instalacion completa en un usb 4GB.

Es interesante de cara a actualizaciones pero el wifislax small en modo live-usb en un pen de 512MB va echando leches. Me va mas rápido que con la instalacion completa. ¿Es normal?.


digamos que en la small se le quito mucho peso y el acceso de usb 2.0 es rapisimo


Uso una ipw3945 y con airoway va lentisimo con la instalacion completa en el pen de 4GB. Sin embargo el airoscript va ma rapidito. bueno, seguiremos cacharreando.

Gracias por estos fantasticos manuales

usa la configuracion que creas mas adecuda, por eso hay varias, tienes lo bueno de una, y lo bueno de la otra, por eso esta claro que en el futuro las livecd deberan llevar un entorno xwin no tan pesado como el kde, si bien si debe llevar el kde, pero tambien lo otro, eso lo tengo claro, porque a  aveces se hacen unas cosas y a vaces otras y en temas de wireless, digamos no importan tanto el diseño visual de una xwin sino su rapidez, supongo sera fluxbox que le meteremos, pero solo es supongo


Conectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #147 en: 23-02-2008, 00:24 (Sábado) »
hola, necesito ayuda para poder ejecutar el wifislax desde memoria 2gb, he quemado ya mi cd wifislax 3.1 iso y booteo con el ingreso mis contraseñas, tambien copie las carpetas boot y wifislax a la memoria usb, asi que inicio con el cd wifislax3.1., posteriormente ingreso las contraseñas e inicio el entorno grafico, ....empero luego no se que mas debo hacer
 nota...soy un poco nahualt para estas cosas

esto corresponde al otro manual


Conectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #148 en: 29-02-2008, 15:05 (Viernes) »
http://packages.slackware.it/package.php?q=current/mkinitrd-1.3.1-i486-4. respecto a la parte de crear propios initrd.gz propios


javacrack

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #149 en: 29-03-2008, 19:38 (Sábado) »
Bueno, no se si continuar en este hilo o abrir uno nuevo, pero como esta relacionado con este tema, pues seguire por aqui si asi lo consideraís.

Antes de nada, decir que he estado leyendo bastante sobre la instalación en USB Completa, me abre leido todos los post como 5 - 6 veces por si me dejaba algo, y otros muchos mas, asi que por falta de lectura no creo que sea el problema que tengo.

Decir que la memoria USB esta formateada con Ext3 con el qtparted, eso si, no he creado ninguna particion del tipo swap, no se si sera necesaria

Bueno, el proceso completo lo he conseguido terminar, desde el 1 al 3, asi como meterle a la memoria USB en /boot , el wmlinuz y el initrdsda1.gz (en mi caso me la reconoce como sda1)
Logicamente he editado el menu.lst y lo he dejado asi:

Citar
gfxmenu /boot/grub/message.wifiway
default = 0
timeout = 10
# Archivos de configuracion del GRUB  '/boot/grub/menu.lst'.
# Creado por  by 'hadrianweb' a dia de  Sat Mar 29 10:56:10 2008
#
# La copia antigua de tu MBR esta en '/dev/sda' is
# here '/boot/grub/mbr.sda.30517'.  You can restore it like this.
# dd if=mbr.sda.30517 of=/dev/sda bs=512 count=1
#
# Comienzo de la seccion global del GRUB
#timeout 30
#color light-gray/blue black/light-gray
# End GRUB global section
# Comienzo de la configuracion del GRUB para WIFISLAX 3.0
title Wifislax 3.1
root (hd0,0)
kernel /boot/vmlinuz root=/dev/sda1
initrd /boot/initrdsda1.gz
save default
#Configuracion del grub para WIFISLAX terminada
# Comienzo de la configuracion del GRUB para WIFISLAX 3.0
title Wifislax 3.1 (nopcmcia)
root (hd0,0)
kernel /boot/vmlinuz root=/dev/sda1 ro vga=791 splash=silent showopts nopcmcia
initrd /boot/initrdsda1.gz
save default
#Configuracion del grub para WIFISLAX terminada
# Comienzo de la configuracion del GRUB para WIFISLAX 3.0
title Wifislax 3.1 (normalnopcmcia)
root (hd0,0)
kernel /boot/vmlinuz root=/dev/sda1 ro vga=normal splash=silent showopts nopcmcia
initrd /boot/initrdsda1.gz
save default
#Configuracion del grub para WIFISLAX terminada
# Other bootable partition config begins
  title Windows on (/dev/hda1)
  rootnoverify (hd0,0)
  makeactive
  chainloader +1
# Other bootable partition config ends
# Other bootable partition config begins
  title Windows on (/dev/hda5)
  map (hd0,0) (hd0,4)
  map (hd0,4) (hd0,0)
  rootnoverify (hd0,4)
  makeactive
  chainloader +1
# Other bootable partition config ends
# Other bootable partition config begins
  title Windows on (/dev/hdc1)
  map (hd0) (hd1)
  map (hd1) (hd0)
  rootnoverify (hd1,0)
  makeactive
  chainloader +1
# Other bootable partition config ends
Vamos, que me he creado 3 arranques por probar

Tambien he ejecutado el script de simulación con el siguiente resultado, no sé si sera OK o no:
Citar
wifislax ~ # ifconfig eth0 up
wifislax ~ # dhcpcd eth0
wifislax ~ # wget http://telefonica.net/web2/wifislax/usb/1.sh
--19:00:56--  http://telefonica.net/web2/wifislax/usb/1.sh
           => `1.sh'
Resolving telefonica.net... 213.4.130.95
Connecting to telefonica.net|213.4.130.95|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 940 [application/x-sh]

100%[====================================================>] 940           --.--K/s

19:00:56 (79.16 MB/s) - `1.sh' saved [940/940]

wifislax ~ # chmod +x 1.sh
wifislax ~ # 1.sh
Indicar particion donde emular
sda1

umount /mnt/sda1
export LFS=/mnt/sda1
mkdir -pv /mnt/sda1
mkdir: created directory `/mnt/sda1/dev'
mkdir: created directory `/mnt/sda1/proc'
mkdir: created directory `/mnt/sda1/sys'
mount -v -t ext3 /dev/sda1 /mnt/sda1
/dev/sda1 on /mnt/sda1 type ext3 (rw)
mknod -m 600 /mnt/sda1/dev/console c 5 1
mknod: `/mnt/sda1/dev/console': File exists
mknod -m 666 /mnt/sda1/dev/null c 1 3
mknod: `/mnt/sda1/dev/null': File exists
mount --bind /dev /mnt/sda1/dev
mount -vt devpts devpts /mnt/sda1/dev/pts
devpts on /mnt/sda1/dev/pts type devpts (rw)
mount -vt tmpfs shm /mnt/sda1/dev/shm
shm on /mnt/sda1/dev/shm type tmpfs (rw)
mount -vt proc proc /mnt/sda1/proc
proc on /mnt/sda1/proc type proc (rw)
mount -vt sysfs sysfs /mnt/sda1/sys
sysfs on /mnt/sda1/sys type sysfs (rw)
wifislax / #


Pero cuando arranco desde el USB, me sale el Menu Grafico, seleciono el arranque 1 -el 2 y el 3 lo mismo- , y lo que consigo es esto:
Citar
root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
Kernel /boot/wmlinuz root=/dev/sda1
 [linux-bzImage, setup=0x1e00, size=0x311188]
initrd /boot/initrdsda1.gz
 [linux-initrd @ 0x1ff3600, 0xb9f6e bytes]

Ucompressing linux
crc error
-- System halted

Esta claro, que esas 3 ultimas lineas ya pueden dar idea de por donde falla el tema, alguna idea. gracias.

Saludos



« Última modificación: 29-03-2008, 19:53 (Sábado) por javacrack »

chinitiw

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #150 en: 29-03-2008, 19:53 (Sábado) »
yo juraria , que si te da un error de crc en el initrd deberias volver a descargarlo e introducirlo por si las moscas , pero solo es una idea

Saludos

javacrack

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #151 en: 29-03-2008, 20:30 (Sábado) »
Hola chinitiw

Gracias una vez mas por echarme un cable...el tema es que lo he vuelto a bajar y el fichero no lo veo corrupto, su tamaño sin comprimir es de 761.710 , y si lo descomprimo por si estuviera roto, me sale un unico fichero llamado "initrsda1" de 1.459.712

No se, pero he probado con otro disco USB que tengo de un portatil viejo -mira por donde, le podria sacar utilidad- y al finalizar todo el proceso, IDEM, el mismo error xD

Esto se complica por momentos, no pensaba que fuera tan complicado, y la idea de crear particiones en el disco duro del PC para instalar el wifislax no me gusta.

Ya se me pasa por la cabeza, el si arrancar siempre con el LIVECD WifiSlax3.1 y luego , decirle que instale sobre el disco USB, seria otra opcion, pero me hubiera gustado porder usar un LIVE-USB Completo.

Un Saludo.

chinitiw

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #152 en: 29-03-2008, 20:43 (Sábado) »
prueba a particionar sin el qtparted , a mi me dio bastantes problemas ,prueba con el cfdisk te pongo un enlace de un tuto de un compi del foro drvalium

https://foro.seguridadwireless.net/index.php/topic,9035.0.html

Saludos

javacrack

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #153 en: 29-03-2008, 20:56 (Sábado) »
Bueno, cosa curiosa, ¿ Sera que no lo entendi bien ?
Pues he descomprimido el initrdsda1.gz y le he dejado el fichero que contenia "initrdsda1" en el /boot, y he modificado uno de los 3 arranques haciendo alusion a este fichero y vuala, ese error ha desaparecido, lo que me da de pensar que no podia descomprimir el initrdsda1.gz.

No obstante, despues de salir bastantes lineas.. me salta otro error, haciendo alusion a que no puede montar o el fichero o directorio no esta... asi que como tengo 2 discos USB que quito y pongo facil, voy a formatear con el cfdisk que si no lo hice antes fue porque cuando ejecute cfdisk, me salia arriba por defecto como Unidad de Disco /dev/hdxx  y no se como cambiarlo para que sea mi sda1.

Creo que el wifiway lleva el gparted -en lugar del qparted- , igual podria usar ese tambien.

Gracias.
« Última modificación: 29-03-2008, 21:18 (Sábado) por javacrack »

chinitiw

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #154 en: 29-03-2008, 21:18 (Sábado) »
jod.. no te había entendido bien ese initrdsda1.gz no lo descomprimas tiene que ser tal cual , por eso no te tira

Saludos

javacrack

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #155 en: 29-03-2008, 21:22 (Sábado) »
Citar
initrdsda1.gz no lo descomprimas tiene que ser tal cual , por eso no te tira

No no, si me habias entendido perfectamente, justamente cuando lo he descomprimido (he dejado los dos, comprimido y descomprimido) es cuando ya no ha salido el error... pero por el error que ha salido despues, tiene toda la pinta de que el disco USB que se ha formateado con el qparted me esta dando problemas.

usua69

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #156 en: 11-04-2008, 00:33 (Viernes) »
Buenas noches a tod@s...
Despues de leer y entender los pasos para instalar wifiway en un pendrive, he conseguido hacer que arranque el sistema. carga el initrd.gz y el vmlinuz perfectamente... pero se me queda el portatil enganchado en lo siguiente:

--------------
.
.
.
.
initrd.gz: Loading kernel modules from initrd image:
input: AT Translated Set 2 keyboard as /class/input/input4
mount: mounting /dev/sdb1 on /mnt failed: No such file or directory
ERROR: NO /sbin/init found on rootdev (or not mounted). Trouble ahead.
             You can try to fix it. Type 'exit' when things are done.
--------------

Por lo que puedo entender parece que no puede montar el pendrive (/dev/sdb1) en (/mnt)
La carpeta existe perfectamente en el pendrive....
en la parte donde dice ERROR... imagino que es porque no monta el pendrive en la linea anterior..

¿alguien puede echarme una mano?

Gracias




iTek

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #157 en: 14-04-2008, 16:15 (Lunes) »
Buenaaaas....

Mi primer mensaje por aqui ^^ (soy Pex2 en foro de elhacker.net)

Bueno, mi problema/duda

Tengo un Kingston de 4 Gb, en ext3 con el primer paso del grub realizado...
El caso, es que hago lo que he leido

Desmonto, intento instalar el segundo paso del grub... tanto textual como graficamente...

Me dice que no existe la cacharra (el pen me lo detecta como sdb1... por lo que uso los comandos tal y como los posteais aqui)

Bueno, lo monto y lo intento... me dice que el stage1 no puede leerse correctamente

Y hay me quedo :S

Que hago?

Gracias por la ayuda :D

Conectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #158 en: 14-04-2008, 21:24 (Lunes) »
auqne sea sdb1, quizas una vez arrancado con el solo ya no sea sdb1 sino otro, eso para usua69

para iTek

yo miraria de hacer los pasos 2 y 3 de forma manual



iTek

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #159 en: 15-04-2008, 21:43 (Martes) »
Por mas que e instalado y desinstalado (formateando) la instalacion... me quedo en el paso 1

Paso 1
Formateo a ext3

Paso 2
Instalo WifiSlax 3.1 en el pendrive (lo hago desde la distro instalada en el pc... puede ser el problema?)

Paso 3
Intento hacer la instalacion Grub... y por metodo grafico me dice que sdb1 no es particion linux y por manual me dice que Stage1 no puede ser leido correctamente o algo asi.

Ai me quedo. U.U

Saludos y gracias.

Lo necesitaba para mañana, asi que hice una instalacion live, y me queda espacio en el pendrive para guardar las capturas... aunque tenga que guardarlas fuera, porque si no tmb se borran :S

Saludos!!!! xDD