Autor Tema: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO  (Leído 212896 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ChimoC

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #40 en: 13-11-2007, 11:23 (Martes) »
Buenas:

Seguro que lo has formateado en ext3....

Un saludo

ChimoC



ieslajanda

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #41 en: 13-11-2007, 11:43 (Martes) »
sí sí seguro, ya te digo que lo he hecho con el qtpart y de hecho mirando con el comando mount me lo monta de tipo ext3 y posteriormente mirando la información q da el qtpart tb lo indica como de tipo ext3

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #42 en: 13-11-2007, 18:44 (Martes) »
Hazlo de forma manual

grub-install --root-directory=/mnt/sdb1/ /dev/sdb

porque eso es lo que hace el lanzador de paso 2

supongo que en el lanzdor grafico has puesto

/mnt/sdb1
y
/dev/sdb

en todo caso abre shell y pruebalo de esa forma


 


Portmeo

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #43 en: 14-11-2007, 12:34 (Miércoles) »
Buenas primero felicitar por el trabajo que aseis.

Bueno pues os cuanto, tengo un disco duro de 80g SATA en una carcasa USB, con 2 particiones nua ntfs de datos na mas y un que hice para el wifislax. la formate en ext3. Hasta todo sin problemas. bueno pues he intentao intalar wifilax y no tengo raviolli. Primero lo instale con el instalador normal que viene en el wifilax (no con el grub) y me funciono pero se me keda pillao en el arramke. y anoche lo intente con el grub y no me funciona y encima despues de tanto rato al final me cargue el arranke de XP :). Entonces haber si me podeis echar una mano GRACIAS

e_8

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #44 en: 14-11-2007, 14:35 (Miércoles) »
Saludos y gracias por el initrdsdb3.
Resumo
- Realizo la instalación desde una llave Usb con wifislax en formato comprimido a otra Usb sin comprimir con el proceso de instalación de Wifislax
- Instalo y configuro Grub para disco hd0,2 , vmlinuz y initrdsdb3.gz (bajados de los enlaces)
- El boot se queda en un bucle con el error que te paso

sdb: sdb1 sdb2 sdb3
sd 4:0:0:0: Attached scsi removable disk sdb
sd 4:0:0:0: Attached scsi removable sg1 type 0
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
:exiting
Bad initab entry: id:3:initdefaultd:
Bad initab entry: pf::powerfail:/sbin/genpowerfail start
Bad initab entry: pg::powerofwait:/sbin/genpowerfail stop

No continua

Acepto sugerencias

Para terminar , dependiendo si los hdd del pc donde este son ide o scci , la particion a cargar es la sdb3 o sda3 por ello en el menu.lst de Grub he definido los 2 posibilidades , si no te es mucho problema podrias generar el sda3

Gracias






Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #45 en: 14-11-2007, 14:41 (Miércoles) »
quizas alguna carpeta no se copio bien, copia la carpeta al completo /sbin desde el modo live sea usb o cd al pusb donde esta completa.


a la tarde te creo el sda3
« Última modificación: 14-11-2007, 18:39 (Miércoles) por Hwagm »


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #46 en: 14-11-2007, 14:43 (Miércoles) »
Buenas primero felicitar por el trabajo que aseis.

Bueno pues os cuanto, tengo un disco duro de 80g SATA en una carcasa USB, con 2 particiones nua ntfs de datos na mas y un que hice para el wifislax. la formate en ext3. Hasta todo sin problemas. bueno pues he intentao intalar wifilax y no tengo raviolli. Primero lo instale con el instalador normal que viene en el wifilax (no con el grub) y me funciono pero se me keda pillao en el arramke. y anoche lo intente con el grub y no me funciona y encima despues de tanto rato al final me cargue el arranke de XP :). Entonces haber si me podeis echar una mano GRACIAS

como reconoce wifislax a esa particion en linux del USB SATA??


Portmeo

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #47 en: 14-11-2007, 16:42 (Miércoles) »
Bueno pues despues de otro intento he conseguio instalar el wifislax con el grub, arranco con el disco externo y me sale el menu, pero al seleccionar el wifislax en el menu cuando se ejecuta me sale este error:

"root (hd1,0)
Filesystem type unknown, partition type 0x7
kernel /boot/vmlinuz root=/dev/sdb1 ro vga=791 splash=silent

Error 17: Cannot mount selected partition"

el disco duro me lo reconoce como sdb1 y me bajao el initrd que ay puesto que creo que es el sdb1 no?

Bueno un saludo y aver si sigue esto palante. GRACIAS

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #48 en: 14-11-2007, 18:25 (Miércoles) »
Saludos y gracias por el initrdsdb3.
Resumo
- Realizo la instalación desde una llave Usb con wifislax en formato comprimido a otra Usb sin comprimir con el proceso de instalación de Wifislax
- Instalo y configuro Grub para disco hd0,2 , vmlinuz y initrdsdb3.gz (bajados de los enlaces)
- El boot se queda en un bucle con el error que te paso

sdb: sdb1 sdb2 sdb3
sd 4:0:0:0: Attached scsi removable disk sdb
sd 4:0:0:0: Attached scsi removable sg1 type 0
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
:exiting
Bad initab entry: id:3:initdefaultd:
Bad initab entry: pf::powerfail:/sbin/genpowerfail start
Bad initab entry: pg::powerofwait:/sbin/genpowerfail stop

No continua

Acepto sugerencias

Para terminar , dependiendo si los hdd del pc donde este son ide o scci , la particion a cargar es la sdb3 o sda3 por ello en el menu.lst de Grub he definido los 2 posibilidades , si no te es mucho problema podrias generar el sda3

Gracias







http://telefonica.net/web2/wifislax/usb/initrdsda3.gz

Citar
quizas alguna carpeta no se opio bien, copia la carpeta al comleto /sbin desde el modo live sea usb o cd al pusb donde esta completa.


copia tambien la carpeta /etc por si el inittab no se hubiera grabado bien



Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #49 en: 14-11-2007, 18:28 (Miércoles) »
Bueno pues despues de otro intento he conseguio instalar el wifislax con el grub, arranco con el disco externo y me sale el menu, pero al seleccionar el wifislax en el menu cuando se ejecuta me sale este error:

"root (hd1,0)
Filesystem type unknown, partition type 0x7
kernel /boot/vmlinuz root=/dev/sdb1 ro vga=791 splash=silent

Error 17: Cannot mount selected partition"

el disco duro me lo reconoce como sdb1 y me bajao el initrd que ay puesto que creo que es el sdb1 no?

Bueno un saludo y aver si sigue esto palante. GRACIAS

root (hd0,0)


estaba comentado en el post bloqueado del desarrollo y las pruebas.

https://foro.seguridadwireless.net/index.php/topic,6774.0.html

esto se debe a que el menul.st que genera el instaldor, si corresponde la usb a hd1,0, pero cuando arranca directamente con el usb, pues el suyo mismo es hd0,0 ... ojo no preocuparse con esta circunstamcia, a mi por ejemplo me costo horas dar con ese detalle.

O modificas el menu.lst y nada mas, o justo al arrancar puedes editar esa linea, como tu lo veas, casi mejor el menu.lst

pd: si . el initrd.gz que hay puesto corresponde a sdb1, que es mi caso
« Última modificación: 14-11-2007, 18:43 (Miércoles) por Hwagm »


ChimoC

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #50 en: 14-11-2007, 18:44 (Miércoles) »
Buenas:

Hwagm... cuando te refieres a editar desde el arranque y no desde menu.lst.. lo que hay que hacer cuando veas que ha arrancado el usb apretar el escape (esc).... no?

Un saludo

ChimoC


Portmeo

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #51 en: 14-11-2007, 18:48 (Miércoles) »
Que deberia modificar en el menu.lst no lo tengo claro vamos ni idea de que tengo que modificar.

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #52 en: 14-11-2007, 18:50 (Miércoles) »
donde dice

root (hd1,0)

que diga

root (hd0,0)

un 0 por un 1.


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #53 en: 14-11-2007, 18:52 (Miércoles) »
Buenas:

Hwagm... cuando te refieres a editar desde el arranque y no desde menu.lst.. lo que hay que hacer cuando veas que ha arrancado el usb apretar el escape (esc).... no?

Un saludo

ChimoC



si, si es el grub que se ha instalado con el wifislax-3.1 para que pase  a modo texto, y luego ya se puede editar como siempre se han editado los grubs, c, e, b, etc..............

Pero que es lo mismo que editar el menu.lst, pero para ir mas rapido se edita en el propio arranque, asi es como dimos con ello, porque si hay que editar el menu.lst cada vez pues es mucho tiempo, pero en el caso de Portmeo tengo clarisimo que necesita un root(hd0,0) y para que no se lie con el arranque mejor que carge en modo liveCD que acceda a la  particion USB donde instalo el wifislax y que edite el menu.lst, es mas,. se puede meter varios arranques para probar, pero en su caso basta con root(hd0,0) solo es un fichero de texto que se modifica rapido

« Última modificación: 14-11-2007, 18:54 (Miércoles) por Hwagm »


Portmeo

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #54 en: 14-11-2007, 18:57 (Miércoles) »
Pues siento decirte que no a funcionao. cambio el 1 por el 0 y nada sigue dando el mismo error.

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #55 en: 14-11-2007, 19:03 (Miércoles) »
hay una forma de averiguar cual es.

Arranca con el usb, teclea <esc> entraras en modo texto, situate sobre la linea

root (hd0,0)

pulsar e para editar


borrala entera

escribe

root
luego unos cuantos espacios y luego

(

root           (
justo hay dale al tabulador y podras ver los hd que hay

prueba con ellos

luego mete coma

,

y otra vez tabulador

asi sabras que root necesitas

es facil de hacer

.........................

teclas usadas, escape , e para editar, enter y b para arrancar
« Última modificación: 14-11-2007, 21:20 (Miércoles) por Hwagm »


Portmeo

  • Visitante
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #56 en: 14-11-2007, 19:18 (Miércoles) »
Bueno te explico lo que tengo, me han salido 4 posible disk are : fd0,hd0,hd1,hd2

si pruebo con fd0 me dice que disk read error

con el hd0 me saca 3 posibles particiones :

partition num 0, filesystem type is ext2fs, partition type 0x83
partition num 1, filesystem type unknown, partition type 0x82
partition num 2, filesystem type unknown, partition type 0x7


y en hd1 nada y hd2 nada
« Última modificación: 14-11-2007, 19:24 (Miércoles) por Portmeo »

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #57 en: 14-11-2007, 21:17 (Miércoles) »
la hd0 debe ser la particion de windows, que es lo normal que suele ser en los poartatiles, a mi me saca tambien 3, pero a mi me la da en hd1 y no hd0.

En todo caso en hd1 y hd2, es rarisimo que despues de poner la com (,) no te ponga cero.

Es muy raro.


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #58 en: 14-11-2007, 21:19 (Miércoles) »
¿en modo liveCD o liveUSB, puedes llegar a ver y montar el usb donde has instalado wifislax?

esta correcto la particion verdad?

te dice con el qtparted que es una particion de linux ext3, verdad?

con

fdisk -l tambien te da la informacion correcta verdad, es que no salga nada despues del hd1 y el hd2 es muy raro


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17738
    • GNU/Linux Wifislax
Re: Instalacion liveCD en USB - no modo liveusb sino completo . LOGRADO
« Respuesta #59 en: 14-11-2007, 22:57 (Miércoles) »
la hd0 debe ser la particion de windows


 ;D ;D ;D ;D hay lo he bordado, gracias a ChimoC que me lo ha corregido , sorry


//FINAL Y MÁS DOS RESPUESTAS