Autor Tema: Hilo exclusivo desarrollo wifislax64  (Leído 168830 veces)

0 Usuarios y 1 Visitante están viendo este tema.

sol666

  • Visitante
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #240 en: 23-05-2016, 00:31 (Lunes) »
lo bueno es que la del dia 12 si que instala,parece que todo viene desde que esta lo del efi.



KaitoMX

  • Visitante
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #241 en: 23-05-2016, 01:02 (Lunes) »
puede tener algo que ver con que el dico cuando lo formateas para efi va en gpt y sino en mbr no se si podria ser eso

carco

  • Visitante
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #242 en: 23-05-2016, 08:37 (Lunes) »
buenas,ya estoy otra vez mareando jejejej,pues me he decidido a instalar la del dia 21 en el portatil y me he llevado el chasco,todo bien hasta que procede a instalar el GRUB,selecciono MBR (recomendado) y me salta

Ocurrio un error durante la instalacion,no se puede continuar,



Edito:He probado tambien la del dia 22 con el mismo resultado incluso haciendola booteable desde win7 pero sin embargo tengo la del dia 12 y si que me ha dejado instalarla el grub.

Me pasa lo mismo instalando la del 22052016 me cargado el grub2 .

como recupero el GRUB2 rescue.... e probado con el cmd ls (hd0.msdos..) y nada.

saludos.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #243 en: 23-05-2016, 15:31 (Lunes) »
el error es este..

Código: [Seleccionar]
Path `/boot/grub' is not readable by GRUB on boot. Installation is impossible. Aborting.
pero no tengo solucion

Cambiando en el script la orden

Código: [Seleccionar]
chroot "$MNT" grub-install --target=i386-pc --boot-directory=/boot --recheck --force "$DEVICE"

por

Código: [Seleccionar]
chroot "$MNT" grub-install --debug --target=i386-pc --boot-directory=/boot --recheck --force "$DEVICE"

en la terminal se puede ver

Código: [Seleccionar]
+ /usr/sbin/grub-probe -t fs /boot/grub
+ return 1
+ gettext_printf 'Path `%s'\'' is not readable by GRUB on boot. Installation is impossible. Aborting.\n' /boot/grub


Lo que significa que la instalación falla porque al ejecutar

Código: [Seleccionar]
grub-probe -t fs /boot/grub

este devuelve un error... ok entonces lo hacemos a mano para ver cual es el error...

Código: [Seleccionar]
wifislax ~ # MNT=/mnt/sdb1
wifislax ~ # mount --bind /dev "$MNT"/dev
wifislax ~ # mount --bind /dev/pts  "$MNT"/dev/pts
wifislax ~ # mount --bind /proc "$MNT"/proc
wifislax ~ # mount --bind /sys  "$MNT"/sys
wifislax ~ # chroot "$MNT"
wifislax / # grub-probe -t fs /boot/grub
grub-probe: error: unknown filesystem.

Problema identificado: grub-probe no reconoce el sistema de archivos... será por los últimos cambios en el initrd? lo digo porque ahora el archivo fstab es diferente...

Código: [Seleccionar]
wifislax / # cat /etc/fstab
# System mounts:
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0

# Raiz del sistema
/dev/sdb1 /                ext4        defaults         1   1

# Otras particiones
/dev/sda1 /mnt/sda1 ntfs noauto,noatime,nodiratime,suid,dev,exec,async 0 0
/dev/sda2 /mnt/sda2 ntfs noauto,noatime,nodiratime,suid,dev,exec,async 0 0
/dev/sda3 /mnt/sda3 ntfs noauto,noatime,nodiratime,suid,dev,exec,async 0 0


No se si tendrá algo que ver... pero la cosa es que cuando consigamos que grub-probe reconozca el sistema de archivos, la instalación no fallará.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14481
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #244 en: 23-05-2016, 17:50 (Lunes) »
llevo meses instalandola al hdd tanto la de 64 como la de 32 (mismo initrd)

acabo de probar la de 32  y pasa lo mismo ..

debe ser alguno de los ultimos updates de slackware..algo cambia.

CONFIRMADO ,es algo que cambio en los updates del dia 20 en slackware , por que una iso justo antes que no lleva dichos updates funciona bien.


apuesto por el ultimo de estos

Fri May 20 21:20:29 UTC 2016
a/aaa_base-14.2-i586-2.txz: Rebuilt.
       Updated your your initial email. ;-)
       Thanks to Tonus for the typo report.
a/aaa_elflibs-14.2-i586-15.txz: Rebuilt.
a/btrfs-progs-v4.5.3-i586-1.txz: Upgraded.
a/e2fsprogs-1.43-i586-1.txz: Upgraded.
« Última modificación: 23-05-2016, 17:57 (Lunes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14481
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #245 en: 23-05-2016, 18:11 (Lunes) »
confirmadisimo..

iso que a pelo me funciona perfecta le añado en modules


Código: [Seleccionar]
a/e2fsprogs-1.43-i586-1.txz: Upgraded.
y la instalacion falla
« Última modificación: 23-05-2016, 18:12 (Lunes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14481
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #246 en: 23-05-2016, 19:38 (Lunes) »
ya lo tengo

/etc/mke2fs.conf


debe estar como siempre ha estado , no se que han hecho en el ultimo paquete que viene distinta la config...
Código: [Seleccionar]

[defaults]
base_features = sparse_super,large_file,filetype,resize_inode,dir_index,ext_attr
default_mntopts = acl,user_xattr
enable_periodic_fsck = 0
blocksize = 4096
inode_size = 256
inode_ratio = 16384

[fs_types]
ext3 = {
features = has_journal
}
ext4 = {
features = has_journal,extent,huge_file,flex_bg,uninit_bg,dir_nlink,extra_isize
auto_64-bit_support = 1
inode_size = 256
}
ext4dev = {
features = has_journal,extent,huge_file,flex_bg,uninit_bg,dir_nlink,extra_isize
inode_size = 256
options = test_fs=1
}
small = {
blocksize = 1024
inode_size = 128
inode_ratio = 4096
}
floppy = {
blocksize = 1024
inode_size = 128
inode_ratio = 8192
}
big = {
inode_ratio = 32768
}
huge = {
inode_ratio = 65536
}
news = {
inode_ratio = 4096
}
largefile = {
inode_ratio = 1048576
blocksize = -1
}
largefile4 = {
inode_ratio = 4194304
blocksize = -1
}
hurd = {
     blocksize = 4096
     inode_size = 128
}

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14481
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #248 en: 23-05-2016, 21:29 (Lunes) »
Pues a ver como resuelven  ;D

Me he cepillado TODO MI EQUIPO , asi que no se cuando voy a poder subir algo ...  >:(

He formateado sin darme cuenta

/dev/sda   en vez de  /dev/sda1

con lo que he perdido todos los sitemas ,.. isos  , ... jajaja toa toa toa...formateriaaa toaaa  >:D >:(

sol666

  • Visitante
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #249 en: 23-05-2016, 22:59 (Lunes) »
pues yo tengo la del dia 12,21 y 22,si te hacen falta dimelo  ;) ;)

Desconectado lupox

  • Colaborador
  • *
  • Mensajes: 531
  • volver....
Re:
« Respuesta #250 en: 24-05-2016, 17:49 (Martes) »
Particiones formateadas --- testdisk

alonsote

  • Visitante
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #251 en: 25-05-2016, 17:38 (Miércoles) »
La aplicación YAMAS,al final cuando se tienen que abrir dos ventanas aparece lo siguiente:
- una ventana con el nombre arpspoof con el mensaje: "xterm: Can't execvp arpspoof: No existe el fichero o el directorio".
- otra ventana con el nombre Passwords con el mensaje: "Analizando /tmp/yamas.txt para credenciales.

La primera ventana indicada es la que tiene el error.

Saludos

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14481
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #252 en: 25-05-2016, 20:05 (Miércoles) »
Código: [Seleccionar]
arpspoof
Me lo anoto , gracias.


Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #253 en: 25-05-2016, 22:20 (Miércoles) »
Pues a ver como resuelven  ;D

Me he cepillado TODO MI EQUIPO , asi que no se cuando voy a poder subir algo ...  >:(

He formateado sin darme cuenta

/dev/sda   en vez de  /dev/sda1

con lo que he perdido todos los sitemas ,.. isos  , ... jajaja toa toa toa...formateriaaa toaaa  >:D >:(

si quieres te paso un GetDataBack, con eso se recuperan datos hasta si has reinstalado el SO encima de lo formateado.

Aunque hagas un formateo de bajo nivel, los datos siguen ahí.
« Última modificación: 25-05-2016, 22:22 (Miércoles) por drvalium »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14481
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #254 en: 25-05-2016, 22:23 (Miércoles) »
no os preocupes por lo perdido ...el mismo lunes ya estaba en marcha todo ...

formateado y reinstalado todo .. , ya le hacia falta , llevaba un año o asi isn formatear , asi que  .. ;)


por suerte tengo otro hdd , tipo "almacen" ..donde guardo todo lo que necesito instalar ,y en un par de horas esta todo en sus sitio  ;)

gracias a todos por el interes.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14481
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #255 en: 25-05-2016, 22:52 (Miércoles) »
parece que ya ha llegado el arreglo oficial,al paquete e2fsprogs , y ademas syslinux 4.07 ,lastima no sea uno mas nuevo (6.x) , pero algo es algo ..

ahora me tocara actualizar los bootloaders y crear isos nuevas para que lleven ese syslinux..  ;)


a/e2fsprogs-1.43-i586-2.txz: Rebuilt.
       Do not use 64-bit by default on ext4, since some bootloaders cannot handle
       it yet. But use "auto_64-bit_support = 1", which will enable 64-bit if the
       number of blocks for the file system requires the feature to be enabled.
a/syslinux-4.07-i586-1.txz: Upgraded.

sol666

  • Visitante
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #256 en: 26-05-2016, 22:52 (Jueves) »
hola,¿la de hoy 26 lleva ya el arreglo oficial para poder instalarla al hdd?

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14481
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #257 en: 26-05-2016, 23:17 (Jueves) »
hola,¿la de hoy 26 lleva ya el arreglo oficial para poder instalarla al hdd?

si

teik

  • Visitante
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #258 en: 27-05-2016, 00:02 (Viernes) »
hola,¿la de hoy 26 lleva ya el arreglo oficial para poder instalarla al hdd?

si
Se puede probar a instalar en HDD en UEFi? o eso aun andaen incognita? para meterle mano en el finde o estarme quieto jeje
Saludos

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14481
Re: Hilo exclusivo desarrollo wifislax64
« Respuesta #259 en: 27-05-2016, 00:10 (Viernes) »
hola,¿la de hoy 26 lleva ya el arreglo oficial para poder instalarla al hdd?

si
Se puede probar a instalar en HDD en UEFi? o eso aun andaen incognita? para meterle mano en el finde o estarme quieto jeje
Saludos

UEFI , solo live , pero han actualizado un driver de tablets  ..por lo del tactil...no se si seria eso , .