Autor Tema: [Tutorial] Cómo compilar OpenWrt a nuestro gusto  (Leído 295552 veces)

0 Usuarios y 1 Visitante están viendo este tema.

x_redentor

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #200 en: 26-03-2013, 13:46 (Martes) »
buenas gracias por el tutorial , yo estoy en archlinux , en cuanto el error instalad todo lo que podais de la lista que hay en el wiki , en teoria no se puede compilar en archlinux, estoy en la R36131


"Table of known prerequisites and their corresponding packages"

http://wiki.openwrt.org/doc/howto/buildroot.exigence

mis pasos son
los primeros asta que empiezan estos
.....
make defconfig
make prereq
make menuconfig
make -j 5 V=99 (por que tengo un cuatro nucleos)



manuelacantasaetas

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #201 en: 07-04-2013, 14:24 (Domingo) »
Yo uso archlinux y no he tenido ningún problema por ahora en compilar el openwrt.
Solo hay que buscar que paquete es el que te hace falta.  ^-^

Noltari

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #202 en: 03-05-2013, 13:45 (Viernes) »
Eliminado el branch de ramips de Github, ya que no es necesario al estar integrado los parches en el repositorio oficial.

Actualizado el branch de bcm63xx a la última versión con soporte SMP.
Más información: https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-5813n/msg274850/#msg274850

Saludos!

farguis

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #203 en: 06-06-2013, 11:06 (Jueves) »
Hola, estoy intentado compilar como pone el tutorial pero tengo un problema, es que al elegir el target solo me sale la opcion de ar7xx y yo necesito Broadcom bcm947 ... [2.4], para un router linksys wrt54g. Resulta que haciendo
svn co svn://svn.openwrt.org/openwrt/branches/8.09/  .

consigo el kamikaze y si que puedo compilar esa version que quiero. El problema es al compilar que necesito php y me sale este error

checking whether to enable LIBXML support... no
checking libxml2 install dir... no
checking for OpenSSL support... yes, shared
checking for Kerberos support... no
checking for DSA_get_default_method in -lssl... yes
checking for OpenSSL version... >= 0.9.6
checking for CRYPTO_free in -lcrypto... yes
checking for SSL_CTX_set_ssl_version in -lssl... yes
checking for PCRE support... yes, shared
checking for ZLIB support... yes
checking if the location of ZLIB install directory is defined... /home/farguis/kamikaze2/staging_dir/mipsel/usr
checking for gzgets in -lz... yes
checking whether to enable bc style precision math functions... no
checking for BZip2 support... no
checking whether to enable calendar conversion support... no
checking whether to enable ctype functions... no
checking for cURL support... yes, shared
checking if we should use cURL for url streams... no
checking for cURL in default path... found in /usr
checking for cURL 7.10.5 or greater... libcurl 7.29.0
checking for SSL support in libcurl... yes
checking how to run the C preprocessor... mipsel-linux-uclibc-gcc -E
checking for openssl support in libcurl... no
checking for gnutls support in libcurl... no
checking for curl_easy_perform in -lcurl... no
configure: error: There is something wrong. Please check config.log for more information.
make[3]: *** [/home/farguis/kamikaze2/build_dir/mipsel/php-5.2.6/.built] Error 1
make[3]: Leaving directory `/home/farguis/kamikaze2/feeds/packages/lang/php5'
make[2]: *** [package/feeds/packages/php5/compile] Error 2
make[2]: Leaving directory `/home/farguis/kamikaze2'
make[1]: *** [/home/farguis/kamikaze2/staging_dir/mipsel/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/farguis/kamikaze2'
make: *** [world] Error 2


Alguna duda de porque me da error? Gracias.
 

alf133

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #204 en: 12-06-2013, 17:10 (Miércoles) »
hola,
 He realizado una compilacion siguiendo este tutorial (que es genial) pero a la hora de elegir el .bin para mi router no lo encuentro. EL router que tengo es un ADB de telefonica y utilizo el "target profile" BMC63xx (entiendo que es el correcto). Pero me genera un monton de archivos .bin que no se cual es el mio.
Alguien lo sabe??

Gracias por vuestra ayuda

Noltari

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #205 en: 12-06-2013, 17:45 (Miércoles) »
hola,
 He realizado una compilacion siguiendo este tutorial (que es genial) pero a la hora de elegir el .bin para mi router no lo encuentro. EL router que tengo es un ADB de telefonica y utilizo el "target profile" BMC63xx (entiendo que es el correcto). Pero me genera un monton de archivos .bin que no se cual es el mio.
Alguien lo sabe??

Gracias por vuestra ayuda

openwrt-963281T_TEF-generic-squashfs-cfe.bin

Saludos.

javidecris

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #206 en: 18-06-2013, 11:45 (Martes) »
Hola genios, después de días y horas....horas y horas he conseguido compilar sin ningún error, es para un comtred ar5387un
he seguido el tutorial de como compilar de jar229
svn checkout svn://svn.openwrt.org/openwrt/trunk/ descargando esto
después de muchos errores compile solo con el driver bcm63xx , el wifi brcmsmac  y luci saliéndome este
openwrt-96328A-1441N1-generic-squashfs-cfe.bin
mi problema es que al forzar las dependencias en los que teneis aquí no funcionaban las cosas
me gustaría haceros unas preguntas,
 metiendo este firm podría volver a flashear desde luci o debería poner algo mas en la compilación
 podría conectarlo a internet via wifi o cable para actualizar paquetes sin forzar las dependencias

gracias y después de estar leyendo muchísimo y de muchas horas espero que no este contestado

si serve de algo y para intentar aportar
primero lo hice desde Ubuntu en un usb y me daba error tardaba nada en compilar el problema era falta de espacio a si que ojo necesita espacio para compilar
al final instale virtualbox y tela que lento, cámara lenta total, pero dale que dale al configurarlo bien como la seda
 ^-^

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4590
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #207 en: 18-06-2013, 12:03 (Martes) »
Hola genios, después de días y horas....horas y horas he conseguido compilar sin ningún error, es para un comtred ar5387un
he seguido el tutorial de como compilar de jar229
svn checkout svn://svn.openwrt.org/openwrt/trunk/ descargando esto
después de muchos errores compile solo con el driver bcm63xx , el wifi brcmsmac  y luci saliéndome este
openwrt-96328A-1441N1-generic-squashfs-cfe.bin
mi problema es que al forzar las dependencias en los que teneis aquí no funcionaban las cosas
me gustaría haceros unas preguntas,
 metiendo este firm podría volver a flashear desde luci o debería poner algo mas en la compilación
 podría conectarlo a internet via wifi o cable para actualizar paquetes sin forzar las dependencias

gracias y después de estar leyendo muchísimo y de muchas horas espero que no este contestado

si serve de algo y para intentar aportar
primero lo hice desde Ubuntu en un usb y me daba error tardaba nada en compilar el problema era falta de espacio a si que ojo necesita espacio para compilar
al final instale virtualbox y tela que lento, cámara lenta total, pero dale que dale al configurarlo bien como la seda
 ^-^

Si la compilación es para el Comtrend 5387un y quieres poder usar la wifi, en lugar de usar svn checkout svn://svn.openwrt.org/openwrt/trunk/ deberías haber obtenido las fuentes con git clone git://github.com/Noltari/openwrt.git -b bcm63xx-r36529
Esta avisado en el primer post del hilo: https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-ar5387un/msg247662/#msg247662

Citar
Estado
Los parches para que el WiFi funcione no han sido aún integrados en el repositorio oficial de OpenWrt, por lo que cualquier compilación del repositorio oficial no dispondrá de WiFi.
El driver brcmsmac funciona tanto en modo Station (cliente) como en modo AP. Por tanto, a partir de ahora sólo compilaré firmwares con brcmsmac, dado que funciona muchísimo mejor que b43.

Lo que no entiendo, es lo de las dependencias. Ya que te compilas tu propio firmware, incluye los paquetes que uses, así te olvidas de problemas posteriores ...

En lugar de usar virtualbox, prueba con vmware, seguro que notas diferencia  ;)

Y para actualizar, lo más práctico es usar el CFE (encenderlo con el botón de reset pulsado y mantenerlo 30 segundos, etc)
Valoraciones positivas en compra/venta:
148 en Htcmania
196 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

javidecris

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #208 en: 18-06-2013, 12:49 (Martes) »
Gracias jar229 mas rápido imposible
tienes razón no tiene sentido si compilo compilo ya todo hecho
el virtualbox después de configurado como la seda
estoy compilando con este git clone git://github.com/Noltari/openwrt.git -b bcm63xx-r36114 y tu pones este git clone git://github.com/Noltari/openwrt.git -b bcm63xx-r36529
cual debo poner el primero es el del post 1 de este router
supongo que las operaciones son las mismas que para compilar de (como compilar openwrt)
una cosa en el Target Profile   debo poner brcmsmac o el propietario
ya he terminado de compilar el de noltari y todo correcto supongo que es este
openwrt-96328A-1441N1-generic-squashfs-cfe.bin
 ;D
« Última modificación: 18-06-2013, 13:05 (Martes) por javidecris »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4590
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #209 en: 18-06-2013, 13:20 (Martes) »
estoy compilando con este git clone git://github.com/Noltari/openwrt.git -b bcm63xx-r36114 y tu pones este git clone git://github.com/Noltari/openwrt.git -b bcm63xx-r36529
cual debo poner el primero es el del post 1 de este router
supongo que las operaciones son las mismas que para compilar de (como compilar openwrt)
una cosa en el Target Profile   debo poner brcmsmac o el propietario
ya he terminado de compilar el de noltari y todo correcto supongo que es este
openwrt-96328A-1441N1-generic-squashfs-cfe.bin
 ;D

Supongo que cualquiera de las dos versiones vale.
Yo he copiado/pegado del primer post de este hilo (Noltari lo va actualizando).
Debes escoger brcmsmac.
Sí ese es el firmware que tienes que usar  ;)
Valoraciones positivas en compra/venta:
148 en Htcmania
196 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

miniyo88

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #210 en: 22-06-2013, 09:56 (Sábado) »
buenas, después de mucos intentos he podido compilar para el ADB de Movistar desde el git de Noltari pero creo que me dejado algo, cuando entro al router 192.168.1.1 me sale el fondo negro y pone arriba LUA-Luci configuraction interface y se me descarga un archivo que se llama luci y ahí se queda tengo acceso por ssh pero no tengo ninguna configuración y el opkg no me descarga nada obvio.
[spoiler]

[/spoiler]

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4590
Re: Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #211 en: 22-06-2013, 10:32 (Sábado) »
Prueba con otro navegador.

Enviado desde mi Cube U30GT
Valoraciones positivas en compra/venta:
148 en Htcmania
196 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

miniyo88

  • Visitante
Re: Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #212 en: 22-06-2013, 11:51 (Sábado) »
Prueba con otro navegador.

Enviado desde mi Cube U30GT
he probado con opera, chrome e IE y todos hacen lo mismo

skywalky

  • Visitante
Re: Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #213 en: 26-06-2013, 16:00 (Miércoles) »
he probado con opera, chrome e IE y todos hacen lo mismo

¿Has compilado añadiendo algún servidor web adicional al que usa Luci?

miniyo88

  • Visitante
Re:
« Respuesta #214 en: 27-06-2013, 03:50 (Jueves) »
Ya está arreglado gracias puede acceder por https y flashee otro firm en failsafe

Enviado desde mi GT-I9000 usando Tapatalk 4 Beta

Noltari

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #215 en: 05-07-2013, 16:00 (Viernes) »
Añadido al primer post el último branch actualizado en mi GitHub.
También he cambiado el repositorio principal para clonarlo utilizando git, en lugar de svn, ya que es mucho más rápido.

Saludos!

manuelacantasaetas

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #216 en: 13-07-2013, 14:40 (Sábado) »
Estoy compilando desde la versión attitude_adjustment y al hacer el menuconfig, no me aparecen los paquetes de luci.

El problema creo que esta al hacer ./scripts/feeds update -a que sale este error:

Updating feed 'luci' from 'http://svn.luci.subsignal.org/luci/branches/luci-0.11/contrib/package' ...
svn: E175004: The PROPFIND response did not include the requested properties
failed.

Os pasa lo mismo?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4590
Re: Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #217 en: 13-07-2013, 15:51 (Sábado) »
Será un problema puntual de los servidores de OpemWrt (a veces me ha pasado).

Vuelve a intentarlo más tarde a ver ...

Enviado desde mi U8500 usando Tapatalk 2
Valoraciones positivas en compra/venta:
148 en Htcmania
196 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

manuelacantasaetas

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #218 en: 23-07-2013, 23:22 (Martes) »
10 días después y la cosa sigue igual.  :(

¿Alguna forma de solucionarlo?

manuelacantasaetas

  • Visitante
Re: [Tutorial] Cómo compilar OpenWrt a nuestro gusto
« Respuesta #219 en: 23-07-2013, 23:35 (Martes) »
10 días después y la cosa sigue igual.  :(

¿Alguna forma de solucionarlo?

  ^-^ No me hagáis ni puto caso, el fallo creo que es mio.   ^-^

Se ve que es un error con la versión del subversion del servidor y la mía.  ;D

//FINAL Y MÁS DOS RESPUESTAS