Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 2026297 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

masuele

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1420 en: 01-05-2013, 11:55 (Miércoles) »
lo primnero agradecer las 71 paginas que llevais. Jamas he comentado nada siempre he tenido suficiente, pero ahora que estoy tratando de hacer un hotspot cautivo no me entero, me faltan dependencias al intentar instalar los paquetes con luci etc. total que tengo el router como lo tenia pero mas atravesado que nunca :

1- Bajate este( me funciono con atheros, pone que es pa todos) http://www.mediafire.com/?59ghjh5jt063ie1
2- configura tu ip 192.168.1.2 y mascara de subred 255.255.255.0
3-Apreta el boton restart con el router apagado.Mientas pulsas restart enchufa la corriente y mantienes 20 segundos mas restart con el router encendido.
4-Vas al navegador y pones http://192.168.1.1
5-Elijes el archivo descargado previamente y le das a actualizar.
6-esperas 3 minutos y vuelves al navegador y con 192.168.1.1 accedes a la interface openwrt.


Con esto tienes todo lo que necesites instalado.



Pd: Jar ahora si me de intenet a traves del cable de red el router pero mi red creada no me da ips a lo que se conecta y tengo lo de dar dchp activado en lan. la borro y creo otra aver?me refiero a la nueva red virtual.


« Última modificación: 01-05-2013, 15:23 (Miércoles) por masuele »

juanantofb

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1421 en: 02-05-2013, 11:32 (Jueves) »
Hola, al final me he puesto el traje de faena, y por raviolli me voy a aprender a trastear con openwrt.

He instalado el firm del trunk, he configurado el fichero network, para darle internet, he instalado Luci, pero me encuentro que no aparece nada de nada del wifi, segun el primer hilo, existe la forma de restaurar la particion de los caldata, pero yo soy invidente, y no se que tipo de flash tengo.

Se podria intentar con el metodo prueba y ensallo? osea, intentar 1 a 1 hasta que se solucione el tema?

O si existe una forma de saber el modelo de flash sin abrir el cacharro?

Y si el metodo prueba 1 a 1, valiese, alguien tiene los ficheros, para no tener que flasear con el firm que los incluye?

Los pasaria al router con winscp.

el tema de consola lo medio domino.

Gracias.

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1422 en: 02-05-2013, 14:07 (Jueves) »
Me temo que si pierdes los datos de calibración, la partición encoge, y por tanto no puedes flashearlo desde el propio firmware que tengas instalado.

Por prueba y error no tendrás ningún problema, si ya perdiste esos datos, no vas a perder nada más importante en esa zona de la flash.

juanantofb

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1423 en: 02-05-2013, 14:17 (Jueves) »
Hola, gracias Dani, a fuerza de cabezazos se enseña uno, el problema hera que no tenia los drivers instalados, he instalado el paquete ath9k, pero creo que no es el correcto, ya que me va solo a 54, y me lo reconoce como wifi g.

Estoy investigando el tipo de chip wifi que es, para instalar su paquete, pero me extraña que el kernel  no lo haya reconocido.

Saludos.

juanantofb

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1424 en: 02-05-2013, 14:45 (Jueves) »
Hola, ahora si que la he liado, ya se que el chip wifi es el ar9223, pero no encuentro ningun paquete que contenga ese driver, me he cargado el caldata?

Alguien me podria decir como instalar el drivers correcto para ese chip en el hg556a?

Gracias.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1425 en: 02-05-2013, 14:57 (Jueves) »
Tienes que instalar kmod-ath9k.

Lo que no entiendo muy bien, es porqué estás usando la rama trunk.
En el primer post del hilo, tienes un backport a backfire (de danitool) que funciona estupendamente en los routers con atheros  ;)

juanantofb

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1426 en: 02-05-2013, 15:29 (Jueves) »
Hola, si, ese modulo fue el que instale, pero me lo reconocia como wifi g solo.

lo de la rama trunk es por tonterias del frikismo :)

Voy a probar la que me indicas a ver.

Tan solo una cosa, que o que sintomas, presenta el router si se descalibra los caldata?

Gracias.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1427 en: 03-05-2013, 08:20 (Viernes) »

Tan solo una cosa, que o que sintomas, presenta el router si se descalibra los caldata?

Gracias.

Si te refieres a qué pasaría si perdieras la partición caldata, pues que te quedarías sin wifi  >:D

juanantofb

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1428 en: 03-05-2013, 10:24 (Viernes) »
Hola, gracias por tu respuesta.

De todas formas, he probado con varias compilaciones, y el rendimiento del wifi es muy pobre, una pena, ya que es lo mas interesante de este router.

Saludos.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1429 en: 03-05-2013, 11:28 (Viernes) »
Hola, gracias por tu respuesta.

De todas formas, he probado con varias compilaciones, y el rendimiento del wifi es muy pobre, una pena, ya que es lo mas interesante de este router.

Saludos.

No se a qué te refieres con muy pobre ...  ^-^

En mi caso, tengo dos hg556a (wifi atheros) ambos con OpenWrt enlazados por wifi y WDS, y estoy encantado del rendimiento  >:(
No es como tener los equipos conectados por cable de red, pero ... se le acerca bastante  ;D

Transferencia por ftp: Velocidad sostenida a 5.0 MB/s


Enlace wifi a 300 Mbit/s



juanantofb

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1430 en: 03-05-2013, 11:50 (Viernes) »
Hola, no lo dudo, supongo que sera por mi inesperiencia en este tema, pero no he podido hacer una conexion wifi a 300 Mbit/s, con ningun adaptador, lo maximo a 144 Mbit/s.

Cuando con otros firm en otros routers sin problemas, incluso con Gargoile que al fin y al cabo es openwrt y un TP-Link TLWR1043ND, que tambien lleba chip wifi atheros.

Se aceptan sugerencias.

Saludos.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1431 en: 03-05-2013, 12:34 (Viernes) »
Hola, no lo dudo, supongo que sera por mi inesperiencia en este tema, pero no he podido hacer una conexion wifi a 300 Mbit/s, con ningun adaptador, lo maximo a 144 Mbit/s.

Cuando con otros firm en otros routers sin problemas, incluso con Gargoile que al fin y al cabo es openwrt y un TP-Link TLWR1043ND, que tambien lleba chip wifi atheros.

Se aceptan sugerencias.

Saludos.

Para pasar de los 150 Mbit/s debe escoger en las opciones avanzadas (estoy hablando de hacerlo desde LuCi) del interface wifi: Modo 802.11g+n y en Modo HT 40 MHz 2º Canal por encima (o por debajo, dependiendo del router principal).
Esto está explicado en el enlace WDS de este tutorial: https://foro.seguridadwireless.net/openwrt/%28tutorial%29-modo-clienterepetidor-openwrt/

A qué equipo estás intentando conectar ?
Qué wifi tiene ?

juanantofb

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1432 en: 03-05-2013, 13:07 (Viernes) »
Hola, me referia a usarlo como AP, osea, que los pcs se conecten a el por wifi, y el hg conectado al router principal por cable, con el dhcp desactivado.

Lo que me comentas del apartado avanzado en la configuracion wifi, lo revise todo y estaba como dices.

Lo del modo cliente o puente wifi, no he vuelto a intentarlo.

Saludos.

gercris

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1433 en: 04-05-2013, 11:01 (Sábado) »
lo primnero agradecer las 71 paginas que llevais. Jamas he comentado nada siempre he tenido suficiente, pero ahora que estoy tratando de hacer un hotspot cautivo no me entero, me faltan dependencias al intentar instalar los paquetes con luci etc. total que tengo el router como lo tenia pero mas atravesado que nunca :

1- Bajate este( me funciono con atheros, pone que es pa todos) http://www.mediafire.com/?59ghjh5jt063ie1
2- configura tu ip 192.168.1.2 y mascara de subred 255.255.255.0
3-Apreta el boton restart con el router apagado.Mientas pulsas restart enchufa la corriente y mantienes 20 segundos mas restart con el router encendido.
4-Vas al navegador y pones http://192.168.1.1
5-Elijes el archivo descargado previamente y le das a actualizar.
6-esperas 3 minutos y vuelves al navegador y con 192.168.1.1 accedes a la interface openwrt.


Con esto tienes todo lo que necesites instalado.



Pd: Jar ahora si me de intenet a traves del cable de red el router pero mi red creada no me da ips a lo que se conecta y tengo lo de dar dchp activado en lan. la borro y creo otra aver?me refiero a la nueva red virtual.


lo hice y aun no consigo instalar nodogsplash via luci ni puty esto es la respuesta
root@OpenWrt:~# opkg install nodogsplash
Installing nodogsplash (0.9_beta9.9.6-3) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/nodogsplash_0.9_beta9.9.6-3_brcm63xx.ipk.
Multiple packages (kmod-ipt-core and kmod-ipt-core) providing same name marked HOLD or PREFER. Using latest.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for nodogsplash:
 *      kernel (= 3.8.11-1-e79ee935802ec7d0b9dbbba509bea223) *
 * opkg_install_cmd: Cannot install package nodogsplash.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1434 en: 04-05-2013, 12:22 (Sábado) »
lo hice y aun no consigo instalar nodogsplash via luci ni puty esto es la respuesta
root@OpenWrt:~# opkg install nodogsplash
Installing nodogsplash (0.9_beta9.9.6-3) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/nodogsplash_0.9_beta9.9.6-3_brcm63xx.ipk.
Multiple packages (kmod-ipt-core and kmod-ipt-core) providing same name marked HOLD or PREFER. Using latest.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for nodogsplash:
 *      kernel (= 3.8.11-1-e79ee935802ec7d0b9dbbba509bea223) *
 * opkg_install_cmd: Cannot install package nodogsplash.

https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/

Si tienes un router con wifi atheros (versión C según la etiqueta trasera), instala el backport a backfire de danitool del primer post del hilo. Así seguro que no tendrás problemas con las dependencias.

jgerardo

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1435 en: 08-05-2013, 01:54 (Miércoles) »
Tras preparar varios HG556a (modo repetidor) Ralink y Ateros he encontrado un fallo, que no veo que se comente en ninguna parte del foro... y he buscado mucho mucho....... he llegado a pensar que hacia algo mal.

El caso es que si apago el router por la noche, a la mañana siguiente ya no puedo conectarme a la Wifi de mi router porque no esta activada. El unico modo es entrar con el cable LAN y activarlo denuevo. Siempre me ocurre !!!

Teneis alguno el mismo problema ?


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1436 en: 08-05-2013, 10:46 (Miércoles) »
Qué compilación estás usando ?

jgerardo

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1437 en: 08-05-2013, 15:25 (Miércoles) »
Pues estoy usando las dos del primer post, la r36114 y la r35318.
Al tener varios HG556a he usado ambas versiones siguiendo las recomendaciones del post, pero el dichoso problema de desconexion de la wifi me ocurre en ambas versiones.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1438 en: 09-05-2013, 08:33 (Jueves) »
Pues estoy usando las dos del primer post, la r36114 y la r35318.
Al tener varios HG556a he usado ambas versiones siguiendo las recomendaciones del post, pero el dichoso problema de desconexion de la wifi me ocurre en ambas versiones.


No tengo instaladas ninguna de estas versiones, pero me resulta rarísimo, que nadie haya comentado antes el problema ...  ^-^

En el primer post del hilo, tienes un backport de danitool a backfire. Instálalo en uno de los routers con atheros y nos cuentas.

masuele

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1439 en: 09-05-2013, 09:15 (Jueves) »
Yo creo aberte estado pidiendo ayuda de algo parecido pero ultimamente no me as contestado...