Autor Tema: [Desarrollo] OpenWrt en Comtrend WAP-5813n  (Leído 315344 veces)

0 Usuarios y 1 Visitante están viendo este tema.

atiencilla

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #460 en: 05-05-2015, 10:36 (Martes) »
Buenas a todos, soy muy nuevo en estos temas y veo que en este foro hay mucho profesional que seguro que me puede ayudar.

Tengo un 5813n y quiero hacerlo siguiente: Necesito conectar dicho router a un Netgear de ONO (mi compañia actual) y utilizar el comtrend como repetidor.
Para hacer esto me instale OpenWRT, segui los pasos que encontre en un manual y consigo que me de internet por cable de red pero no que repita ya que cuando genero la segunda conexion y guardo y aplico los cambios en Network>Wifi me aparecen las dos conexiones pero como master y no como cliente otra master y tras hacer eso pierdo la conexion con cable.

Alguien podría decirme por que motivo me puede estar ocurriendo?
Cual es la ultima versiona estable (para mi uso, es decir, router neutro) que tenemos?

Muchisimas gracias por tod



Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #461 en: 05-05-2015, 10:55 (Martes) »
Buenas a todos, soy muy nuevo en estos temas y veo que en este foro hay mucho profesional que seguro que me puede ayudar.

Tengo un 5813n y quiero hacerlo siguiente: Necesito conectar dicho router a un Netgear de ONO (mi compañia actual) y utilizar el comtrend como repetidor.
Para hacer esto me instale OpenWRT, segui los pasos que encontre en un manual y consigo que me de internet por cable de red pero no que repita ya que cuando genero la segunda conexion y guardo y aplico los cambios en Network>Wifi me aparecen las dos conexiones pero como master y no como cliente otra master y tras hacer eso pierdo la conexion con cable.

Alguien podría decirme por que motivo me puede estar ocurriendo?
Cual es la ultima versiona estable (para mi uso, es decir, router neutro) que tenemos?

Muchisimas gracias por tod
https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/#post_FAQ_Repeater

Con WiFi Broadcom no se puede montar un repetidor a no ser que tengas dos dispositivos, uno como cliente y otro como AP, que no es el caso.

atiencilla

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #462 en: 05-05-2015, 11:07 (Martes) »
Buenas a todos, soy muy nuevo en estos temas y veo que en este foro hay mucho profesional que seguro que me puede ayudar.

Tengo un 5813n y quiero hacerlo siguiente: Necesito conectar dicho router a un Netgear de ONO (mi compañia actual) y utilizar el comtrend como repetidor.
Para hacer esto me instale OpenWRT, segui los pasos que encontre en un manual y consigo que me de internet por cable de red pero no que repita ya que cuando genero la segunda conexion y guardo y aplico los cambios en Network>Wifi me aparecen las dos conexiones pero como master y no como cliente otra master y tras hacer eso pierdo la conexion con cable.

Alguien podría decirme por que motivo me puede estar ocurriendo?
Cual es la ultima versiona estable (para mi uso, es decir, router neutro) que tenemos?

Muchisimas gracias por tod
https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/#post_FAQ_Repeater

Con WiFi Broadcom no se puede montar un repetidor a no ser que tengas dos dispositivos, uno como cliente y otro como AP, que no es el caso.

Vaya... mi gozo en un pozo, no se si es el sitio para preguntar sino es asi por favor decirmelo. Tambien tengo un cajon un ZXHN ZTE H108n  sabes si con este podré hacer lo que quiero o... estamos en las mismas?

laid

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #463 en: 04-06-2015, 09:23 (Jueves) »
Hoy he conseguido hacer funcionar el USB. Lo he estado probando (copias de ficheros, transmission, dlna) y la verdad es que no da mal rendimiento.

¿No da mal rendimiento? Debería ser, de entre los routers que entregan los proveedores, el más rápido con casi cualquier cosa que se le pida.
http://wiki.openwrt.org/inbox/benchmark.openssl

Por cierto, ¿qué tipo de core MIPS es el que usa el BCM6369? Lo único que he encontrado es que puede ser un 4kc, pero no termino de tenerlo claro.
Creo que todos los bcm63xx son 4kc. De todas formas, el 6369 es idéntico al 6368, a excepción de que no lleva dsl.

He obtenido 4MB/s en lectura desde un pendrive formateado en NTFS, pero con ext4 el rendimiento es superior.

Hola Noltari

Leyendo en https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-vr-3025un/ veo que también has instalado OpenWrt en el router Comtrend VR-3025un, por lo tanto puedes compararlo con el Comtrend WAP-5813n; la pregunta es: ¿funcionara el USB del WAP-5813n (con USB MOD) tan bien como del VR-3025un?, o quizás el USB MOD del WAP-5813n perderá algo de funcionalidad si lo comparáramos con un Router similar (idéntico SoC) el Netgear EVG2000 que tiene 2 puertos USB de fabrica (https://wikidevi.com/wiki/Netgear_EVG2000 - http://wiki.openwrt.org/toh/netgear/evg2000).

Por ejemplo, los 4MB/s en lectura desde un pendrive formateado en NTFS que tu has obtenido con el  WAP-5813n, si haces la misma prueba con el VR-3025un este dará similares velocidades, o quizás mas? Digo con NTFS solo por poner el ejemplo que tu mismo has posteado, pero mi pregunta se refiere al funcionamiento en general del USB MOD del WAP-5813n. Pregunto todo esto porque esto indeciso en pillar un Comtrend VR-3025u o el WAP-5813n para hacerle el USB MOD, si es que vale la pena...

Un saludo.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #464 en: 04-06-2015, 12:51 (Jueves) »
Hoy he conseguido hacer funcionar el USB. Lo he estado probando (copias de ficheros, transmission, dlna) y la verdad es que no da mal rendimiento.

¿No da mal rendimiento? Debería ser, de entre los routers que entregan los proveedores, el más rápido con casi cualquier cosa que se le pida.
http://wiki.openwrt.org/inbox/benchmark.openssl

Por cierto, ¿qué tipo de core MIPS es el que usa el BCM6369? Lo único que he encontrado es que puede ser un 4kc, pero no termino de tenerlo claro.
Creo que todos los bcm63xx son 4kc. De todas formas, el 6369 es idéntico al 6368, a excepción de que no lleva dsl.

He obtenido 4MB/s en lectura desde un pendrive formateado en NTFS, pero con ext4 el rendimiento es superior.

Hola Noltari

Leyendo en https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-vr-3025un/ veo que también has instalado OpenWrt en el router Comtrend VR-3025un, por lo tanto puedes compararlo con el Comtrend WAP-5813n; la pregunta es: ¿funcionara el USB del WAP-5813n (con USB MOD) tan bien como del VR-3025un?, o quizás el USB MOD del WAP-5813n perderá algo de funcionalidad si lo comparáramos con un Router similar (idéntico SoC) el Netgear EVG2000 que tiene 2 puertos USB de fabrica (https://wikidevi.com/wiki/Netgear_EVG2000 - http://wiki.openwrt.org/toh/netgear/evg2000).

Por ejemplo, los 4MB/s en lectura desde un pendrive formateado en NTFS que tu has obtenido con el  WAP-5813n, si haces la misma prueba con el VR-3025un este dará similares velocidades, o quizás mas? Digo con NTFS solo por poner el ejemplo que tu mismo has posteado, pero mi pregunta se refiere al funcionamiento en general del USB MOD del WAP-5813n. Pregunto todo esto porque esto indeciso en pillar un Comtrend VR-3025u o el WAP-5813n para hacerle el USB MOD, si es que vale la pena...

Un saludo.

Si te atreves a hacer el mod del USB yo iría a por el WAP-5813n por el hecho de que tiene ethernet gigabit. Si no te ves capaz entonces elige el VR-3025un.
No creo que haya difearencias de rendimiento entre routers que vienen con USB de fábrica y routers a los que se le hace un mod para que lo tengan. La única diferencia podría darse en la alimentación del dispositivo.

El BCM6368 tiene soporte para dos puertos USB sin necesidad de un hub, pero dicho soporte ha de ser habilitado específicamente via software. Por eso algunos fabricantes deciden añadir un segundo USB directo al soc y otros utilizan un hub que les permite añadir 2+ USBs.

Saludos.

laid

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend CT-5813n
« Respuesta #465 en: 04-06-2015, 13:53 (Jueves) »
Noltari muchas gracias por tu pronta respuesta, y para finalizar:

No creo que haya difearencias de rendimiento entre routers que vienen con USB de fábrica y routers a los que se le hace un mod para que lo tengan.
¿O sea que se puede concluir que dan similares resultados el funcionamiento del USB tanto del WAP-5813n (con USB MOD) así como del VR-3025un?

La única diferencia podría darse en la alimentación del dispositivo.
Si yo solamente quisiera agregarle el puerto USB al WAP-5813n pero sin sacar la alimentación de corriente desde el Router, para que los 5V estén provistos externamente, entonces quizás sería solo usando las terminales D+, D- y GND del USB del Router más las 2 resistencias de 4K7 más algunos (o todos) los puentes, pero sin tener que usar el LM7805 y el capacitor electrolítico; ¿o no seria tan simple como lo planteo?

El BCM6368 tiene soporte para dos puertos USB sin necesidad de un hub, pero dicho soporte ha de ser habilitado específicamente via software. Por eso algunos fabricantes deciden añadir un segundo USB directo al soc y otros utilizan un hub que les permite añadir 2+ USBs.
Como es el caso del Observa Telecom VH4032N (BCM6368) que tiene 3 USB; y que justamente quería preguntarte: ¿como conecto al WAP-5813n (con USB MOD) dos dispositivos USB, por ejemplo un adaptador WiFi y un Pendrive para que no se estorben entre si y para que el Router y los 2 dispositivos USB conectados simultáneamente no pierdan nada o casi nada de performance?

En mi caso, utilizo este router con una tarjeta WiFi Mini-PCI que compré hace un tiempo (atheros - ath9k) y 0 problemas.
Por ultimo, si es posible ¿podrías subir el firmware que tu utilizas que incluye el paquete atheros - ath9k, o cualquier otro que tenga soporte para Atheros AR9223 Mini-PCI?

Gracias por tu gran ayuda, un gran saludo para ti...
« Última modificación: 04-06-2015, 20:06 (Jueves) por laid »

the devil

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #466 en: 11-06-2015, 12:42 (Jueves) »
hola muy buenos  ???.

os cuento mi problema estoy haciendo un proyecto de fin de curso y tengo que modificar un comtrend 5813. entonces me he puesto a buscar en los post y vi lo de openwrt entonces encontré un firmware de noltari, procedí a flashearlo.
Cual fue mi sorpresa que ahora no puedo acceder al router. he visto que a otro le paso también y que lo había solucionado pero mi cuestión es que no se como poder meter otro firmware sin poder acceder vía web al router.

aaa decir también que he intentado por ssh acceder a el y no hay manera.

muchas gracias.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1956
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #467 en: 11-06-2015, 14:03 (Jueves) »
hola muy buenos  ???.

os cuento mi problema estoy haciendo un proyecto de fin de curso y tengo que modificar un comtrend 5813. entonces me he puesto a buscar en los post y vi lo de openwrt entonces encontré un firmware de noltari, procedí a flashearlo.
Cual fue mi sorpresa que ahora no puedo acceder al router. he visto que a otro le paso también y que lo había solucionado pero mi cuestión es que no se como poder meter otro firmware sin poder acceder vía web al router.

aaa decir también que he intentado por ssh acceder a el y no hay manera.

muchas gracias.

¿Te has asegurado de cambiar la IP al PC, para que esté dentro de la misma subred que el router? (192.168.1.1)

P.D.: Antes de poder acceder a él por SSH tienes que acceder por telnet y ponerle password.
« Última modificación: 11-06-2015, 14:04 (Jueves) por Tki2000 »
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

luilly

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #468 en: 12-06-2015, 12:55 (Viernes) »
Buenas amigos.

Tengo el firmware  openwrt-WAP-5813n-squashfs-cfe-smp-39167-20131227 (11n).bin  instalado y acaban de migrarme a 300Mbps de FTTH Movistar y cuando he ido a hacer el test de velocidad, veo que no pasa de 104Mbps.
Si instalo el firmware original de Comtrend/Telefónica, si que me coge los 300.
Respecto al upload, me coge los 30Mbps sin problema con ambos firmwares.

Si reviso en la parte de Switch veo que están los puertos activados a 1000baseT
full dúplex.

Podéis indicarme dónde puede estar el problema o si tengo que compilar algún paquete adicional?

PD. Si utilizo cualquiera de los firmwares de la 1a página, no puedo conectar al router.

Muchas gracias!

maki22

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #469 en: 12-06-2015, 17:13 (Viernes) »
Eso es porque en openwrt no hay soporte para aceleración de NAT por hardware y ademas tengo entendido que solo se usa 1 núcleo de los 2 para enrutar, por lo que con la potencia de este router no podrás alcanzar los 300.

luilly

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #470 en: 12-06-2015, 17:28 (Viernes) »
Muchas gracias @maki22 , me has quitado un verdadero quebradero de cabeza. Ya no sabía qué hacer.
De todas maneras, atendiendo a tu respuesta, ¿ningún router con openwrt podrá alcanzar esa velocidad? En caso de que si se pueda alcanzar, el mikrotik 951g-2hnd podría ser la solución? anda bien de cobertura wifi?
Es que veo que es buen router, por lo menos en lo que a precio se refiere.

O si me puedes recomendar otro que pueda alcanzar esta velocidad, con buena wifi y usb.

Muchas gracias!
« Última modificación: 12-06-2015, 17:30 (Viernes) por luilly »

maki22

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #471 en: 12-06-2015, 18:53 (Viernes) »
Si hay routers capaces de mover openwrt a esas velocidades, pero basicamente porque tienen bastante mejor CPU-RAM que el 5813n.

En cuanto a lo del mikrotik no sabría decirte, no estoy muy puesto en eso.

luilly

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #472 en: 12-06-2015, 19:01 (Viernes) »
Gracias por la respuesta @maki22 , lo tendré en cuenta.

eq7mavala

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #473 en: 22-06-2015, 20:32 (Lunes) »
A alguien le pasa que mete los firmwares oficiales y funciona todo bien, es meter los firmwares de openwrt y joderse todo? Ni responder a ping ni nada...

Increible

matias.rivera

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #474 en: 18-08-2015, 04:01 (Martes) »
Buenas Noches,
  Noltari, he vuelto a intentar hacer funcionar este router. Hoy flashee el firmware que se encuentra en el primer post WAP-5813n-P401-402TLF-C04_R09.bin y por primera vez logré que responda el router.

Device Info

Board ID:   96369R-1231N
Software Version:   P401-402TLF-C04_R09
Bootloader (CFE) Version:   1.0.37-102.1-5
Wireless Driver Version:   5.10.120.0.cpe4.402.9

Sin embargo, cuando intento flashear el firmware de openwrt me dice lo siguiente

DSL Router Update

Image uploading failed. The selected file contains an illegal image.


Se que todo el mundo aqui logró hacerlo funcionar. Me podrías indicar cual es el inconveniente con mi equipo? Debo modificar algo antes de poder flashear openwrt?

Gracias de antemano,

Matias

matias.rivera

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #475 en: 18-08-2015, 04:27 (Martes) »
Agrego otra información, he intentado flashear openwrt via tftp entrando por telnet y al parecer el .bin es demasiado grande

> tftp -g -t i -f openwrt-15.05-rc3-brcm63xx-generic-WAP-5813n-squashfs-cfe.bin 192.168.1.2
Allocating 4194324 bytes for flash image.
Memory allocated
Image could not fit into 4194324 byte buffer.
tftp: write: No such file or directory
Tftp Image failed: tftp server OR file name not found.

Algo evidentemente estoy haciendo mal. Agradezco cualquier ayuda.

Saludos,

Matias

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1956
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #476 en: 18-08-2015, 10:03 (Martes) »
Agrego otra información, he intentado flashear openwrt via tftp entrando por telnet y al parecer el .bin es demasiado grande

> tftp -g -t i -f openwrt-15.05-rc3-brcm63xx-generic-WAP-5813n-squashfs-cfe.bin 192.168.1.2
Allocating 4194324 bytes for flash image.
Memory allocated
Image could not fit into 4194324 byte buffer.
tftp: write: No such file or directory
Tftp Image failed: tftp server OR file name not found.

Algo evidentemente estoy haciendo mal. Agradezco cualquier ayuda.

Saludos,

Matias

¿Has probado esto?


Para cargar el firmware al router se hace como en todos los routers con bootloader CFE, es decir, configurando la IP del PC a 192.168.1.2, la máscara de subred a 255.255.255.0 y la puerta de enlace a 192.168.1.1. Después, con el router apagado, mantienes presionado el botón de reset, enciendes el router y pasados unos 20-30 segundos lo sueltas. En el PC vas a la url http://192.168.1.1/ y te aparecerá un formulario para subir el firmware al router.

Saludos ;).
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

matias.rivera

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #477 en: 18-08-2015, 15:38 (Martes) »
Gracias por tu respuesta Tki2000,

No lo aclaré porque consideré que era claro que había realizado eso antes del intento de telnet + tftp server. Cuando realicé el flasheo a través de la interfaz web, no tuve ningún error. El firmware subio, el router se reinició, pero nada mas sucedió. Solo queda la luz de power en verde y la del puerto lan al que estoy conectado. No sucede nada mas, no responde la interfaz web ni tampoco puedo ingresar por telnet a la dirección 192.168.1.1 que es la que creo que viene por defecto en openwrt.

Por lo tanto, estoy muy muy perdido, por ahora el único firmware que pude flashear correctamente es el que indiqué en mi post anterior WAP-5813n-P401-402TLF-C04_R09.bin. Todo lo demás falla.

Saludos y gracias,

Matias

matias.rivera

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #478 en: 18-08-2015, 21:58 (Martes) »
Algo que sigue llamandome la atención es que al intentar realizar el flash por tftp el router indica que tiene 4194324 byte buffer de espacio para almacenar y las imagenes de openwrt tienen todas 4194560, le están faltando 236 bytes de espacio. ¿No les parece extraño?

Saludos,

Matías

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend WAP-5813n
« Respuesta #479 en: 19-08-2015, 00:55 (Miércoles) »
Algo que sigue llamandome la atención es que al intentar realizar el flash por tftp el router indica que tiene 4194324 byte buffer de espacio para almacenar y las imagenes de openwrt tienen todas 4194560, le están faltando 236 bytes de espacio. ¿No les parece extraño?

Saludos,

Matías
Imagino que se trata de un Comtrend WAP-5813n de fuera de España, puesto que la versión española tiene 8MB y el resto de versiones que he visto tienen 4MB.

¿Podrías poner un bootlog del firmware original?

Saludos!

//FINAL Y MÁS DOS RESPUESTAS