Autor Tema: Problema con idioma del teclado  (Leído 7495 veces)

0 Usuarios y 1 Visitante están viendo este tema.

MrChan

  • Visitante
Problema con idioma del teclado
« en: 16-01-2015, 12:52 (Viernes) »
Buenos días,

Mi consulta es un poco rara, pues no se refiere a ninguna duda de las apps de Wifislax, sino al sistema operativo en sí.

Llevo utilizando Wifiway como Wifislax una temporada y me ha surgido una duda. Yo por lo general soy usuario de Windows, tanto de XP como de 7, y en ambos casos, cambiando la configuración del teclado, puedo escribir caracteres chinos, esto me sirve porque soy estudiante de dicho idioma.

Tras trastear por mi cuenta, he pinchado en la "disposición del teclado/configurar" y ahí, en "distribuciones", he añadido el chino, pero por más que escribo en pinyin (o transcripción fonética), me salen letras en alfabeto.

He buscado en el foro, con las palabras chino y simplificado, y no he encontrado nada al respecto, así que abro un hilo para preguntar.

Por otro lado, entre actualizaciones de distribuciones, se puede actualizar o hay que hacer siempre formateo e instalación nueva? Quiero decir, de pasar de 4.9 a la 4.10, he de formatear y luego instalar o se puede actualizar? Qué es más recomendable? He buscado y he leído en un post que solo se podía hacer instalación limpia.

Un saludo y gracias.

EDIT: Hice también pruebas a ver si tenía soporte para idiomas asiáticos, así que hice una búsqueda por firefox de un actor y en la wikipedia se veían los caracteres, por lo que soporte de lectura tiene.


« Última modificación: 16-01-2015, 13:10 (Viernes) por MrChan »

Fr3dY

  • Visitante

Garcad

  • Visitante
Re: Problema con idioma del teclado
« Respuesta #2 en: 16-01-2015, 14:23 (Viernes) »

MrChan

  • Visitante
Re: Problema con idioma del teclado
« Respuesta #3 en: 17-01-2015, 16:14 (Sábado) »
Antes de nada, muchas gracias Fr3dY y Garcad.

He intentado usar el SCIM, pero no sé qué pasa, pero escribe lo que le sale de los "ejem", así que, leyendo el hilo del foro que me ha pasado Fr3dY, hay varios usuarios que recomiendan el uso de fcitx, y eso he hecho.

Voy a recapitular lo que he hecho por si alguien lo necesita (o si en el futuro me vuelvo a topar con el mismo problema):

He hecho una búsqueda del archivo en cuestión para Slackware y he encontrado la última versión (la 4.2.6.1) en este enlace.

http://slackbuilds.org/repository/14.0/misc/fcitx/

Me he bajado los archivos fcitx.tar.gz y fcitx-4.2.6.1_dict.tar.xz.

Ejecutamos "tar xzf /root/Descargas/fcitx.tar.gz" y el archivo se descomprime en root.

Entramos en la carpeta fcitx escribiendo "cd fcitx"

Luego ejecutamos "chmod +x fcitx.SlackBuild" para hacer el script ejecutable.

Seguidamente ejecutamos el script escribiendo "./fcitx.SlackBuild" y nos saltará un error y es que falta el archivo "fcitx-4.2.6.1_dict.tar.xz", lo agregamos a la carpeta y volvemos a ejecutar el comando.

Una vez terminado el proceso, el archivo de instalación se encontrará en "/tmp/fcitx-4.2.6.1-i486-1_SBo.tgz"

Ya solo queda traer el archivo de instalación a /root/ e instalar el archivo mediante el comando "installpkg fcitx-4.2.6.1-i486-1_SBo.tgz"

Una vez instalado, ejecutamos el comando "chmod +x /etc/profile.d/fcitx.*", no sé para qué es esto, pero si para el scim tuve que hacerlo... para esto lo hice también.

Y finalmente escribimos "fcitx -d" para iniciar el fcitx.

Ya para acabar, si no salen los caracteres, hay que pulsar Cntrl + Espacio para hacer el cambio de teclado y si aún así no funciona, probad a reiniciar para que cargue las librerías necesarias.

Nota: No sé si es por la instalación del teclado, pero el YouTube se me ve raro, en el sentido de que los botones se juntan todos a la izquierda, pero por lo demás... todo perfecto.

Nota 2: Al parecer esto solo escribe en chino simplificado, si luego me dan más ganas, buscaré alguna manera de escribir en tradicional.

Saludos.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14708
Re: Problema con idioma del teclado
« Respuesta #4 en: 18-01-2015, 13:24 (Domingo) »
el problema de youtube es por el paquete alsaequal ...hay que eliminarlo.


dentro de nada sacare una revision 4.10.1 , con eso ya resuelto.



respecto al tema, no se si te faltara alguna de las fuentes de escritura  ^-^


tambien miraria con gslapt , por que hay como 6 paquetes extras reñacionados con scim que no vienen de serie en la iso.

y en fuentes hay varias que ponen algo de japones y chino ...
« Última modificación: 18-01-2015, 14:14 (Domingo) por USUARIONUEVO »

MrChan

  • Visitante
Re: Problema con idioma del teclado
« Respuesta #5 en: 18-01-2015, 18:15 (Domingo) »
谢谢你 USUARIONUEVO,

Me he puesto a buscar el paquete en buscar archivos y carpetas y no lo encontraba, y se me encendió la bombilla y dije, voy a probar el comando nuevo que aprendí ayer "removepkg alsaequal" para desinstalarlo y me funcionó. He reiniciado y YouTube ya me funciona perfectamente.

Se nota con mis comentarios que soy un poco novatillo en este OS, pero bueno, ya he dado el primer paso... a ver como sigo...

Antes de leer esta recomendacion, instale el Chrome, y en ese navegador YouTube me iba perfecto, pero los caracteres me los muestra en cuadrados.

Tras probar el Gslapt, busque "scim" y saco varios paquetes extras como dijo USUARIONUEVO, instale "scim-pinyin", que me permite escribir solo en simplificado y "scim-tables", que son tablas adicionales para otros idiomas, incluido el tradicional, pero desgraciadamente no he encontrado manera de escribir en tradicional con el pinyin.

Ya para terminar, segui los consejos de USUARIONUEVO e instale una fuente de escritura (y lectura dicho sea de paso), concretamente "wqy-zenhei-font-ttf", y tras reiniciar, puedo ver tanto en tradicional como en simplificado y se arreglo el tema de los caracteres cuadrados del Chrome. Por lo visto, la fuente es una fuente CJK, es decir, contiene los caracteres Chinos, Japoneses y Koreanos.

En fin, ya he dado otro pasito mas. Ahora buscare alguna manera de escribir en tradicional con el pinyin y, si encuentro algo, lo compartire por aqui.

Saludos y gracias a tod@s.

EDIT: Añadir que, además de eliminar el paquete "alsaequal", hay que borrar manualmente el fichero "/root/.asoundrc", de lo contrario, los archivos locales del HDD no se escucharán.
« Última modificación: 20-01-2015, 12:43 (Martes) por MrChan »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14708
Re: Problema con idioma del teclado
« Respuesta #6 en: 18-01-2015, 20:37 (Domingo) »
puedes probar a reinstalar scim  ....   por si estubiera mal el de serie d ela iso.

o necesitara ficheros que fueran eliminados o algo ... por probar.


me paso algo parecido con las fuentes y el paquete steam ... no se veian las letras , y era que me faltaba una fuente de escritura..que si, ademas es de lectura si el programa de turno tiene configurada esa fuente.  ;)

MrChan

  • Visitante
Re: Problema con idioma del teclado
« Respuesta #7 en: 19-01-2015, 14:34 (Lunes) »
Hmm, creo que el scim va bien, o por lo menos se comporta bien. El problema es que no han sacado ningún script que diga, en lugar de escribir en simplificado, lo haces en tradicional.

Según he ido leyendo estos días, hay post de 2008 que llevan pidiendo lo que busco, y por lo que he podido probar, ahora comentaré lo que he investigado por ahí.

Por un lado, hay personas que dicen que pruebes el "scimfanti", en este enlace: http://dheera.net/projects/scimfanti.php pero parece que ya ha dejado de existir, así que nada...

Lo siguiente que he probado es el Google PinYin, a través de este enlace: http://code.google.com/p/scim-googlepinyin/wiki/install#whb , ahí solo he tenido que ejecutar los comandos que aparecen en "grab the source" y "build and install". (Añadir que el comando "cd scim-googlepinyin.git" está mal, sería "cd scim-googlepinyin", es decir, sin el ".git" Los resultados, pues los mismos, siempre que escribas algo, sale en simplificado, pero si buscas en la lista de caracteres caracteres, te sale en tradicional, cosa que es más coñazo, pero funciona.

Otra manera que he visto, sin necesidad de instalar nada, es con el propio smart-pinyin de scim, para ello tenemos que presionar en la barra donde pone 智能拼音, cambiamos 中 a 繁. El problema es el mismo que antes, en simplificado escribo 'weishenme' y me sale directamente 为什么, en cambio para tradicional, tengo que escribir 'wei', buscar el caracter y pulsar espacio para que salga 為, y lo mismo para 'shen' 什 y para 'me' 麼.

Por último, hay gente que dice que escriben en simplificado y luego con google translator, lo pasan a tradicional...

Voy a seguir investigando y cuando sepa novedades os lo informaré por aquí.

MrChan

  • Visitante
Re: Problema con idioma del teclado
« Respuesta #8 en: 19-01-2015, 15:22 (Lunes) »
Perfecto, creo que ya lo he conseguido, pero tengo un problemilla... El que la sigue, la consigue, o eso dicen!  >:( >:( >:(

Bueno, comento lo que hice, instalé el ibus (http://slackbuilds.org/repository/14.1/misc/ibus/) y el ibus-pinyin (http://slackbuilds.org/repository/14.1/misc/ibus-pinyin/) y reinicié.

En las preferencias de ibus, seleccioné como método de entrada Chino-PinYin, una vez cambiado el teclado con cntrl + espacio, pinchamos en el ibus con el izquierdo y podremos cambiar entre simplificado y tradicional pinchando en 简/繁.

NOTA: Ahora tengo un problema... resulta que hablando por Skype, las tildes me las coloca delante de la palabra, es decir, si escribo la palabra 'estación', en Skype me sale 'estaci'on'. Voy a reiniciar y a ver qué pasa...

EDIT: Ya lo he solucionado, al final he tenido que instalar el ibus-qt (http://slackbuilds.org/repository/14.1/misc/ibus-qt/) para compatibilizar el teclado.

EDIT 2: Como recordatorio, no olvidar instalar por Gslapt la fuente "wqy-zenhei-font-ttf" y reiniciar.
« Última modificación: 22-01-2015, 22:37 (Jueves) por MrChan »

//FINAL Y MÁS DOS RESPUESTAS