Autor Tema: Wifislax Updater GUI  (Leído 133568 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Wifislax Updater GUI
« Respuesta #120 en: 05-04-2015, 22:08 (Domingo) »
Versión 1.2: https://mega.co.nz/#!kwIRwJ6b!6ykV4bcTxyVDTNzpaIFko3Mrb62FKkbu2F1MdOU4hOg

Ahora al abrirlo desde el menú aparece un checkbox para activar o desactivar el autorun, tambien se puede guardar la config en un módulo xzm.

Al pulsar el boton para guardar la config, primero se intenta guardar directamente en la carpeta módules del live-usb, si no se puede porque no estemos en modo live o por cualquier otra razón, se guarda el módulo en el escritorio.


Siempre intento seguir el standar de slackware, por eso lo que he hecho es añadirlo como un servicio mas del sistema, así que también se puede activar/desactivar desde Sistema > Salix tools > Servicios del sistema




La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Wifislax Updater GUI
« Respuesta #121 en: 09-04-2015, 22:42 (Jueves) »
Holas, he estado un par de dias sin mirar nada , hoy he arrancado wifislax, y sabia que tenia updates de aircrack-ng, pero no se han mostrado.

he empezado a mirar y creo es esto ..


wifislax ~ # /etc/rc.d/rc.WifislaxUpdaterGUI
/etc/rc.d/rc.WifislaxUpdaterGUI: línea 6: error sintáctico cerca del elemento inesperado `)'
/etc/rc.d/rc.WifislaxUpdaterGUI: línea 6: `     --rm-mutex) WifislaxUpdaterGUI --rm-mutex #Only used for autorun'

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Wifislax Updater GUI
« Respuesta #122 en: 09-04-2015, 23:05 (Jueves) »
Cierto... parece que ese archivo me lo dejé a medias  :-\

Aquí está solucionado: http://www.downloadwireless.net/modulos-fase-testing/wifislax-current/WifislaxUpdaterGUI-1.3-noarch-1sw.xzm

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Wifislax Updater GUI
« Respuesta #123 en: 09-04-2015, 23:09 (Jueves) »
Thanks!  ;D

Garcad

  • Visitante
Re: Wifislax Updater GUI
« Respuesta #124 en: 02-07-2015, 19:14 (Jueves) »
Error al actualizar aircrack-ng wifislax-30062015.iso

Código: [Seleccionar]
######################################
##
##  Actualizando aircrack-ng
##
######################################

]2;aircrack-ng_updatersvn: E175002: Unable to connect to a repository at URL 'http://svn.aircrack-ng.org'
svn: E175002: OPTIONS de 'http://svn.aircrack-ng.org': Could not resolve hostname `svn.aircrack-ng.org': Fallo temporal en la resolución del nombre (http://svn.aircrack-ng.org)
/tmp/WifislaxUpdaterGUI/aircrack-ng_updater: línea 29: [: =: se esperaba un operador unario
El sitio svn de aircrack-ng no responde ... el script se cerrara.


Removing package /var/log/packages/aircrack-ng-1.2-rc2-r2563-i486-1sw...
Removing files:
  --> //tmp/build/aircrack-ng/aircrack-ng-1.2-rc2-r2563-i486-1sw no longer exists. Skipping.
  --> Deleting /etc/aircrack-ng/airodump-ng-oui.txt
  --> Deleting /usr/bin/aircrack-ng
  --> Deleting /usr/bin/airdecap-ng
  --> Deleting /usr/bin/airdecloak-ng
  --> Deleting /usr/bin/airolib-ng
  --> Deleting /usr/bin/besside-ng-crawler
  --> Deleting /usr/bin/buddy-ng
  --> Deleting /usr/bin/ivstools
  --> Deleting /usr/bin/kstats
  --> Deleting /usr/bin/makeivs-ng
  --> Deleting /usr/bin/packetforge-ng
  --> Deleting /usr/bin/wpaclean
  --> Deleting /usr/sbin/airbase-ng
  --> Deleting /usr/sbin/aireplay-ng
  --> Deleting /usr/sbin/airmon-ng
  --> Deleting /usr/sbin/airmon-zc
  --> Deleting /usr/sbin/airodump-ng
  --> Deleting /usr/sbin/airodump-ng-oui-update
  --> Deleting /usr/sbin/airserv-ng
  --> Deleting /usr/sbin/airtun-ng
  --> Deleting /usr/sbin/besside-ng
  --> Deleting /usr/sbin/easside-ng
  --> Deleting /usr/sbin/tkiptun-ng
  --> Deleting /usr/sbin/wesside-ng
  --> Deleting empty directory /etc/aircrack-ng

Salu2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Wifislax Updater GUI
« Respuesta #125 en: 03-07-2015, 22:46 (Viernes) »
te ha pasado por que tenias varios paquetes a la vez de aircrack ...

operador unario ... te delata.

Garcad

  • Visitante
Re: Wifislax Updater GUI
« Respuesta #126 en: 03-07-2015, 23:53 (Viernes) »
te ha pasado por que tenias varios paquetes a la vez de aircrack ...

operador unario ... te delata.

Salio actualización y le di a a actualizar.
Cuando termino verifique que funcionara y me di cuenta que no encontraba el paquete.

Lo recupere con los scripts de Wifislax Update

Editado: Unable to connect to a repository at URL

Supongo que en algún momento antes de empezar la actualización se quedo el pc sin conexión a Internet y no descargo nada, ahun no teniendo un paquete valido para instalar la gui siguió desinstalando el paquete y me quede sin el.

Salu2
« Última modificación: 04-07-2015, 00:08 (Sábado) por Garcad »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Wifislax Updater GUI
« Respuesta #127 en: 04-07-2015, 00:19 (Sábado) »
te ha pasado por que tenias varios paquetes a la vez de aircrack ...

operador unario ... te delata.

Salio actualización y le di a a actualizar.
Cuando termino verifique que funcionara y me di cuenta que no encontraba el paquete.

Lo recupere con los scripts de Wifislax Update

Editado: Unable to connect to a repository at URL

Supongo que en algún momento antes de empezar la actualización se quedo el pc sin conexión a Internet y no descargo nada, ahun no teniendo un paquete valido para instalar la gui siguió desinstalando el paquete y me quede sin el.

Salu2


eso es por que no tienes los scripts actualizados ...  en la current , solo se desinstala la del sistema si se consigue crear el xzm de la version nueva...si hay error, se para todo , y no te quedas sin paquete  ;D

lo sugirio en su dia geminis  , y lo apadate , por que es mejor asi.

Garcad

  • Visitante
Re: Wifislax Updater GUI
« Respuesta #128 en: 04-07-2015, 00:36 (Sábado) »
Sucedió después de actualizar todos los scripts sin usar el modulo, usando la opción de updater.

Es lo primero que hice después de iniciar el sistema y no me ofreció ninguna actualización de ningún script

Editado: Por cierto en la ultima de desarollo veo paquetes repetidos.

cmake-3.1.3-i486-1
cmake-3.2.1-i486-1
gst-plugins-ugly-0.10.19-i486-2sw
gst-plugins-ugly-1.4.4-i486-1sw
moc-2.5.0-i486-1
moc-2.5.0_beta1-i486-1
openjpeg-1.5.2-i486-1sw
openjpeg-2.1.0-i486-1

Salu2
« Última modificación: 04-07-2015, 00:38 (Sábado) por Garcad »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Wifislax Updater GUI
« Respuesta #129 en: 04-07-2015, 00:44 (Sábado) »
paquetes repetidos..

el unico el cmake


los demas son por que hay dos ramas

0.X
1.X

busca gstreamer y veras que llevas las dos ramas ...para compatibilidad con viejas y nuevas aplicaciones
openjpeg , igual ... algunas apps, piden rama 0.x y otras 1.x


el de cmake si es un fail mio.

gracias.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Wifislax Updater GUI
« Respuesta #130 en: 04-07-2015, 01:51 (Sábado) »
He probado a engañar al sistema con el paquete coreutils, bajandole la version para que crea que hay un update..



en la current de wifislax ...  detecta el update, pero da error al actualizar , ..no actualiza pero no borra las coreutils del sistema, con lo que me quedo solo con el error y nada mas.


no se por que no puede actualizar ese paquete...

igual deberiamos usar

slackpkg update

en el gui



EDIT:  OK , actualizado coreutils , sin drama, el sistema no rompe ...

no descargaba por que he cambiado las sources de slapt-get y el updater no podia grepear la url
es culpa mia , antes usaba direcciones http  y ahora uso la url  del ftp directo de slackware ...


por eso al grepear http , como ahora es ftp .. no pillaba la direccion.

he modificado el updater ..para que si url esta vacia, intenta con ftp.


________________________________________________________________________________________________
« Última modificación: 04-07-2015, 02:31 (Sábado) por USUARIONUEVO »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Wifislax Updater GUI
« Respuesta #131 en: 31-07-2015, 04:18 (Viernes) »
Versión 1.5

http://www.downloadwireless.net/modulos-fase-testing/wifislax-current/WifislaxUpdaterGUI-1.5-noarch-1sw.xzm

Reparado el bug que no guardaba la config al pulsar el botón de salir.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Wifislax Updater GUI
« Respuesta #132 en: 31-07-2015, 05:48 (Viernes) »
Versión 1.5

http://www.downloadwireless.net/modulos-fase-testing/wifislax-current/WifislaxUpdaterGUI-1.5-noarch-1sw.xzm

Reparado el bug que no guardaba la config al pulsar el botón de salir.

ya que te pusiste , le podias haber mirao lo otro  ;D

si abre gparted , al acabar todo el proceso el instalador se resetea , osea se ejecuta de nuevo al acabar todo.

testeare esta ,gracias.  ;)

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Wifislax Updater GUI
« Respuesta #133 en: 31-07-2015, 23:02 (Viernes) »
Versión 1.5

http://www.downloadwireless.net/modulos-fase-testing/wifislax-current/WifislaxUpdaterGUI-1.5-noarch-1sw.xzm

Reparado el bug que no guardaba la config al pulsar el botón de salir.

ya que te pusiste , le podias haber mirao lo otro  ;D

si abre gparted , al acabar todo el proceso el instalador se resetea , osea se ejecuta de nuevo al acabar todo.

testeare esta ,gracias.  ;)


vaya nuub , estoy hecho , jajaja , lo de gparted es en instalador, cierto , me he liado.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Wifislax Updater GUI
« Respuesta #134 en: 16-08-2015, 03:24 (Domingo) »
Versión 1.6

https://mega.co.nz/#!BwxGlJqT!j3KqCWVx0yvbsXbhI4WUWhzsuSfGNmsnZuGBRITIuHE

Reparada la función de actualizar updaters (que no funcionaba y nadie se había coscado  ;D) y adaptada para guithub
También he añadido nuevas variables que se usan para determinar la versión online, ya que había bastantes updaters posteriores a la creación de este script de los que no se buscaba actualizaciones, porque usaban variables diferentes.

Actualmente estas son las que busca el script:

Código: [Seleccionar]
egrep "PRGNAM=|WEB=|RAMA=|DOWNLOAD=|LAGRANWEB=|ELGRANARCHIVO=|VERSION=|VERSION_REAL=|FICHERO="
Para futuros updaters o modificaciones de los existentes, si añadís variables nuevas en la función de determinar versión, avisarme para que las añada please.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Wifislax Updater GUI
« Respuesta #135 en: 16-08-2015, 03:50 (Domingo) »
gracias men.


si se usa el base_updater , no tienen por que crearse desajustes , ya que vienen ya casi cocinados.

Desconectado pepe10000

  • *******
  • Mensajes: 565
Re: Wifislax Updater GUI
« Respuesta #136 en: 16-08-2015, 11:07 (Domingo) »
Versión 1.6

https://mega.co.nz/#!BwxGlJqT!j3KqCWVx0yvbsXbhI4WUWhzsuSfGNmsnZuGBRITIuHE

Reparada la función de actualizar updaters (que no funcionaba y nadie se había coscado  ;D) y adaptada para guithub
También he añadido nuevas variables que se usan para determinar la versión online, ya que había bastantes updaters posteriores a la creación de este script de los que no se buscaba actualizaciones, porque usaban variables diferentes.

Actualmente estas son las que busca el script:

Código: [Seleccionar]
egrep "PRGNAM=|WEB=|RAMA=|DOWNLOAD=|LAGRANWEB=|ELGRANARCHIVO=|VERSION=|VERSION_REAL=|FICHERO="
Para futuros updaters o modificaciones de los existentes, si añadís variables nuevas en la función de determinar versión, avisarme para que las añada please.

He detectado un problemilla con esta versión.

Si se usa junto con el driver de Nvidia (014-Driver_nvidia-352.21_wifislax_4.11.1-i486-1sw.xzm) no puedo arrancar en SMP (ni en KFCE ni en KDE), se queda el cursor parpadeando arriba a la izquierda y tengo que reiniciar.

Sin embargo en 486 arranca sin problemas junto con el módulo de Nvidia  ???

También he hecho pruebas sin el driver de Nvidia y perfecto en todos los modos.

Editado:

Me ha dado por probar la versión anterior (WifislaxUpdaterGUI-1.5-noarch-1sw.xzm) y sucede lo mismo, se lleva fatal con el driver de Nvidia en SMP.

Un saludo.
« Última modificación: 16-08-2015, 11:22 (Domingo) por pepe10000 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: Wifislax Updater GUI
« Respuesta #137 en: 16-08-2015, 14:36 (Domingo) »
@pepe10000

prueba a apagar el equipo y arrancar smp nada mas encenderlo , a veces cuando saltas entre normal y smp sucede eso.

también puedes probar a meter los modulos en la carpeta base ...o al menos el del updatergui , y ver si asi no te pasa lo de la pantalla en negro.


este modulo es imposible que cause conflictos.

Desconectado pepe10000

  • *******
  • Mensajes: 565
Re: Wifislax Updater GUI
« Respuesta #138 en: 16-08-2015, 17:04 (Domingo) »
@pepe10000

prueba a apagar el equipo y arrancar smp nada mas encenderlo , a veces cuando saltas entre normal y smp sucede eso.

también puedes probar a meter los modulos en la carpeta base ...o al menos el del updatergui , y ver si asi no te pasa lo de la pantalla en negro.


este modulo es imposible que cause conflictos.

1.- Es lo primero que se me ha ocurrido, así que directamente he apagado el ordenador, esperado unos segundos por si acaso y después lo he encendido directamente arrancando en SMP y da el fallo cuando están los dos módulos juntos en el sistema.

Incluso he probado reiniciando desde Ruindows por si acaso pero nada.

2.- Eso no se me había ocurrido, pero lo acabo de probar y también falla el arranque, lo he intentado con un módulo, después con el otro y finalmente con los dos en la carpeta base pero nada, no arranca se queda el cursor parpadeando.

3.- Eso mismo me he dicho yo, que puñetas tiene que ver el módulo de la GUI con el driver gráfico, incluso he descomprimido el módulo de la GUI por si acaso se hubiese escapado algún fichero de configuración extraño al crearlo, pero no he visto nada fuera de lo normal, por eso me he decidido a postearlo en el foro para que lo miréis vosotros.

Un saludo.
« Última modificación: 16-08-2015, 17:06 (Domingo) por pepe10000 »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2383
  • Prácticas precisas precisan práctica
Re: Wifislax Updater GUI
« Respuesta #139 en: 16-08-2015, 17:56 (Domingo) »
¿Cuantos módulos tienes?

Puede que el problema no sea este módulo en sí, si no que tengas demasiados módulos y se sobrepase el límite de loops que puede crear el kernel.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.