Autor Tema: Wifislax Updater GUI  (Leído 123849 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17429
  • Misántropo
Re: Wifislax Updater GUI
« Respuesta #260 en: 12-10-2015, 23:48 (Lunes) »
Lo quiero todo jajajajajajjajaja



Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2389
  • Prácticas precisas precisan práctica
Re: Wifislax Updater GUI
« Respuesta #261 en: 12-10-2015, 23:55 (Lunes) »
el tema gestion de log packages ...


tenia el usb con

youtube-dl-2015.10.08
youtube-dl-2015.10.12


aun asi , me ha saliso que "update"

youtube-dl-2015.10.12


cuando ya la tenia en el usb , ...esto es lo que comente , que en usb , siempre es posible tener mas de un log package...


por cada log  ,  un removepkg


Código: [Seleccionar]
  for x in `find /var/log/packages -iname "${PRGNAM}-[0-9]*"`; do
   echo ""
   echo "$ROJO"Eliminando la version del sistema..."$CIERRE"
   sleep 2
   removepkg /var/log/packages/$x
   done



EDIT: Desde el updater directo usando el funciones_updater , todo va como debe , por si te sirve de algo.


Estoy buscando la forma correcta de determinar a versión y de desinstalar la versión antigua.

Imagínate que tienes algo como esto:

Código: [Seleccionar]
wifislax ~ # ls /var/log/packages|grep "youtube"
youtube-dl-2014.10.12-i586-1sw
youtube-dl-2015.10.12-i586-1sw
youtube-dl-4gui-0.3.8-i486-1sw
youtube-dl-gui-0.3.8-i486-1sw
youtube-dl-gui-2016.10.12-i486-1sw

Ni la GUI ni el youtube-dl_updater son capaces de determinar la versión correcta, y esa es una situación que se puede dar.

Estoy buscando la solución a eso.

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #262 en: 13-10-2015, 00:15 (Martes) »
pues a mi en los scripts sueltos no me falla nada.


PRGNAM ..siempre es el valor excato a buscar


PRGNAM-[0-9]

no puede ser que si PRGNAM=macedonia

AL BUSCAR macedonia-[0-9]  , se cuelen cosas como

macedonia4-3.4.5
« Última modificación: 13-10-2015, 00:18 (Martes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #263 en: 13-10-2015, 00:23 (Martes) »
Código: [Seleccionar]
find /var/log/packages -iname youtube-dl-[0-9]*
es como esta en el funciones ---> no falla

asumiendo que hasta donde -{0-9]  lo de antes es el PRGNAM y no hay dos PRGNAM IGUALES

pruebalo desde consola...


Código: [Seleccionar]
find /var/log/packages -iname youtube-[0-9]*no devuelve nada por que no hay pquete que solo sea youtube-VERSION


este solo devuelve el de youtube-dl a secas
PRGNAM=youtube-dl
Código: [Seleccionar]
find /var/log/packages -iname youtube-dl-[0-9]*
este el de la gui solo
PRGNAM=youtube-dl-gui
Código: [Seleccionar]
find /var/log/packages -iname youtube-dl-gui-[0-9]*
« Última modificación: 13-10-2015, 00:26 (Martes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #264 en: 13-10-2015, 00:27 (Martes) »
es tu amigo  ;)

Código: [Seleccionar]
find /var/log/packages -iname $PRGNAM-[0-9]*

solo aparecera mas de un resultado si hay dos logs del mismo paquete (frecuente en modo live) , asi que añadiria un head -1 , para pillar el mas alto
« Última modificación: 13-10-2015, 00:30 (Martes) por USUARIONUEVO »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2389
  • Prácticas precisas precisan práctica
Re: Wifislax Updater GUI
« Respuesta #265 en: 13-10-2015, 00:35 (Martes) »
Ahora imagínate que hay un paquete llamado "youtube-dl-2video-2016.10.12-i586-1sw", puede pasar perfectamente... pues en ese caso tu comando ya no es capaz de determinar la versión correcta.

Haz una prueba, crea un archivo con ese nombre en /var/log/packages y ejecuta el actualizador de youtube-dl.


La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #266 en: 13-10-2015, 00:44 (Martes) »
Ahora imagínate que hay un paquete llamado "youtube-dl-2video-2016.10.12-i586-1sw", puede pasar perfectamente... pues en ese caso tu comando ya no es capaz de determinar la versión correcta.

Haz una prueba, crea un archivo con ese nombre en /var/log/packages y ejecuta el actualizador de youtube-dl.



si lo es cabezon ...por que PRGNAM=youtube-dl-2video

QUE PRGNAM ES SIEMPRE EL NAME DEL PAQUETE  ;D

que esto lo arreglemos hace unas semanas en el funciones ...por que nos pasaba que se colaban cosas que no eran.


ls  -->  muestra todos los resultados aunque solo sean parcialmente = se cuela de mas
find --> busca la cadena estrica, solo aparecera si la cadena es exacta.



Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #267 en: 13-10-2015, 00:46 (Martes) »
find /var/log/packages -iname $PRGNAM-[0-9]*


no hay dos PRGNAM iguales , ..no pueden haber dos coincidencias a menos que sean logs del mismo paquete ...

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #268 en: 13-10-2015, 00:49 (Martes) »
PRGNAM=PEPE
PRGNAM=PEPE2
PRGNAM=PEPE3


PRGNAM , - numero


absolutamente todos los paquetes son asi ,por que es el estandard

no hay ni uno solo asi

PEPE-2-2.4.5

fijate que hay paquetes que son


python
python3

para respetar el estandard de cracion de paquetes de cualquier distro ...no solo slackware todas trabajan asi


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #269 en: 13-10-2015, 00:52 (Martes) »
te estas dejando engañar ...  ;)


youtube-dl-2video-2016.10.12-i586-1sw


PRGNAM=youtube-dl-2video
VERSION=2016.10.12
ARCH=i586
BUILD=1sw


$PRGNAM-$VERSION

No hay lugar a errores ...

El campo PRGNAM es estatico , el de verison es variable, por eso el [0-9]*

« Última modificación: 13-10-2015, 00:53 (Martes) por USUARIONUEVO »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2389
  • Prácticas precisas precisan práctica
Re: Wifislax Updater GUI
« Respuesta #270 en: 13-10-2015, 00:53 (Martes) »
A ver, no me estás entendiendo...

Manolo crea un programa que se llama "youtube-dl" y Antonio que no conoce a Manolo de nada, crea otro programa que se llama "youtube-dl-2video"

Pues si nosotros tenemos esos dos programas en wifislax, el updater de youtube-dl falla.

Solo te estas basando es suposiciones, yo te lo estoy diciendo porque lo he comprobado.. compruebalo y me cuentas...
« Última modificación: 13-10-2015, 00:56 (Martes) por geminis_demon »

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #271 en: 13-10-2015, 00:55 (Martes) »
NO FALLA TIO

..jajaja

cawen , que estes callendo en eso ...


haber , mas facil imposible ...

crea los supuestos logs , y usa find , en vez de ls ...


el PRGNAM de manolo sera youtube-dl  , mientras el de antonio sera youtube-dl-2video



SI USAS LS  SE LISTARAN TODOS , POR QUE LS LISTA INCLUSO LAS COINCIDENCIAS PARCIALES ...

MIENTRAS SI USAS FIND, EL RESULTADO ES EXACTO ...

« Última modificación: 13-10-2015, 00:56 (Martes) por USUARIONUEVO »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2389
  • Prácticas precisas precisan práctica
Re: Wifislax Updater GUI
« Respuesta #272 en: 13-10-2015, 00:57 (Martes) »
Puedes probarlo para que te quede claro por favor? o te tengo que hacer yo un vídeo?  ;D

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #273 en: 13-10-2015, 01:02 (Martes) »
ok ,ahora ya lo veo .... ;D

por que es un numero tras el guion ...y se cuela igualmente  ;)


he creado el supuesto log ,para hacer pruebas ...

 :-[


y si despues del 0-9  que coincida otro numero o un punto  ... aunque estariamos igual ...
« Última modificación: 13-10-2015, 01:04 (Martes) por USUARIONUEVO »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2389
  • Prácticas precisas precisan práctica
Re: Wifislax Updater GUI
« Respuesta #274 en: 13-10-2015, 01:06 (Martes) »
Gracias  ;D

Aclarado esto, pongo el comando que no falla  >:D

Código: [Seleccionar]
INSTALADA="$(ls /var/log/packages|rev|cut -d'-' -f3-|sed 's/-/ /'|rev|grep "^$PRGNAM "|cut -d' ' -f2|tail -1)"


Y para eliminar el paquete antiguo:

Código: [Seleccionar]
removepkg $(ls /var/log/packages|rev|cut -d'-' -f3-|sed 's/-/ /'|rev|grep "^$PRGNAM "|cut -d' ' -f1)

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #275 en: 13-10-2015, 01:14 (Martes) »
el removepkg que pones tiene en cuenta que hubiese mas de un log ?¿


me autorespondo ,   SI

por cada log , aparecera un resultado , por que si si por ejemplo hay

pepe-1.0
pepe-1.1

el resultado es

pepe pepe


removepkg pepe pepe

por lo que   SI
« Última modificación: 13-10-2015, 01:22 (Martes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #276 en: 13-10-2015, 01:23 (Martes) »
les das la vuelta por que por detras la cantidad de guiones SIEMPRE ES LA MISMA ... que carbon  >:D >:D


menos mal que eres mas cabezon que yo ,  y no te achantas  ;D ;)   >:( >:( >:(



bueno , pues ahora , te copio los comandos para el funciones y lo subo al git.   ;)

« Última modificación: 13-10-2015, 01:24 (Martes) por USUARIONUEVO »

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2389
  • Prácticas precisas precisan práctica
Re: Wifislax Updater GUI
« Respuesta #277 en: 13-10-2015, 01:26 (Martes) »
He estado caso 2 horas probando comandos hasta dar con el bueno  ;D



Citar
bueno , pues ahora , te copio los comandos para el funciones y lo subo al git.   Wink

Okay  ;)
« Última modificación: 13-10-2015, 01:27 (Martes) por geminis_demon »

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #278 en: 13-10-2015, 01:29 (Martes) »
no se si lo rompere , por que veo demasiado movimiento aqui ..


Código: [Seleccionar]
# Detecta la version instalada en el sistema
f_versionInstalada() {
  INSTALADA=""
  POSIBLES_INSTALADAS=$(find /var/log/packages -iname "${PRGNAM}-[0-9]*" | head -1)
   if [ -f $POSIBLES_INSTALADAS ] && [ $POSIBLES_INSTALADAS ]; then
      INSTALADA="$(ls /var/log/packages/$PRGNAM-[0-9]*-* 2>/dev/null|cut -d '/' -f5-|sed "s/^${PRGNAM}-//"|rev|cut -d'-' -f3-|rev|tail -1)"
      echo ""
      echo ""$AMARILLO"La version del sistema es..."$CYAN"$PRGNAM-$INSTALADA"$CIERRE""
      sleep 1
      echo ""
      echo "__________________________________________"
      echo ""
      echo ""$AMARILLO"La version mas nueva en su pagina web es..."$CYAN"$PRGNAM-$VERSION"$CIERRE""
      echo ""
      if [ $PRGNAM = x265 ]; then
      echo "${ROJO}ADVERTENCIA:"
      echo "${BLANCO}Actualizar este paquete puede romper ${AMARILLO}ffmpeg"
      echo "${BLANCO}Es posible que necesites recompilar ${AMARILLO}ffmpeg"
      echo
      fi
      echo ""$BLANCO"Pulsa $ROJO"ENTER" $BLANCO"si deseas actualizarla""
      read junk
      echo ""
   fi
   
# Si el paquete esta instalado y es el mismo se sube el numero de build
if [ ! -z $INSTALADA ] && [ $INSTALADA = $VERSION ]; then
BUILDLOCAL="$(ls /var/log/packages/$PRGNAM-[0-9]*-* 2>/dev/null|cut -d '/' -f5-|sed "s/^${PRGNAM}-//" | rev | cut -d- -f1 | grep -o [0-9] | head -1)"
BUILD=`expr $BUILDLOCAL + 1`
fi
}

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14258
Re: Wifislax Updater GUI
« Respuesta #279 en: 13-10-2015, 01:30 (Martes) »
creo que el POSIBLES_INSTALADAS , ahora sobra.


Código: [Seleccionar]
# Detecta la version instalada en el sistema
f_versionInstalada() {
      INSTALADA="$(ls /var/log/packages|rev|cut -d'-' -f3-|sed 's/-/ /'|rev|grep "^$PRGNAM "|cut -d' ' -f2|tail -1)"
      if [ ! -z $INSTALADA ]; then
      echo ""
      echo ""$AMARILLO"La version del sistema es..."$CYAN"$PRGNAM-$INSTALADA"$CIERRE""
      sleep 1
      echo ""
      echo "__________________________________________"
      echo ""
      echo ""$AMARILLO"La version mas nueva en su pagina web es..."$CYAN"$PRGNAM-$VERSION"$CIERRE""
      echo ""
      if [ $PRGNAM = x265 ]; then
      echo "${ROJO}ADVERTENCIA:"
      echo "${BLANCO}Actualizar este paquete puede romper ${AMARILLO}ffmpeg"
      echo "${BLANCO}Es posible que necesites recompilar ${AMARILLO}ffmpeg"
      echo
      fi
      echo ""$BLANCO"Pulsa $ROJO"ENTER" $BLANCO"si deseas actualizarla""
      read junk
      echo ""
      fi
   
# Si el paquete esta instalado y es el mismo se sube el numero de build
      if [ ! -z $INSTALADA ]; then
      BUILDLOCAL="$(ls /var/log/packages/$PRGNAM-[0-9]*-* 2>/dev/null|cut -d '/' -f5-|sed "s/^${PRGNAM}-//" | rev | cut -d- -f1 | grep -o [0-9] | head -1)"
      BUILD=`expr $BUILDLOCAL + 1`
     fi
}


tengo que revisar lo del build
« Última modificación: 13-10-2015, 01:39 (Martes) por USUARIONUEVO »