Autor Tema: OpenWRT + LUCI en WR740N V4.2 (unos 20€)  (Leído 30885 veces)

0 Usuarios y 1 Visitante están viendo este tema.

zcampy

  • Visitante
OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« en: 23-02-2012, 21:06 (Jueves) »
https://docs.google.com/document/d/1JgNRyVE5NwykKaQaJSMsB4B7ubcMcz_IXQTicUG9IYg

INSTALAR OPENWRT EN WR740N V4.2

¿Porqué este router? Pues por que es compatible con openwrt y tiene un precio de 18 euros más o menos.

openwrt: https://openwrt.org/
Tp-Link WDR740N: http://www.tp-link.com/ar/products/details/?model=TL-WR740N
 



1.       Cambiar la ip del router a 192.168.1.2 (Esto es opcional, pero no debe coincidir con el otro router)

Para ellos entramos en la web de configuración, por defecto 192.168.0.1

Buscamos opción LAN y cambiamos la ip del router
Guardar los cambios y reiniciar el router para asegurarnos que ahora entramos al router por la 192.168.1.2
 
Importante conectar un cable Ethernet Lan rj45 desde el puerto WAN  del TPLINK a uno de los puertos lan del router con internet.
 
2.       Instalación firmware mediante la web de configuración:

El firmware a  instalar es el siguiente.
openwrt-ar71xx-generic-tl-wr740n-v4-squashfs-factory.bin
Descarga desde: http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr740n-v4-squashfs-factory.bin
3.       Una vez instalado, reiniciamos en el router.
4.       Ahora solo podremos entrar por telnet:
 
Abrimos consola de ms-dos y los siguiente comandos:

telnet 192.168.1.2
User:admin              
Pass:admin

 
Nos pedirá que solo podremos entrar mediante ssh, para ellos tenemos que cambiar la contraseña root.
Al cambiarla solo podemos acceder medienta ssh, en Windows lo podemos hacer mediante Putty
 
http://the.earth.li/~sgtatham/putty/latest/x86/putty.exe
 
Desde ahora todos los comandos lo haremos con la consola de Putty.
 
5.       No hay interfaz web. Pongamosla:



Para poder tener interfaz web, hacemos lo siguiente:
En el ssh del putty, nos logamos como root y la nueva passwd.
Escribimos los siguiente comandos:
               
opkg update
opkg install luci
/etc/init.d/uhttpd restart

           
Una vez hecho esto tenemos LUCI en el router.
Ahora lo activamos de la siguiente manera:

/etc/init.d/uhttpd start
/etc/init.d/uhttpd enable

 
Y por últimos activamos wifi del router:
Wifi up

AHORA YA PODEMOS ACCEDER A LUCI PARA CONFIGURAR EN MODO REPETIDOR

MODO REPETIDOR:

Para modo repetidor con otro router, primero add nuestro interface para el wifi.
Elegimos como modo AP y Network LAN
Elegimos la encriptacion
Y save and aply
Ya tenemos nuestra red wifi del router.
Probamos a conectarnos a ella mediante wifi.
Debe estar todo ok

Quedaría algo así




Como crear el Enlace Repetidor

Ahora creamos en modo REPETIDOR (Cliente)
Scanemos la red a conectar como modo cliente
Elegimos la nuestra conectando en modo CLIENT
En network tenemos que elegir wwan
En seguridad tenemos que poner la clave wifi del otro router (El principal que tiene internet)

Nos debe quedar algo así:




Y en el principal de interface nos quedará así:



Uploaded with ImageShack.us

Perdonar por estar un poco con las prisas, me pongo ahora y lo dejo algo mejor, pero mientras teneis lo principal.

Y así acabamos, si tenéis dudas en el foro se veran.


« Última modificación: 03-04-2013, 20:01 (Miércoles) por zcampy »

SERASER

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #1 en: 23-02-2012, 21:17 (Jueves) »
Hola.

Gracias por tu aporte. ;)

Te he editado la direccion de correo, no es norma que en foros se de atencion personalizada, el foro es por y para compartir toda la informacion de manera abierta.

Un saludo y espero lo entiendas.

darkvier

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #2 en: 13-06-2012, 02:53 (Miércoles) »
Me lo apunto, creo k lo voy a pillar de repetidor
Muchas gracias

vicent_nb1

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #3 en: 29-07-2012, 12:54 (Domingo) »
Guay, mola esto de subirlo al google docs  ;)

litronas

  • Visitante
Re: Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #4 en: 26-10-2012, 19:45 (Viernes) »
Gracias por el aporte yo llevo tiempo liado con este router y ya solo me queda ponerle el puerto usb y lo tendre completo y como yo quiero. Hay algun adelanto con eso?. As visto algo por hay? Gracisas.

Enviado desde mi GT-S5570 usando Tapatalk 2

danin19

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #5 en: 17-01-2013, 16:38 (Jueves) »
Hola estoy intentando meter el openwrt en mi to link 740n v4.2 y he hecho lo de subir el firmware que me he bajado de esta pagina y he entrado por telnet a 192.168.1.2 luego lo he reiniciado y ya no me deja entrar por telnet, pero si me deja entrar por puty pero a la direccion 192.168.1.1 y cuando le doy a opkg update en puty me sale el siguiente error:
Collected errors:
* opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1.
Alguien sabe que estoy haciendo mal? ah cuando subi el firmware al tp link no tenia puesto el cable de mi otro router con internet al puerto wan solo tenia enchufado el cable al pc, gracias

« Última modificación: 17-01-2013, 17:23 (Jueves) por jar229 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #6 en: 17-01-2013, 17:24 (Jueves) »

Hola estoy intentando meter el openwrt en mi to link 740n v4.2 y he hecho lo de subir el firmware que me he bajado de esta pagina y he entrado por telnet a 192.168.1.2 luego lo he reiniciado y ya no me deja entrar por telnet, pero si me deja entrar por puty pero a la direccion 192.168.1.1 y cuando le doy a opkg update en puty me sale el siguiente error:
Collected errors:
* opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1.
Alguien sabe que estoy haciendo mal? ah cuando subi el firmware al tp link no tenia puesto el cable de mi otro router con internet al puerto wan solo tenia enchufado el cable al pc, gracias


Para actualizar la lista de paquetes, necesitas conexión a internet.
Debes configurar la IP del router, de acuerdo al rango de ip's de tu red y conectarlo por cable o wifi a la misma  ;)
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

danin19

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #7 en: 18-01-2013, 14:56 (Viernes) »

Hola estoy intentando meter el openwrt en mi to link 740n v4.2 y he hecho lo de subir el firmware que me he bajado de esta pagina y he entrado por telnet a 192.168.1.2 luego lo he reiniciado y ya no me deja entrar por telnet, pero si me deja entrar por puty pero a la direccion 192.168.1.1 y cuando le doy a opkg update en puty me sale el siguiente error:
Collected errors:
* opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1.
Alguien sabe que estoy haciendo mal? ah cuando subi el firmware al tp link no tenia puesto el cable de mi otro router con internet al puerto wan solo tenia enchufado el cable al pc, gracias


Para actualizar la lista de paquetes, necesitas conexión a internet.
Debes configurar la IP del router, de acuerdo al rango de ip's de tu red y conectarlo por cable o wifi a la misma  ;)

Hola mira aber si me puedes ayudar el router en el que tengo internet tiene este rango:
ip 192.168.1.101
mascara: 255.255.255.0
puerta de enlace: 192.168.1.254
y de este router saco un cable asta el tp link wr740n en la boca wan y de una boca lan saco un cable que va al pc por lo que deberia tener internet en el pc a traves del wr740n no? la ip y demas del pc la tengo en automatica esta bien o tengo que ponerle una fija? porque con el `putty accedo al router wr740n metiendo la direccion 192.168.1.1 mediante ssh pero no baja los paquetes de opkg y ya le cambiado el archivo opkg.conf porque la direccion ala que apuntaba estaba mal puesta, podrias ayudarme? gracias

danin19

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #8 en: 18-01-2013, 18:08 (Viernes) »

Hola estoy intentando meter el openwrt en mi to link 740n v4.2 y he hecho lo de subir el firmware que me he bajado de esta pagina y he entrado por telnet a 192.168.1.2 luego lo he reiniciado y ya no me deja entrar por telnet, pero si me deja entrar por puty pero a la direccion 192.168.1.1 y cuando le doy a opkg update en puty me sale el siguiente error:
Collected errors:
* opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1.
Alguien sabe que estoy haciendo mal? ah cuando subi el firmware al tp link no tenia puesto el cable de mi otro router con internet al puerto wan solo tenia enchufado el cable al pc, gracias

Hola al final he logrado ponerle este firmware:

OpenWrt | OpenWrt Barrier Breaker r35181 |Load: 0.30 0.24 0.11 Auto Refresh:on
   

existe algun firmware mas nuevo o es este el que tengo que tener?

Para actualizar la lista de paquetes, necesitas conexión a internet.
Debes configurar la IP del router, de acuerdo al rango de ip's de tu red y conectarlo por cable o wifi a la misma  ;)

marikilla

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #9 en: 07-03-2013, 15:22 (Jueves) »
se puede poner este ruter en modo cliente gracias

marikilla

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #10 en: 10-03-2013, 17:30 (Domingo) »
hola tengo un ruter tp-LINK wr740n ver 1.4 le e actualizado eel firware a openwrt-ar71xx-generic-tl-wr740n-v1-squashfs-factory me lo a hecho bien que yo sepa pero ahora no tiene puerta de enlace que yo canbien antes a 192.168.1.2 que e hecho mal me meto con putty en telnet para meterle los comandos de luci pero se abre el puttyn y se ciera del tiron gracias espero que me alludeis

zcampy

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #11 en: 03-04-2013, 18:13 (Miércoles) »
Hola estoy intentando meter el openwrt en mi to link 740n v4.2 y he hecho lo de subir el firmware que me he bajado de esta pagina y he entrado por telnet a 192.168.1.2 luego lo he reiniciado y ya no me deja entrar por telnet, pero si me deja entrar por puty pero a la direccion 192.168.1.1 y cuando le doy a opkg update en puty me sale el siguiente error:
Collected errors:
* opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1.
Alguien sabe que estoy haciendo mal? ah cuando subi el firmware al tp link no tenia puesto el cable de mi otro router con internet al puerto wan solo tenia enchufado el cable al pc, gracias



Sin conexión a internet con el primer router, revisa las IP lan de los routers que no coincidan

zcampy

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #12 en: 03-04-2013, 18:15 (Miércoles) »

Hola estoy intentando meter el openwrt en mi to link 740n v4.2 y he hecho lo de subir el firmware que me he bajado de esta pagina y he entrado por telnet a 192.168.1.2 luego lo he reiniciado y ya no me deja entrar por telnet, pero si me deja entrar por puty pero a la direccion 192.168.1.1 y cuando le doy a opkg update en puty me sale el siguiente error:
Collected errors:
* opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1.
Alguien sabe que estoy haciendo mal? ah cuando subi el firmware al tp link no tenia puesto el cable de mi otro router con internet al puerto wan solo tenia enchufado el cable al pc, gracias


Para actualizar la lista de paquetes, necesitas conexión a internet.
Debes configurar la IP del router, de acuerdo al rango de ip's de tu red y conectarlo por cable o wifi a la misma  ;)

Hola mira aber si me puedes ayudar el router en el que tengo internet tiene este rango:
ip 192.168.1.101
mascara: 255.255.255.0
puerta de enlace: 192.168.1.254
y de este router saco un cable asta el tp link wr740n en la boca wan y de una boca lan saco un cable que va al pc por lo que deberia tener internet en el pc a traves del wr740n no? la ip y demas del pc la tengo en automatica esta bien o tengo que ponerle una fija? porque con el `putty accedo al router wr740n metiendo la direccion 192.168.1.1 mediante ssh pero no baja los paquetes de opkg y ya le cambiado el archivo opkg.conf porque la direccion ala que apuntaba estaba mal puesta, podrias ayudarme? gracias

Mira la ip de los routers que no coincidan, router 1: 192.168.1.1   Router2: 192.168.1.2  por ejemplo

zcampy

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #13 en: 03-04-2013, 18:16 (Miércoles) »
hola tengo un ruter tp-LINK wr740n ver 1.4 le e actualizado eel firware a openwrt-ar71xx-generic-tl-wr740n-v1-squashfs-factory me lo a hecho bien que yo sepa pero ahora no tiene puerta de enlace que yo canbien antes a 192.168.1.2 que e hecho mal me meto con putty en telnet para meterle los comandos de luci pero se abre el puttyn y se ciera del tiron gracias espero que me alludeis

No importa, que puerta de enlace tiene ahora, sólo tendriamos que cambiar la del otro router.pero dime antes la ip del otro router

zcampy

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2
« Respuesta #14 en: 03-04-2013, 18:19 (Miércoles) »
Siempre hay que cargar Luci por SSH (22) si se hace a través del Telnet (23) nos dara errores en algunos modulos

Para los que no podeis acceder al ssh , entrar primero por así por ejemplo con la ip 192.168.1.1 y cambiais la passwd del ssh de esta forma


> Telnet 192.168.1.1
> passwd
> claveconletrasynumeros
> claveconletrasynumeros
« Última modificación: 03-04-2013, 18:46 (Miércoles) por zcampy »

eq7mavala

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #15 en: 09-04-2013, 09:28 (Martes) »
Una pregunta, este equipo se puede utilizar como un repetidor universal?

Es decir, puede repetir una red dentro del rango 192.168.1.X?

O solo podría como cliente a 192.168.1.X y emitiría 192.168.2.X?

Grac¡as

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #16 en: 09-04-2013, 09:34 (Martes) »
Una pregunta, este equipo se puede utilizar como un repetidor universal?

Es decir, puede repetir una red dentro del rango 192.168.1.X?

O solo podría como cliente a 192.168.1.X y emitiría 192.168.2.X?

Grac¡as

Instalándole gargoyle, seguro que sí.
Con OpenWrt y relayd también, pero ... ya sabemos que relayd no funciona bien con todos los routers  ;D
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

eq7mavala

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #17 en: 09-04-2013, 09:44 (Martes) »
Es que tengo que repetir en varios clientes la red wifi en sus casas y necesito un equipo barato que pueda realizarlo, si se os ocurre otro equipo barato que pueda repetir wifi...

Gracías

eq7mavala

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #18 en: 18-04-2013, 14:52 (Jueves) »
Funcionar perfectamente el modo repetidor transparente...

Deberemos instalar los siguientes paquetes contando con que acabamos de instalar openwrt y no tenemos absolutamente nada.

Conectamos el puerto WAN a un router y que nos de acceso a internet.

instalamos los paquetes:

opkg install luci luci-i18n-spanish relayd

Habilitamos/deshabilitamos los servicios necesarios:

/etc/init.d/firewall stop
/etc/init.d/firewall disable
/etc/init.d/relayd start
/etc/init.d/relayd enable

editamos y configuramos los archivos necesarios:

vi /etc/config/wireless

option htmode 'HT20'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '27'
        option country 'US'

config wifi-iface
        option network 'wwan'
        option ssid 'NOMBRE_AP' #Nombre del SSID que deseamos repetir
        option encryption 'psk2' #Aqui es donde no tengo muy claro como funciona
        option device 'radio0'
        option mode 'sta'
        option key 'PASSWORDWIFI' #Password de la red wifi

config wifi-iface
        option ssid 'Repetidor' #Nombre de la red wifi a la que nos conectaremos
        option encryption 'psk2'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option key 'PASSWORD' #Clave que deseemos

vi /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde5:146d:6a7::/48'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.1' # Esta IP no debe ser del rango de la red que deseamos repetir, EJ: red principal: #192.168.1.0 y en esta 192.168.2.0, osea la ip 192.168.2.1
        option netmask '255.255.255.0'
        option ip6assign '64'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

config 'interface' 'stabridge'
        option 'proto' 'relay'
        option 'network' 'lan wwan'
        option ipadr '192.168.0.25' # Esta IP no debe ser del rango de la red que deseamos repetir

config interface 'wwan'
        option proto 'dhcp'

vi /etc/config/dhcp

config dnsmasq
        option domainneeded     1
        option boguspriv        1
        option filterwin2k      0  # enable for dial on demand
        option localise_queries 1
        option rebind_protection 1  # disable if upstream must serve RFC1918 add
        option rebind_localhost 1  # enable for RBL checking and similar service
        #list rebind_domain example.lan  # whitelist RFC1918 responses for domai
        option local    '/lan/'
        option domain   'lan'
        option expandhosts      1
        option nonegcache       0
        option authoritative    1
        option readethers       1
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
        #list server            '/mycompany.local/1.2.3.4'
        #option nonwildcard     1
        #list interface         br-lan
        #list notinterface      lo
        #list bogusnxdomain     '64.94.110.11'

config dhcp lan
        option interface        lan
        option start    100
        option limit    150
        option leasetime        12h
        option ignore 1

config dhcp wan
        option interface        wan
        option ignore   1

ahora reiniciamos la interfaz wifi

wifi down;wifi.

Si no estamos seguros:

reboot

Y ya deberia funcionar.


Es un mini manual rapido, me voy corriendo, ya lo depuraremos!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #19 en: 18-04-2013, 16:39 (Jueves) »
No es lo mismo que esto ?? https://foro.seguridadwireless.net/openwrt/huawei-hg556a-modo-repetidor-%28-openwrt%29/msg244074/#msg244074 ???

Cuando escribí que relayd no funcionaba con todos los routers, no me refería al router con OpenWrt, si no al 'principal'  ;D
« Última modificación: 18-04-2013, 16:40 (Jueves) por jar229 »
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

//FINAL Y MÁS DOS RESPUESTAS