Autor Tema: OpenWRT + LUCI en WR740N V4.2 (unos 20€)  (Leído 30886 veces)

0 Usuarios y 1 Visitante están viendo este tema.

eq7mavala

  • Visitante
Re: Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #20 en: 18-04-2013, 17:49 (Jueves) »
Basicamente si...

Siento plagiarte, en este router funcionar perfect! 

;D

Sent from my GT-I8190 using Foro seguridadwireless mobile app



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #21 en: 18-04-2013, 19:06 (Jueves) »
Basicamente si...

Siento plagiarte, en este router funcionar perfect! 

;D

Sent from my GT-I8190 using Foro seguridadwireless mobile app

Eso me parecía  ;)

Con respecto al plagio, ya te mandaré a mis abogados  ;D
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

8carlos88

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #22 en: 20-04-2013, 18:34 (Sábado) »
Hola he metido openwrt en tp-link 740n v4.2, el firmware que me he bajado de esta pagina y antes entre en lan del router y puse esta ip 192.168.1.253 luego lo he reinicie y me entre en el router, meti el firmware, ya no me deja entrar por telnet 192.168.1.253, pero si me deja entrar por telnet pero a la direccion 192.168.1.1.

pero mi router tiene puerta de enlace 192.168.1.1.....

para actualizarlo a luci y ponerlo en modo repetidor pone q hay q conectarlo a router con internet....mis dudas?

con cable rj45 de la wan del tp link  a una lan del router con internet y se ¿supone q otro rj45 del tp link al pc?

cuando hago alguna combinacion de cable y entro por telnet 192.168.1.1
 y cuando le doy a opkg update  me sale el siguiente error:
Collected errors:
* opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1.

cuando meti el firmware al tp link no tenia puesto el cable de mi otro router con internet al puerto wan solo tenia enchufado el cable al pc.

q puedo hacer?
primero como conectar los cables bien?
puedo cambiar por telnet la puerta de enlace para no hacerla coincidir router q tiene internet?
volver a meter el firmware original, como? tengo cd....

alguien q me eche un cable nunca mejor dicho.

un saludo y gracias


8carlos88

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #23 en: 22-04-2013, 00:58 (Lunes) »
hola he cambiado la puerta de enlace del router q tengo internet la he puesto 192.168.2.1 o 192.168.1.2 y con identico resultado, ome sale:

-Collected errors:
* opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1.

- o no se puede conectar por remoto al host.....y despues esto.
* opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1.

todo dependiendo de como conecto el cable de ethernet.

por lo q leido el del pc va al tplink y mi duda es como conectar entre si los dos router a la wan de los 2 routers o q wan de q router?

un saludo.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #24 en: 22-04-2013, 08:06 (Lunes) »
Cual es la ip del router principal ?

Postea aquí el contenido del fichero /etc/config/network del Tp-Link.
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

8carlos88

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #25 en: 22-04-2013, 10:51 (Lunes) »
el rango q tiene es de 192.168.2.100 al 254 y la del pc es 192.168.2.100

root@OpenWrt:/# vi /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd75:57cd:7a42::/48'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

un saludo, pero no si toy conectado bien el cable ethernet.

eq7mavala

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #26 en: 22-04-2013, 11:21 (Lunes) »
Segun lo que has puesto el router esta en el rango 192.168.1.X, por lo que si quieres que este en el 192.168.2.X debes cambiar la linea:

option ipaddr '192.168.1.1'
por
option ipaddr '192.168.2.X' # X es la ip que quieras darle al router, debe ser un numero entre el 1 y el 254 y que no este siendo usado por otro equipo y a poder ser que no este en el rango de un servidor DHCP si lo hubiera.

8carlos88

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #27 en: 22-04-2013, 14:13 (Lunes) »
hola antes tenia el  rango q tiene es de 192.168.1.100 al 254 y la del pc es 192.168.1.100 y lo cambie en el router de internet pero cuando lo conectaba no me daba internet, era pq coincidia el 192.168.1.1 de los dos routes?

cambio la linea option ipaddr '192.168.2.X' # X, se cambia con el comando:
vi /etc/config/network
 y me voy a la linea, la cambio y como guardo los cambios, lo voy hacer con putty?

el tplink va conectado al pc por ethernet (line1)

pero el router con internet(es livebox) y el tplink van conectados, el cable ethernet de la wan de livebox a una line 2 del tplink, por ejemplo?

o el router con internet(es livebox) y el tplink van conectados, el cable ethernet de la lan 2 de livebox a la wan del tplink, por ejemplo?

un saludo y gracias
« Última modificación: 22-04-2013, 14:16 (Lunes) por 8carlos88 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #28 en: 22-04-2013, 14:27 (Lunes) »
El fichero debería quedarte así (sólo te pongo la parte que tienes que modificar):

Código: [Seleccionar]
config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.50'
        option netmask '255.255.255.0'
        option gateway '192.168.2.1'
        option dns '8.8.8.8'
        option ip6assign '64'

Eso contando con que el router principal tenga la IP 192.168.2.1
Conecta los routers con cable de LAN a LAN.
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

8carlos88

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #29 en: 23-04-2013, 15:57 (Martes) »
hola
configurado como dices @jar229 y conectado router con internet a lan y al tplink por wan y asi todo correcto.

intento instalar este paquete y me dice q no existe o algo asi.

opkg install luci luci-i18n-spanish relayd

un saludo y gracias.

eq7mavala

  • Visitante
Re: Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #30 en: 23-04-2013, 17:00 (Martes) »
opkg update

Luego el resto

Sent from my GT-I8190 using Foro seguridadwireless mobile app

8carlos88

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #31 en: 25-04-2013, 18:51 (Jueves) »
hola hice eso pero cuando le di a esto me dio el fallo...pero me va bien con lo q tengo.

un saludo

8carlos88

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #32 en: 20-11-2013, 17:29 (Miércoles) »
hola

me ha llegado a mis manos este modelo de router pero la version 4.22, le meto el openwrt q pone en el primer post, y le intento meter el luci y me da este fallo:

en ingles como no se copiarlo lo pongo lo q entiendo

coleccion de errores:

un monton sobre el firewall y pone: no space left on device


y al final dice q no ha instalado el luci.

un saludo y gracias

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #33 en: 20-11-2013, 19:19 (Miércoles) »
Código: [Seleccionar]
no space left on device
No queda espacio :-X

No se porqué os empeñáis en instalar la versión trunk (desarrollo y sin LuCi) cuando tiene soporte en Attitude Adjustemt (más estable y con LuCi)   ^-^

Aquí tienes AA para la versión 4.22:

http://downloads.openwrt.org/attitude_adjustment/12.09-beta/ar71xx/generic/openwrt-ar71xx-generic-tl-wr740n-v4-squashfs-sysupgrade.bin
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

8carlos88

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #34 en: 21-11-2013, 13:58 (Jueves) »
hola

gracias por tu respuesta lo voy meter esta firm, pero yo meti el q me salio en el primer post, la pregunta es como le meto este nuevo firm, ya tiene el del primer post pq de linux ni idea...


un saludo
« Última modificación: 21-11-2013, 14:01 (Jueves) por 8carlos88 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #35 en: 21-11-2013, 14:29 (Jueves) »
hola

gracias por tu respuesta lo voy meter esta firm, pero yo meti el q me salio en el primer post, la pregunta es como le meto este nuevo firm, ya tiene el del primer post pq de linux ni idea...


un saludo

Lo primero, renombra el nuevo firmware como tplink.bin, después deberías copiarlo al directorio /tmp  del router (usando WinSCP por ejemplo). Finalmente, desde una conexión ssh ejecutar el siguiente comando:

Código: [Seleccionar]
mtd -r write /tmp/tplink.bin firmware
Si todo ha ido bien, después de unos minutos se reiniciará con Attitude Adjustment instalado.
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

8carlos88

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #36 en: 22-11-2013, 12:36 (Viernes) »
gracias todo correcto.

un saludo

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4597
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #37 en: 22-11-2013, 15:05 (Viernes) »
gracias todo correcto.

un saludo

 ;)
Valoraciones positivas en compra/venta:
158 en Htcmania
211 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

pachu315

  • Visitante
Re: OpenWRT + LUCI en WR740N V4.2 (unos 20€)
« Respuesta #38 en: 18-08-2014, 20:39 (Lunes) »
Hola

Estoy instalando Openwrt en dicho router y al conectarme con putty y ejecutar el comando "opkg update" me da error de descarga de los archivos.Ya he comprobado que el router tenga conexión a internet y ahora he encontrado en este foro que parece ser por lo que entiendo que han cambiado la ubicación de los archivos.

https://forum.openwrt.org/viewtopic.php?id=52219

A ver si alguien puede echarme una mano para saber como se instalan ahora.

Saludos y gracias

vk496

  • Visitante
Re:
« Respuesta #39 en: 19-08-2014, 01:37 (Martes) »
Tengo este router, y la verdad, ni me he planteado en ponerle OpenWRT.

Creo que DD-wrt va mas acorde con él...

Salu2

//FINAL Y MÁS DOS RESPUESTAS