Autor Tema: HG556a + USB WiFi (TP-Link TL-WN722N)  (Leído 45712 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2040
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #60 en: 29-05-2014, 21:13 (Jueves) »
Por favor, ¿alguna idea?

Lo dicho:
¿Tienes posibilidad de realizar la prueba con un picho que no sea el 722N? ¿Que tenga otro chipset?
Es para descartar que sea problema del driver.


No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

bmwjavier

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #61 en: 29-05-2014, 21:36 (Jueves) »
Ya hice las pruebas con una ALFA, chipset RTL8187L. Identico resultado. Me temo que el problema no es ese.

 ¿Alguna idea más?

  Gracias,

bmwjavier

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #62 en: 30-05-2014, 17:25 (Viernes) »
Si no hubiera solución, ¿habría algún router con dos radios aunque no fuera Openwrt para que pudiera repetir la señal sin perder mucha velocidad? Es que de verdad que esto esta resultando un problemón para mi. Necesito solucionarlo rápidamente.

 Gracias de antemano y saludos.

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #63 en: 30-05-2014, 17:51 (Viernes) »
Otra opción es que uses dos routers unidos por cable de red, uno en modo cliente y otro en modo AP. Eso es lo que yo uso y consigo el casi el máximo de ancho de banda, unos 20 megabits/s con el antiguo 802.11b/g estándar en routers antiguos (bcm6348), aunque en modo WDS.
« Última modificación: 30-05-2014, 17:52 (Viernes) por danitool »

bmwjavier

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #64 en: 02-06-2014, 19:23 (Lunes) »
Otra opción es que uses dos routers unidos por cable de red, uno en modo cliente y otro en modo AP. Eso es lo que yo uso y consigo el casi el máximo de ancho de banda, unos 20 megabits/s con el antiguo 802.11b/g estándar en routers antiguos (bcm6348), aunque en modo WDS.


Eso ya lo hacía antes con un Zyxel de telefónica conectado por cable al HG556a. Pero la verdad es que prefiero tener un sólo aparato. La solución era clara. Utilizar un router compatible openwrt con puerto USB para conectar un pincho wifi. Pero por desgracia como sabeis esto no me ha funcionado con el HG556a y mi TL-WN722N.

Opciones:

  1.-Comprar un router que tenga dos radios, así captaría la señal con una radio y la repetiría con la otra. De esta forma no perdería velocidad.

  2.- Un router compatible con openwrt con puerto usb para conectarle el TL-WN722N y captar la señal con él y repetirla con la radio interna del Router, ¿Sabéis de alguno que funcione bien de esta forma?

 Saludos,




devde

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #65 en: 02-06-2014, 19:40 (Lunes) »
yo si te sirve de algo tengo conectado un tp link tl-wn422gc a HG556a VER.C Con esta compilación r38342
y me funciona casi perfecto y no tengo problemas de velocidad espero te sirva de algo y suerte

wolf_rider

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #66 en: 02-06-2014, 22:47 (Lunes) »
y yo tengo Hg556 ver.c con chipset ralink + alfa verde Ra3070 wifi 10Mb no me pierde casi nada. Alfa r36 + la misma alfa Ra3070 wifi 10  Mb no pierde casi nada, pero ahora he visto unos wd mynet n600 y n750 que son dual band 2.4 y 5 Ghz con total openwrt tienen dos radios pero una a 2.4 y otra a 5 ghz no creo que te sirven. Pero por lo visto también le funciona las Ra3070 .

bmwjavier

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #67 en: 02-06-2014, 23:20 (Lunes) »
Vaya, pues mi router tiene un HW versión: HG56BZRB VER.A

Se ve que me ha tocado el chungo....

 No se si arriesgarme a comprar otro HG556A o probar con otra marca...

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #68 en: 02-06-2014, 23:46 (Lunes) »
No encuentro demasiado sentido que la versión HG56BZRB VER.A tenga una diferencia tan abultada de rendimiento, cuando básicamente el hardware es el mismo BCM6358, excepto por el wifi interno que es ralink, pero este wifi funciona bien por separado al menos.

Prueba enchufando el wifi USB en el puerto puerto superior, Y configurando la wifi interna como cliente y el USB en modo AP.

La cosa esta de los wifis cuando se hacen ciertas combinaciones no conjugan muy bien.

Pteridium

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #69 en: 04-06-2014, 10:11 (Miércoles) »
He estado haciendo un par de pruebas con un ARV4518, la wifi interna y un pincho usb rt73 y las interrupciones de software (TASKLET en concreto) y de hardware (la plataforma Lantiq tiene tendencia a generar muchas interrupciones cuando hay un dispositivo usb conectado, pero no tan a lo bestia), lo que provoca que la cpu se sobrecargue con algunos procesos del kernel (varios kworker y un ksoftirqd).
Si puedes postear una captura del comando "top" sería de gran ayuda, ya que se podría ver un poco mejor que es lo que pasa. También pon la salida del comando dmesg.
Por mi parte voy a probar una cosilla a ver si mejora, pero no puedo prometer nada.

Por cierto, dijiste que tu HG556 tiene chip wifi atheros, que tiene la posibilidad de configurar un cliente y un AP en el mismo chip (probado en el ARV4518 y funcionó bien durante la prueba). Intenta esa opción.

Pteridium

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #70 en: 06-06-2014, 23:22 (Viernes) »
Creo que deberíais echarle un ojo a este post de Tki2000 por si soluciona algo el problema.

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #71 en: 07-06-2014, 17:16 (Sábado) »
Bien sigo con los firmwares de prueba por si todavía hay interés. Esta nueva compilación tiene un par de modificaciones entre varias que pueden ayudar.
- Compilado con el SLUB allocator en lugar de SLAB. Me da la impresión de que SLUB le sienta mejor al USB.
- Los módulos del usb EHCI y OHCI van integrados en el propio kernel.

https://docs.google.com/uc?export=download&id=0B-EMoBe-_OdBc3QxdlpVTkx6ekU

edudi

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #72 en: 15-06-2014, 03:18 (Domingo) »
Bien sigo con los firmwares de prueba por si todavía hay interés. Esta nueva compilación tiene un par de modificaciones entre varias que pueden ayudar.
- Compilado con el SLUB allocator en lugar de SLAB. Me da la impresión de que SLUB le sienta mejor al USB.
- Los módulos del usb EHCI y OHCI van integrados en el propio kernel.

https://docs.google.com/uc?export=download&id=0B-EMoBe-_OdBc3QxdlpVTkx6ekU

Buenas, por fin he podido regresar a este tema (he estado con el PC a menos 2 "no hay nada como quemar dos fuentes").

He probado este último firmware de prueba que has publicado y los resultados han sido así:

- Por más que intento despues de flashear (ya van 3 veces) no consigo que el router me de IP (DHCP), le puse IP fija al PC y la 1ª vez si me reconoció el router (Vodafonexxx) pero no pude acceder a 192.168.1.1

Por si acaso volví a flashear con el RESTART típico, y le costó, pero al final pude volver a flashearlo con diferentes firmwares como el del USB fix de semanas atrás (y sigo con 6,5 Mbits de conexión teniendo el 100% de cobertura en ambas radios). Así que volví a flashear esta última que has publicado y sigue igual, no puedo acceder al router de ninguna forma y esta vez ya no me identifica la red de ninguna manera, el router se queda como esperando IP, pero no se la proporciona. Le puse la IP fija y red no identificada, así que no pude hacer nada.


Creo que deberíais echarle un ojo a este post de Tki2000 por si soluciona algo el problema.

Estuve mirando ese hilo, y pienso pues: ¿Hay una web de atheros que facilite los drivers y nos lleve a uno completamente diferente al oficial de OPENWRT y por tanto al éxito?


Vuelvo a estar 100% operativo para las pruebas, repito 100%. Estas pruebas han sido con un Ver. C, también tengo Ver. A por si quieren lanzarme firmwares de prueba para ambas versiones.


Un saludo y disculpen la ausencia (ya que fuí el que inició el post)
« Última modificación: 15-06-2014, 03:23 (Domingo) por edudi »

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #73 en: 15-06-2014, 14:52 (Domingo) »
la última compilación que hice va perfectamente bien, lo acabo de verificar

http://pastebin.com/3E2wSRDC

El dhcp también funciona bien, tanto cliente como servidor.

edudi

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #74 en: 15-06-2014, 19:11 (Domingo) »
Señores, tengo la grata noticia  -->  CONSEGUIDOOOOOOOOO !!!!!!!

Gracias enormemente a danitool, y a todos obviamente. Estas pruebas han sido con el TP-Link en el USB superior y con el firmware que publica danitool el 07-06-2014, 17:16 (Sábado) (he usado otro Ver.C que tenía por ahí, al igual era de 64K y le puse la de 128K...ya miraré en que fallé anoche, porque esta vez funcionó a la 1ª)

Bien sigo con los firmwares de prueba por si todavía hay interés. Esta nueva compilación tiene un par de modificaciones entre varias que pueden ayudar.
- Compilado con el SLUB allocator en lugar de SLAB. Me da la impresión de que SLUB le sienta mejor al USB.
- Los módulos del usb EHCI y OHCI van integrados en el propio kernel.

https://docs.google.com/uc?export=download&id=0B-EMoBe-_OdBc3QxdlpVTkx6ekU


He usado ese firmware de arriba y comprobado las 2 configuraciones con iguales correctos resultados:


- HG556a Master + TP Link 722N Cliente (OK)  (Esta es por la que hemos estado luchando)




- HG556a Cliente + TP Link 722N Master (OK)
(Y esta obviamente, era necesaria también probarla)



Como vemos, la velocidad de conexión es igual en ambas configuraciones (lo típico, cada vez que se hace un test nunca marca exactamente igual siempre).


- Conexión correcta entre el Router principal ADSL vía WiFi y el TP-Link como Cliente. HG556a como punto de acceso funcionando vía WiFi (OK)



Así que me alegro un montón por vuestra ayuda, sin ustedes no lo hubiera conseguido.


Un saludo y si hay que hacer mejoras, pues aquí estamos, sigo abierto a más pruebas si se requieren.


________________________________________________________________________________________________
CORRIJO ESTE PÁRRAFO y sus 2 imágenes (estas medidas ocurren si se usan 2 repetidores WiFi enlazados entre si + el router principal:  Router Principal <-- 1º Repetidor WiFi --> <-- 2º Repetidor WiFi --> PC desde donde hago las pruebas)
Esto es algo que no termino de entender, que ponga 6,5 Mbps de ancho de banda de la conexión WiFi. Pero ahora me da que no es correcto, ya que va bien llegando a 4,11 Mbps y no creo que teniendo 6,5 Mbps fuera tan bien como para proporcionar los 4,11 Mbps que marca. Si alguien tiene más de 6 Mbps de Internet, xq yo no los tengo en mi ADSL (está clarísimo que no tiene nada que ver que tenga 6,5 Mbps de ancho de banda en la conexión WiFi con respecto a mis 6 Mbps de ADSL. Lo digo por si alguien se despista y le lleva a malinterpretar los datos, o si no que me corrijan)




__________________________________________________________________________________________________


PD: Disculpen tantas modificaciones a lo largo de esta tarde, pero quise darle una forma bien documentada y que fuera lo más clara posible.
« Última modificación: 15-06-2014, 20:12 (Domingo) por edudi »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #75 en: 15-06-2014, 22:12 (Domingo) »
No acabo de entender el final ... has conseguido la velociad máxima de línea o no ?

En cuanto a enlazar 2 repetidores ... creo que ya es un poco exagerado  ;D
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

edudi

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #76 en: 15-06-2014, 22:31 (Domingo) »
No acabo de entender el final ... has conseguido la velociad máxima de línea o no ?

En cuanto a enlazar 2 repetidores ... creo que ya es un poco exagerado  ;D

Si, velocidad de la línea conseguida. Usando un único repetidor Ver. C y el TP-Link.


El final es usando 2 repetidores Ver. C, q de igual modo también consigo la velocidad de la línea prácticamente. Creo q si tuviera 10 Mb según esa gráfica solo me llegarían 6 a 6,5 Mbps como máximo. Pero no puedo saberlo con mi línea.


Ahora me falta probar el firmware 40xxx q tú probaste con y sin el fix USB y te iban bien los test. Yo siempre he hecho mis pruebas usando 2 repetidores Ver. C, así q puedo decir q esta última que posteó danitool funciona incluso linkando 2 repetidores Ver. C (dos pájaros de un tiro).

Así da gusto acabar la semana.


Saludos y gracias como siempre

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #77 en: 15-06-2014, 23:03 (Domingo) »
El hecho de que te marque 6.5 Mbps puede no ser relevante, puede fluctuar bastante y además es una velocidad de subida (la de bajada es otra).

De todas formas no son grandes velocidades las que requieres, por lo que todavía me quedan dudas de donde está el límite máximo o/y si hay algún obstáculo que impida dar más.

La forma de ver hasta que tope llega sería poner un servidor ftp (en un PC)  en un extremo de la red local y conectarse en el otro extremo con otro ordenador y ver a que velocidad descarga un archivo gordo.

Me alegra que te haya funcionado al fin.

edudi

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #78 en: 22-06-2014, 13:25 (Domingo) »
El hecho de que te marque 6.5 Mbps puede no ser relevante, puede fluctuar bastante y además es una velocidad de subida (la de bajada es otra).

De todas formas no son grandes velocidades las que requieres, por lo que todavía me quedan dudas de donde está el límite máximo o/y si hay algún obstáculo que impida dar más.

La forma de ver hasta que tope llega sería poner un servidor ftp (en un PC)  en un extremo de la red local y conectarse en el otro extremo con otro ordenador y ver a que velocidad descarga un archivo gordo.

Me alegra que te haya funcionado al fin.


Buenas, ya estoy montando el chiringuito e hice la primera prueba, pero veo que al estar en redes diferentes no se ven. Estuve mirando que tengo que ponerle el "RELAYD" o poner una ruta fija. ¿Me pueden dar el link para configurar una ruta fija y como se hace?. Ya estuve anoche de madrugada y tardé en encontrar que para lo que quería había que usar el RELAYD, siempre lo había oído mencionar pero nunca me detuve en para qué servía.

Desde el router con OPENWRT:

   Dirección IPv4. . . . . . . . . . . . . . : 192.168.3.248
   Máscara de subred . . . . . . . . . . . . : 255.255.255.0
   Puerta de enlace predeterminada . . . . . : 192.168.3.1


ping 192.168.1.91   (PC con el FTP Server)

Haciendo ping a 192.168.1.91 con 32 bytes de datos:
Respuesta desde 192.168.1.43: Host de destino inaccesible.
Respuesta desde 192.168.1.43: Host de destino inaccesible.
Respuesta desde 192.168.1.43: Host de destino inaccesible.
Respuesta desde 192.168.1.43: Host de destino inaccesible.


¿Tengo que hacer algún PORT FORDWARING en los routers?


Saludos
« Última modificación: 22-06-2014, 13:26 (Domingo) por edudi »

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #79 en: 22-06-2014, 16:12 (Domingo) »
Buenas, ya estoy montando el chiringuito e hice la primera prueba, pero veo que al estar en redes diferentes no se ven. Estuve mirando que tengo que ponerle el "RELAYD" o poner una ruta fija. ¿Me pueden dar el link para configurar una ruta fija y como se hace?. Ya estuve anoche de madrugada y tardé en encontrar que para lo que quería había que usar el RELAYD, siempre lo había oído mencionar pero nunca me detuve en para qué servía.

Desde el router con OPENWRT:

   Dirección IPv4. . . . . . . . . . . . . . : 192.168.3.248
   Máscara de subred . . . . . . . . . . . . : 255.255.255.0
   Puerta de enlace predeterminada . . . . . : 192.168.3.1


ping 192.168.1.91   (PC con el FTP Server)

Haciendo ping a 192.168.1.91 con 32 bytes de datos:
Respuesta desde 192.168.1.43: Host de destino inaccesible.
Respuesta desde 192.168.1.43: Host de destino inaccesible.
Respuesta desde 192.168.1.43: Host de destino inaccesible.
Respuesta desde 192.168.1.43: Host de destino inaccesible.


¿Tengo que hacer algún PORT FORDWARING en los routers?


Saludos

Aparentemente, o bien tienes el ping bloqueado en la máquina donde tienes el server ftp, o algo mal configurado.

La transparencia no es necesaria para descargar desde el lado LAN, tampoco ningún port forwarding.  Sería necesario si descargases desde el lado WAN del router con Openwrt, cosa que intuyo no es el caso.

Relayd no me parece buena idea, podría sesgar el resultado del test.

//FINAL Y MÁS DOS RESPUESTAS