Autor Tema: HG556a + USB WiFi (TP-Link TL-WN722N)  (Leído 45714 veces)

0 Usuarios y 1 Visitante están viendo este tema.

edudi

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #20 en: 02-05-2014, 21:48 (Viernes) »
No terminé de entenderle del todo.... entonces es eso, que ese firm backport es el que debo flashear en mi HG556a? y a hacer las pruebas se ha dicho...¿?

Digamos que estoy espeso....



danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #21 en: 02-05-2014, 21:49 (Viernes) »
Pues sí, el fix está includo tal como indico aunque ten en cuenta que es Attitude Adjustment

https://docs.google.com/uc?export=download&id=0B-EMoBe-_OdBdU5VTHc5Q2o2aEU

y no estoy seguro de que tenga una gama tan amplia de USBs reconocidos como en las últimas revisiones, pero probar es fácil, solo es flashear el firmware y luego instalar los drivers que necesites con opkg

configuras el router para que tenga conexión a internet y ejecutas
Código: [Seleccionar]
opkg update
opkg install mipaquete

edudi

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #22 en: 02-05-2014, 22:19 (Viernes) »
configuras el router para que tenga conexión a internet y ejecutas
Código: [Seleccionar]
opkg update
opkg install mipaquete


**********************************
** OpenWrt firmware 12.09 final **     
** released 25th April 2013     **
** HG556a VER.A/VER.C           **
** backport 2nd May 2014        **
**********************************

For versions with flash chips with 64k block size:
openwrt-HG556a_64k-squashfs-cfe.bin

For versions with flash chips with 128k block size:
openwrt-HG556a_128k-squashfs-cfe.bin


Vale a ver,

1º Cual flasheo? la de 64k ó la de 128K de flash tengo un HG556a Ver C

2º Tengo que poner estos comandos por lo que veo no?

svn checkout
svn://svn.openwrt.org/openwrt/tags/attitude_adjustment_12.09/
cd attitude_adjustment_12.09/
patch -p0 -i AA-magic.patch
patch -p0 -i hg556a-12.09_backport.patch
make menuconfig
make kernel_menuconfig
make V=s


Hasta aquí sería ese el proceso?

3º instalar el driver el USB si no está no?

opkg update
opkg install mipaquete     (mipaquete, jajaajaj......te refieres a por ejemplo al driver USB de la atheros no? Una vez me dió problemas de dependencias al querer instalarlo....)

Si es eso es todo, avísame y flasheo la de 64 ó 128 y comienzo a ejecutar los comandos....os iría informado si todo sale bien,,,y obviamente si algo sale mal.

Si hay que poner algún comando para saber de cuanto es la flash,,,, todo oídos.

Saludos
« Última modificación: 02-05-2014, 22:21 (Viernes) por edudi »

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #23 en: 02-05-2014, 22:50 (Viernes) »
si tienes ahora mismo openwrt instalado ejecutas el comando
Código: [Seleccionar]
cat /proc/mtd
si en la columna erasesize aparece 20000 entonces flasheas
openwrt-HG556a_128k-squashfs-cfe.bin

si en la columna erasesize aparece 10000 entonces flasheas
openwrt-HG556a_64k-squashfs-cfe.bin

luego configuras la conexión para que tenga internet el router y usas opkg tal como indiqué.

mipaquete es tu paquete, quiero decir tus drivers o lo que sea que necesite tu adaptador usb, las dependencias las debiera coger automáticamente sin problemas

No necesitas hacer nada más, lo otro que aparece en el readme es para hacer compilaciones personalizadas.

edudi

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #24 en: 02-05-2014, 23:58 (Viernes) »
Mal asunto....lo detecta con el lsusb, pero no se añade como una nueva interfaz. He instalado el driver para el TP-Link TL-WN722N "AR9271" (kmod-ath9k-htc) y nada. Tampoco se llegó a encender en ningún momento ningún led del USB WiFi.

He probado en los 3 puertos USB y el mismo resultado, incluso como tengo dos TP-Link TL-WN722N he probado poner también los dos por si acaso, estos son los pasos que he hecho (he reiniciado el router varias veces por si acaso):

A) Instalados:

- usbutils
- kmod-ath9k-htc   (no dió problemas de dependencias)
- wirelesstools
- screen


B) Comandos realizados en esta compilación por consola (funcionan con otros firm en el HG556a y reconocían el TP-Link TL-WN722N)

En el punto 4º tengo pinchados "dos" TP-Link TL-WN722N


1º TP-Link por el puerto trasero
-------------------------------------------



login as: root
root@192.168.9.1's password:


BusyBox v1.19.4 (2014-05-01 22:53:56 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 ATTITUDE ADJUSTMENT (Attitude Adjustment, r36422)
 -----------------------------------------------------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:~# ls
root@OpenWrt:~# cd ..
root@OpenWrt:/# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:2502 Standard Microsystems Corp.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
root@OpenWrt:/# rm /etc/config/wireless
root@OpenWrt:/# wifi detect > /etc/config/wireless
root@OpenWrt:/# cat /etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  f4:c7:14:b9:68:3f
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   TX-STBC
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

root@OpenWrt:/#



2º TP-Link por el puerto lateral
--------------------------------



login as: root
root@192.168.9.1's password:


BusyBox v1.19.4 (2014-05-01 22:53:56 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 ATTITUDE ADJUSTMENT (Attitude Adjustment, r36422)
 -----------------------------------------------------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:2502 Standard Microsystems Corp.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
root@OpenWrt:~# rm /etc/config/wireless
root@OpenWrt:~# wifi detect > /etc/config/wireless
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  f4:c7:14:b9:68:3f
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   TX-STBC
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

root@OpenWrt:~#




3º TP-Link por el Puerto Superior
--------------------------------



login as: root
root@192.168.9.1's password:


BusyBox v1.19.4 (2014-05-01 22:53:56 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 ATTITUDE ADJUSTMENT (Attitude Adjustment, r36422)
 -----------------------------------------------------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:2502 Standard Microsystems Corp.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
root@OpenWrt:~# rm /etc/config/wireless
root@OpenWrt:~# wifi detect > /etc/config/wireless
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  f4:c7:14:b9:68:3f
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   TX-STBC
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

root@OpenWrt:~#
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  f4:c7:14:b9:68:3f
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   TX-STBC
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none



4º (2x) TP-Link´s por el Puerto Superior y lateral
--------------------------------------------------


root@OpenWrt:~# lsusb
Bus 001 Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:2502 Standard Microsystems Corp.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
root@OpenWrt:~# rm /etc/config/wireless
root@OpenWrt:~# wifi detect > /etc/config/wireless
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  f4:c7:14:b9:68:3f
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   TX-STBC
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

root@OpenWrt:~#




5º TP-Link por el Puerto Superior
----------------------------------


login as: root
root@192.168.9.1's password:


BusyBox v1.19.4 (2014-05-01 22:53:56 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 ATTITUDE ADJUSTMENT (Attitude Adjustment, r36422)
 -----------------------------------------------------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:2502 Standard Microsystems Corp.
Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
root@OpenWrt:~# rm /etc/config/wireless
root@OpenWrt:~# wifi detect > /etc/config/wireless
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  f4:c7:14:b9:68:3f
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   TX-STBC
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

root@OpenWrt:~#



Parece que no ha habido suerte.....he cometido algún error?


Avisen para probar cualquier comando para ver su salida, instalación de lo que sea, a ver si esto arranca.

Saludos
« Última modificación: 03-05-2014, 00:02 (Sábado) por edudi »

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #25 en: 03-05-2014, 00:30 (Sábado) »
Supongo que tu adaptador no está soportado en esta versión de Openwrt, seguramente por la ID del dispositivo que no está en los drivers.

Así que poco se puede hacer.

edudi

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #26 en: 03-05-2014, 00:39 (Sábado) »
Y...si no es mucho preguntar....es posible añadir la ID del dispositivo en los drivers para que lo detecte y funcione?


Saludos y a descansar ;)

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #27 en: 03-05-2014, 14:36 (Sábado) »
O más fácil, una compilación hecha en trunk, con los drivers USB de atheros incluidos, y también con el fix mencionado

https://docs.google.com/uc?export=download&id=0B-EMoBe-_OdBcnJKbVQ2N01GNWs

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #28 en: 07-05-2014, 12:02 (Miércoles) »
O más fácil, una compilación hecha en trunk, con los drivers USB de atheros incluidos, y también con el fix mencionado

https://docs.google.com/uc?export=download&id=0B-EMoBe-_OdBcnJKbVQ2N01GNWs

Voy a probarla  >:(

La instalo, y en un rato comento  ;)

EDITO: ahora sí que sí  >:(

danitool: si necesitas algún log, avisa  ;)
« Última modificación: 07-05-2014, 12:33 (Miércoles) por jar229 »
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #29 en: 07-05-2014, 13:05 (Miércoles) »
O más fácil, una compilación hecha en trunk, con los drivers USB de atheros incluidos, y también con el fix mencionado

https://docs.google.com/uc?export=download&id=0B-EMoBe-_OdBcnJKbVQ2N01GNWs

Voy a probarla  >:(

La instalo, y en un rato comento  ;)

EDITO: ahora sí que sí  >:(

danitool: si necesitas algún log, avisa  ;)

lo siento pero no me enteré de nada

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #30 en: 07-05-2014, 14:11 (Miércoles) »
O más fácil, una compilación hecha en trunk, con los drivers USB de atheros incluidos, y también con el fix mencionado

https://docs.google.com/uc?export=download&id=0B-EMoBe-_OdBcnJKbVQ2N01GNWs

Voy a probarla  >:(

La instalo, y en un rato comento  ;)

EDITO: ahora sí que sí  >:(

danitool: si necesitas algún log, avisa  ;)

lo siento pero no me enteré de nada


No veo nada raro con dmesg ni con logread  :'(

Lo que si puedo decir, es que con el pincho wifi usb con chipset atheros en modo cliente, ni siquiera consigo pasar el test de velocidad de testdevelocidad.es  :-\

Las prueba, las estoy haciendo con relayd deshabilitado  ;)

Con esta compilación todo va perfectamente  ;D

Espero que ahora sí, este todo más claro  ;)
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #31 en: 07-05-2014, 14:22 (Miércoles) »
Vale, lo que no me queda claro es si es por el fix que añadí o no. así que compilaré de nuevo sin el fix, a ver si el problema reaparece.

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #32 en: 07-05-2014, 15:25 (Miércoles) »
El mismo firmware pero sin el fix
https://docs.google.com/uc?export=download&id=0B-EMoBe-_OdBdll3b0RxNEgxeVE

Una vez instalado, quítale la corriente al router al menos unos 10 segundos, luego prueba a ver si reaparece el problema

edudi

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #33 en: 07-05-2014, 22:06 (Miércoles) »
Con esta compilación todo va perfectamente  ;D

Espero que ahora sí, este todo más claro  ;)

Ahora al menos el router no se queda en pesca, pero me va mega lento:

jar229, ¿a qué velocidad te va? ...a mi por fin no se cae la red, pero la velocidad es de 39KB´s como máximo en la parte del router como cliente (wlan0) y de 12 KB´s como máximo en la parte del USB WiFi como AP (wlan1).

Intento hacer un Test de Velocidad en varias WEB´s y en todas consigo ping, pero no llega a realizar el test de bajada (x lo que no hace obviamente el de subida tampoco, aunque si puedo navegar muy muy lento)

WLAN0

Inbound:    0 kbit/s
(0 kB/s)    Average:    0 kbit/s
(0 kB/s)    Peak:    313.9 kbit/s
(39.24 kB/s)
Outbound:    0 kbit/s
(0 kB/s)    Average:    0 kbit/s
(0 kB/s)    Peak:    84.56 kbit/s
(10.57 kB/s)


WLAN1

Inbound:    4.53 kbit/s
(0.57 kB/s)    Average:    4.6 kbit/s
(0.58 kB/s)    Peak:    12.3 kbit/s
(1.54 kB/s)
Outbound:    15.41 kbit/s
(1.93 kB/s)    Average:    35.98 kbit/s
(4.5 kB/s)    Peak:    117.73 kbit/s
(14.72 kB/s)


Haciendo PING son más las veces q va, q las q no  (112 a 74 ms):

C:\Users\XXX>ping www.google.es
La solicitud de ping no pudo encontrar el host www.google.es. Compruebe el nomb
e y
vuelva a intentarlo.


C:\Users\XXX>ping www.google.es

Haciendo ping a www.google.es [173.194.34.215] con 32 bytes de datos:
Tiempo de espera agotado para esta solicitud.
Tiempo de espera agotado para esta solicitud.
Tiempo de espera agotado para esta solicitud.
Respuesta desde 173.194.34.215: bytes=32 tiempo=76ms TTL=55

Estadísticas de ping para 173.194.34.215:
    Paquetes: enviados = 4, recibidos = 1, perdidos = 3
    (75% perdidos),
Tiempos aproximados de ida y vuelta en milisegundos:
    Mínimo = 76ms, Máximo = 76ms, Media = 76ms

C:\Users\XXX>ping www.google.es

Haciendo ping a www.google.es [173.194.34.215] con 32 bytes de datos:
Respuesta desde 173.194.34.215: bytes=32 tiempo=112ms TTL=55
Respuesta desde 173.194.34.215: bytes=32 tiempo=76ms TTL=55
Respuesta desde 173.194.34.215: bytes=32 tiempo=74ms TTL=55
Respuesta desde 173.194.34.215: bytes=32 tiempo=75ms TTL=55

Estadísticas de ping para 173.194.34.215:
    Paquetes: enviados = 4, recibidos = 4, perdidos = 0
    (0% perdidos),
Tiempos aproximados de ida y vuelta en milisegundos:
    Mínimo = 74ms, Máximo = 112ms, Media = 84ms

C:\Users\XXX>ping www.google.es

Haciendo ping a www.google.es [173.194.34.215] con 32 bytes de datos:
Tiempo de espera agotado para esta solicitud.
Respuesta desde 173.194.34.215: bytes=32 tiempo=76ms TTL=55
Respuesta desde 173.194.34.215: bytes=32 tiempo=83ms TTL=55
Tiempo de espera agotado para esta solicitud.

Estadísticas de ping para 173.194.34.215:
    Paquetes: enviados = 4, recibidos = 2, perdidos = 2
    (50% perdidos),
Tiempos aproximados de ida y vuelta en milisegundos:
    Mínimo = 76ms, Máximo = 83ms, Media = 79ms



Vamos progresando, pero se ve que la red AP (WLAN1) baja de 65Mb a 6,5Mb estando sobretodo en 6,5 Mb.

Generic 802.11bgn Wireless Controller (radio0)   
[Signal: -40 dBm / Noise: -95 dBm]
97%   SSID: XXX_1
Mode: Client
Channel: 6 (2.437 GHz)
Bitrate: 130 Mbit/s
BSSID: 00:XX:XX:XX:XX:XX
Encryption: -


Generic 802.11bgn Wireless Controller (radio1)   
[Signal: -30 dBm / Noise: 0 dBm]
100%   SSID: WLAN_XXXX
Mode: Master
Channel: 11 (2.462 GHz)
Bitrate: 6.5 Mbit/s
BSSID: F4:00:XX:XX:XX:XX
Encryption: WPA2 PSK (CCMP)


Como véis el tema? A ti te ocurre lo mismo jar229?


Saludos y en fase de pruebas.

PD: Avisen cualquier cosa a probar...

danitool

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #34 en: 07-05-2014, 23:07 (Miércoles) »
¿has probado intercambiando los modos de ambas interfaces? la que está en modo cliente ponerla en modo AP, y la que está en modo AP ponerla en modo cliente

También podrías probar usando otros canales, el 3 en uno y el 9 en otro p.ej.

Y por último probar distintas encriptaciones, primero sin encriptación, luego con wpa, wpa-aes.. etc. También comprobar que tienes activado el wmm en todos los dispositivos 802.11N

Da la impresión que tienes algo mal configurado, o algún bug por incompatibilidades de hardware, porque no se explica que con esa señal tengas 6.5 Mb

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #35 en: 08-05-2014, 08:59 (Jueves) »
Probado sin el fix, obtengo el mismo resultado  ^-^

Parece que han corregido alguna cosa en las últimas versiones del trunk, que al menos en mi caso, solucionan el bajo rendimiento de mi wifi atheros usb.

Capturas:

Con el fix



Sin el fix
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

edudi

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #36 en: 11-05-2014, 02:09 (Domingo) »
Buenas,

jar229 ¿tú tienes el mismo USB WiFi (TP-Link TL-WN722N "AR9271") ?   ¿o tienes el mismo chipset "AR9271" en otro marca y modelo?

Desde que pueda sigo con las pruebas,,,,tengo el PC con una pesca mortal y estoy como loco salvando datos pa formatear y limpiar el Win7 que me tiene hartito. Con la misma le va a caer a mi PC el WifiSlax 4.8 DVD v2 con una partición verdadera de unos 40 GB mínimo.


Saludos a todos

bmwjavier

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #37 en: 20-05-2014, 19:29 (Martes) »
O más fácil, una compilación hecha en trunk, con los drivers USB de atheros incluidos, y también con el fix mencionado

https://docs.google.com/uc?export=download&id=0B-EMoBe-_OdBcnJKbVQ2N01GNWs

Hola danitool. Instale esta compilación pero resulta que tras arrancar el router voy a NETWORK y no aparece Wifi por ningún lado. No me reconoce el wifi interno. Mi router es un HG556a Ver A y creo que lleva chipset Ralink. Si instalo el r39304usb me reconoce todo sin problema pero al repetir la señal con mi Tp link WN722N apenas hay velocidad.

¿Qué puedo hacer? Por favor danitool, ¿podrías compilar con el trunk una versión con el fix incorporado y drivers para un WN722N que necesito usar como repetidor?

Muchas gracias de antemano.
« Última modificación: 21-05-2014, 16:18 (Miércoles) por bmwjavier »

bmwjavier

  • Visitante
Re: HG556a + USB WiFi (TP-Link TL-WN722N)
« Respuesta #38 en: 21-05-2014, 20:34 (Miércoles) »
Por favor echadme una mano....

danitool

  • Visitante

//FINAL Y MÁS DOS RESPUESTAS