Autor Tema: [Tutorial] Instalando OpenWrt en Comtrend  (Leído 374722 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Instalando OpenWrt en comtrend
« Respuesta #480 en: 01-05-2012, 14:01 (Martes) »



rpachecoh

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #481 en: 01-05-2012, 22:46 (Martes) »
Vale, me temo que soy un poco novato en esto. Hasta ahora, todo lo que he hecho ha sido por la interfaz gráfica, podría intentarlo con los comandos a los que tanto hacéis mención, pero... cómo lo hago? Con un  putty o cómo? Cuando lo hago por la interfaz gráfica, hay que hacer algún reinicio o algo? Saludos!

lekarin

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #482 en: 03-05-2012, 16:46 (Jueves) »
Hola a todos, llevo un tiempo siguiendo el hilo y he aprendido mucho leyéndoos sobre el comtrend y el firmware openwrt, gracias de antemano.

Tengo una duda que espero que alguien pueda aclararme, os explico:
Me dieron un Comtrend CT-5361 con la versión de firm instalada Backfire 10.03.1 bajada directamente de openwrt.org. Estoy usándolo como router neutro conectado a un cablemodem Webstar de ono, lo he configurado como leí en este hilo (VLAN's separadas para LAN y WAN...etc) y no he tenido ningún problema, todo perfecto.

La duda que me surge es que tengo contratados 12mb de conexión, y conectando por ethernet me llegan íntegros esos 12mb, pero por wifi se queda en unos 7 u 8mb. He probado con varios PC con distintos PCs y SOs (windows 7/XP, distros de linux como arch, lubuntu...) y en todos pasa lo mismo.
También comentar que me prestó mi hermano un WRT54GL con dd-wrt para ir descartando cosas y sí que me daba los 12mb de conexión a todos los PCs.

¿Alguien sabe por qué se debe esto? ¿Se podría mejorar el wifi? Igual es por el driver que lleva integrada la version "oficial" del firmware para la controladora wireless del router... no sé.

Espero que si alguien sabe la razón me pueda sacar de la duda.
Gracias!! Un saludo.
« Última modificación: 03-05-2012, 16:56 (Jueves) por lekarin »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Instalando OpenWrt en comtrend
« Respuesta #483 en: 03-05-2012, 17:07 (Jueves) »
Pues sí, podría ser por el driver opensource ... Pero claro, para averiguarlo tendrías que instalar una versión del firmware con el driver propietario de broadcom y probarlo ...  ^-^
Yo nunca lo he usado como router neutro, pero como cliente, sí me funcionaba mejor el wifi con el broadcom.
En el hilo, tienes unas cuantas compilaciones con dicho driver (por si no quieres compilarlo tú mismo)  ;)

lekarin

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #484 en: 05-05-2012, 12:21 (Sábado) »
Hola de nuevo!
Al final sí que era el driver opensource como me comentabas, instalé el firmware compilado por RollerDK con el driver de broadcom y ahora ya va perfecto el wifi.
Tambien comentar que con el driver b43 había veces que caía la interfaz wireless y no dejaba conectar por wifi (por ethernet sí), y tenía que reiniciar el router para poder conectar, con este por ahora todo perfecto.
Un saludo a todos!

EDITO:
Pues después de un día de pruebas parece que no va tan bien como creía, más o menos pasa lo mismo.
Me he fijado que en la página de configuración del router que en la interfaz wifi fluctúa mucho el bitrate, casi nunca está en 54Mb/s, normalmente esta en 24Mb/s o incluso 6Mb/s.
Alguien tiene alguna idea?
Gracias y un saludo!
« Última modificación: 05-05-2012, 15:48 (Sábado) por lekarin »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Re: Instalando OpenWrt en comtrend
« Respuesta #485 en: 06-05-2012, 11:32 (Domingo) »
Has probado a cambiar el canal?
Es posible que sea un problema de ruido.

Enviado desde mi u8500 usando Tapatalk 2

lekarin

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #486 en: 08-05-2012, 18:16 (Martes) »
Sí, he probado con distintos canales y todo sigue igual, muy muy inestable. Un momento llegan 12 Mb y al rato sólo llegan 2 Mb. Lo más extraño es que todo el rato va cambiando la velocidad de la red, como ya comenté, no llega en ningún momento en quedarse estable a 54 Mb/s.
Seguiré probando cosas a ver si consigo algo, e informaré por aquí de cualquier avance.
Un saludo y gracias!

txusss87

  • Visitante
Re: Re: Instalando OpenWrt en comtrend
« Respuesta #487 en: 09-05-2012, 09:59 (Miércoles) »
Hola gente! Despues de leerme el hilo entero.. No me a quedado claro la diferencia entre la compilaciones de RollerDK y las oficiales... Necesitaria poner mi CT-5361 de Jazztel en modo cliente wifi y repartir por cable. Alguien me podria decir q compilacion deberia instalar? Decir q no controlo mucho el codigo en linux por lo q me interesaria una interfaz grafica, osea una version con Luci imagino. Haber si alguien me puede aconsejar q compilacion ponerle. Muchas gracias de antemano!!


Enviado desde mi iPhone usando Tapatalk

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Re: Instalando OpenWrt en comtrend
« Respuesta #488 en: 09-05-2012, 21:16 (Miércoles) »
Pues la diferencia es el driver wifi. Las compilaciones de RollerDk llevan el driver propietario de Broadcom, que permiten el modo 'cliente trasparente' sin instalar paquetes adicionales (relayd).
Tienes más info en la wiki de openwrt.org

Enviado desde mi u8500 usando Tapatalk 2

txusss87

  • Visitante
Re: Re: Instalando OpenWrt en comtrend
« Respuesta #489 en: 10-05-2012, 09:57 (Jueves) »
Gracias compañero. Estuve leyendo en la Wiki y algo mas claro me a quedado, pero me gustaría saber que versión es la mas sencilla y estable a la vez para lo que necesito hacer: poner CT-5361 como cliente wifi y repartir por cable a dos pcs. Gracias.


Enviado desde mi iPhone usando Tapatalk

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Re: Instalando OpenWrt en comtrend
« Respuesta #490 en: 10-05-2012, 14:52 (Jueves) »
Usa la compilación de RollerDK.

Enviado desde mi u8500 usando Tapatalk 2

phullock

  • Visitante
Re: Re: Instalando OpenWrt en comtrend
« Respuesta #491 en: 16-07-2012, 03:25 (Lunes) »
Usa la compilación de RollerDK.

Enviado desde mi u8500 usando Tapatalk 2

Hola Jar229, yo tengo el problema también del wifi, que no me sale la interfaz.


root@OpenWrt:/# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

br-lan    no wireless extensions.



Tengo instalado el "firm rev. 28208 - broadcom con Luci" que puso un compañero unos mensajes atrás.

Gracias.

EDITO: Tenía la tarjeta wifi mal puesta y el comtrend no la detectaba. Dos horas liado para nada.

Saludos y gracias de todas formas por si alguien ha estado buscando cómo solucionar el problema.
« Última modificación: 16-07-2012, 04:49 (Lunes) por phullock »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Re: Instalando OpenWrt en comtrend
« Respuesta #492 en: 16-07-2012, 08:47 (Lunes) »

EDITO: Tenía la tarjeta wifi mal puesta y el comtrend no la detectaba. Dos horas liado para nada.

Saludos y gracias de todas formas por si alguien ha estado buscando cómo solucionar el problema.

Este tipo de 'fallos' es habitual  ;D
También suele pasar, que el pigtail que une la tarjeta wifi con la antena se suelta, y dejamos de 'ver' redes  ;)

phullock

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #493 en: 18-07-2012, 20:27 (Miércoles) »
Hola de nuevo Jar229!

Pues aquí vengo con un fallo que no consigo salir de él. Mi intención es conectar el router como cliente a una red eduroam. Ya tengo WAN y LAN  bien montado, me he conectado a mi red local sin problemas por Wifi, y ahora estoy probando con eduroam.

Una de las cosas que requiere wpa_supplicant es el driver de la interfaz wireless. He probado con broadcom  y nada, he probado con  BCM4318 y tampoco:


root@OpenWrt:/etc/init.d# wpa_supplicant -D broadcom -i wl0 -c /etc/wpa_supplicant.conf
wl0: Unsupported driver 'broadcom'



root@OpenWrt:/etc/init.d# wpa_supplicant -D BCM4318 -i wl0 -c /etc/wpa_supplicant.conf
wl0: Unsupported driver 'BCM4318'


¿Cual es el driver del wifi? La opción D es:   -D = driver name (can be multiple drivers: nl80211,wext)


Saludos.
« Última modificación: 18-07-2012, 20:28 (Miércoles) por phullock »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Instalando OpenWrt en comtrend
« Respuesta #494 en: 19-07-2012, 00:26 (Jueves) »
brcm-wl  ???

phullock

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #495 en: 19-07-2012, 00:35 (Jueves) »
brcm-wl  ???

root@OpenWrt:/etc/init.d# wpa_supplicant -D brcm-wl   -i wl0 -c /etc/wpa_supplicant.conf
wl0: Unsupported driver 'brcm-wl'

 :-\


Mira lo que pone en http://www.esdebian.org/wiki/configuracion-manual-wpasupplicant:


El campo wpa_driver hace referencia al driver de la tarjeta que tengamos instalados, por lo que deberemos asegurarnos e informarnos para no andar dando palos de ciego. En esta pequeña lista aparecen los drivers mas comunes:

hostap --- Host AP driver (Intersil Prism2/2.5/3)
madwifi --- MADWIFI 802.11 support (Atheros...)
wext --- Linux wireless extensions (generic)
atmel --- ATMEL AT76C5XXx (USB, PCMCIA...)
ndiswrapper --- Linux ndiswrapper
ipw --- Intel ipw2100/2200 driver
wired --- Wired Ethernet driver
b43 --- Broadcom Corporation BCM43XX

Es decir, que poniendo b43 debería funcionar pero no es así. ¿Crees que será por el driver del compañero del foro? ¿si me pongo el otro me funcionaría?

Saludos.

Edit. En efecto, me toca instalar el otro firm: " b43 con Luci -> http://www.gigasize.com/get/83xn2h9lsqb "

Pues nada, a actualizar :D
« Última modificación: 19-07-2012, 00:55 (Jueves) por phullock »

phullock

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #496 en: 19-07-2012, 18:40 (Jueves) »
Hola, vengo con otro error. Con este llevo una hora y no me he quedado bloqueado. A ver si alguien me puede echar un cable. QUiero desinstalar wpad-mini para instalar wpad porque el primero no tiene soporte para wpa-enterprise y el problema es que al instalar el último me sale este mensaje:

root@OpenWrt:~# opkg install wpad_20110527-1_brcm63xx.ipk --force-overwrite
Installing wpad (20110527-1) to root...
Collected errors:
 * verify_pkg_installable: Only have 140kb available on filesystem /overlay, pkg wpad needs 362

No tengo espacio!!! E instalando por Internet no puedo porque he desinstalado el wpad-mini, ¿Qué puedo hacer?

Gracias.
« Última modificación: 19-07-2012, 18:43 (Jueves) por phullock »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Instalando OpenWrt en comtrend
« Respuesta #497 en: 19-07-2012, 19:25 (Jueves) »
Hola, vengo con otro error. Con este llevo una hora y no me he quedado bloqueado. A ver si alguien me puede echar un cable. QUiero desinstalar wpad-mini para instalar wpad porque el primero no tiene soporte para wpa-enterprise y el problema es que al instalar el último me sale este mensaje:

root@OpenWrt:~# opkg install wpad_20110527-1_brcm63xx.ipk --force-overwrite
Installing wpad (20110527-1) to root...
Collected errors:
 * verify_pkg_installable: Only have 140kb available on filesystem /overlay, pkg wpad needs 362

No tengo espacio!!! E instalando por Internet no puedo porque he desinstalado el wpad-mini, ¿Qué puedo hacer?

Gracias.


Lo primero, intenta rebotar el router, a veces se que 'tonto' intentando instalar aplicaciones y un reinicio lo soluciona.
Después, bájate el fichero (http://downloads.openwrt.org/backfire/10.03.1-rc6/brcm63xx/packages/wpad_20110527-1_brcm63xx.ipk) desde un PC con conexión a internet y se lo envias al router con winscp (al directorio /tmp por ejemplo).
Desde putty ejecutas:

Código: [Seleccionar]
opkg install /tmp/wpad_20110527-1_brcm63xx.ipk
Si ni aún así lo consigues, me temo que tendrás que volver a empezar ...  ^-^

Si no necesitas el interfaz LuCi, puedes usar la última compilación de la rama backfire que ocupa poco, y por tanto te dejará más espacio para instalar lo que quieras: http://downloads.openwrt.org/backfire/10.03.1-rc6/brcm63xx/openwrt-96348GW-generic-squashfs-cfe.bin

En teoría, usa el driver b43.

phullock

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #498 en: 19-07-2012, 19:52 (Jueves) »
El fallo fue que tenía el paquete en el directorio /root y hay que ponerlo en /tmp porque es otro punto de montaje.

Ya estoy conectado a Eduroam jejeje En fin, sigo con esto trasteando... XD  Lo que pasa es que mañana me traen el raspberry y voy a dejar esto de lado seguro XD

Saludos!!
« Última modificación: 19-07-2012, 19:53 (Jueves) por phullock »

phullock

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #499 en: 24-07-2012, 20:18 (Martes) »
Buenas de nuevo, a ver si me podéis echar una mano. He conectado mi Comtrend como cliente a un AP, pero me da una IP pública. El problema es que no sé cómo configurar el router para que cree una nueva red dando IP privada y conectarme mediante el router al punto de acceso que se ha conectado.

Supongo que tendré que crear una vlan, pero no tengo ni idea de cómo hacerlo.

Saludos.

EDIT: Mi archivo network es el siguiente, que tengo puesto como prueba utilizando lo que mencionaron más atrás:

Citar

config interface loopback
        option ifname   lo
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0

config 'switch' 'eth1'
        option 'reset' '1'
        option 'enable_vlan' '1'
        option 'enable' '1'

config 'switch_vlan'
        option 'device' 'eth1'
        option 'vlan' '1'
        option 'ports' '0 1 2 5t'

config 'switch_vlan'
        option 'device' 'eth1'
        option 'vlan' '2'
        option 'ports' '3 5t'

config 'interface' 'lan'        
        option 'type' 'bridge'  
        option 'ifname' 'eth1.1'
        option 'proto' 'static'  
        option 'netmask' '255.255.255.0'
        option 'nat' '1'                
        option 'ipaddr' '192.168.3.1'  
        option 'defaultroute' '0'      
        option 'peerdns' '0'            
        option 'dns' '62.14.2.1'        
                                        
config 'interface' 'wan'                
        option 'ifname' 'eth1.2'        
        option 'defaultroute' '0'      
        option 'peerdns' '0'            
        option 'proto' 'dhcp'          
        option 'macaddr' '00:1D:20:57:64:6A'
                                            
config 'interface' 'int'                    
        option 'ifname' 'eth0'              
        option 'proto' 'dhcp'              

Y no funciona.
« Última modificación: 25-07-2012, 00:53 (Miércoles) por phullock »