Autor Tema: [Tutorial] Instalando OpenWrt en Comtrend  (Leído 374723 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Instalando OpenWrt en comtrend
« Respuesta #440 en: 03-10-2011, 15:59 (Lunes) »
No se cual puede ser el problema de los puertos ... yo tengo el Comtrend en modo cliente conectado por wifi a mi router principal (un Linksys com Tomato). Detrás del Comtrend oto router, un Huawei HG533 con OpenWRT (el wifi de este, funciona peor) y un cliente torrent (transmission) bajando sin problemas. Eso sí, el cortafuegos del Comtrend está deshabilitado  :-X



manolin2

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #441 en: 03-10-2011, 17:41 (Lunes) »
No se cual puede ser el problema de los puertos ... yo tengo el Comtrend en modo cliente conectado por wifi a mi router principal (un Linksys com Tomato). Detrás del Comtrend oto router, un Huawei HG533 con OpenWRT (el wifi de este, funciona peor) y un cliente torrent (transmission) bajando sin problemas. Eso sí, el cortafuegos del Comtrend está deshabilitado  :-X
deve ser ese el problema esta noche provare.... tengo 2 comtrend de jazztel uno como ap y otro de cliente wifi ..eso si... la ultima version de la pagina oficial lo unico que le he puesto por ahora es el español..y wpa suplicant... va de lujo sin cortes.... el que se puso aqui..va muy pesado..y a la primera conecta...pero cuando lo desenchufas y enchufas al dia siguiente..no conecta.... con el oficial...de lujo..lounico es lo de los torrents... los puertos van correctamentes direccionados.. el firewall no lo he tocado..por que el añopasado lo desavilite y se fastido el internet..jejej.... supungo que lo que te fieres es a quitar las pestañas tanto de wan como de lan... en todos los routers..¿o hay que aceptar alguna de las casillas? vamos... cual es exactamente tu configuracion..jejejej..saludos...
« Última modificación: 03-10-2011, 17:44 (Lunes) por manolin2 »

CCCP

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #442 en: 06-10-2011, 01:29 (Jueves) »
jar229, RollerDK,...

Finalmente he flasheado el ct5361 con RollerDK, he puesto rev. 28208 - broadcom con Luci -> http://www.gigasize.com/get/6tpldbo6r8f.
Es decir la que va con b43

Todo ok y consigo que se enlace en modo cliente con mi AP. pero.... no navego ni veo mis máquinas en red.

Por tanto, obviamente estoy haciendo algo mal en WAN, LAN Y WWAN
A ver si me echaís un cable (jeje) o un wireless

Configuro por LUCI web interface.


En WAN dejo DHCP y no pongo IPs.
¿Hago bridged?

____________________________________

En LAN pongo las ips de mi AP
192.168.1.151
255.255.255.0
192.168.1.1
192.168.1.1
¿La ip de broadcast?
¿Hago bridged?

___________________________________

En Wifi. Radio0
si lo hago a mano se conecta a mi AP con la interface WAN
si lo hago con el gestor de wifi openwrt se conecta con la interface WWAN

_____________________________________

¿QUE HAGO MAL? peña

Muchas gracias de antemano

PD: si una eventual solución no funkara, posteo los archivos de configuración network y wireless

hasta ahora

ayllon306

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #443 en: 07-10-2011, 23:00 (Viernes) »
si quieres te ayudo ,yo tengo instalado OpenWrt Backfire 10.03.1-rc5 / LuCI 0.10 Branch 0.10+svn7292

pon esto en networ  para modo cliente

config 'interface' 'loopback'
   option 'ifname' 'lo'
   option 'proto' 'static'
   option 'ipaddr' '127.0.0.1'
   option 'netmask' '255.0.0.0'

config 'interface' 'lan'
   option 'type' 'bridge'
   option 'ifname' 'eth1'
   option 'proto' 'static'
   option 'netmask' '255.255.255.0'
   option 'nat' '1'
   option 'ipaddr' '192.168.2.1'           le cambio la ip a una subred y luego es por donde entraremos a luci
   option 'gateway' '192.168.1.1'         y esta es la gateway de la conexion ,fijarse cual es la correspondiente a el roueter cliente

config 'interface' 'wan'
   option 'proto' 'dhcp'


config 'interface' 'wwan'
   option 'proto' 'dhcp'
 

a mi me funciona en wan y en wwan ,me da conexion igual

esto en dhcp

config 'dnsmasq'
   option 'domainneeded' '1'
   option 'boguspriv' '1'
   option 'filterwin2k' '0'
   option 'localise_queries' '1'
   option 'rebind_protection' '1'
   option 'rebind_localhost' '1'
   option 'local' '/lan/'
   option 'domain' 'lan'
   option 'expandhosts' '1'
   option 'nonegcache' '0'
   option 'authoritative' '1'
   option 'readethers' '1'
   option 'leasefile' '/tmp/dhcp.leases'
   option 'resolvfile' '/tmp/resolv.conf.auto'

config 'dhcp' 'lan'
   option 'interface' 'lan'
   option 'ignore' '0'
   option 'start' '100'
   option 'limit' '150'
   option 'leasetime' '12h'
   list 'dhcp_option' '6,80.58.61.250,80.58.61.254'           para mi esto es importante ,a mi me va muy bien

config 'dhcp' 'wan'
   option 'interface' 'wan'
   option 'ignore' '1'


esto en wireless

config 'wifi-device' 'radio0'
   option 'type' 'mac80211'
   option 'macaddr' '00:1a:2b:5c:66:75'   esta es la mac del cliente  el cliente
   option 'hwmode' '11g'
   option 'disabled' '0'
   option 'txpower' '0'
   option 'country' 'ES'
   option 'channel' '11'

config 'wifi-iface'
   option 'key1' 'jeoba'               esta es la contraseña que en un principio te pide wpa , le das a submit y luego en seguridad lo cambias a wep
   option 'network' 'wwan'
   option 'encryption' 'wep-open'
   option 'device' 'radio0'
   option 'mode' 'sta'
   option 'key' '1'
   option 'ssid' 'Jazztel Wireless'  este es el cliente





En Wifi. Radio0
si lo hago a mano se conecta a mi AP con la interface WAN
si lo hago con el gestor de wifi openwrt se conecta con la interface WWAN

                      debe de conectarse igual
 va bien en los reinicios y si lo desconecto vuelve a conectarse bien ,guarda bien la configuracion tema fledermaus y el idioma spain


Post fusionado: 07-10-2011, 23:17 (Viernes)
espero haberte ayudado  ,un saludo


el rolerdk ,no se como ira ,pero este OpenWrt Backfire 10.03.1-rc5 va muy bien

http://wiki.openwrt.org/toh/comtrend/ct5361
« Última modificación: 07-10-2011, 23:17 (Viernes) por ayllon306 »

manolin2

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #444 en: 08-10-2011, 09:54 (Sábado) »
el de la pagina oficial va de lujo.... el de RollerDK...me conecta solo una vez ..cuando paras y enchufas de nuevo no conecta mas lo he provado en 2 comtrend de jazztel azules uno de 6 años y otro de 2 años aparentemente igua les ..pero por dentro no lo son tanto .... saludos.

CCCP

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #445 en: 16-10-2011, 18:39 (Domingo) »
si quieres te ayudo ,yo tengo instalado OpenWrt Backfire 10.03.1-rc5 / LuCI 0.10 Branch 0.10+svn7292

pon esto en networ  para modo cliente

config 'interface' 'loopback'
   option 'ifname' 'lo'
   option 'proto' 'static'
   option 'ipaddr' '127.0.0.1'
   option 'netmask' '255.0.0.0'

config 'interface' 'lan'
   option 'type' 'bridge'
   option 'ifname' 'eth1'
   option 'proto' 'static'
   option 'netmask' '255.255.255.0'
   option 'nat' '1'
   option 'ipaddr' '192.168.2.1'           le cambio la ip a una subred y luego es por donde entraremos a luci
   option 'gateway' '192.168.1.1'         y esta es la gateway de la conexion ,fijarse cual es la correspondiente a el roueter cliente

config 'interface' 'wan'
   option 'proto' 'dhcp'


config 'interface' 'wwan'
   option 'proto' 'dhcp'
 

a mi me funciona en wan y en wwan ,me da conexion igual

esto en dhcp

config 'dnsmasq'
   option 'domainneeded' '1'
   option 'boguspriv' '1'
   option 'filterwin2k' '0'
   option 'localise_queries' '1'
   option 'rebind_protection' '1'
   option 'rebind_localhost' '1'
   option 'local' '/lan/'
   option 'domain' 'lan'
   option 'expandhosts' '1'
   option 'nonegcache' '0'
   option 'authoritative' '1'
   option 'readethers' '1'
   option 'leasefile' '/tmp/dhcp.leases'
   option 'resolvfile' '/tmp/resolv.conf.auto'

config 'dhcp' 'lan'
   option 'interface' 'lan'
   option 'ignore' '0'
   option 'start' '100'
   option 'limit' '150'
   option 'leasetime' '12h'
   list 'dhcp_option' '6,80.58.61.250,80.58.61.254'           para mi esto es importante ,a mi me va muy bien

config 'dhcp' 'wan'
   option 'interface' 'wan'
   option 'ignore' '1'


esto en wireless

config 'wifi-device' 'radio0'
   option 'type' 'mac80211'
   option 'macaddr' '00:1a:2b:5c:66:75'   esta es la mac del cliente  el cliente
   option 'hwmode' '11g'
   option 'disabled' '0'
   option 'txpower' '0'
   option 'country' 'ES'
   option 'channel' '11'

config 'wifi-iface'
   option 'key1' 'jeoba'               esta es la contraseña que en un principio te pide wpa , le das a submit y luego en seguridad lo cambias a wep
   option 'network' 'wwan'
   option 'encryption' 'wep-open'
   option 'device' 'radio0'
   option 'mode' 'sta'
   option 'key' '1'
   option 'ssid' 'Jazztel Wireless'  este es el cliente





En Wifi. Radio0
si lo hago a mano se conecta a mi AP con la interface WAN
si lo hago con el gestor de wifi openwrt se conecta con la interface WWAN

                      debe de conectarse igual
 va bien en los reinicios y si lo desconecto vuelve a conectarse bien ,guarda bien la configuracion tema fledermaus y el idioma spain


Post fusionado: 07-10-2011, 23:17 (Viernes)
espero haberte ayudado  ,un saludo


el rolerdk ,no se como ira ,pero este OpenWrt Backfire 10.03.1-rc5 va muy bien

http://wiki.openwrt.org/toh/comtrend/ct5361

gracias por el nuevo aporte. comento

configuro el router tal y como especificas pero no consigo navegar.

Es decir. POngo network con ip en subred 192.168.2.1 y gateway 192.168.1.1 (router madre)
Previamente me logeo contra el router por wifi con radio 0. Todo ok. Se autentiva y si hago un ping a google desde consola (putty) en router resuelve la direción ip y no se corta. Por tanto el wifi funciona pero no consigo puentearlo de manera efectiva para que salga por el cable.

En mi pc pogo ip estatico en relación a lops parametros para el luci tal y como manda lan

192.168.2.153
255.255.255.0
192.168.2.1
87.216.1.65 (DNS ISP)
87.216.1.66 (DNS ISP)

NOTA: no puedo poner el firm mencionado del wiki oficial. Solo los dos posteados por RollerDK

¿He de dejar el pc en dhcp?
¿Es correcto tal y como tengo?
¿Como ostias configuro LAN, entendiendo q WAN no se toca?
Porq la cosa es q el router tiene conexion wifi contra el router madre¡¡¡¡


Gracias por la ayuda

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Instalando OpenWrt en comtrend
« Respuesta #446 en: 17-10-2011, 07:43 (Lunes) »
Y has probado a configurar TODO en la misma subred ?
Desde luego tienes un router raro ... mira que aceptar únicamente algunos firms ...  :-X

nhocpo

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #447 en: 20-10-2011, 01:44 (Jueves) »
Hola, pido ayuda porque no he encontrado como conectar con otro Comtrend por Wifi. Os cuento:

He instalado la ultima version de RollerDk, y luego he cambiado la ip del router en lan para que fuese 192.168.1.151, asignando puerta de enlace y dns a 192.168.1.1. Con esto consigo una especie de router neutro.

 Ahora queria eliminar el cable, conectar por wireless al otro comtrend y salir por la tomas ethernet de este con Openwrt. Como algo?

 Muchas gracias.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Instalando OpenWrt en comtrend
« Respuesta #448 en: 20-10-2011, 07:50 (Jueves) »
Quizás si te tomaras la molestia de leer el hilo ...  ^-^

nhocpo

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #449 en: 23-10-2011, 04:02 (Domingo) »
Hola, llevo 2 noches leyendo y creo que ahora puedo decir que no es falta de lectura, sino falta de conocimientos de linux.
 A ver si puedo ser mas claro, vosotros os conectais por telner con el putty ese y veis los ficheros de configuracion. Yo quería conectar utilizando la interfaz LuCi, pero no se como se activa para buscar las redes disponibles (debo reconocer, que me pierdo del todo con el telner).
 En otro orden de cosas, he conseguido un Us Robotics usr-9108, que me dicen que es el mismo chipset que este CT-536, pero con una ventaja para mi: tiene puerto usb. Colará con el mismo firmware que estamos instalando aqui o lo dejaré "pajarito" de por vida?

 Un saludo.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Instalando OpenWrt en comtrend
« Respuesta #450 en: 27-10-2011, 22:01 (Jueves) »
Lo primero, desde LuCi debes activar el wireless (por defecto está desactivado). A partir de ahí, configurarlo en modo Station (o cliente), indicarle los datos de conexión (nombre de red, tipo de encriptación, etc.) y en teoría poco más.
Si no lo consigues, pon los datos del fichero /etc/config/wireless por aquí  ;)

nhocpo

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #451 en: 28-10-2011, 02:59 (Viernes) »
Vale, muchas gracias. No activaba el wifi...... Mejor no digo nada y pago unas cervezas!! (Si a alguno le queda cerca Coruña...)

Y ahora, como hago para engañar al Usr-9108A (en teoría es el mismo chip) y que cuele con el firmwware este?
Me vendría de perlas, pq este ultimo esta un poco jodido y lo dejaba solo para hacer de repartidor de red en varias tomas... la funcion que ahora hace el Comtrend CT536. Se le puede engañar con el tftp?

Y el comtrend, lo destinaba a hacer el Wake on Lan de mi equipo principal , que algo he leido que se puede... Aunque no sé si el OpenWrt tiene DynDNS o algo similar.

Muchas gracias.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Instalando OpenWrt en comtrend
« Respuesta #452 en: 28-10-2011, 08:23 (Viernes) »
Si no tienes miendo a perder el router, puedes probarlo. Eso o probar con este otro: http://downloads.openwrt.org/backfire/10.03.1-rc5/brcm63xx/openwrt-USR9108-jffs2-64k-cfe.bin
En cuanto a qué puedes instalar: /Sistema/Software/Actualizar lista de paquetes. Verás el espacio disponible y un montón de cosas que puedes meter al router.
Para el wol instala:    luci-app-wol

nhocpo

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #453 en: 19-11-2011, 10:17 (Sábado) »
Hola Jar229,

 te cuento el firmware que tu me pasaste funciona a las mil maravillas, pero sólo un rato.
Pasados unos 10 min, al igual que con el firmware original, el aparato se bloquea y no hay forma de revivirlo, exceptuando hacer un reset...
 Debe ser algún problema de hardware, así que lo desmontaré y trataré de aprovechar para otra cosa la tarjeta wifi integrada (si no está soldada claro).

Muchas gracias por el link y un saludo.

aguera-competicion

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #454 en: 09-12-2011, 20:05 (Viernes) »
Hola me he conseguido un router comtrend con el chip broadcom bcm6339

es un router nuevo que entrega telefónica con características de gigabit y Wifi N

He estado mirando soporte para este chip y no he leído nana al respecto ¿alguien a probado si es compatible con algún firware como el de open?.

Saludos

aguera-competicion

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #455 en: 11-12-2011, 18:00 (Domingo) »
He estado indagando y he recopilado mas información de este router

Comtrend 5813n

broadcom BCM4322 --> 400MHZ dual core mips
     "          BCM4322 --> B/G/N
     "          BCM311 ---> 10/100/1000 Mbps

La verdad que no he visto que den soporte directo a este chip en la pagina de OpenWRT pero si hablan de la familia de estos, por lo que no se si sera critico o no el soporte, sobre todo no quiero meter la pata y que darme en tierra de nadie ni para alante ni para atrás.

Haber si alguien experto en estos temas me hecha una mano por aquí, y me comenta si es posible que "chute" esto con algún firmware que no sea el original.

Un saludo

aguera-competicion

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #456 en: 15-12-2011, 22:54 (Jueves) »
Viendo que no hay nadie que aya podido responder a mi duda , me he arriesgado a actualizar el router y directamente me da un error como podeis ver , quizas nadie sepa la solucion o quizas ...si pero si me permitis os presento un pantallazo del resultado



El router corresponde a un comtrend 5813N
« Última modificación: 15-12-2011, 22:59 (Jueves) por aguera-competicion »

SERASER

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #457 en: 15-12-2011, 22:58 (Jueves) »
Mejor dejalo correr que la vas a liar.

http://wiki.openwrt.org/doc/hardware/soc/soc.broadcom.bcm63xx

No sale en la lista de soportados, ni tan siquiera en la de trabajo en curso, asi pues nada de momento podras hacer.

pd: Pero hombre por web jamas te lo cogeria(y mejor asi), solo te admite firms originales.

« Última modificación: 15-12-2011, 23:03 (Jueves) por sERASEr »

aguera-competicion

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #458 en: 15-12-2011, 23:36 (Jueves) »
Mejor dejalo correr que la vas a liar.

http://wiki.openwrt.org/doc/hardware/soc/soc.broadcom.bcm63xx

No sale en la lista de soportados, ni tan siquiera en la de trabajo en curso, asi pues nada de momento podras hacer.

pd: Pero hombre por web jamas te lo cogeria(y mejor asi), solo te admite firms originales.



La verdad que el tema este de comtend + openWrt no lo tengo toqueteado , gogleando un poco, leí o entendí que se podían hacer ya actualizaciones por Web pero ya te digo que no lo tengo este tema por la mano y prefiero que seáis vosotros los que me guiéis en estos inventos.

Lo de la tabla no la encontré a pesar de remenear el foro de OpenWrt, te la agradezco un montón ya que ahora me queda claro que no hay soporte actualmente.

Gracias.

progrhed

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #459 en: 21-12-2011, 14:24 (Miércoles) »
.

Un hilo muy interesante, si señor.
Me ha animado a instalar el openWRT en el comtrend hg536+  y hasta ha funcionado y todo!  >:(

Por cierto, me he hecho una chuleta con los puertos del switch, que si no siempre me pierdo :)  espero que le pueda servir a alguien mas.



« Última modificación: 28-10-2015, 03:10 (Miércoles) por progrhed »