Autor Tema: [Tutorial] Instalando OpenWrt en Comtrend  (Leído 352048 veces)

0 Usuarios y 1 Visitante están viendo este tema.

xeonpj

  • Visitante
Re: [Tutorial] Instalando OpenWrt en Comtrend
« Respuesta #580 en: 06-05-2014, 09:06 (Martes) »
hola amigos, hace tiempo que ando desconectado de este router.

actualmente lo tengo con Kamikaze (r20613)

cual es la ultima version estable para este router? lo tengo como cliente, no va mal, pero a veces se vuelve lento y ando reiniciandolo.

un saludo.



Cuprum

  • Visitante
Re: [Tutorial] Instalando OpenWrt en Comtrend
« Respuesta #581 en: 10-11-2014, 22:54 (Lunes) »
Hola a todos, y muchas gracias por tanta buena información con respecto al CT5361 que habéis aportado entre todos.
Me he decidido a registrarme en el foro para compartir la configuración un poco 'distinta' que he hecho con este router y que de momento me funciona muy bien, he llegado a tener conectados hasta 15 clientes wifi y con buen rendimiento.  No tengo datos objetivos, pero en general muy bien.

Tenía necesidad de montar un router con multi SSID y con varias Vlanes cableadas y un puerto trunk a otro router con configuración similar.  El planteamiento era el siguiente:

Tengo una conexión a Internet mediante un router ADSL (con su firmware original que no he tocado), quiero dar Internet en otro edificio situado a unos 60 metros mediante un primer router [openwrt1] y un segundo router [openwrt2] a una distancia de otros 30 metros más en ese mismo edificio. 
Las conexiones entre los router las hago todas mediante cable categoría 5e.

En cada openwrt voy a difundir el SSID-1 correspondiente a la LAN-1 principal (la misma lan del router de internet), con direccionamiento 192.168.1.0/24

Además quiero montar una segunda LAN-2 con SSID-2 con direccionamiento 192.168.2.0/24.

El router [openwrt1] será el encargado de dar DHCP, DNS a la LAN-2 y enrutar las comunicaciones entre LAN-2 a la LAN-1 (mediante NAT) y hacia internet a través del router principal de Internet.

Entre los router [openwrt1] y [openwrt2] se establece un trunk mediante Vlanes  con la LAN-2 (vlan2) tagged y la LAN-1 (vlan1) untagged.
 
Por último los puertos cableados de cada router los he asignado a la LAN-1(vlan1) o la LAN-2(vlan2) según las necesidades, para conectar una impresora de red y un NAS, por ejemplo a una u otra red.

Tenía a mano un Comtrend CT-5361 y un CT-5365.  La cosa quedó así:


                                      cable 60m      CT-5361         cable 30m       CT-5365
Inet ---- [ Router ppal ] -----------------[ openwrt1 ]---------------------[ openwrt2 ]
             192.168.1.1                       192.168.1.243                      192.168.1.244    LAN-1: SSID-1
                                                       192.168.2.1                                                     LAN-2: SSID-2

Puesto que la premisa imprescindible era difundir dos SSID en cada openwrt, tuve que utilizar una versión de openwrt estable para este router y compilada con el driver propietario de broadcom (el driver b43 opensource hasta donde he investigado no permite multi-SSID). Así que he cogido la compilación de RollerDK r28208 (ver respuesta 407 de hace 3 años) en este mismo foro.  Hubiera preferido la compilación sin Luci, pero ya no estaba disponible en gigasize, así que me conformé con la de Luci que aún estaba.  Me dio pereza compilarla sin Luci.

rev. 28208 - broadcom con Luci -> http://www.gigasize.com/get/6tpldbo6r8f

Por el puerto 0 he hecho el trunk con el otro comtrend, la vlan 1 va sin tagear y la vlan 2 va tageada.

Probablemente pueda haber alguna configuración mejor. Cualquier opinión será bienvenida.

En el openwrt2 que es un CT-5365 hice una configuración similar al openwrt1 pero flasheando con una versión estable para ese modelo. En ese caso si me tocó compilar, también con el driver propietario. 

El router tarda un poco en arrancar.  En estar operativas las dos wifis serán unos 2 minutos,  así que paciencia a la hora de probar.

Los archivos de configuración del [openwrt1] quedan:

Código: [Seleccionar]
# ----------------------------------------------------
# /etc/confi/network
# ----------------------------------------------------
config 'interface' 'loopback'
option 'ifname' 'lo'
option 'proto' 'static'
option 'ipaddr' '127.0.0.1'
option 'netmask' '255.0.0.0'

config 'interface' 'lan'
option 'type' 'bridge'
option 'ifname' 'eth1.1'
option 'proto' 'static'
option 'netmask' '255.255.255.0'
option 'gateway' '192.168.1.1'
option 'dns' '192.168.1.1'
option 'nat' '1'
option 'ipaddr' '192.168.1.243'

config 'interface' 'wan'
option 'ifname' 'eth0'
option 'proto' 'dhcp'

config 'interface' 'lan2'
option 'type' 'bridge'
option 'ifname' 'eth1.2'
option 'proto' 'static'
option 'ipaddr' '192.168.2.1'
option 'netmask' '255.255.255.0'
option 'defaultroute' '0'

config 'switch' 'eth1'
option 'enable' '1'
option 'reset' '1'
option 'enable_vlan' '1'

config 'switch_vlan'
option 'device' 'eth1'
option 'vlan' '1'
option 'ports' '0 3 5t'

config 'switch_vlan'
option 'device' 'eth1'
option 'vlan' '2'
option 'ports' '0t 1 2 5t'

#---------------------------------------------------
# /etc/config/wireless
#---------------------------------------------------

config 'wifi-device' 'wl0'
option 'type' 'broadcom'
option 'channel' '11'
option 'disabled' '0'
option 'txpower' '18'
option 'hwmode' '11bg'

config 'wifi-iface'
option 'device' 'wl0'
option 'network' 'lan'
option 'mode' 'ap'
option 'encryption' 'psk2'
option 'key' 'password.ssid-1'
option 'ssid' 'SSID-1'

config 'wifi-iface'
option 'device' 'wl0'
option 'mode' 'ap'
option 'network' 'lan2'
option 'ssid' 'SSID-2'
option 'encryption' 'psk2'
option 'key' 'password.ssid-2'

#-------------------------------------------
# /etc/config/dhcp
#-------------------------------------------

config 'dnsmasq'
option 'domainneeded' '1'
option 'boguspriv' '1'
option 'localise_queries' '1'
option 'rebind_protection' '1'
option 'rebind_localhost' '1'
option 'local' '/lan/'
option 'domain' 'lan'
option 'expandhosts' '1'
option 'authoritative' '1'
option 'readethers' '1'
option 'leasefile' '/tmp/dhcp.leases'
option 'resolvfile' '/tmp/resolv.conf.auto'

config 'dhcp' 'lan'
option 'interface' 'lan'
option 'ignore' '1'
# option 'start' '100'
# option 'limit' '150'
# option 'leasetime' '12h'

config 'dhcp' 'wan'
option 'interface' 'wan'
option 'ignore' '1'

config 'dhcp' 'lan2'
option 'interface' 'lan2'
option 'ignore' '0'
option 'start' '30'
option 'limit' '40'
option 'leasetime' '12h'
list 'dhcp_option' '3,192.168.2.1'


#---------------------------------------------
# /etc/config/firewall
#---------------------------------------------

config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward ACCEPT

config zone
option name lan
option network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
option masq 1
option mtu_fix 1

config zone                               
        option name             lan2       
        option network          'lan2'     
        option input            ACCEPT     
        option output           ACCEPT
        option forward          ACCEPT
                                       
config forwarding
option src      lan2
option dest      lan

config rule
option src lan2
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4
 

baxon

  • Visitante
Re: Instalando OpenWrt en comtrend
« Respuesta #582 en: 08-01-2015, 13:03 (Jueves) »
Hola a todos,

he conseguido hacer funcionar el firmware "rev. 28208 - broadcom con Luci -> http://www.gigasize.com/get/6tpldbo6r8f" de RollerDK como repetidor (cliente+ap) en un Comtrend CT-5361 de Jazztel. Aunque lo he conseguido de una forma poco ortodoxa, os explicaré como lo he hecho por si alguien con más conocimientos puede pulir esta solución.

Cuando creas dos interfaces wifi (wl0 en modo 'sta' y wl0.1 en modo 'ap' formando bridge con eth1) sucede que el cliente 'sta' se conecta correctamente a la red wifi a repetir pero, aunque el 'ap' difunde el ESSID para nuestra wifi local, es imposible conectarse a ella. Se me ocurrió crear un tercer interfaz wifi (wl0.2 en una interfaz de red a parte llamada wlan)  y cual fué mi sorpresa al ver que ya me podía conectar a mi wifi local creada en el interfaz wl0.1 y recibía IP de forma dinámica por dhcp.

Paso a pegar mis archivos de configuración:

/etc/config/network

Código: [Seleccionar]
config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.1'
        option 'netmask' '255.255.255.0'
        option 'ifname' 'eth1'

config 'interface' 'wan'
        option 'proto' 'static'
        option 'ipaddr' '192.168.2.250'
        option 'netmask' '255.255.255.0'
        option 'gateway' '192.168.2.1'
        option 'broadcast' '192.168.2.255'
        option 'dns' '192.168.2.1'

config 'interface' 'wlan'
        option 'proto' 'none'

/etc/config/wireless

Código: [Seleccionar]
config 'wifi-device' 'wl0'
        option 'type' 'broadcom'
        option 'disabled' '0'
        option 'hwmode' '11bg'
        option 'channel' '7'
        option 'diversity' '1'
        option 'country' 'ES'
        option 'txpower' '20'

config 'wifi-iface'
        option 'mode' 'ap'
        option 'ssid' 'MANZANARES'
        option 'network' 'lan'
        option 'device' 'wl0'
        option 'encryption' 'psk2'
        option 'key' '**********'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'mode' 'sta'
        option 'ssid' 'WLANxxxxxx'
        option 'encryption' 'wep-shared'
        option 'key' '1'
        option 'key1' '*************'
        option 'network' 'wan'

config 'wifi-iface'
        option 'mode' 'ap'
        option 'ssid' 'MANZANARES2'
        option 'device' 'wl0'
        option 'network' 'wlan'
        option 'hidden' '1'
        option 'encryption' 'psk2'
        option 'key' '*********'

WLANxxxxxx es el interfaz wl0
MANZANARES es el interfaz wl0.1
MANZANARES2 es el interfaz wl0.2
esta no la utilizo para nada pero es la artífice de que todo este tinglado funcione  >:(

El dispositivo eth0 lo he deshabilitado ya que no lo necesito, por lo que la interfaz de red 'wan' la forma wl0.

Espero haberme explicado de forma clara y serviros de ayuda.

Un saludo.

¿alguien más ha conseguido esto?
No veo que se le halla dado importancia...
Supongo que es con el router sólo, sin ningun usb wifi...

Un saludo,