Autor Tema: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.  (Leído 619859 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #900 en: 16-10-2013, 09:26 (Miércoles) »
Con relayd, lo que se pretende es que todos los equipos estén en la misma subred  ;)

En cuanto a lo de asignar una IP a una MAC determinada, sí se puede hacer según este manual. Es para el livebox 2 pero presupongo que sea igual o similar en el 2.1:  http://www.redeszone.net/routers/livebox-2-manual-del-router-de-orange-con-wi-fi-n-manual-de-configuracion/ (mira en - Asignar IP estática a nuestro PC.).

Por lo tanto, deberías asignar/reservar la IP 192.168.1.140 a la MAC del router con OpenWrt.



falisco

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #901 en: 16-10-2013, 10:24 (Miércoles) »
Con relayd, lo que se pretende es que todos los equipos estén en la misma subred  ;)

En cuanto a lo de asignar una IP a una MAC determinada, sí se puede hacer según este manual. Es para el livebox 2 pero presupongo que sea igual o similar en el 2.1:  http://www.redeszone.net/routers/livebox-2-manual-del-router-de-orange-con-wi-fi-n-manual-de-configuracion/ (mira en - Asignar IP estática a nuestro PC.).

Por lo tanto, deberías asignar/reservar la IP 192.168.1.140 a la MAC del router con OpenWrt.

¿Osea que le debo poner una ip fija al DreamBox de la red 192.168.1.* a pesar de estar conectado al router OpenWRT con LAN 192.168.2.*? Supongo que será como está especificado aquí, la verdad es que no me había fijado que los equipos conectados a esta red pertenecen a la misma red que la principal. Entonces seguro que lo tengo mal porque el DreamBox tiene una ip fija 192.168.2.230.

Muchas gracias por buscar la forma de hacerlo con el LiveBox.

¡¡¡Esta tarde lo pruebo todo!!!

victor8490

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #902 en: 16-10-2013, 12:51 (Miércoles) »
Buenas ante todo daros las gracias a todos ya que con vuestras aportaciones he podido instalar openwrt en mi hg556 asi como actualizar el kernel y poner el transmission. Lo que no consigo de ninguna manera es poner un pincho formateado en fat para que me descargue ahi el trasmission. He puesto en el arranque esto:
mkdir -p/usb
mount -t vfat /dev/sda1 /usb
En el trasmission el directorio de descarga lo he configurado en /usb pero cuando me voy a los puntos de montaje para ver si se ha montado el pincho no aparece nunca montado.
Me podrias dar alguna solucion? me faltaria algun paquete para que fuera compatible con el formato fat?

falisco

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #903 en: 16-10-2013, 18:44 (Miércoles) »
Bueno, pues ya le he puesto al DreamBox la ip fija 192.168.1.230 y la puerta de enlace 192.168.1.1. He hecho un ping desde el PC y esto es lo que me devuelve.

ping 192.168.1.230

Haciendo ping a 192.168.1.230 con 32 bytes de datos:
Respuesta desde 192.168.1.140: Puerto de destino inaccesible.
Respuesta desde 192.168.1.140: Puerto de destino inaccesible.
Respuesta desde 192.168.1.140: Puerto de destino inaccesible.
Respuesta desde 192.168.1.140: Puerto de destino inaccesible.

Estadísticas de ping para 192.168.1.230:
    Paquetes: enviados = 4, recibidos = 4, perdidos = 0
    (0% perdidos),

Es decir, yo creo que lo encuentra pero es como si hubiera un problema con los puertos ¿no?, lo que es evidente es que algo ha cambiado porque antes me devolvía:.

Tiempo de espera agotado para esta solicitud.

Por otro lado no soy capaz de encontrar la opción para asignar una IP a una MAC, la versión 2.1 no tiene nada que ver con la 2.  :'(
« Última modificación: 16-10-2013, 18:46 (Miércoles) por falisco »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #904 en: 16-10-2013, 19:20 (Miércoles) »
Necesito que postees por aquí los ficheros 'network', 'wireless' y 'firewall' (están dentro de /etc/config).

Para asignar las IP's por MAC, debes hacerlo entrando en la administración web del router: Básica, LAN, DHCP Estáticas

falisco

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #905 en: 16-10-2013, 20:53 (Miércoles) »
Pues no voy a poder asignar las IP's por MAC, la opción de configuración no está. Sólo puedo activar o desactivar el DHCP, pero nada más.



Pongo el contenido de los ficheros que me has pedido:

Código: [Seleccionar]
network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.2.1'
        option dns '192.168.1.1'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4 5t'

config interface 'wwan'
        option _orig_ifname 'wlan0'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.1.140'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config interface 'stabridge'
        option proto 'relay'
        option ipaddr '192.168.1.140'
        list network 'lan'
        list network 'wwan'

wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11ng'
        option path 'pci0000:00/0000:00:01.0'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '19'
        option country 'US'
        option channel '6'
        option disabled '0'

config wifi-iface
        option network 'wwan'
        option ssid 'XXXXXXXXXXX'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'XX:XX:XX:XX:XX:XX'
        option key 'XXXXXXXX'


firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Enforce-ULA-Border-Src'
        option src '*'
        option dest 'wan'
        option proto 'all'
        option src_ip 'fc00::/7'
        option family 'ipv6'
        option target 'REJECT'

config rule
        option name 'Enforce-ULA-Border-Dest'
        option src '*'
        option dest 'wan'
        option proto 'all'
        option dest_ip 'fc00::/7'
        option family 'ipv6'
        option target 'REJECT'

config include
        option path '/etc/firewall.user'


toneleti

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #906 en: 16-10-2013, 21:45 (Miércoles) »
Hola, ¿como podria configurar el samba para poder acceder a una carpeta desde cualquier pc de mi red sin que pida usuario y contraseña?

Le he puesto el invitado pero no me deja escribir en la carpeta.

Gracias

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #907 en: 17-10-2013, 08:41 (Jueves) »
Pues no voy a poder asignar las IP's por MAC, la opción de configuración no está. Sólo puedo activar o desactivar el DHCP, pero nada más.




Si activas el servidor DHCP, en la parte inferior, te permitirá asignar las IP's fijas a determinadas MAC's.

En cuanto a los ficheros de configuración, deberías dejarlos así:

network
Código: [Seleccionar]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.2.1'
option gateway '192.168.1.1'
        option dns '8.8.8.8'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4 5t'

config interface 'wwan'
        option proto 'dhcp'
        
config interface 'stabridge'
        option proto 'relay'
        option ipaddr '192.168.1.140'
        option 'network' 'lan wwan'

firewall
Código: [Seleccionar]
config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan wwan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Enforce-ULA-Border-Src'
        option src '*'
        option dest 'wan'
        option proto 'all'
        option src_ip 'fc00::/7'
        option family 'ipv6'
        option target 'REJECT'

config rule
        option name 'Enforce-ULA-Border-Dest'
        option src '*'
        option dest 'wan'
        option proto 'all'
        option dest_ip 'fc00::/7'
        option family 'ipv6'
        option target 'REJECT'

config include
        option path '/etc/firewall.user'

Y me olvidaba, el fichero dhcp debe quedarte así:

Código: [Seleccionar]
config dnsmasq
option domainneeded 1
option boguspriv 1
option filterwin2k 0  # enable for dial on demand
option localise_queries 1
option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
option rebind_localhost 1  # enable for RBL checking and similar services
#list rebind_domain example.lan  # whitelist RFC1918 responses for domains
option local '/lan/'
option domain 'lan'
option expandhosts 1
option nonegcache 0
option authoritative 1
option readethers 1
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
#list server '/mycompany.local/1.2.3.4'
#option nonwildcard 1
#list interface br-lan
#list notinterface lo
#list bogusnxdomain     '64.94.110.11'

config dhcp lan
option interface lan
option start 100
option limit 150
option leasetime 12h
option ignore 1

config dhcp wan
option interface wan
option ignore 1
« Última modificación: 17-10-2013, 09:26 (Jueves) por jar229 »

falisco

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #908 en: 17-10-2013, 09:05 (Jueves) »
Ok, gracias jar229, lo probaré esta tarde.

Un par de cosas:

- Si habilito el DHCP en el LiveBox 2.1 no me aparece nada debajo para activar las IPs fijas.

- Entiendo que en el fichero network la linea de config interface 'lan':

option gateway '192.268.1.1' sería option gateway '192.168.1.1' ¿no?


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #909 en: 17-10-2013, 09:25 (Jueves) »

- Entiendo que en el fichero network la linea de config interface 'lan':

option gateway '192.268.1.1' sería option gateway '192.168.1.1' ¿no?



Sí, ha sido un despiste. Ya lo he corregido  >:D

He visto que has posteado en adslzone. A ver si te dices algo los de Orange ...  ^-^
« Última modificación: 17-10-2013, 09:27 (Jueves) por jar229 »

falisco

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #910 en: 17-10-2013, 09:31 (Jueves) »
He visto que has posteado en adslzone. A ver si te dices algo los de Orange ...  ^-^

A lo mejor suena la flauta... ^-^.

La verdad es que este router tiene buena pinta en características pero está capadísimo por Orange, es una pena que no haya una manera de liberarlo para poder meterle más mano.

falisco

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #911 en: 17-10-2013, 21:13 (Jueves) »
Una pregunta,

¿Cómo pasáis los ficheros network, dhcp, etc. del pc al router y alrevés?, me estoy volviendo mico conectando con el putty y editando con el vi... ???

Edito: Le he cambiado los ficheros, he reiniciado el router y ha sido imposible conectarme de nuevo a él. Le he tenido que volver a meter el firmware.

Volveré a intentar empezar desde cero a ver.
« Última modificación: 17-10-2013, 21:58 (Jueves) por falisco »

falisco

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #912 en: 19-10-2013, 12:11 (Sábado) »
¡¡¡¡LO HE CONSEGUIDOOOOOOO!!!!!! ;D ;D

Sólo añadiría una cosa más al tutorial de Noltari: "una vez terminada la configuración apagar el router y volver a encenderlo", me he vuelto majara, he repasado todo unas 10 veces, ya no sabía que hacer ni que cambiar, y ha sido apagar y encender y ¡voilá! todo funcionaba perfectamente.

Desde el servicio técnico de orange, en adslzone, me respondieron diciéndome que reseteara el router a los valores de fábrica, lo hice, y ya podía volver a activar el dhcp y pude asignar IP's a MAC's. La verdad es que me resulta un poco raro que se pierdan opciones así como así... ???

Sólo me queda agradecer a Noltari su magnifico tutorial, a jar229 la gran ayuda recibida, y a todos los que contribuyen al foro para que los que no tenemos mucha idea podamos beneficiarnos de sus conocimientos.  >:( >:( >:(
« Última modificación: 19-10-2013, 12:12 (Sábado) por falisco »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
¡¡¡¡LO HE CONSEGUIDOOOOOOO!!!!!! ;D ;D


Felicidades ;D

Enviado desde mi CUBOT GT99 usando Tapatalk

bombe

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #914 en: 30-10-2013, 15:27 (Miércoles) »
Hola a todos,
Os cuento ya tengo funcionando el hg553 con la version r33378 todo me funciona correctamente , tengo una ralink 3070 en usb puesta que se conecta como cliente a mi router de la planta baja del chalet mio y en el piso de arriba donde esta reparto con la que broadcom interna  (todo esto es por que la cobertura del wifi a la planta de arriba no llega a toda), pero resulta que haciendo pruebas la estabilidad de la conexion al descargar  sube y baja la velocidad , todo esto tiene pinta que es por la ralink ya que con un portatil desde el piso de arriba me conecto desde una habitacion al router de abajo con buena estabilidad de descarga. 

Queria saber si hay alguna tarjeta que pueda enchufar por usb aunque no sea de 1w o largo alcance pero que me de estabilidad para conectarse como cliente al router que tiene internet abajo.

Si es economico mucho mejor jejeje.


Gracias

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #915 en: 30-10-2013, 15:44 (Miércoles) »
Una USB con chipset atheros seguro que te dará buen resultado.

Enviado desde mi CUBE U30GT usando Tapatalk

sankosme

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #916 en: 31-10-2013, 10:08 (Jueves) »
Hola, algún firmware similar al de la primera página, completito que a mayores tenga multiwan. Ya que por separado fuí incapaz de instalarlo.
Y tambien quería saber como activar el pyload por defecto cuando se reinicia el router.

Salu2

bombe

  • Visitante
Una USB con chipset atheros seguro que te dará buen resultado.

Enviado desde mi CUBE U30GT usando Tapatalk


Muchas gracias jar mirare alguna barata si sabes alguna te lo agradeceria que tenga ese chipset

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #918 en: 31-10-2013, 17:22 (Jueves) »
Yo tengo esta: http://dx.com/p/comfast-cf-wu150n-802-11b-g-n-usb-wireless-receiving-network-adapter-169303 y funciona muy bien.

Aunque la uso conectada a un portatil, no a un router ...  ^-^

bombe

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #919 en: 08-11-2013, 18:36 (Viernes) »
Yo tengo esta: http://dx.com/p/comfast-cf-wu150n-802-11b-g-n-usb-wireless-receiving-network-adapter-169303 y funciona muy bien.

Aunque la uso conectada a un portatil, no a un router ...  ^-^

Bueno pues ya tengo la tp-link tl-wn722n

Pero ahora intento instalar el modulos para atheros pero me da el siguiente error y no consigo que lo instale el modulo.

opkg update
opkg install kmod-ath9k-htc
Package kmod-ath9k-htc (3.10.18+2013-06-27-1) installed in root is up to date.
Configuring kmod-fuse.
//usr/lib/opkg/info/kmod-fuse.postinst: line 4: insert_modules: not found
Collected errors:
 * pkg_run_script: package "kmod-fuse" postinst script returned status 127.
 * opkg_configure: kmod-fuse.postinst returned 127.


Si pudieras jar229 con su sapiencia echarme un cablecito, te lo agradeceria