Autor Tema: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.  (Leído 619338 veces)

0 Usuarios y 3 Visitantes están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1000 en: 13-02-2014, 21:47 (Jueves) »
Cualquiera de las otras dos te vale.

No entiendo el empeño en lo de los puntos de montaje. Se puede hacer (el montaje también desde LuCi) sin tener ese módulo instalado.

Por cierto, que creo que si instalas fstab, ya lo tendrás ....???

Enviado desde mi CUBE U30GT usando Tapatalk



xumixurri

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1001 en: 14-02-2014, 19:24 (Viernes) »
Sigo con ello!!!  ;)

xumixurri

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1002 en: 14-02-2014, 19:58 (Viernes) »
Ahora con la version r30875 me aparece esto. no me monta el hdd. he mirado en los paquetes y no me aparece ninguno que ponga fstab.    ???

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1003 en: 15-02-2014, 10:34 (Sábado) »
Ahora con la version r30875 me aparece esto. no me monta el hdd. he mirado en los paquetes y no me aparece ninguno que ponga fstab.    ???

Lee el primer mensaje del hilo con calma, y verás cómo montar los discos duros sin necesidad del módulo de los puntos de montaje.

En lugar de fstab quería decir block-mount.

luiyivinily

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1004 en: 17-02-2014, 21:11 (Lunes) »
Ya consegui montar un pendrive con format ext4, pero sólo me funciona conectándolo en el usb de arriba en el de abajo es como si no funcionara, conseguí hacer funcionar transsmision y descargar un disco de musica, el problema que mi windows no detecta ese formato por eso me interesa utilizar un disco duro que tendo de 2tb en fat32.
Pruebo de la siguiente forma:
ls /dev y no me detecta el usb enganchado abajo y esta formateado en fat32

arriba lo intento montar y me dice esto:
wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

Un saludo,  
« Última modificación: 17-02-2014, 22:00 (Lunes) por luiyivinily »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1005 en: 18-02-2014, 10:06 (Martes) »
Y porqué no transfieres los ficheros por ftp o samba y te ahorras de quitar y poner los discos duros ?

xumixurri

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1006 en: 20-02-2014, 17:19 (Jueves) »
Estoy probando a compilarme una version de Openwrt. Cuanto es el máximo tamaño de Rom de Openwrt que admite el HG553 ????

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1007 en: 20-02-2014, 21:29 (Jueves) »
Estoy probando a compilarme una version de Openwrt. Cuanto es el máximo tamaño de Rom de Openwrt que admite el HG553 ????

La flash es de 16 megas. Yo no metería un firmware de más de 14 megas  ;)

xumixurri

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1008 en: 21-02-2014, 20:38 (Viernes) »
Estoy probando a compilarme una version de Openwrt. Cuanto es el máximo tamaño de Rom de Openwrt que admite el HG553 ????

La flash es de 16 megas. Yo no metería un firmware de más de 14 megas  ;)

Sigo con ello, pero me da el tipico error al compilar que le da a mucha gente, que en principio se dice que es por la descarga de archivos del servidor de openwrt, aunque he probado varios días y sigue petando en la compilacion.

miguelcmran

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1009 en: 24-02-2014, 14:33 (Lunes) »
Buenas jar229

Aquí ando intentando seguir el tutorial para instalar Swap + Samba + MlDonkey + Rtorrent - rutorrent en el WDR4300

Hasta ahora tengo ya funcionando el ExtRoot y ahora estoy parado con el tema del Swap, el samba y el MLDonkey, te cuento lo que he hecho hasta ahora y los problemas que me encuentro:

Pendrive 64 GB (1 GB Ext4 ExtRoot (sda1) / 256 MB SWAP (sda2) / 62,75 GB Ext4 (sda3))

Samba + swap

Paquetes instalados:

Código:
opkg install luci-app-samba
opkg install kmod-usb2
opkg install kmod-usb-core
opkg install kmod-usb-ohci
opkg install usbutils
opkg install kmod-usb-storage
opkg install swap-utils
opkg install ntfs-3g kmod-fs-ext4


mkdir /mnt/Almacenamiento

vi /etc/rc.local

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.
swapon /dev/sda2
mount -t ext4 /dev/sda3 /mnt/Almacenamiento -o rw,sync
exit 0


/etc/init.d/samba enable

/etc/init.d/samba start


vi /etc/passwd

root:PcJ8cToKAkeCk:0:0:root:/root:/bin/ash
network:*:101:101:network:/var:/bin/false
nobody:*:65534:65534:nobody:/var:/bin/false
daemon:*:65534:65534:daemon:/var:/bin/false
samba:*:1000:65534:samba:/mnt/Almacenamiento:/bin/ash


passwd samba

smbpasswd -a samba mi_password

vi /etc/config/samba

Mi fichero de ejemplo

Citar
config 'samba'
   option 'homes' '1'
   option 'name' 'Router'
   option 'description' 'Router'
   option 'workgroup' 'GRUPO_TRABAJO'

config 'sambashare'
   option 'name' 'Almacenamiento'
   option 'path' '/mnt/Almacenamiento'
   option 'read_only' 'no'
   option 'writeable' 'yes'
   option 'create_mask' '0777'
   option 'dir_mask' '0777'
   option 'guest_ok' 'no'
   option 'users' 'samba'


reboot

Cuando voy a Mis Sitios de Red veo el equipo Router y dentro veo 2 recursos (Samba y Almacenamiento lo cual no me cuadra del todo) a los cuales accedo con el usuario y contraseña configurados pero una vez dentro no me deja crear ningún fichero diciéndome Windows que no dispongo de permisos. Si copio algo a traves de SFTP a \mnt\Almacenamiento (por ejemplo cuando muevo la carpeta mldonkey en el procedimento de mldonkey) desde Mis Sitios de Red me aparece la carpeta en Samba en vez de en Almacenamiento.

MLDonkey


opkg update
opkg install screen

Descargo mldonkey Versión 3.1.3

minimal
Carpeta mldonkey-distrib-3.1.0.CVS renombrada como mldonkey. Descomprimo el fichero libraries.tar.bz dentro de mldonkey

Transfiero carpeta mldonkey a /mnt/Almacenamiento

vi /mnt/Almacenamiento/start_mlnet


Código:
#ruta donde tenemos mldonkey y sus ficheros de configuración

MAIN_FOLDER="/mnt/Almacenamiento/mldonkey/"

#ruta a la carpeta lib (el fichero libraries.tar.bz2 descomprimimos previamente

MY_LIBRARY_PATH="/mnt/Almacenamiento/mldonkey/lib/"

LD_LIBRARY_PATH=$MY_LIBRARY_PATH:$LD_LIBRARY_PATH

export LD_LIBRARY_PATH

#este es el comando para ejecutarlo, en la primera parte 'apuntamos' el directorio de mldonkey
#y en la segunda parte al ejecutable en sí, que es mlnet

export MLDONKEY_DIR="/mnt/Almacenamiento/mldonkey/" && /mnt/Almacenamiento/mldonkey/mlnet

Guardo el fichero y lo hago ejecutable

Código:
chmod +x /mnt/Almacenamiento/start_mlnet

Lanzo screen y ejecuto script:

/mnt/Almacenamiento/start_mlnet

Me sale:

root@OpenWrt:~# /mnt/Almacenamiento/start_mlnet
/mnt/Almacenamiento/start_mlnet: line 16: /mnt/Almacenamiento/mldonkey/mlnet: Permission denied

He visto que para que funcione el kernel tiene que estar compilado con FPU emulation (no sé si este error tiene que ver con eso) y no se si el firmware  que me recomendaste en el post de Movistar-Imagenio lo trae:

http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-sysupgrade.bin

El caso es que ando parado en este punto, a ver si me puedes iluminar un poco. He creído conveniente ponerlo en este post ya que en el de Movistar-Imagenio  no tenía que ver nada ya con el tema.

Como siempre se agradece la ayuda.

Un cordial saludo.
« Última modificación: 24-02-2014, 16:27 (Lunes) por miguelcmran »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1010 en: 25-02-2014, 12:27 (Martes) »
Cita de: miguelcmran

Citar
config 'samba'
   option 'homes' '1'
   option 'name' 'Router'
   option 'description' 'Router'
   option 'workgroup' 'GRUPO_TRABAJO'

config 'sambashare'
   option 'name' 'Almacenamiento'
   option 'path' '/mnt/Almacenamiento'
   option 'read_only' 'no'
   option 'writeable' 'yes'
   option 'create_mask' '0777'
   option 'dir_mask' '0777'
   option 'guest_ok' 'no'
   option 'users' 'samba'




reboot

Cuando voy a Mis Sitios de Red veo el equipo Router y dentro veo 2 recursos (Samba y Almacenamiento lo cual no me cuadra del todo) a los cuales accedo con el usuario y contraseña configurados pero una vez dentro no me deja crear ningún fichero diciéndome Windows que no dispongo de permisos. Si copio algo a traves de SFTP a \mnt\Almacenamiento (por ejemplo cuando muevo la carpeta mldonkey en el procedimento de mldonkey) desde Mis Sitios de Red me aparece la carpeta en Samba en vez de en Almacenamiento.

Añade la línea option homes '0' al fichero /etc/config/samba para que te quede así:

Código: [Seleccionar]
config 'samba'
   option 'homes' '1'
   option 'name' 'Router'
   option 'description' 'Router'
   option 'workgroup' 'GRUPO_TRABAJO'
   option homes '0'

config 'sambashare'
   option 'name' 'Almacenamiento'
   option 'path' '/mnt/Almacenamiento'
   option 'read_only' 'no'
   option 'writeable' 'yes'
   option 'create_mask' '0777'
   option 'dir_mask' '0777'
   option 'guest_ok' 'no'
   option 'users' 'samba'

Reinica samba, desde putty:

Código: [Seleccionar]
/etc/init.d/samba restart
Ahora únicamente verás el recurso compartido Almacenamiento
Con respecto a que no te deje escribir, o crear ficheros, es un tema de permisos. Desde putty, ejecuta:

Código: [Seleccionar]
chmod 777 /mnt/Almacenamiento

Cita de: miguelcmran
MLDonkey

Me sale:

root@OpenWrt:~# /mnt/Almacenamiento/start_mlnet
/mnt/Almacenamiento/start_mlnet: line 16: /mnt/Almacenamiento/mldonkey/mlnet: Permission denied

He visto que para que funcione el kernel tiene que estar compilado con FPU emulation (no sé si este error tiene que ver con eso) y no se si el firmware  que me recomendaste en el post de Movistar-Imagenio lo trae:

http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-sysupgrade.bin

El caso es que ando parado en este punto, a ver si me puedes iluminar un poco. He creído conveniente ponerlo en este post ya que en el de Movistar-Imagenio  no tenía que ver nada ya con el tema.

Como siempre se agradece la ayuda.

Un cordial saludo.

El error que te da, es probable que sea a causa de que el ejecutable mlnet está dentro de una subcarpeta.

De todas formas, el firmware que tienes instalado no tiene FPU emulation así que mldonkey no te va a funcionar  :(

No te queda otra, me temo, que compilarte un firmware con esta característica. O usar amule ... que en mi caso, siempre que lo he probado, se ha comportado de forma inestable  :-[

miguelcmran

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1011 en: 25-02-2014, 13:31 (Martes) »
Cita de: miguelcmran

Citar
config 'samba'
   option 'homes' '1'
   option 'name' 'Router'
   option 'description' 'Router'
   option 'workgroup' 'GRUPO_TRABAJO'

config 'sambashare'
   option 'name' 'Almacenamiento'
   option 'path' '/mnt/Almacenamiento'
   option 'read_only' 'no'
   option 'writeable' 'yes'
   option 'create_mask' '0777'
   option 'dir_mask' '0777'
   option 'guest_ok' 'no'
   option 'users' 'samba'




reboot

Cuando voy a Mis Sitios de Red veo el equipo Router y dentro veo 2 recursos (Samba y Almacenamiento lo cual no me cuadra del todo) a los cuales accedo con el usuario y contraseña configurados pero una vez dentro no me deja crear ningún fichero diciéndome Windows que no dispongo de permisos. Si copio algo a traves de SFTP a \mnt\Almacenamiento (por ejemplo cuando muevo la carpeta mldonkey en el procedimento de mldonkey) desde Mis Sitios de Red me aparece la carpeta en Samba en vez de en Almacenamiento.

Añade la línea option homes '0' al fichero /etc/config/samba para que te quede así:

Código: [Seleccionar]
config 'samba'
   option 'homes' '1'
   option 'name' 'Router'
   option 'description' 'Router'
   option 'workgroup' 'GRUPO_TRABAJO'
   option homes '0'

config 'sambashare'
   option 'name' 'Almacenamiento'
   option 'path' '/mnt/Almacenamiento'
   option 'read_only' 'no'
   option 'writeable' 'yes'
   option 'create_mask' '0777'
   option 'dir_mask' '0777'
   option 'guest_ok' 'no'
   option 'users' 'samba'

Reinica samba, desde putty:

Código: [Seleccionar]
/etc/init.d/samba restart
Ahora únicamente verás el recurso compartido Almacenamiento
Con respecto a que no te deje escribir, o crear ficheros, es un tema de permisos. Desde putty, ejecuta:

Código: [Seleccionar]
chmod 777 /mnt/Almacenamiento

Cita de: miguelcmran
MLDonkey

Me sale:

root@OpenWrt:~# /mnt/Almacenamiento/start_mlnet
/mnt/Almacenamiento/start_mlnet: line 16: /mnt/Almacenamiento/mldonkey/mlnet: Permission denied

He visto que para que funcione el kernel tiene que estar compilado con FPU emulation (no sé si este error tiene que ver con eso) y no se si el firmware  que me recomendaste en el post de Movistar-Imagenio lo trae:

http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-sysupgrade.bin

El caso es que ando parado en este punto, a ver si me puedes iluminar un poco. He creído conveniente ponerlo en este post ya que en el de Movistar-Imagenio  no tenía que ver nada ya con el tema.

Como siempre se agradece la ayuda.

Un cordial saludo.

El error que te da, es probable que sea a causa de que el ejecutable mlnet está dentro de una subcarpeta.

De todas formas, el firmware que tienes instalado no tiene FPU emulation así que mldonkey no te va a funcionar  :(

No te queda otra, me temo, que compilarte un firmware con esta característica. O usar amule ... que en mi caso, siempre que lo he probado, se ha comportado de forma inestable  :-[

Como siempre muchas gracias jar229

Lo del Samba ha funcionado perfectamente, ya veo solo el recurso Almacenamiento y tengo permisos para crear y borrar ficheros y carpetas.

Lo del MLDonkey me quedo con la miel en los labios, así que probare el amule que lo tengo también instalado en el WebTV de Blusens y me funciona perfectamente, a ver que tal se comporta en el router.

Ahora ando líado con el rtorrent. He seguido tu procedimiento al pie de la letra y me conecto perfectamente al interfaz web y he quitado el mensaje de no puede acceder al programa 'stat', pero tengo otro mensaje aún más feo que se genera cada 2 minutos y que dice lo siguiente:

Bad response from server: (404 [error,list]) <?xml version="1.0" encoding="iso-8859-1"?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> <head> <title>404 - Not Found</title> </head> <body> <h1>404 - Not Found</h1> </body> </html>

Según he investigado el error está relacionado con el scgi_port y el RPC2 pero he mirado el procedimiento y revisado todo varias veces y está clavado, así que no se me ocurre que puede ser.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1012 en: 25-02-2014, 15:06 (Martes) »

Como siempre muchas gracias jar229

Lo del Samba ha funcionado perfectamente, ya veo solo el recurso Almacenamiento y tengo permisos para crear y borrar ficheros y carpetas.

Lo del MLDonkey me quedo con la miel en los labios, así que probare el amule que lo tengo también instalado en el WebTV de Blusens y me funciona perfectamente, a ver que tal se comporta en el router.

Ahora ando líado con el rtorrent. He seguido tu procedimiento al pie de la letra y me conecto perfectamente al interfaz web y he quitado el mensaje de no puede acceder al programa 'stat', pero tengo otro mensaje aún más feo que se genera cada 2 minutos y que dice lo siguiente:

Bad response from server: (404 [error,list]) <?xml version="1.0" encoding="iso-8859-1"?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> <head> <title>404 - Not Found</title> </head> <body> <h1>404 - Not Found</h1> </body> </html>

Según he investigado el error está relacionado con el scgi_port y el RPC2 pero he mirado el procedimiento y revisado todo varias veces y está clavado, así que no se me ocurre que puede ser.

Un punto, una coma o un paréntesis de más (o de menos), pueden ser la causa del problema.

Si subes a algun servidor los ficheros 'conflictivos' (.rtorrent.rc, lighttpd.conf y php.ini), los miro a ver si yo veo algo raro  ^-^

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1013 en: 25-02-2014, 15:14 (Martes) »
Como estás usando Attitude Adjustment, tienes versiones antiguas de rtorrent y libtorrent.

Prueba a ver si instalando las nuevas, se soluciona.

Antes de actualizar, asegúrate que rtorrent no está en marcha.

Código: [Seleccionar]
opkg install http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/rtorrent_0.9.3-git--1_ar71xx.ipk
http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/libtorrent_0.13.3-git-6fb96e38f166a1189c1b9af2a6e95bf569a81d4b-1_ar71xx.ipk

miguelcmran

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1014 en: 25-02-2014, 18:01 (Martes) »
Como estás usando Attitude Adjustment, tienes versiones antiguas de rtorrent y libtorrent.

Prueba a ver si instalando las nuevas, se soluciona.

Antes de actualizar, asegúrate que rtorrent no está en marcha.

Código: [Seleccionar]
opkg install http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/rtorrent_0.9.3-git--1_ar71xx.ipk
http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/libtorrent_0.13.3-git-6fb96e38f166a1189c1b9af2a6e95bf569a81d4b-1_ar71xx.ipk

He actualizado los paquetes a la nueva versión y continuo con el mismo error, te dejo en este enlace los ficheros que me solicitas:

https://www.dropbox.com/sh/ghh2a1rhmt1apcx/YFQM-Zzlf_

Se me olvidó comentarte que cuando ejecuto el comando screen - rtorrent me aparece el siguiente mensaje por si sirve de pista:

The SCGI socket is bound to a specific network device yet may still pose a security risk, consider using 'scgi_local'.

Otra cosa es que cada vez que reinicio el router me toca ejecutar los comandos "/etc/init.d/lighttpd enable" "/etc/init.d/lighttpd restart" ya que si no al abrir el interfaz web me sale el mensaje "Sin conexión a rTorrent. Compruebe si se encuentra ejecutado. Verifique $scgi_port y $scgi_host en config.php y scgi_port en el archivo de configuración de rTorrent"

Como siempre gracias por tu estimada ayuda.


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1015 en: 25-02-2014, 19:03 (Martes) »

He actualizado los paquetes a la nueva versión y continuo con el mismo error, te dejo en este enlace los ficheros que me solicitas:

https://www.dropbox.com/sh/ghh2a1rhmt1apcx/YFQM-Zzlf_

Se me olvidó comentarte que cuando ejecuto el comando screen - rtorrent me aparece el siguiente mensaje por si sirve de pista:

The SCGI socket is bound to a specific network device yet may still pose a security risk, consider using 'scgi_local'.

Otra cosa es que cada vez que reinicio el router me toca ejecutar los comandos "/etc/init.d/lighttpd enable" "/etc/init.d/lighttpd restart" ya que si no al abrir el interfaz web me sale el mensaje "Sin conexión a rTorrent. Compruebe si se encuentra ejecutado. Verifique $scgi_port y $scgi_host en config.php y scgi_port en el archivo de configuración de rTorrent"

Como siempre gracias por tu estimada ayuda.



Te has equivocado a la hora de subir uno de los ficheros. Te pedí el lighttpd.conf, que está en /etc/lighttpd y me has subido el que está dentro de /etc/init.d (que además no tiene extensión .conf)

Cuando lo hayas subido, avisa. Los otros dos ficheros, están correctos ;)

Ya de paso, mira a ver qué 'cuenta' el fichero /var/log/lighttpd/error.log

El aviso que te da rtorrent (The SCGI socket is bound to a specific network device yet may still pose a security risk, consider using 'scgi_local'.) es normal.

Añade esto al final del archivo .rtorrent.c

# Enable logging
log.open_file = "rtorrent.log", (cat,/mnt/Almacenamiento/rtorrent/log/rtorrent.log)
log.add_output = "info", "rtorrent.log"


Debes crear previamente la carpeta /mnt/Almacenamiento/rtorrent/log y el fichero /mnt/Almacenamiento/rtorrent/rtorrent.log

Así veremos también si hay mensajes de error por parte de rtorrent. Por cierto, la carpeta /mnt/Almacenamiento/rtorrent/sesion, la creaste, verdad ?

miguelcmran

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1016 en: 25-02-2014, 19:51 (Martes) »

He actualizado los paquetes a la nueva versión y continuo con el mismo error, te dejo en este enlace los ficheros que me solicitas:

https://www.dropbox.com/sh/ghh2a1rhmt1apcx/YFQM-Zzlf_

Se me olvidó comentarte que cuando ejecuto el comando screen - rtorrent me aparece el siguiente mensaje por si sirve de pista:

The SCGI socket is bound to a specific network device yet may still pose a security risk, consider using 'scgi_local'.

Otra cosa es que cada vez que reinicio el router me toca ejecutar los comandos "/etc/init.d/lighttpd enable" "/etc/init.d/lighttpd restart" ya que si no al abrir el interfaz web me sale el mensaje "Sin conexión a rTorrent. Compruebe si se encuentra ejecutado. Verifique $scgi_port y $scgi_host en config.php y scgi_port en el archivo de configuración de rTorrent"

Como siempre gracias por tu estimada ayuda.



Te has equivocado a la hora de subir uno de los ficheros. Te pedí el lighttpd.conf, que está en /etc/lighttpd y me has subido el que está dentro de /etc/init.d (que además no tiene extensión .conf)

Cuando lo hayas subido, avisa. Los otros dos ficheros, están correctos ;)

Ya de paso, mira a ver qué 'cuenta' el fichero /var/log/lighttpd/error.log

El aviso que te da rtorrent (The SCGI socket is bound to a specific network device yet may still pose a security risk, consider using 'scgi_local'.) es normal.

Añade esto al final del archivo .rtorrent.c

# Enable logging
log.open_file = "rtorrent.log", (cat,/mnt/Almacenamiento/rtorrent/log/rtorrent.log)
log.add_output = "info", "rtorrent.log"


Debes crear previamente la carpeta /mnt/Almacenamiento/rtorrent/log y el fichero /mnt/Almacenamiento/rtorrent/rtorrent.log

Así veremos también si hay mensajes de error por parte de rtorrent. Por cierto, la carpeta /mnt/Almacenamiento/rtorrent/sesion, la creaste, verdad ?


Mea culpa por hacer las cosas tan rapido  ;D... ya tienes subido el fichero lighttpd.conf

Te adjunto también en el mismo enlace de dropbox los ficheros log. Efectivamente la carpeta /mnt/Almacenamiento/rtorrent/sesion la tengo creada (hay dos ficheros dentro "rtorrent.dht_cache y rtorrent.lock").

Muchas gracias máquina  >:(

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1017 en: 25-02-2014, 20:12 (Martes) »
Pues la configuración de los ficheros es correcta  ???

Lo único que quedaría por probar, sería a forzar la instalación de las nuevas versiones de lighttpd, php5, etc.

Para ello, debes editar (puedes hacerlo desde LuCi: Sistema/Instalación de programas/Configuración), la url del repositorio de la que descargas los paquetes. Debes sustituir http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages/ por http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages

Después desde putty ejecutas

Código: [Seleccionar]
opkg update
opkg install opkg install lighttpd php5 php5-cgi lighttpd-mod-access lighttpd-mod-auth lighttpd-mod-cgi lighttpd-mod-scgi

Ojo, con lighttpd parado  :P

Si esto no funciona ...  ^-^

miguelcmran

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1018 en: 26-02-2014, 09:31 (Miércoles) »
Pues la configuración de los ficheros es correcta  ???

Lo único que quedaría por probar, sería a forzar la instalación de las nuevas versiones de lighttpd, php5, etc.

Para ello, debes editar (puedes hacerlo desde LuCi: Sistema/Instalación de programas/Configuración), la url del repositorio de la que descargas los paquetes. Debes sustituir http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages/ por http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages

Después desde putty ejecutas

Código: [Seleccionar]
opkg update
opkg install opkg install lighttpd php5 php5-cgi lighttpd-mod-access lighttpd-mod-auth lighttpd-mod-cgi lighttpd-mod-scgi

Ojo, con lighttpd parado  :P

Si esto no funciona ...  ^-^

Realizado y sigue saliendo el mismo mensaje. Así que me da que también me quedo sin rtottent  :'(

He buscado el error en foros: http://forums.rutorrent.org/index.php?topic=835.0

Y la respuesta que dan es esta: Configure RPC mount point by normal way or simple try to use plugin rpc. Or httprpc.

miguelcmran

  • Visitante
Re: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #1019 en: 26-02-2014, 09:33 (Miércoles) »
Pues la configuración de los ficheros es correcta  ???

Lo único que quedaría por probar, sería a forzar la instalación de las nuevas versiones de lighttpd, php5, etc.

Para ello, debes editar (puedes hacerlo desde LuCi: Sistema/Instalación de programas/Configuración), la url del repositorio de la que descargas los paquetes. Debes sustituir http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages/ por http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages

Después desde putty ejecutas

Código: [Seleccionar]
opkg update
opkg install opkg install lighttpd php5 php5-cgi lighttpd-mod-access lighttpd-mod-auth lighttpd-mod-cgi lighttpd-mod-scgi

Ojo, con lighttpd parado  :P

Si esto no funciona ...  ^-^

Realizado y sigue saliendo el mismo mensaje. Así que me da que también me quedo sin rtottent  :'(

He buscado el error en foros: http://forums.rutorrent.org/index.php?topic=835.0

Y la respuesta que dan es esta: Configure RPC mount point by normal way or simple try to use plugin rpc. Or httprpc.

Aún así muchas gracias por todo jar229, si consigo algo lo comentaré por aquí y si no migraré a Transmission.