Autor Tema: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)  (Leído 543153 veces)

0 Usuarios y 1 Visitante están viendo este tema.

seny

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1060 en: 21-02-2015, 17:24 (Sábado) »
Buenas,

Necesito algo de ayuda con la config de la parte de ADSL en un ARV4518.
Le he puesto el firm del compañero tekkon (3.10.49), mi idea es sustituir un Comtrend 5381u por este.

He configurado todos los parámetros en el router según mi proveedor ISP (Jazztel), desde la consola he comprobado que sincroniza correctamente con modulación ADSL2+

Datos de sincronismo:
ADSL
Código: [Seleccionar]
Line State: UP showtime_tc_sync [0x801]
Line Speed: 19.929 Mb/s / 1.022 Mb/s
Line Attenuation: 16.1 dB / 13.7 dB
Noise Margin: 7.3 dB / 13.7 dB

Esta es la config en /etc/config/network

Código: [Seleccionar]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd1:a7bf:fb60::/48'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config atm-bridge 'atm'
        option payload 'bridged'
        option vci '35'
        option vpi '8'
        option encaps 'vc'

config interface 'wan'
        option _orig_ifname 'nas0'
        option _orig_bridge 'false'
        option proto 'pppoa'
        option encaps 'vc'
        option atmdev '0'
        option vci '35'
        option vpi '8'
        option username 'xxxxxxx'
        option password 'xxxxxxx'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config adsl 'dsl'
        option annex 'a2p'
        option firmware '/lib/firmware/adsl.bin'

El problema es que no funciona internet, si lanzo un ping desde la consola del router a www.google.es no funciona.
Hay que hacer algo mas una vez sincroniza el router?

Un saludo

Tanto en llc como en vc el router sincroniza pero no consigo navegar.
Vaya, pero si te faltan un monton de datos como:
   option gateway '192.168.1.1'
   option broadcast '192.168.1.255'
   option dns '87.216.1.65 87.216.1.66'
Espero que solo sea eso..  :-[


« Última modificación: 21-02-2015, 17:25 (Sábado) por seny »

DAIkiri2KS

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1061 en: 21-02-2015, 18:49 (Sábado) »
Buenas,

Necesito algo de ayuda con la config de la parte de ADSL en un ARV4518.
Le he puesto el firm del compañero tekkon (3.10.49), mi idea es sustituir un Comtrend 5381u por este.

He configurado todos los parámetros en el router según mi proveedor ISP (Jazztel), desde la consola he comprobado que sincroniza correctamente con modulación ADSL2+

Datos de sincronismo:
ADSL
Código: [Seleccionar]
Line State: UP showtime_tc_sync [0x801]
Line Speed: 19.929 Mb/s / 1.022 Mb/s
Line Attenuation: 16.1 dB / 13.7 dB
Noise Margin: 7.3 dB / 13.7 dB

Esta es la config en /etc/config/network

Código: [Seleccionar]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd1:a7bf:fb60::/48'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config atm-bridge 'atm'
        option payload 'bridged'
        option vci '35'
        option vpi '8'
        option encaps 'vc'

config interface 'wan'
        option _orig_ifname 'nas0'
        option _orig_bridge 'false'
        option proto 'pppoa'
        option encaps 'vc'
        option atmdev '0'
        option vci '35'
        option vpi '8'
        option username 'xxxxxxx'
        option password 'xxxxxxx'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config adsl 'dsl'
        option annex 'a2p'
        option firmware '/lib/firmware/adsl.bin'

El problema es que no funciona internet, si lanzo un ping desde la consola del router a www.google.es no funciona.
Hay que hacer algo mas una vez sincroniza el router?

Un saludo

Tanto en llc como en vc el router sincroniza pero no consigo navegar.
Vaya, pero si te faltan un monton de datos como:
   option gateway '192.168.1.1'
   option broadcast '192.168.1.255'
   option dns '87.216.1.65 87.216.1.66'
Espero que solo sea eso..  :-[

Esos datos los he configurado en el apartado de LAN, pero sigue sin funcionar.

Alguna otra idea?

DAIkiri2KS

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1062 en: 21-02-2015, 19:53 (Sábado) »
Hola a todos,
Aquí comparto las imágenes qué he compilado para el ARV4518:


Version 12.09 sincronizada con Openwrt 12.09 oficial con parches para qué el wifi funciona:

la imagen funciona con R0A1 como con R0A
* con luci + FPU:
https://docs.google.com/file/d/0BzBSJsSR-T9icDBEcTFkUTFDYTg
 
* sin luci + FPU
https://docs.google.com/file/d/0BzBSJsSR-T9ieU9nZ0Zoc05YSkE


Version 14.07 sincronizada con Openwrt 14.07 oficial con parches para corregir las particiones (Wifi funciona):

por R0A1:
* con luci, FPU, suporte de USB v2, Block-Mount y Ext4:
https://docs.google.com/file/d/0BzBSJsSR-T9iY0pQTWxKRVhrTWs

* sin luci, FPU, suporte de USB v2 y 1.x, USB Card Readers, Block-Mount y Ext4:
https://docs.google.com/file/d/0BzBSJsSR-T9ibmZMN09QZDZnMDg
 

por R0A:
* con luci, FPU, suporte de USB v2, Block-Mount y Ext4:
https://docs.google.com/file/d/0BzBSJsSR-T9iVEZOMDhnT29LdjQ

* sin luci, FPU, suporte de USB v2 y 1.x, USB Card Readers, Block-Mount y Ext4:
https://docs.google.com/file/d/0BzBSJsSR-T9ibDFybnlvcnpuOFk


La versión 14.07 con luci no tiene detalles des paquetes integrados. Después de haber flasheado y montar la partición /overlay sobre une memoria usb formateada con ext2/3/4 (pagina wik: http://wiki.openwrt.org/doc/howto/extroot#openwrt_barrier_breaker_trunk) extrae el fichero opkg.tar (https://docs.google.com/file/d/0BzBSJsSR-T9iRS1hMmV3aHpLTjg) como asi para restituirlos:

Código: [Seleccionar]
cd /tmp/
wget http://192.168.1.2/opkg.tar
cd /
tar  -xf /tmp/opkg.tar


Todas la imágenes entran en las 4mb del flash sin problemas.



Por cierto medber, he probado tus imagenes en un ARV4518 R01A y no arrancan las versiones de Barrier Breaker 14.07, sale un error Kernel Panic cuando estas cargando.
Pego el error:

Código: [Seleccionar]
[    0.572000] VFS: Cannot open root device "(null)" or unknown-block(0,0): erro
r -6
[    0.576000] Please append a correct "root=" boot option; here are the availab
le partitions:
[    0.584000] 1f00             128 mtdblock0  (driver?)
[    0.592000] 1f01              64 mtdblock1  (driver?)
[    0.596000] 1f02            3840 mtdblock2  (driver?)
[    0.600000] 1f03              64 mtdblock3  (driver?)
[    0.604000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

La versión 12.09 funciona sin problemas.
Alguna idea de porque puede fallar con 14.07?

Saludos y gracias por el curro
« Última modificación: 21-02-2015, 19:56 (Sábado) por DAIkiri2KS »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1953
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1063 en: 21-02-2015, 20:21 (Sábado) »
Buenas,

Necesito algo de ayuda con la config de la parte de ADSL en un ARV4518.
Le he puesto el firm del compañero tekkon (3.10.49), mi idea es sustituir un Comtrend 5381u por este.

He configurado todos los parámetros en el router según mi proveedor ISP (Jazztel), desde la consola he comprobado que sincroniza correctamente con modulación ADSL2+

Datos de sincronismo:
ADSL
Código: [Seleccionar]
Line State: UP showtime_tc_sync [0x801]
Line Speed: 19.929 Mb/s / 1.022 Mb/s
Line Attenuation: 16.1 dB / 13.7 dB
Noise Margin: 7.3 dB / 13.7 dB

Esta es la config en /etc/config/network

Código: [Seleccionar]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd1:a7bf:fb60::/48'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config atm-bridge 'atm'
        option payload 'bridged'
        option vci '35'
        option vpi '8'
        option encaps 'vc'

config interface 'wan'
        option _orig_ifname 'nas0'
        option _orig_bridge 'false'
        option proto 'pppoa'
        option encaps 'vc'
        option atmdev '0'
        option vci '35'
        option vpi '8'
        option username 'xxxxxxx'
        option password 'xxxxxxx'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config adsl 'dsl'
        option annex 'a2p'
        option firmware '/lib/firmware/adsl.bin'

El problema es que no funciona internet, si lanzo un ping desde la consola del router a www.google.es no funciona.
Hay que hacer algo mas una vez sincroniza el router?

Un saludo


Con esta configuración conseguía navegar con Pazztel:
Código: [Seleccionar]
config interface 'USB_ADSL'
        option proto 'pppoa'
        option encaps 'vc'
        option atmdev '0'
        option vci '35'
        option vpi '8'
        option username 'xxxxxx'
        option password 'xxxxxx'
        option auto '0'

Sincroniza tanto con VC como con LLC.
Si utilizas pppoa no necesitas atm-bridge. Esto es sólo para cuando utilizas pppoe. Prueba a ver...
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

mekkon

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1064 en: 21-02-2015, 22:00 (Sábado) »
Buenas, en su momento conecte por ADSL el arv4518 a temefonica, pero ahora tengo arange con un arv7518:

Código: [Seleccionar]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd0b:cf37:e624::/48'

config interface 'lan'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option ifname 'eth0.1'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 2 3 4 5'

config atm-bridge 'atm'
option vci '32'
option encaps 'llc'
option payload 'bridged'
option vpi '8'

config interface 'wan'
option ifname 'nas0'
option _orig_ifname 'nas0'
option _orig_bridge 'false'
option proto 'dhcp'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config adsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/adsl.bin'

lo tengo por DHCP, no pide ni user ni pass ni nada. Las dns las tengo con dnscrypt.

medber

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1065 en: 22-02-2015, 01:39 (Domingo) »

Por cierto medber, he probado tus imagenes en un ARV4518 R01A y no arrancan las versiones de Barrier Breaker 14.07, sale un error Kernel Panic cuando estas cargando.
Pego el error:

Código: [Seleccionar]
[    0.572000] VFS: Cannot open root device "(null)" or unknown-block(0,0): erro
r -6
[    0.576000] Please append a correct "root=" boot option; here are the availab
le partitions:
[    0.584000] 1f00             128 mtdblock0  (driver?)
[    0.592000] 1f01              64 mtdblock1  (driver?)
[    0.596000] 1f02            3840 mtdblock2  (driver?)
[    0.600000] 1f03              64 mtdblock3  (driver?)
[    0.604000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

La versión 12.09 funciona sin problemas.
Alguna idea de porque puede fallar con 14.07?

Saludos y gracias por el curro

@DAIkiri2KS

Tengo dos routers RO1A (ARV4518PW-A-LF-LT  y SMC7908A-ISP). he flasheado los dos con 14.07 con luci y sin luci y he probado flashearlos con el firmware R01 y no me ha resultado el mismo error que te salgue.

Estas seguro que tienes R01A y no el R01? descarga la imagen de nuevo e inténtalo de nuevo


DAIkiri2KS

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1066 en: 22-02-2015, 09:58 (Domingo) »

Por cierto medber, he probado tus imagenes en un ARV4518 R01A y no arrancan las versiones de Barrier Breaker 14.07, sale un error Kernel Panic cuando estas cargando.
Pego el error:

Código: [Seleccionar]
[    0.572000] VFS: Cannot open root device "(null)" or unknown-block(0,0): erro
r -6
[    0.576000] Please append a correct "root=" boot option; here are the availab
le partitions:
[    0.584000] 1f00             128 mtdblock0  (driver?)
[    0.592000] 1f01              64 mtdblock1  (driver?)
[    0.596000] 1f02            3840 mtdblock2  (driver?)
[    0.600000] 1f03              64 mtdblock3  (driver?)
[    0.604000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

La versión 12.09 funciona sin problemas.
Alguna idea de porque puede fallar con 14.07?

Saludos y gracias por el curro

@DAIkiri2KS

Tengo dos routers RO1A (ARV4518PW-A-LF-LT  y SMC7908A-ISP). he flasheado los dos con 14.07 con luci y sin luci y he probado flashearlos con el firmware R01 y no me ha resultado el mismo error que te salgue.

Estas seguro que tienes R01A y no el R01? descarga la imagen de nuevo e inténtalo de nuevo



Pues precisamente tengo los dos mismos routers que tu (ARV4518PW-A-LF-LT  y SMC7908A-ISP), ambos R01A, probé a flashear con 14.07 el SMC tanto desde Luci como por puerto serie y siempre me sale ese error cuando esta cargando, incluso llegue a probar la versión R01 por si me hubiera confundido al descargarla pero con esta ni la llegaba a cargar.

Sl2

medber

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1067 en: 22-02-2015, 13:30 (Domingo) »
@DAIkiri2KS

Vale, pienso que uses u-boot.bin de Pteridium lo que tiene suporte de BrnBoot  ?  https://foro.seguridadwireless.net/openwrt/openwrt-para-roters-astoria-de-ya-com/msg256236/#msg256236

Yo uso el u-boot de CieNTi https://foro.seguridadwireless.net/openwrt/openwrt-para-roters-astoria-de-ya-com/msg246595/#msg246595

la diferencia es que el tamaño del u-boot de Pteridium es 128kb mientras de CieNTi es 64kb. Yo he compilado la versión 14.07 por un u-boot de 64kb y no me dado cuenta que de Pteridium es diferente.

sospecho que eso es el origen de problema.

voy compilar una imagen que tiene en cuenta un u-boot de 128kb y la compartiré en unos minutes


medber

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1068 en: 22-02-2015, 14:56 (Domingo) »
@DAIkiri2KS

Aquí están para el RO1A:

14.07 por ARV4518 con luci y u-boot ( bnrboot ) de Pteridium
https://docs.google.com/file/d/0BzBSJsSR-T9ib2dHRmtkak1jTDA

14.07 por ARV4518 sin luci y u-boot ( bnrboot ) de Pteridium
https://docs.google.com/file/d/0BzBSJsSR-T9iTXgxRnd5ajcwLVk

Por favor comprueba si funcionan y el resultado  ;)


A mi me dieron un Kernel Panic con u-boot de CieNTi
Código: [Seleccionar]
[    0.576000] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    0.580000] Please append a correct "root=" boot option; here are the available partitions:
[    0.588000] 1f00             128 mtdblock0  (driver?)
[    0.596000] 1f01             256 mtdblock1  (driver?)
[    0.600000] 1f02            3648 mtdblock2  (driver?)
[    0.604000] 1f03              64 mtdblock3  (driver?)
[    0.608000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

« Última modificación: 22-02-2015, 15:28 (Domingo) por medber »

medber

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1069 en: 22-02-2015, 17:02 (Domingo) »
Si todavía las ultimas imágenes no funcionen vuelve a flashear el 12.09 y dame el resultado de

Código: [Seleccionar]
cat /proc/mtd

A mi me sale
Código: [Seleccionar]
root@OpenWrt:/# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00020000 00010000 "uboot"
mtd1: 00010000 00010000 "uboot_env"
mtd2: 003c0000 00010000 "linux"
mtd3: 000e5204 00010000 "kernel"
mtd4: 002dadfc 00010000 "rootfs"
mtd5: 000d0000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "board_config"

DAIkiri2KS

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1070 en: 22-02-2015, 18:21 (Domingo) »
Hola medber,

luego pruebo las imágenes y te cuento.

Saludos

DAIkiri2KS

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1071 en: 22-02-2015, 21:24 (Domingo) »
Con el firm que tengo actualmente Barrier Breaker 14.07 r43116 he hecho un cat /proc/mtd y este es el resultado:

Código: [Seleccionar]
root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00010000 00002000 "uboot"
mtd1: 00010000 00010000 "uboot_env"
mtd2: 003d0000 00010000 "firmware"
mtd3: 001098d5 00010000 "kernel"
mtd4: 002c672b 00010000 "rootfs"
mtd5: 00050000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "boardconfig"

Veo que no coincide con el tuyo, pruebo a flashear las ultimas compilaciones?


medber

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1072 en: 23-02-2015, 00:14 (Lunes) »
gracias DAIkiri2KS

Flashea las siguientes:

* para el ARV4518 R01A : OpenWRT 14.07 final (r42625) con LuCi + FPU, USB2, kmod-usb-storage,  kmod-scsi-core, Block-Mount y Ext4. Espacio flash libre = 108KB
https://docs.google.com/file/d/0BzBSJsSR-T9iQ0l5aEhtaDA5RlU

* para el ARV4518 R01A : OpenWRT 14.07 final (r42625) sin LuCi + FPU, USB2, kmod-usb-storage,  kmod-usb-storage-extras, kmod-scsi-core, Block-Mount y Ext4.  Espacio flash libre = 432KB
https://docs.google.com/file/d/0BzBSJsSR-T9iWHEzVHRrT1ZPQWM

esos dos van muy bien con la configuración siguiente :

Código: [Seleccionar]
root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00010000 00002000 "uboot"
mtd1: 00010000 00010000 "uboot_env"
mtd2: 003d0000 00010000 "firmware"
mtd3: 001098d5 00010000 "kernel"
mtd4: 002c672b 00010000 "rootfs"
mtd5: 00050000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "boardconfig"
« Última modificación: 23-02-2015, 00:15 (Lunes) por medber »

DAIkiri2KS

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1073 en: 24-02-2015, 19:56 (Martes) »
gracias DAIkiri2KS

Flashea las siguientes:

* para el ARV4518 R01A : OpenWRT 14.07 final (r42625) con LuCi + FPU, USB2, kmod-usb-storage,  kmod-scsi-core, Block-Mount y Ext4. Espacio flash libre = 108KB
https://docs.google.com/file/d/0BzBSJsSR-T9iQ0l5aEhtaDA5RlU

* para el ARV4518 R01A : OpenWRT 14.07 final (r42625) sin LuCi + FPU, USB2, kmod-usb-storage,  kmod-usb-storage-extras, kmod-scsi-core, Block-Mount y Ext4.  Espacio flash libre = 432KB
https://docs.google.com/file/d/0BzBSJsSR-T9iWHEzVHRrT1ZPQWM

esos dos van muy bien con la configuración siguiente :

Código: [Seleccionar]
root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00010000 00002000 "uboot"
mtd1: 00010000 00010000 "uboot_env"
mtd2: 003d0000 00010000 "firmware"
mtd3: 001098d5 00010000 "kernel"
mtd4: 002c672b 00010000 "rootfs"
mtd5: 00050000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "boardconfig"


Perdona medber, he estado bastante liado.

He probado ambas compilaciones y funcionan perfectamente, era por el tema del u-boot de Pteridium que es de 128kb.

Un saludo

pizcolq

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1074 en: 03-03-2015, 18:43 (Martes) »
Hola, acabo de instalar el openwrt a un ARV4518 y funcionando sin problemas. Mi desilusion viene por el hecho de que me doy cuenta que despues de instalar lo básico, lo que venia de serie, es de decir ADSL, interface web y USB, no queda espacio para nada más...

En concreto ha instalado la compilación creada por medber de pero me queda muy poquito espacio y no de deja instalar samba.

- Habria alguna posibilidad de instalar ADSL, Luci, DDNS, y Samba o me olvido del tema.
- He visto compilaciones en las que se instala USB, pero no Samba, por ejemplo la que yo he instalado. Mi pregunta es y disculpad mi torpeza, ¿que utildad tiene eso? quiero decir como se accede desde cualquier dispositivo a lo que tengas pinchado sin haber un servidor de por medio.

medber

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1075 en: 04-03-2015, 00:16 (Miércoles) »
prácticamente puede instalar todo los paquetes que quieres cuando conectas un usb o un disco duro externo formateado en Ext2/3/4 y activas extroot

brunorro

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1076 en: 04-03-2015, 17:46 (Miércoles) »
Buenas !!

EDITO (3)

He compilado para el ARV4518PR01 un trunk que he bajado hará unas horas, el 44621. Aquí tenéis disponibles la imagen y la configuración.

https://drive.google.com/open?id=0B1Kk1ydONmsHfjMybTgwWWp6Wk5HSFdWZ1MtMGJ4ZGkxdTRscTNlRnBxa3hYZTlNaTNUMkk&authuser=0

En el fichero https://drive.google.com/open?id=1fCq2bBCaf5IO0hTLMgyyE9Fqe6E_V9uIt65IzbmpwRE&authuser=0 está explicado lo que he ido descubriendo sobre cómo compilar trunk. Espero que sea de utilidad... He intentado explicarme, espero que no líe demasiado.

Por defecto, esta imagen intenta montar las siguientes particiones :
- /dev/sda1 como /overlay (reformatear en ext3 ó ext4 cada vez que se actualice la imagen)
- /dev/sda2 como /home (es persistente, no haría falta reformatearla cada vez)
- /dev/sda3 como swap (Si no se montase, hacer un mkswap)
Las tres particiones son opcionales: si alguna no existe no se montará. Es un poco chapuza tener esto hardcoded, pero no he visto forma de salvar el problema de tamaño manteniendo ethernet, wireless, ADSL y block-mount...

El .config que he puesto por defecto (haced un make menuconfig antes de compilar!) tiene:

- Toolchain: gcc 4.8 (con 4.9 la imagen era muy grande), uclibc (con musl también cabe pero no he conseguido hacerlo arrancar)
- ADSL (OJO: no me cupieron los módulos de VoIP), Ethernet y Wireless, ipv6 por defecto
- USB block mount de ext3/4 (OJO: sin vfat ni NTFS)
- ZRAM por defecto, danube crypto , cosas mías en busybox (opción -l de nc y applet renice)

De hecho, lo más importante para que todo cupiese fue subir el tamaño de bloque de squashfs al máximo, supongo que LZA en bloques de 1MB da mejores ratios de compresión que con los 256 por defecto. Ya he empezado directamente en modo "con paciencia y saliva el elefante se ... a la hormiga", ni he intentado meter luci ni similares. De hecho, ni he instalado los feeds (lo tengo pendiente cuando vea mejor si esto funciona)

Gracias a todos !
« Última modificación: 08-03-2015, 12:02 (Domingo) por brunorro »

Joseba30

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1077 en: 04-03-2015, 19:29 (Miércoles) »
Hola, acabo de instalar el openwrt a un ARV4518 y funcionando sin problemas. Mi desilusion viene por el hecho de que me doy cuenta que despues de instalar lo básico, lo que venia de serie, es de decir ADSL, interface web y USB, no queda espacio para nada más...

En concreto ha instalado la compilación creada por medber de pero me queda muy poquito espacio y no de deja instalar samba.

- Habria alguna posibilidad de instalar ADSL, Luci, DDNS, y Samba o me olvido del tema.
- He visto compilaciones en las que se instala USB, pero no Samba, por ejemplo la que yo he instalado. Mi pregunta es y disculpad mi torpeza, ¿que utildad tiene eso? quiero decir como se accede desde cualquier dispositivo a lo que tengas pinchado sin haber un servidor de por medio.

Instalas un pincho usb, instalas otros programas en el pincho, por ejemplo samba. un extroot de los de toda la vida vamos.  no te entra usb+otras cosas y empiezas por acceder al usb. Por otro lado mucha gente no usamos samba ni que nos paguen, talibanismo radical contra protocolos ponzoñosos de la wintendo. los ficheros por sftp, ftp, usando el servidor web, etc.

calhemp

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1078 en: 04-04-2015, 22:58 (Sábado) »
gracias DAIkiri2KS

Flashea las siguientes:

* para el ARV4518 R01A : OpenWRT 14.07 final (r42625) con LuCi + FPU, USB2, kmod-usb-storage,  kmod-scsi-core, Block-Mount y Ext4. Espacio flash libre = 108KB
https://docs.google.com/file/d/0BzBSJsSR-T9iQ0l5aEhtaDA5RlU

* para el ARV4518 R01A : OpenWRT 14.07 final (r42625) sin LuCi + FPU, USB2, kmod-usb-storage,  kmod-usb-storage-extras, kmod-scsi-core, Block-Mount y Ext4.  Espacio flash libre = 432KB
https://docs.google.com/file/d/0BzBSJsSR-T9iWHEzVHRrT1ZPQWM

esos dos van muy bien con la configuración siguiente :

Código: [Seleccionar]
root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00010000 00002000 "uboot"
mtd1: 00010000 00010000 "uboot_env"
mtd2: 003d0000 00010000 "firmware"
mtd3: 001098d5 00010000 "kernel"
mtd4: 002c672b 00010000 "rootfs"
mtd5: 00050000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "boardconfig"


solo decir.  tenia este router al cajon.

lo he actualizado hoy con este firmware con luci, y me ha funcionado correctamente la instalación.

lo tengo configurado para que se conecte al router principal inalambricamente.
de momento perfecto por cable y por wifi para mi uso.

este es mi /proc/mtb por si  interesa comparar.

root@OpenWrt-Garatge:/# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00010000 00002000 "uboot"
mtd1: 00010000 00010000 "uboot_env"
mtd2: 003d0000 00010000 "firmware"
mtd3: 000f6563 00010000 "kernel"
mtd4: 002d9a9d 00010000 "rootfs"
mtd5: 00050000 00010000 "rootfs_data"
mtd6: 00010000 00010000 "boardconfig"

no se que uboot le he puesto ;(. con tanto leer ya no se si es el de 64 o 128kb
se puede saber desde linea de comandos, por si puede ayudar a alguien mas.

MUCHAS GRACIAS a todos por el esfuerzo de preparar los firmwares, pues sin este foro y la buena gente, yo ni siquiera me huebiera aventurado a esto.

saludos.

muchas gracias

medber

  • Visitante
Re: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
« Respuesta #1079 en: 09-04-2015, 00:38 (Jueves) »
@calhemp 10000 en hexa da 64kb. Lo tienes todo en orden  ;)