Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 2013441 veces)

0 Usuarios y 1 Visitante están viendo este tema.

wishi2

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2180 en: 30-06-2014, 10:02 (Lunes) »
Es donde he mirado y no me aparece.
Intentaré instalar el firm desde cero a ver si el problema es que no me está acutalizando desde Luci.

Saludos.

Act: Flasehado desde cero ya me aparece el nodogsplash, ahora a pelearse con él.
Muchas Gracias.



« Última modificación: 30-06-2014, 10:20 (Lunes) por wishi2 »

pissmen

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2181 en: 30-06-2014, 13:53 (Lunes) »

Es donde he mirado y no me aparece.
Intentaré instalar el firm desde cero a ver si el problema es que no me está acutalizando desde Luci.

Saludos.

Act: Flasehado desde cero ya me aparece el nodogsplash, ahora a pelearse con él.
Muchas Gracias.

De nada!!

Ahora cuando termines de configurarlo, aporta al hilo un tuto para que los demás podamos aprender como lo has hecho.

Un saludo.

pissmen

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2182 en: 01-07-2014, 19:33 (Martes) »
Actualizo la versión anterior compartida por mi con esta "Barrier Breaker r41363", con los mismos paquetes anteriores, además de soporte para hostpot y webcam.

Podéis actualizar directamente guardando la configuración anterior (los que tenéis versiones compiladas por mi).

Enlace:
https://www.dropbox.com/s/kmhzwingp0glzio/r41363_openwrt-HW556-squashfs-cfe.bin

Próximamente añadiré soporte para módems 3g

Un saludo.

extrem69

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2183 en: 03-07-2014, 00:07 (Jueves) »
Hola, en primer lugar gracias a todos los que habeis hecho posible el openwrt para este router.

en segundo lugar.. he instalado el firmware r39304usb en mi router muerto de risa con la esperanza de poder usarlo como router 3G junto al modem que viene de origen, un K3765. Cundo he abierto la configuracion de este router he alucinado de la cantidad de opciones que hay con lo cual no tengo mucha idea al respecto de como configurarlo o si directamente funciona el modem 3g.

Podeis decirme si la version r39304usb soporta los modems 3g ? o debo usar una concreta? o mejor volver al firmware original si no voy a usar casi nada de openwrt? en caso de volver a stock, podeis indicarme la mejor version de firmware original o similar que debiera instalar ?

gracias

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Re: Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2184 en: 03-07-2014, 09:56 (Jueves) »
Hola, en primer lugar gracias a todos los que habeis hecho posible el openwrt para este router.

en segundo lugar.. he instalado el firmware r39304usb en mi router muerto de risa con la esperanza de poder usarlo como router 3G junto al modem que viene de origen, un K3765. Cundo he abierto la configuracion de este router he alucinado de la cantidad de opciones que hay con lo cual no tengo mucha idea al respecto de como configurarlo o si directamente funciona el modem 3g.

Podeis decirme si la version r39304usb soporta los modems 3g ? o debo usar una concreta? o mejor volver al firmware original si no voy a usar casi nada de openwrt? en caso de volver a stock, podeis indicarme la mejor version de firmware original o similar que debiera instalar ?

gracias
No, esta compilación no incluye el soporte para 3G.

Para volver al firmware original, te vale cualquiera.

enviado desde mi Onda v975i


parotris

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2185 en: 03-07-2014, 10:36 (Jueves) »
Buenas, necesito que me echéis una manos porque me acabo de cargar el openwrt :(

Resulta que desde hace unos días tengo un problema y es que si reinicio el router, es como si se corrompieran algunos archivos y pierdo la wifi, no puedo acceder por putty...

Tengo instalado ext-root en una usb, y cuando me pasa esto saco la usb, reinicio y funciona todo, por lo que lo iba solucionando volviendo a copiar el sistema de archivos del router en la usb y reiniciando con la usb.

El caso es que intentando averiguar el origen del problema, me cargué la carpeta /lib del router y ahora no hay manera de que arranque, se queda todo el rato con la luz de encender parpadeando, da igual que arranque con usb o sin usb.

¿hay alguna posible solución para restaurar la carpeta /lib?

Gracias y saludos.

extrem69

  • Visitante
Re: Re: Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2186 en: 03-07-2014, 11:36 (Jueves) »
Hola, en primer lugar gracias a todos los que habeis hecho posible el openwrt para este router.

en segundo lugar.. he instalado el firmware r39304usb en mi router muerto de risa con la esperanza de poder usarlo como router 3G junto al modem que viene de origen, un K3765. Cundo he abierto la configuracion de este router he alucinado de la cantidad de opciones que hay con lo cual no tengo mucha idea al respecto de como configurarlo o si directamente funciona el modem 3g.

Podeis decirme si la version r39304usb soporta los modems 3g ? o debo usar una concreta? o mejor volver al firmware original si no voy a usar casi nada de openwrt? en caso de volver a stock, podeis indicarme la mejor version de firmware original o similar que debiera instalar ?

gracias
No, esta compilación no incluye el soporte para 3G.

Para volver al firmware original, te vale cualquiera.

enviado desde mi Onda v975i




Pero esta version concreta que he instalado o cualquiera de las posteadas en el primer post?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Re: Re: Re: Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2187 en: 03-07-2014, 12:26 (Jueves) »
Hola, en primer lugar gracias a todos los que habeis hecho posible el openwrt para este router.

en segundo lugar.. he instalado el firmware r39304usb en mi router muerto de risa con la esperanza de poder usarlo como router 3G junto al modem que viene de origen, un K3765. Cundo he abierto la configuracion de este router he alucinado de la cantidad de opciones que hay con lo cual no tengo mucha idea al respecto de como configurarlo o si directamente funciona el modem 3g.

Podeis decirme si la version r39304usb soporta los modems 3g ? o debo usar una concreta? o mejor volver al firmware original si no voy a usar casi nada de openwrt? en caso de volver a stock, podeis indicarme la mejor version de firmware original o similar que debiera instalar ?

gracias
No, esta compilación no incluye el soporte para 3G.

Para volver al firmware original, te vale cualquiera.

enviado desde mi Onda v975i




Pero esta version concreta que he instalado o cualquiera de las posteadas en el primer post?
Todas las compilaciones indican los paquetes que llevan.
Busca alguna con soporte 3G (que creo que alguna hay a lo largo del hilo).

enviado desde mi Onda v975i


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Re: Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2188 en: 03-07-2014, 12:26 (Jueves) »
Buenas, necesito que me echéis una manos porque me acabo de cargar el openwrt :(

Resulta que desde hace unos días tengo un problema y es que si reinicio el router, es como si se corrompieran algunos archivos y pierdo la wifi, no puedo acceder por putty...

Tengo instalado ext-root en una usb, y cuando me pasa esto saco la usb, reinicio y funciona todo, por lo que lo iba solucionando volviendo a copiar el sistema de archivos del router en la usb y reiniciando con la usb.

El caso es que intentando averiguar el origen del problema, me cargué la carpeta /lib del router y ahora no hay manera de que arranque, se queda todo el rato con la luz de encender parpadeando, da igual que arranque con usb o sin usb.

¿hay alguna posible solución para restaurar la carpeta /lib?

Gracias y saludos.
Y si vuelves a flashear el firmware ?

enviado desde mi Onda v975i


parotris

  • Visitante
Re: Re: Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2189 en: 03-07-2014, 23:50 (Jueves) »
Buenas, necesito que me echéis una manos porque me acabo de cargar el openwrt :(

Resulta que desde hace unos días tengo un problema y es que si reinicio el router, es como si se corrompieran algunos archivos y pierdo la wifi, no puedo acceder por putty...

Tengo instalado ext-root en una usb, y cuando me pasa esto saco la usb, reinicio y funciona todo, por lo que lo iba solucionando volviendo a copiar el sistema de archivos del router en la usb y reiniciando con la usb.

El caso es que intentando averiguar el origen del problema, me cargué la carpeta /lib del router y ahora no hay manera de que arranque, se queda todo el rato con la luz de encender parpadeando, da igual que arranque con usb o sin usb.

¿hay alguna posible solución para restaurar la carpeta /lib?

Gracias y saludos.
Y si vuelves a flashear el firmware ?

enviado desde mi Onda v975i



Al final es lo que he hecho, pero tengo un cacao montado en el ext-root que creo que voy a reinstalar todo de cero, con paciencia...


Actualizo la versión anterior compartida por mi con esta "Barrier Breaker r41363", con los mismos paquetes anteriores, además de soporte para hostpot y webcam.

Podéis actualizar directamente guardando la configuración anterior (los que tenéis versiones compiladas por mi).

Enlace:
https://www.dropbox.com/s/kmhzwingp0glzio/r41363_openwrt-HW556-squashfs-cfe.bin

Próximamente añadiré soporte para módems 3g

Un saludo.


¿Esta compilación tiene FPU emulation?.

Una última pregunta, veo que todos compilais con el transmission instalado, ¿no os funciona mejor el rtorrent? A mí el transmission me consume muchos recursos y si lo tengo funcionando junto con el servidor oscam y a usar el ftp, me empieza a ir a tirones todo porque el cpu se pone al 100%, sin embargo con el rtorrent no me pasa. ¿es normal o es que tendré algo mal?

Saludos.

pissmen

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2190 en: 04-07-2014, 00:00 (Viernes) »

Buenas, necesito que me echéis una manos porque me acabo de cargar el openwrt :(

Resulta que desde hace unos días tengo un problema y es que si reinicio el router, es como si se corrompieran algunos archivos y pierdo la wifi, no puedo acceder por putty...

Tengo instalado ext-root en una usb, y cuando me pasa esto saco la usb, reinicio y funciona todo, por lo que lo iba solucionando volviendo a copiar el sistema de archivos del router en la usb y reiniciando con la usb.

El caso es que intentando averiguar el origen del problema, me cargué la carpeta /lib del router y ahora no hay manera de que arranque, se queda todo el rato con la luz de encender parpadeando, da igual que arranque con usb o sin usb.

¿hay alguna posible solución para restaurar la carpeta /lib?

Gracias y saludos.
Y si vuelves a flashear el firmware ?

enviado desde mi Onda v975i



Al final es lo que he hecho, pero tengo un cacao montado en el ext-root que creo que voy a reinstalar todo de cero, con paciencia...


Actualizo la versión anterior compartida por mi con esta "Barrier Breaker r41363", con los mismos paquetes anteriores, además de soporte para hostpot y webcam.

Podéis actualizar directamente guardando la configuración anterior (los que tenéis versiones compiladas por mi).

Enlace:
https://www.dropbox.com/s/kmhzwingp0glzio/r41363_openwrt-HW556-squashfs-cfe.bin

Próximamente añadiré soporte para módems 3g

Un saludo.


¿Esta compilación tiene FPU emulation?.

Una última pregunta, veo que todos compilais con el transmission instalado, ¿no os funciona mejor el rtorrent? A mí el transmission me consume muchos recursos y si lo tengo funcionando junto con el servidor oscam y a usar el ftp, me empieza a ir a tirones todo porque el cpu se pone al 100%, sin embargo con el rtorrent no me pasa. ¿es normal o es que tendré algo mal?

Saludos.
La verdad es que no he probado el rtorrent. Desde que utilizo el router instalo transmission porque me gustó su sencillez. Tienes razón en que consume muchos recursos, llegando a reiniciarse el router cuando transmission tiene mucha carga. Para la próxima voy a poner rtorrent a ver que tal.

Una pregunta: para que utilizas oscam???

Un saludo.

parotris

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2191 en: 04-07-2014, 09:55 (Viernes) »
Es cierto que el transmission es más sencillo y más fácil de instalar, pero el problema es ese, a mí también se me reiniciaba en ocasiones, sobretodo con torrents muy pesados. Con el rtorrent cero problemas.

El oscam es un cliente/servidor multiprotocolo (cccam, newcamd, radegast, mbox, etc) y lo uso pues... para eso jejeje, cardsharing, no se si puede hablar mucho de eso por aquí ;)

¿Tus firmwares llevan activada la FPU emulation?

Saludos.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2192 en: 04-07-2014, 13:21 (Viernes) »
Yo hace mucho que me pasé a rtorrent.
Las versiones recientes de transmission me daban bastantes problemas  :'(

parotris

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2193 en: 04-07-2014, 14:18 (Viernes) »
Me lo parecía...
Pues ya puestos, ¿podíais compilar con el rtorrent en vez de con el transmission?  ^-^

Otro tema:
He estado trasteando para tratar de reparar el cacao que tengo en el ext-root y no tener que volver a instalar todo de cero y he arreglado casi todo, me quedan 2 problemas, os cuento

1.- El blkid me funciona perfectamente, pero si uso block info me sale esto:
Código: [Seleccionar]
block: can't resolve symbol 'md5_begin' in lib 'block'.
¿A qué puede ser debido?

2.- El origen de todos los problemas que tengo es que, a veces, al resetear el router, me quedaba sin wifi, no había forma de activarla.
Bien, he probado a borrar el fichero de configuración de la wifi con rm /etc/config/wireless y volver a generarlo con wifi detect > /etc/config/wireless
El resultado es que lo borra bien, pero al tratar de generarlo me sale lo siguiente:

Código: [Seleccionar]
ls: /sys/class/ieee80211: No such file or directory
El caso es que mirando la usb, veo que el directorio sys estaba vacio, he tratado de copiarlo del sistema de archivos del router, pero me da errores y, entre otros, no me copia el directorio /sys/class/ieee80211

¿Alguna solución que no sea muy enfarragosa? Porque sino me cargo todo y empiezo de cero con una nueva compilación  :-\

Saludos.


pissmen

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2194 en: 04-07-2014, 16:15 (Viernes) »

Es cierto que el transmission es más sencillo y más fácil de instalar, pero el problema es ese, a mí también se me reiniciaba en ocasiones, sobretodo con torrents muy pesados. Con el rtorrent cero problemas.

El oscam es un cliente/servidor multiprotocolo (cccam, newcamd, radegast, mbox, etc) y lo uso pues... para eso jejeje, cardsharing, no se si puede hablar mucho de eso por aquí ;)

¿Tus firmwares llevan activada la FPU emulation?

Saludos.

Si, lleva activo FPU emulation.

Un saludo.

pissmen

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2195 en: 04-07-2014, 16:19 (Viernes) »

Hola, en primer lugar gracias a todos los que habeis hecho posible el openwrt para este router.

en segundo lugar.. he instalado el firmware r39304usb en mi router muerto de risa con la esperanza de poder usarlo como router 3G junto al modem que viene de origen, un K3765. Cundo he abierto la configuracion de este router he alucinado de la cantidad de opciones que hay con lo cual no tengo mucha idea al respecto de como configurarlo o si directamente funciona el modem 3g.

Podeis decirme si la version r39304usb soporta los modems 3g ? o debo usar una concreta? o mejor volver al firmware original si no voy a usar casi nada de openwrt? en caso de volver a stock, podeis indicarme la mejor version de firmware original o similar que debiera instalar ?

gracias

Prueba con la r41363, aunque pongo que próximamente compilare con soporte 3G es posible que esa lo lleve.

Un saludo.

parotris

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2196 en: 07-07-2014, 13:36 (Lunes) »
Actualizo la versión anterior compartida por mi con esta "Barrier Breaker r41363", con los mismos paquetes anteriores, además de soporte para hostpot y webcam.

Podéis actualizar directamente guardando la configuración anterior (los que tenéis versiones compiladas por mi).

Enlace:
https://www.dropbox.com/s/kmhzwingp0glzio/r41363_openwrt-HW556-squashfs-cfe.bin

Próximamente añadiré soporte para módems 3g

Un saludo.


Hola, he instalado esa compilación y tengo un problema.
He configurado la red, el wifi, he creado un usuario, he instalado el oscam y he desinstalado el nodogsplash (porque no lo voy a usar).
Después de todo esto, al entrar en instalación de programas, no puedo ver los paquetes que tengo instalados, me sale este error:

Código: [Seleccionar]
500 Error interno del servidor
El servidor encontró un error inesperado.

/usr/lib/lua/luci/dispatcher.lua:448: Failed to execute call dispatcher target for entry '/admin/system/packages'.
The called action terminated with an exception:
/usr/lib/lua/luci/template.lua:104: Failed to execute template 'admin_system/packages'.
A runtime error occured: [string "/usr/lib/lua/luci/view/admin_system/package..."]:38: table index is nil
stack traceback:
[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:448: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:195: in function

El caso es que lo único que he tocado ahí ha sido desinstalar el nodogsplash, ya que el oscam ni siquiera se instala, es un archivo ejecutable que lo meto en /usr/bin y listo.

¿Alguna solución?

Saludos y gracias de antemano.

parotris

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2197 en: 07-07-2014, 13:47 (Lunes) »
Otro detalle, con el comando opkg list-installed desde putty, sí que me salen los paquetes instalados, pero veo este error:

Código: [Seleccionar]
Package kmod-usb2 version (null) has no valid architecture, ignoring.
Saludos.

parotris

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2198 en: 07-07-2014, 13:52 (Lunes) »
Solucionado forzando la actualización del módulo kmod-usb2... por si le pasa a alguien más.

Saludos.

jbconpepsi

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2199 en: 09-07-2014, 09:28 (Miércoles) »
Es cierto que el transmission es más sencillo y más fácil de instalar, pero el problema es ese, a mí también se me reiniciaba en ocasiones, sobretodo con torrents muy pesados. Con el rtorrent cero problemas.

El oscam es un cliente/servidor multiprotocolo (cccam, newcamd, radegast, mbox, etc) y lo uso pues... para eso jejeje, cardsharing, no se si puede hablar mucho de eso por aquí ;)

¿Tus firmwares llevan activada la FPU emulation?

Saludos.

¿Oscam funciona bien en el router? ¿Como lo has instalado?

Gracias y saludos.