Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 1994709 veces)

0 Usuarios y 3 Visitantes están viendo este tema.

tool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2220 en: 31-07-2014, 12:46 (Jueves) »
Las compilaciones que he subido funcionan perfectamente con ralink. Lee detenidamente los comentarios que se le hace al respecto en la primera que subí. Actualmente tengo 3 routers funcionando con la última. Dos de ellos como repetidores.
Saludos.

Apagando encendiendo quitando el Wifi, he conseguido que funcione, ahora voy a configurar bien a mano .

Sobre el modo repetidor, lo tienes en modo repetidor funcionando en la misma red? Sin relayd?
Voy a ver si lo configuro correctamente para usar de repetidor transparente como el típico:
http://www.amazon.es/Netgear-WN3000RP-Extensor-antenas-externas/dp/B004XACSV2/
Netgear WN300RP

Además de poder usar por Cable



pissmen

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2221 en: 31-07-2014, 18:33 (Jueves) »

Las compilaciones que he subido funcionan perfectamente con ralink. Lee detenidamente los comentarios que se le hace al respecto en la primera que subí. Actualmente tengo 3 routers funcionando con la última. Dos de ellos como repetidores.
Saludos.

Apagando encendiendo quitando el Wifi, he conseguido que funcione, ahora voy a configurar bien a mano .

Sobre el modo repetidor, lo tienes en modo repetidor funcionando en la misma red? Sin relayd?
Voy a ver si lo configuro correctamente para usar de repetidor transparente como el típico:
http://www.amazon.es/Netgear-WN3000RP-Extensor-antenas-externas/dp/B004XACSV2/
Netgear WN300RP

Además de poder usar por Cable

Para no tener problemas instala el firmware desde recovery. Una vez que lo inicies por primera vez vas a wifi y lo habilitas. Reinicias  y listo. Lo tengo como repetidor dentro de una red sin ningún tipo de problemas. El rendimiento es bastante bueno contando con que me extiende la red a otro edificio. Me repite la red de mi oficina hasta mi casa y siempre está por encima de 100.

tool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2222 en: 31-07-2014, 19:09 (Jueves) »
Para no tener problemas instala el firmware desde recovery. Una vez que lo inicies por primera vez vas a wifi y lo habilitas. Reinicias  y listo. Lo tengo como repetidor dentro de una red sin ningún tipo de problemas. El rendimiento es bastante bueno contando con que me extiende la red a otro edificio. Me repite la red de mi oficina hasta mi casa y siempre está por encima de 100.

Lo tengo conectado como Cliente funcionando ahora mismo a 300mbit, pero no me funciona el acceso a la subred principal antes podía acceder sin problemas pero no al revés.

A ver si logro configurarlo correctamente por SSH para que esté en la misma subred a poder ser.
 
ADSL ---> Tp-link 1043 con Gargoyle + WIFI -->NAS por giga eth
Otra habitación HG556a modo cliente para HTPC+Consolas y posibilidad de Repetidor!!!!

La finalidad es tener acceso Wifi-LAn a 12mb/s (100mbit), mientras no termino de cablear.


Cristof_Romuard

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2223 en: 31-07-2014, 20:18 (Jueves) »
jar229

Con el ultimo firm que subiste no tengo jojones de activar el samba... ¿Sabes si a alguien mas le a pasado?

Un saludo y gracias por el curro.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2224 en: 02-08-2014, 12:51 (Sábado) »
jar229

Con el ultimo firm que subiste no tengo jojones de activar el samba... ¿Sabes si a alguien mas le a pasado?

Un saludo y gracias por el curro.

Ya no tengo ningún router de estos para probar ...  ^-^

Pero vamos, que tienes compilaciones 'a patadas' para testear  ;D

Incluso puedes probar la RC_2 de Barrier Braker (bajándola de los servidores de OpenWrt). Ojo, si necesitas la FPU emulation, entonces no te vale.

sianeu

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2225 en: 07-08-2014, 20:04 (Jueves) »
Quería usar mi viejo HG556a versión HG55VDFA VER.C como repetidor wiffi. He entrado como admin y desde allí he actualizado el firm con el  r39304usb.

Pero después de reiniciarse el router, el navegador no puede conectar, y tampoco consigo volver a resetear el router por mucho tiempo que pase apretando el reset.

Ha muerto o hay alguna otra manera de repetir el proceso o colocarle otro firm?

pd: tampoco puedo entrar en modo failsafe
« Última modificación: 07-08-2014, 20:19 (Jueves) por sianeu »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2226 en: 08-08-2014, 08:34 (Viernes) »
Quería usar mi viejo HG556a versión HG55VDFA VER.C como repetidor wiffi. He entrado como admin y desde allí he actualizado el firm con el  r39304usb.

Pero después de reiniciarse el router, el navegador no puede conectar, y tampoco consigo volver a resetear el router por mucho tiempo que pase apretando el reset.

Ha muerto o hay alguna otra manera de repetir el proceso o colocarle otro firm?

pd: tampoco puedo entrar en modo failsafe

Algo haces mal ... seguro.

Después de instalar OpenWrt la nueva IP del router es 192.168.1.1

Con respecto a entrar al CFE para volver a flashear, hay que apretar el botón/pulsador por más de 20 segundos.

sianeu

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2227 en: 09-08-2014, 10:38 (Sábado) »
Tampoco entra con el 192.168.1.1. Probé incluso con el 192.168.2.1. Firefox dice que no puede establecer conexión con el servidar.

También probé por telnet:
sianeu@unicorn:~$ telnet 192.168.1.1
Trying 192.168.1.1...
telnet: Unable to connect to remote host: No route to host
Lo mismo con Putty.

He pasado casi dos minutos con el reset apretado con un clip (se nota que está apretado, hace un clic al pulsar o soltar) pero el router ni se inmuta.

Hay algo más que se pueda probar?

petris1

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2228 en: 09-08-2014, 12:06 (Sábado) »
No es el reset, es el restart

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: Re: Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2229 en: 09-08-2014, 12:08 (Sábado) »
No es el reset, es el restart
Ese es el problema ... que no se lee uno las cosas con calma ;)

Enviado desde uno de mis 'cacharros' usando Tapatalk


sianeu

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2230 en: 09-08-2014, 20:41 (Sábado) »
No si también la probé con restart, pero como para ponerlo de fábrica para poder entrar como admin lo conseguí por el reset.....
Incluso llegué a probar, por qué se yo, de salir de Ubuntu y probar en Windows, y ZAS!!!! va y funciona (entro en Luci). En el mismo momento caigo que en Ubuntu tengo configuradas las ip fijas (a la puerta 192.168.0.1, claro). No digais nada, ya me di de cabezazos......

Ahora tengo que configurarlo para hacer de repetidor wiffi. Conectar al rourter principal por wiffi i repetir la señal para otro pc-wiffi. Podrías indicarme el hilo adecuado para guiarme? De momento lo tengo conectado al pc por cable. He entrado en redes wiffi, ha encontrado mi red, parece que se conecte pero dice 0% Wireless is disabled or not associated

Gracias

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re:
« Respuesta #2231 en: 09-08-2014, 22:01 (Sábado) »
Mira los hilos más relevantes. Tienes un estupendo índice con un enlace al tutorial que te hace falta.

Enviado desde uno de mis 'cacharros' usando Tapatalk


sianeu

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2232 en: 12-08-2014, 20:07 (Martes) »
No si ya había leído un montón..... Lo que pasaba es que tengo filtro mac en el router principal y la mac del openWrt NO es la que lleva escrita detrás. Debí suponerlo, pero tampoco estaba tan claro.

Ahora ya conecta con el router principal por wifi y puedo navegar por internet conectado por cable al OpenWrt-HW556a, pero no puedo conectarme con éste por wifi.

Seguí el tutorial de Noltari, porque parece muy claro y ordenado, aunque no usa el mismo firmware (por eso mi petición de recomendación). Así que supongo que lo más adequado será preguntar en ese hilo.

Gracias

quetzalin

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2233 en: 17-08-2014, 21:58 (Domingo) »
Acabo de compilar una version trunk para este router y me ha sacado 3 firm; openwrt-HW556-A-squashfs-cfe.bin , openwrt-HW556-B-squashfs-cfe.bin , openwrt-HW556-C-squashfs-cfe.bin

¿Lo de A, B o C que va en funcion de la Vdf Version que sale en la wiki de openwrt sobre este equipo?. Es decir, si tengo un VER.A (vamos el que lleva wifi Ralink) tendria que usar openwrt-HW556-C-squashfs-cfe.bin o en su defecto es mas simple y sencillamente tengo que usar openwrt-HW556-A-squashfs-cfe.bin ?.

Menudo lio...

Sinceramente no entiendo por que saca 3 firm diferentes si cuando compilas no hay perfil y hay que seleccionar manualmente el target profile segun el chip wifi que lleva...


EDIT: La ultima version trunk ya me ha sacado de dudas, desde ayer o asi hay un perfil para las diferentes versiones de este router, no se si ha sido casualidad o que Noltari ha leido esto :P, en cualquier caso gracias!.

En definitiva, para la version con wifi Ralink es la C la que hay que usar.
« Última modificación: 20-08-2014, 13:09 (Miércoles) por quetzalin »

xexudj89

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2234 en: 21-08-2014, 20:20 (Jueves) »
He instalado el firmware r39304usb en el HG556A va bastante bien, mi pregunta es, me ha parecido leer que se le puede conectar a los puertos USB, otro dispositivo wifi? por ejemplo un TP LINK  TL-WN722N. Seria posible? se podría montar un servidor de team speak?

Un saludo a todos.

PD: que mas se puede instalar?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2235 en: 21-08-2014, 20:31 (Jueves) »
He instalado el firmware r39304usb en el HG556A va bastante bien, mi pregunta es, me ha parecido leer que se le puede conectar a los puertos USB, otro dispositivo wifi? por ejemplo un TP LINK  TL-WN722N. Seria posible? se podría montar un servidor de team speak?

Un saludo a todos.

PD: que mas se puede instalar?

Sí, le puedes conectar un 'pincho' wifi USB. Cómo hacerlo ... lo tienes explicado en las FAQ.

Sobre team speak ... ni idea  ^-^

Y con respecto a qué le puedes instalar ... cientos de aplicaciones, para casi cualquier uso. Lee por el foro y sacarás ideas  ;)

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2236 en: 22-08-2014, 11:40 (Viernes) »
Acabo de compilar una version trunk para este router y me ha sacado 3 firm; openwrt-HW556-A-squashfs-cfe.bin , openwrt-HW556-B-squashfs-cfe.bin , openwrt-HW556-C-squashfs-cfe.bin

¿Lo de A, B o C que va en funcion de la Vdf Version que sale en la wiki de openwrt sobre este equipo?. Es decir, si tengo un VER.A (vamos el que lleva wifi Ralink) tendria que usar openwrt-HW556-C-squashfs-cfe.bin o en su defecto es mas simple y sencillamente tengo que usar openwrt-HW556-A-squashfs-cfe.bin ?.

Menudo lio...

Sinceramente no entiendo por que saca 3 firm diferentes si cuando compilas no hay perfil y hay que seleccionar manualmente el target profile segun el chip wifi que lleva...


EDIT: La ultima version trunk ya me ha sacado de dudas, desde ayer o asi hay un perfil para las diferentes versiones de este router, no se si ha sido casualidad o que Noltari ha leido esto :P, en cualquier caso gracias!.

En definitiva, para la version con wifi Ralink es la C la que hay que usar.
El parche ya estaba mandado antes de leer el mensaje: http://patchwork.openwrt.org/patch/6104/
Tenéis que tener en cuenta que esto es una versión trunk (puede haber periodos de tiempo en los que ciertas cosas estén mal o no funcionen) y que desde que se mandan parches hasta que se aceptan pasan algunos días.
Keep calm...

He instalado el firmware r39304usb en el HG556A va bastante bien, mi pregunta es, me ha parecido leer que se le puede conectar a los puertos USB, otro dispositivo wifi? por ejemplo un TP LINK  TL-WN722N. Seria posible? se podría montar un servidor de team speak?

Un saludo a todos.

PD: que mas se puede instalar?
Sí, se pueden conectar otros dispositivos WiFi, siempre que haya driver open source para linux.
No, no se puede montar un servidor de TeamSpeak, puesto que el código es propietario y TeamSpeak sólo libera binarios compilados para x86_64.
Lo que sí podrías montar sería un servidor Mumble, ya que sí es open source.

Saludos.

xexudj89

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2237 en: 22-08-2014, 23:36 (Viernes) »
Hola a todos intento instalar los drivers para una alfa de 1w (RTL 8187l) y para la alfa negra (atheros AR9271) y sigo los pasos que pone aquí
https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/

y al poner esto opkg update  opkg install usbutils me salta esto:    
root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/Packa                            ges.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trun                            k/brcm63xx/packages/Packages.gz, wget

returned 1.

Tengo esto instalado:

Sistema
Nombre de máquina   OpenWrt
Model   Unknown
Versión del firmware   OpenWrt Barrier Breaker r39304 / LuCI Trunk (svn-r9948)
« Última modificación: 23-08-2014, 00:59 (Sábado) por Nexus89 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2238 en: 23-08-2014, 12:11 (Sábado) »
Hola a todos intento instalar los drivers para una alfa de 1w (RTL 8187l) y para la alfa negra (atheros AR9271) y sigo los pasos que pone aquí
https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/

y al poner esto opkg update  opkg install usbutils me salta esto:    
root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/Packa                            ges.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trun                            k/brcm63xx/packages/Packages.gz, wget

returned 1.

Tengo esto instalado:

Sistema
Nombre de máquina   OpenWrt
Model   Unknown
Versión del firmware   OpenWrt Barrier Breaker r39304 / LuCI Trunk (svn-r9948)

Esa compilación, en teoría, ya lleva los drivers que necesitas.

Para que te detecte correctamente el 'pincho' wifi USB, una vez que lo hayas conectado, desde una sesión ssh (si usas windows puedes hacerlo con putty) escribe lo siguiente:

Código: [Seleccionar]
wifi detect > /etc/config/wireless
Si todo ha ido correctamente, ahora deberías tener 2 interfaces en el apartado Wifi.

Eso sí, se ha repetido muchas veces, que la alfa con rtl8187 en OpenWrt va fatal ... ^-^
« Última modificación: 23-08-2014, 12:48 (Sábado) por jar229 »

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2239 en: 23-08-2014, 13:30 (Sábado) »
Hola a todos intento instalar los drivers para una alfa de 1w (RTL 8187l) y para la alfa negra (atheros AR9271) y sigo los pasos que pone aquí
https://foro.seguridadwireless.net/openwrt/(faq)-preguntas-mas-comunes-sobre-openwrt/

y al poner esto opkg update  opkg install usbutils me salta esto:    
root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/Packa                            ges.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trun                            k/brcm63xx/packages/Packages.gz, wget

returned 1.

Tengo esto instalado:

Sistema
Nombre de máquina   OpenWrt
Model   Unknown
Versión del firmware   OpenWrt Barrier Breaker r39304 / LuCI Trunk (svn-r9948)
Buenas, tal y como te dice jar, ya deberías tener los drivers instalados.
Si quieres instalar paquetes adicionales, he añadido cierta información a este post:
https://foro.seguridadwireless.net/openwrt/barrier-breaker-14-07/msg313083/#msg313083

Saludos.