?>/script>'; } ?> [Desarrollo] OpenWrt en Huawei HG556a Widgets Magazine

Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 2123819 veces)

0 Usuarios y 6 Visitantes están viendo este tema.

faio86

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2740 en: 17-02-2016, 12:07 (Miércoles) »
Hola ya he conseguido poner la version rtorrent-rpc 0.9.6 y funciona con rutorrent version 3.7 https://github.com/Novik/ruTorrent

Gracias.

juandi_89

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2741 en: 17-02-2016, 20:07 (Miércoles) »

Después de flashearlo, el router tiene la dirección 192.168.1.1 ¿Has cambiado tu IP a una adecuada para poder acceder al router?
El método de recuperación pulsando el botón de reset debe funcionarte en esa dirección.


Gracias por conseguir que averiguara mi novatada xD

Resulta que al ver que en todos los tutoriales indicaban la dirección 192.168.1.1 para entrar al router y yo tenía entraba antes de flashearlo a la 192.168.0.1 me había quedado estancado pensando que tenía que seguir poniendo el 192.168.0.1. para llegar al router y 192.168.0.2 como IP estática...

Vamos, que así normal que no funcionara el RESTART ni nada. Qué pardillo he sido jaja

Ya tengo todo configurado y el modo repetidor funcionando a la perfección.  >:(

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4607
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2742 en: 18-02-2016, 09:21 (Jueves) »
Hola ya he conseguido poner la version rtorrent-rpc 0.9.6 y funciona con rutorrent version 3.7 https://github.com/Novik/ruTorrent

Gracias.

Y no se te ha presentado ningún problema en la configuración de rutorrent ?

La verad es que esto iría mejor en el hilo del hg553, que es dónde está el tutorial de rtorrent + rutorrent  ^-^

faio86

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2743 en: 18-02-2016, 16:00 (Jueves) »
« Última modificación: 18-02-2016, 16:10 (Jueves) por faio86 »

ZID

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2744 en: 19-02-2016, 10:53 (Viernes) »
Hola chicos, quería haceros una pregunta. Tengo un Huawei HG556a que ahora mismo para ADSL y quiero pasarme a Wimax.

Me indican que necesito un router neutro y hasta ahí llego, pero me preguntaba su instalando OpenWrt  a mi HG556a podría usar uno de los puertos LAN como WAN para poder conectarme a Wimax

Otra pregunta que tengo es que, si llegado el caso no se pudiera, y tuviera que comprar un router neutro (el tp link 841N me gusta bastante), me gustaría saber si se podría conectar el HG556a al tp link para usar voip y que inyecte la señal a las rosetas.

Gracias!

Warryor

  • Visitante

ZID

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2746 en: 19-02-2016, 11:12 (Viernes) »
Olvidé preguntar que si consigo con OpenWrt en un Huawei HG556a conectarme a wimax usando un puerto LAN como si fuera uno WAN, podre tambien usar VOIP o si en ese caso se pierde. Imagino que dependera de que OpenWrt permita configurar VOIP. ¿Alguien lo sabe?

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2247
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2747 en: 19-02-2016, 11:25 (Viernes) »
Olvidé preguntar que si consigo con OpenWrt en un Huawei HG556a conectarme a wimax usando un puerto LAN como si fuera uno WAN, podre tambien usar VOIP o si en ese caso se pierde. Imagino que dependera de que OpenWrt permita configurar VOIP. ¿Alguien lo sabe?

¿Qué clase de VOIP? Si te refieres a conectar directamente teléfonos a los puertos de teléfono del HG566a, no podrás. Lo pierdes, junto con la funcionalidad ADSL.

ZID

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2748 en: 19-02-2016, 11:32 (Viernes) »
Olvidé preguntar que si consigo con OpenWrt en un Huawei HG556a conectarme a wimax usando un puerto LAN como si fuera uno WAN, podre tambien usar VOIP o si en ese caso se pierde. Imagino que dependera de que OpenWrt permita configurar VOIP. ¿Alguien lo sabe?

¿Qué clase de VOIP? Si te refieres a conectar directamente teléfonos a los puertos de teléfono del HG566a, no podrás. Lo pierdes, junto con la funcionalidad ADSL.

Gracias por la respuesta. La duda era esa, si. Recapitulando.

Con OpenWrt en un Huawei HG556a puedo usar un puerto LAN como WAN y tenerlo como router neutro para conectarme a Wimax, pero no podre usar sus puertos para voip. ¿Entonces necesitaria un adaptador para voip conectado al router?

Por otro lado, si uso un router neutro (tp link 841N) para conectarme a wimax, ¿podría conectar el HG556a al tp link para usar voip y que reinyecte la señal a las rosetas? En este caso hablo de usar el firm de vodafone, claro.

Gracias!
« Última modificación: 19-02-2016, 11:35 (Viernes) por ZID »

Warryor

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2749 en: 19-02-2016, 14:54 (Viernes) »
Mira esto, puede que te interese https://github.com/pgid69/bcm63xx-phone

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2247
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2750 en: 19-02-2016, 17:21 (Viernes) »
Mira esto, puede que te interese https://github.com/pgid69/bcm63xx-phone

Estar está, pero nadie lo ha probado todavía. Si alguien se atreve, sería un detalle...  ;)

alemap

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2751 en: 19-02-2016, 23:36 (Viernes) »
Hola, y gracias por el foro,

voy a intentar explicar una cosa que no entiendo por si alguien me puede ayudar:

llevo tiempo usando la imagen r39304usb.openwrt-HW556-squashfs-cfe.bin que colgó jar229, que parece que está a prueba de bombas, todo perfecto, funciona bien, pero queria actualizar a la chaos_calmer.

el caso es que tengo:
HW version: HG55VDFA VER.C
con serial: 30634...
por tanto segun la wiki de OpenWRT tengo que instalar la B

pues me pongo a ello tan contento se instala bien pero error pci 0000:00:01.0: invalid calibration data

bien tengo una copia de mi cal_data y en este mismo foro se habla de ello, gracias a Noltari, pero pensé, ¿por qué tengo que restaurar esto si yo no lo he borrado en ningun momento y se supone que al instalar el firmware tampoco lo toca?

asi que volví a instalarle la imagen r39304usb y efectivamente volvió a funcionar, despuésde esto y de leer un poco mas sobre el tema e instalar y desinstalar diferentes versiones todas HG556a_B... le instalé la A HG556a_A en concreto la openwrt-15.05-brcm63xx-generic-HG556a_A-squashfs-cfe.bin y funcionó!!!  y esto ya me rompió la cabeza...

(funcionó parcialmente , configuré el wifi, el radar detecta pero solo hay internet en el momento justo en el que se conecta despues aunque hay buena señal no navega,,quizas mala configuracion mia del wireless)

en fin, mi pregunta es ¿Por que HG556a_B error invalid calibration data y en HG556a_A no, cuando me he asegurado que mi serial empieza con 30634?
¿Que hago, le restauro el cal-data a ver que pasa, aunque estoy casi seguro que ya tiene la correcta?


danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2752 en: 20-02-2016, 00:30 (Sábado) »
Hola, y gracias por el foro,

voy a intentar explicar una cosa que no entiendo por si alguien me puede ayudar:

llevo tiempo usando la imagen r39304usb.openwrt-HW556-squashfs-cfe.bin que colgó jar229, que parece que está a prueba de bombas, todo perfecto, funciona bien, pero queria actualizar a la chaos_calmer.

el caso es que tengo:
HW version: HG55VDFA VER.C
con serial: 30634...
por tanto segun la wiki de OpenWRT tengo que instalar la B

pues me pongo a ello tan contento se instala bien pero error pci 0000:00:01.0: invalid calibration data

bien tengo una copia de mi cal_data y en este mismo foro se habla de ello, gracias a Noltari, pero pensé, ¿por qué tengo que restaurar esto si yo no lo he borrado en ningun momento y se supone que al instalar el firmware tampoco lo toca?

asi que volví a instalarle la imagen r39304usb y efectivamente volvió a funcionar, despuésde esto y de leer un poco mas sobre el tema e instalar y desinstalar diferentes versiones todas HG556a_B... le instalé la A HG556a_A en concreto la openwrt-15.05-brcm63xx-generic-HG556a_A-squashfs-cfe.bin y funcionó!!!  y esto ya me rompió la cabeza...

(funcionó parcialmente , configuré el wifi, el radar detecta pero solo hay internet en el momento justo en el que se conecta despues aunque hay buena señal no navega,,quizas mala configuracion mia del wireless)

en fin, mi pregunta es ¿Por que HG556a_B error invalid calibration data y en HG556a_A no, cuando me he asegurado que mi serial empieza con 30634?
¿Que hago, le restauro el cal-data a ver que pasa, aunque estoy casi seguro que ya tiene la correcta?



Puede que los números de serie no sean del todo correctos, ya se corrijieron algunos.

Podrías ejecutar el comando

cat /proc/mtd

Si el resultado es que te da particiones con erasize de 0x10000 entonces efectivamente es una versión A. Si es así corregiré la wiki.

Hay varias formas de comprobar que versión es, pero comprobando el chip wifi y el erasesize es la forma más fiable. Los números de serie solo son como referencia, Openwrt no puede leerlos en ningún sitio cuando arranca.

alemap

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2753 en: 20-02-2016, 00:59 (Sábado) »
Pues si las particiones tienen el erasesize 00010000

gracias, me has salvado el abrirlo para mirar el modelo del chip de la flash y si puedes cambiar la wiki del OpenWRT genial asi le ahorraras tiempo al que le pase lo mismo y el karma te recompensará ))

Warryor

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2754 en: 20-02-2016, 01:05 (Sábado) »
lo de los numeros es verdad que fallan un poco, estoy con un 30692 y no es un version B si no un A
Lo supe al hacer un backup de cal data al ver que el erasesize era de 10000 en vez de 20000
lo curioso, supongo que estara comentado, que en el A la particion es la mtd4 y en el B es la mtd5
« Última modificación: 20-02-2016, 01:12 (Sábado) por Warryor »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2247
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2755 en: 21-02-2016, 13:58 (Domingo) »
Hola, y gracias por el foro,

voy a intentar explicar una cosa que no entiendo por si alguien me puede ayudar:

llevo tiempo usando la imagen r39304usb.openwrt-HW556-squashfs-cfe.bin que colgó jar229, que parece que está a prueba de bombas, todo perfecto, funciona bien, pero queria actualizar a la chaos_calmer.

el caso es que tengo:
HW version: HG55VDFA VER.C
con serial: 30634...
por tanto segun la wiki de OpenWRT tengo que instalar la B

pues me pongo a ello tan contento se instala bien pero error pci 0000:00:01.0: invalid calibration data

bien tengo una copia de mi cal_data y en este mismo foro se habla de ello, gracias a Noltari, pero pensé, ¿por qué tengo que restaurar esto si yo no lo he borrado en ningun momento y se supone que al instalar el firmware tampoco lo toca?

asi que volví a instalarle la imagen r39304usb y efectivamente volvió a funcionar, despuésde esto y de leer un poco mas sobre el tema e instalar y desinstalar diferentes versiones todas HG556a_B... le instalé la A HG556a_A en concreto la openwrt-15.05-brcm63xx-generic-HG556a_A-squashfs-cfe.bin y funcionó!!!  y esto ya me rompió la cabeza...

(funcionó parcialmente , configuré el wifi, el radar detecta pero solo hay internet en el momento justo en el que se conecta despues aunque hay buena señal no navega,,quizas mala configuracion mia del wireless)

en fin, mi pregunta es ¿Por que HG556a_B error invalid calibration data y en HG556a_A no, cuando me he asegurado que mi serial empieza con 30634?
¿Que hago, le restauro el cal-data a ver que pasa, aunque estoy casi seguro que ya tiene la correcta?



Puede que los números de serie no sean del todo correctos, ya se corrijieron algunos.

Podrías ejecutar el comando

cat /proc/mtd

Si el resultado es que te da particiones con erasize de 0x10000 entonces efectivamente es una versión A. Si es así corregiré la wiki.

Hay varias formas de comprobar que versión es, pero comprobando el chip wifi y el erasesize es la forma más fiable. Los números de serie solo son como referencia, Openwrt no puede leerlos en ningún sitio cuando arranca.

Yo también puedo confirmar que tengo un HG556a con serie 30634... y con erasesize de 0x10000 => Versión A

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2756 en: 21-02-2016, 15:39 (Domingo) »
Me da que las versiones A y B debe haber algunos numeros de serie compartidos en ambas. De todas formas ya lo he corregido en la wiki, gracias.

faio86

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2757 en: 22-02-2016, 17:59 (Lunes) »
Hola monte, overlay por usb me lie a instalar aplicaciones y ahora me da este error.
Código: [Seleccionar]
Your JFFS2-partition seems full and overlayfs is mounted read-only.
Please try to remove files from /overlay/upper/... and reboot!
Gracias.
« Última modificación: 22-02-2016, 21:33 (Lunes) por faio86 »

chufirulo

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2758 en: 25-02-2016, 10:45 (Jueves) »
Hola a todos. He instalado en el Huawei HG556a un firm que encontre, nombre de archivo: backfire.10.3.0.1.openwrt-HW566-squashfs-cfe.bin
Todo fue bien, lleva Luci. Configuré el router para ponerlo en modo bridge y ampliar la wifi del router de casa. Todo correcto y funciona, pero el problema es que funciona a ratos, quiero decir, se queda pillado, no cargan las webs, no da acceso a internet, intento acceder al router y Luci no carga, etc...
Tengo que apagarlo y encenderlo y en ocasiones se arregla, pero en otras no.
¿Que firm estable me recomendais que funcione y no de problemas? Lo unico que quiero es cargar alguna web y facebook desde el movil, no pido grandes velocidades de conexion ni florituras.
Creo que el problema es que ese firm es para el C, y veo por el numero de serie que mi router es version B (30692). Quizas por eso todos los problemas.
Mi pregunta clave es, ¿puedo hacer algun backup de toda la configuracion para despues de flashear con el nuevo firm restaurar todo? es que tengo todo configurado con una lista de acceso de macs y demas, y meterlo todo de nuevo puede ser una ruina.
Gracias!

victormurgar

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2759 en: 29-02-2016, 16:15 (Lunes) »
Llevo unos 2 meses con este router que sino me equivoco es la versión B con wifi atheros, como repetidor, pero alrededor de los 10 días funcionando bien o pierde la conexión con el router principal o deja de emitir la red. Yo sospecho que es la versión de openwrt no funciona de manera estable. Alguien puede pasarme algunas compilación para este router y que esté probado que funciona bien como repetidor. Os adjunto una imagen de la pegatina de atrás.