Autor Tema: Problema al crear particiones en Wifiway 2.0.1  (Leído 38053 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Problema al crear particiones en Wifiway 2.0.1
« en: 07-10-2010, 02:06 (Jueves) »

Esto es un tema partido, el autor del mismo es wepain

Me da error al configurar el grub y no arranca, ¿se te ocurre algo?

   


   


   


   


Saludos.



Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #1 en: 07-10-2010, 02:12 (Jueves) »
pues ahora mismo empezaba a instalarlo y no te puedo decir,  a ver que acabe y te digo algo.


saludos

wepain

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #2 en: 07-10-2010, 06:49 (Jueves) »
Vale, a ver si es del wifiway o algo :s

MadAntrax

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #3 en: 07-10-2010, 10:33 (Jueves) »
Me pasa exactamente LO MISMO! voy a exponer los puntos claves de mi proceso de instalación.

Una vez creadas las particiones swap (sda5) y sistema (sda6) me propongo a formatearlas:

mkswap /dev/sda5
(aquí da un error)
swapoff /dev/sda5
mkswap /dev/sda5

(ahora ya no da error)

mkfs -t ext3 /dev/sda6
(da un error, dice que la partición está montada)
(La desmonto haciendo click derecho -> desmontar)
mkfs -t ext3 /dev/sda6
(ahora sí que funciona.

................................

Procedo a la instalación del wifiway usando el asistente, llego al apartado del GRUB y recibo el MISMO error:



Otra cosa que me mosquea MUCHO es que yo antes cuando instalaba el wifiway 1.0 en mi portatil, me reconocía el disco como /dev/hda y ahora el mismo portatil lo reconoce como /dev/sda

Puede que ahí esté el error?
« Última modificación: 07-10-2010, 10:35 (Jueves) por MadAntrax »

berni69

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #4 en: 07-10-2010, 11:41 (Jueves) »
no deberia ser ese el error puesto que los nuevos kernel reconocen todos los discos como sda

MadAntrax

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #5 en: 07-10-2010, 11:45 (Jueves) »
no deberia ser ese el error puesto que los nuevos kernel reconocen todos los discos como sda

Perfecto...

Voy a ver si puedo instalar LILO y lo utilizo como gestor de arranque (siempre me ha gustado más lilo que grub). En unas horas posteo mis resultados.

También probaré de actualizar Grub a la versión 1.96, alomejor el problema se soluciona...
« Última modificación: 07-10-2010, 11:48 (Jueves) por MadAntrax »

wepain

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #6 en: 07-10-2010, 14:09 (Jueves) »
no deberia ser ese el error puesto que los nuevos kernel reconocen todos los discos como sda

Perfecto...

Voy a ver si puedo instalar LILO y lo utilizo como gestor de arranque (siempre me ha gustado más lilo que grub). En unas horas posteo mis resultados.

También probaré de actualizar Grub a la versión 1.96, alomejor el problema se soluciona...

Cuéntanos si te funciona, a ver si me puedes ayudar si encuentras la solución.
Gracias.
O a ver si alguien sabe solucionarlo :)

MadAntrax

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #7 en: 07-10-2010, 14:37 (Jueves) »
Cuéntanos si te funciona, a ver si me puedes ayudar si encuentras la solución.
Gracias.
O a ver si alguien sabe solucionarlo :)

Bueno, ya lo he probado:

- El módulo de lilo no existe (o no lo he encontrado). Así que eso no lo he podido probar.

- Me he bajado el GRUB 1.96 en formato *.lzm pero hay un problema:

https://foro.seguridadwireless.net/live-cd-wifiway-1-0-renovation-kde/wifiway-2-0-1-error-al-cargar-modulos-lzm/msg172619/?topicseen#msg172619

No puedo cargar NINGÚN modulo en wifiway2. Si pongo el modulo en la carpeta modules da un error. Si lo descomprimo con el comando lzm2dir da otro error.

http://www.slax.org/documentation_create_modules.php

Si monto el modulo como una unidad, da otro error.

Código: [Seleccionar]
mkdir /mnt/aaaa
mount -t squashfs -o loop /path/software.lzm /mnt/aaaa



Y me jode lo de los módulos, ya que antes con wifiway1 podía cargar modulos, descomprimirlos con lzm2dir o montarlos en una unidad. Y ahora no puedo hacer nada de eso, ergo no puedo instalar grub 1.96


wepain

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #8 en: 07-10-2010, 15:16 (Jueves) »
Ahí va mi experiencia:

He instalado grub 2 pero al ejecutar el nuevo grub-install me aparece nosequé de read-only. Voy a borrar la máquina y empezar de cero y ya os contare.

MadAntrax

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #9 en: 07-10-2010, 15:23 (Jueves) »
Ahí va mi experiencia:

He instalado grub 2 pero al ejecutar el nuevo grub-install me aparece nosequé de read-only. Voy a borrar la máquina y empezar de cero y ya os contare.

De donde has bajado grub2 y como lo has instalado?

Lo del read only lo tienes explicado aquí: http://www.guia-ubuntu.org/index.php?title=Recuperar_GRUB (tiene que montar la particion de nuevo en modo escritura)

wepain

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #10 en: 07-10-2010, 18:10 (Jueves) »
Ahí va mi experiencia:

He instalado grub 2 pero al ejecutar el nuevo grub-install me aparece nosequé de read-only. Voy a borrar la máquina y empezar de cero y ya os contare.

De donde has bajado grub2 y como lo has instalado?

Lo del read only lo tienes explicado aquí: http://www.guia-ubuntu.org/index.php?title=Recuperar_GRUB (tiene que montar la particion de nuevo en modo escritura)

ftp://alpha.gnu.org/gnu/grub/grub-1.98.tar.gz

El grub 2 es el 1.98

Respecto al enlace que me diste, no veo los pasos para desmontar y montar en modo escritura.

saludos

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #11 en: 08-10-2010, 00:09 (Viernes) »
buenas

ya podéis dejar de pelearos con el GRUB, el problema es cfdisk >:D

para llegar a esta conclusión he comprobado la dirección del viento, la velocidad del viento y la presión atmosférica, ...ummm... hay no perdón eso era que tiempo iba a hacer mañana ;D

lo que he hecho ha sido arrancar Wifiway 1.0 Final hacer las particiones con el cfdisk y formatearlas desde esta versión, después he arrancado Wifiway 2.0.1 lo he instalado y le he configurado el GRUB sin problemas.

un saludo

Pd. estoy haciendo un modulo con el cfdisk antiguo, en un ratito lo subo.

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17691
    • GNU/Linux Wifislax
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #12 en: 08-10-2010, 02:11 (Viernes) »
2 cositas, porque bajais el modulo del grub, si la wifiway ya lo lleva

y la otra , en la presentacion ya digo que el sistema que usa la live, ya no es el squashfs sino el squashfs 4.0 ese dato es importantisimo tenerlo en cuenta

leer la explicacion de presentacion que os lo comunico, y os digo donde estan los exe antiguos, por si si kieren usar.

Si es cierto que no pusimos herramientas graficas de tratadado de particiones

habra que meter el gparted osimilares.........


Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #13 en: 08-10-2010, 02:20 (Viernes) »
¿había que leerse la presentación? otro dia dilo antes ;D

solo un par de formateadas antes ya hubiese estado bien jajajajajaja

por hoy ya paro estoy de hacer particiones hasta la ......, mañana mas, el modulo que el cfdisk ya me funciona, lo que sigue fallando, ahora estaba pensando en añadir al modulo las otras dos aplicaciones (mkfs y mkswap) pero leído el último post quizás cambio de estrategia.

un saludo

cristi_28

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #14 en: 08-10-2010, 02:30 (Viernes) »
gracias ya me funciona ,esta instalado  >:(

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #15 en: 08-10-2010, 02:43 (Viernes) »
¿podrías decirnos como has hecho las particiones e instalado el GRUB? gracias

un saludo

cristi_28

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #16 en: 08-10-2010, 10:30 (Viernes) »
con el wifiway 1.0 con cfdisk acer particiones si formatearlas y con wifiway 2 instalar y configurar el grub

cfdisk /dev/hda

 hacer partitiones y reboot en wifiway 1.0

fdisk -l

mkswap /dev/hda5     -----formatear en wifiway 1.0
 
mkfs -t ext3 /dev/hda6        -------formatear  en wifiway 1.0
 
reboot
 
arancar deste live cd wifiway 2 y instalar

lo unico que cambia es que in wifiway 2 hda6 es sda6 y no olvidar de reiniciar despues de cada operacion

MadAntrax

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #17 en: 08-10-2010, 10:54 (Viernes) »
con el wifiway 1.0 con cfdisk acer particiones si formatearlas y con wifiway 2 instalar y configurar el grub

cfdisk /dev/hda

 hacer partitiones y reboot en wifiway 1.0

fdisk -l

mkswap /dev/hda5     -----formatear en wifiway 1.0
 
mkfs -t ext3 /dev/hda6        -------formatear  en wifiway 1.0
 
reboot
 
arancar deste live cd wifiway 2 y instalar

lo unico que cambia es que in wifiway 2 hda6 es sda6 y no olvidar de reiniciar despues de cada operacion

Así lo acabo de hacer yo y me ha salido perfecto, solo 2 apuntes:

En el momento de formatear, he tenido que desmontar la swap y el disco de datos:

swapoff /dev/hda5
mkswap /dev/hda5

(Con el konkeror, nos vamos a la unidad hd6, click derecho, desmontar. Y luego):

mkfs -t ext3 /dev/hda6

Saludos !! :)

cristi_28

  • Visitante
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #18 en: 08-10-2010, 11:23 (Viernes) »
se me olvido la de desmontar  ;)

Post Merge: 08-10-2010, 11:27 (Viernes)
ahora le toca a la conexion porque no se porque no pudeo navegar ,me conecta y entra en la pagina de seguridadwireless pero cuando quiero entrar en el foro se queda parada y tengo que cambiar a windows
« Última modificación: 08-10-2010, 11:27 (Viernes) por cristi_28 »

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Problema al crear particiones en Wifiway 2.0.1
« Respuesta #19 en: 08-10-2010, 13:34 (Viernes) »
con el wifiway 1.0 con cfdisk acer particiones si formatearlas y con wifiway 2 instalar y configurar el grub

ok, lo has hecho como decía antes, bueno al menos ya sabemos que hasta que lo solucionemos ese método sirve para todos.

yo no he tenido que desmontar nada, supongo que por que yo reinicio ordenador después de las particiones y vosotros no ¿puede ser?


un saludo