Autor Tema: Modulo vmware-tools de VMware 9 Para Wifislax 4  (Leído 51304 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Modulo vmware-tools de VMware 9 Para Wifislax 4
« en: 17-09-2012, 21:56 (Lunes) »
hi

Este modulo hace funcionar las vmware-tools en los LiveCD y LiveUSB incluidas las Shared Folders.

- El modulo hay que meterlo en la carpeta /wifislax/modules.

- Antes de iniciar Wifislax es necesario configurar las Shared Folders de la máquina virtual.

  

        Descarga modulo vmware-tools




Agradecimientos especiales a USUARIONUEVO por proporcionar el script que soluciona el bug que evitaba que el archivo fstab se actualizara con la entrada necesaria para montar la partición hgfs necesaria para acceder a los archivos compartidos.

el script es este:

- Nombre: rc.local
- Ubicacion: /etc/rc.d

Código: [Seleccionar]
# For shared folders in virtual machines
#!/bin/sh

if [ -d /mnt/hgfs ]; then
  test=$(grep '.host:/ /mnt/hgfs vmhgfs defaults, 0 0 # AutoUpdate' /etc/fstab)
  if [ "$test" = "" ]; then
    echo "" >> /etc/fstab
    echo "# For a shared folders in virtual machines" >> /etc/fstab
    echo ".host:/ /mnt/hgfs vmhgfs defaults, 0 0 # AutoUpdate" >> /etc/fstab
  fi
fi
exit 0


un saludo


« Última modificación: 07-08-2017, 14:48 (Lunes) por drvalium »

susaniita

  • Visitante
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #1 en: 28-01-2013, 01:17 (Lunes) »
funca perfecto

gracias maquina ;D

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #2 en: 28-01-2013, 01:22 (Lunes) »
no hay de que ;)

las Shared foldres han dejado de funcionar en Wifislax 4.3, estoy mirando de solucionarlo.


un saludo

susaniita

  • Visitante
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #3 en: 28-01-2013, 01:33 (Lunes) »
bueno lo que a mi no me funciona es poner la full screem
usando usblive wifislax 4.3 vmware9 x64 aun poniendo el modulo
para las tools

es decir que igual funcionaria si se monta el sistema en la virtual
pero no arrancando wifislax 4.3 desde usb x64 en vmware9

susaniita

  • Visitante
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #4 en: 28-01-2013, 01:40 (Lunes) »
ahora si que funciona
solo trasteando, a veces le cuesta un poco
no se si es porque estoy usando •Máquina virtual de VMware 9 para LiveUSB (x64)
quizas sea mas estable la 86

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #5 en: 28-01-2013, 01:43 (Lunes) »
Para que funciona tienes que configurar VMware así

   

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #6 en: 28-01-2013, 01:52 (Lunes) »
ahora si que funciona
solo trasteando, a veces le cuesta un poco no se si es porque estoy usando •Máquina virtual de VMware 9 para LiveUSB (x64)
quizas sea mas estable la 86

son igual de estables, quizás la configuración tu máquina no está todo lo ajustada que debería, pero eso escapa demasiado del rema original, si tienes dudas sobre el rendimiento abre un tema diciendo las características de tu PC y la configuración que usas actualmente en tu máquina virtual.

por que supongo que sabes que tienes que usar el que corresponda al Wifislax que uses, si usas un Wifislax 32 bits tienes que usar una vmware-tools 32 bits, si estas usando las tools del 64 en un 32 es normal que funcione mal.

susaniita

  • Visitante
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #7 en: 28-01-2013, 02:50 (Lunes) »
descargo la iso que poneis aqui
que es de 32, solo que no selecciono la pae
sino la de menos ram, pues tengo 4g
con las tools descargo el modulo que poneis aqui en este mismo post
igual fallo en la maquina virtual usb x64 vmware pero pense que
como tengo windows7 64 deberia descargar esa
probare con la de 32 a ver
« Última modificación: 28-01-2013, 02:56 (Lunes) por susaniita »

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #8 en: 28-01-2013, 03:14 (Lunes) »
Los bit de Windows no importan, lo que importa es como creas la máquina virtual, si la creas para Linux 32 bits todo lo que metas en ella debe ser para 32 bit.

tienes que ver la máquina virtual como un ordenador mas y no como un programa que corre sobre windows.

susaniita

  • Visitante
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #9 en: 01-03-2013, 16:08 (Viernes) »
chicos siempre me sale un mensaje de instalar vmwaretools, aunque tengo instalado
el modulo que dais
entonces he intentado instalarlo, descomprimiendo en escritorio
abriendo consola y: ./vmware-install.pl
y me sale los siguientes errores





« Última modificación: 01-03-2013, 16:09 (Viernes) por susaniita »

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #10 en: 14-03-2013, 05:43 (Jueves) »
¿lo que has descomprimido ha sido el modulo? eso no lo puedes hacer

si el modulo no te funciona lo que tienes que hacer es instalar las tools desde el menú VM de vmware.


Robertomcat

  • Visitante
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #11 en: 16-03-2013, 16:53 (Sábado) »
Hola chicos buenas tardes. He estado buscando en el foro y creo que aquí es donde tengo que exponer mi problema. Me ha salido un problema parecido con el vmware9, wifislax 4.3 y "Windows8". La máquina virtual la tenía configurada con el wifislax y arrancaba y me funcionaba bien. Antes de ayer recibí una actualización para Windows8, y a partir de esta, cuando arranco la máquina virtual para que corra el Wifislax; en el ordenador se me apaga la pantalla y se reinicia solo.

Por favor, me gustaría que me echarais es una mano por si tengo que configurar de diferente modo la máquina virtual (O deshabilitar el arranque seguro de la BIOS, no se).

Un saludo a todos.

susaniita

  • Visitante
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #12 en: 16-03-2013, 20:31 (Sábado) »
ok gracias dvrion

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #13 en: 29-03-2013, 20:52 (Viernes) »
Hola chicos buenas tardes. He estado buscando en el foro y creo que aquí es donde tengo que exponer mi problema. Me ha salido un problema parecido con el vmware9, wifislax 4.3 y "Windows8". La máquina virtual la tenía configurada con el wifislax y arrancaba y me funcionaba bien. Antes de ayer recibí una actualización para Windows8, y a partir de esta, cuando arranco la máquina virtual para que corra el Wifislax; en el ordenador se me apaga la pantalla y se reinicia solo.

Por favor, me gustaría que me echarais es una mano por si tengo que configurar de diferente modo la máquina virtual (O deshabilitar el arranque seguro de la BIOS, no se).

Un saludo a todos.

disculpa el silencio, no me ha sido posible conectarme en unos dias.

lo primero que deberías decirnos es la actualización que te ha causado ese problema, sin saber que has instalado no se puede buscar una explicación y mucho menos una solución. De entrada lo fácil es desinstalar esa actualización y verificar que todo funciona otra vez.


un saludo

Robertomcat

  • Visitante
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #14 en: 29-03-2013, 21:14 (Viernes) »
Hola, no te preocupes no pasa nada, estamos en semana Santa y te perdono. jajajaja.

Bueno, pues para empezar el "Windows 8" se ha vuelto actualizar y aún no tengo ni idea si pueden ser las actualizaciones. Volví a desinstalar el VMWare, después lo instale de nuevo y tampoco le instale la actualización que me pedía. Con todo esto volví arrancar la máquina virtual para qué correrá el Wifislax y me pasó lo mismo (una vez ya cargando el programa a punto de arrancar se reinicia el ordenador igual).

Entré en la BIOS y vi que la casilla del arranque seguro está activada, pero por miedo de no saber lo que hacer la deje tal cual. Si la desactivo podré arrancar el wifislax desde un live-cd??

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #15 en: 01-04-2013, 14:25 (Lunes) »
hi

no tengo claro si te arrancará con un livecd, si te pudo asegurar que puedes desactivar esa función, es posible que Windows te deje de arrancar pero con volver a activarla se soluciona. No hay peligro en desactivarla.

sobre lo otro no se que decirte, yo también uso Windows 8 y a mi VMware me funciona como siempre.

estaría bien que probases con otra distribución Linux, Ubuntu o la que mas te guste, da igual, es por descartar posibilidades, veo raro que el sistema que corre dentro de la máquina virtual ocasione esos cuelgues a Windows.


un saludo

Robertomcat

  • Visitante
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #16 en: 01-04-2013, 15:24 (Lunes) »
Hola, ayer estuvimos un compañero y yo viéndolo (lo conocí el viernes pasado. jejeje), y la verdad es que lo solucionamos. Antes de arrancar el ordenador entramos en la BIOS y activamos la "tecnología de visualización" y después desactivamos el módulo de "compatibilidad heredada" (yo no me atrevía). Con todo esto pusimos en marcha el programa del VMware y lo arrancamos con el Ultimate Edition 3.4 y la verdad es que corrió de maravilla, y con el Wifislax también.

Otra cosa, también puede arrancar los live-USB y los live-CD. Siempre y cuando aprendes la tecla "esc" antes de arrancar para poder escoger de donde arrancar.

albeixon

  • Visitante
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #17 en: 23-10-2013, 20:30 (Miércoles) »
gente yo con VMware 10 no consigo iniciar un liveusb de wifislax 4.6 . es que no se puede ?

saludos
« Última modificación: 23-10-2013, 20:31 (Miércoles) por albeixon »

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #18 en: 23-10-2013, 23:32 (Miércoles) »
hi

si se pude, pero este no es sitio donde preguntarlo ¿te has fijado en el titulo del tema? pues eso, a menos que tu problema sea con las tools abra un tema nuevo.

un saludo

Haborym

  • Visitante
Re: Modulo vmware-tools de VMware 9 Para Wifislax 4
« Respuesta #19 en: 07-12-2013, 15:09 (Sábado) »
Buenas, acabo de instalar el vmware workstation 10, le instalé el Wifislax 4.7.2....y decir que las tools de este post aunque son para el vmware 9, tambíen funcionan para la 10 sin problema.
Saludos y gracias.