Autor Tema: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!  (Leído 103279 veces)

0 Usuarios y 1 Visitante están viendo este tema.

thorazine74

  • Visitante
Muy buenas:

Tenia este router y le instale la ultima version de DDWRT para probar, pero como no fui capaz de hacer funcionar el modo cliente reinstale el firmware original, usando el archivo de web revert que hay posteado en el foro oficial de DDWRT, pero despues de un tiempo esperando que el router se reiniciara, nunca lo hizo, por lo que me decidi a desactivar y activar la conexion de red.
Despues de esto el router se ha quedado inaccesible, solo se enciendo la luz de power y qss y la del puerto lan correspondiente al conectar el cable, pero no puedo acceder al router desde windows.
El boton de reset no funciona y el 30/30/30 reset tampoco.
Alguna idea de como recuperarlo aparte del puerto serie?



5.1

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #1 en: 22-02-2012, 10:16 (Miércoles) »
Te da ip al conectar el cable de red? En caso afirmativo te responde a un ping? Si no te da IP has probado de ponerlas manuales y hacer un ping??

thorazine74

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #2 en: 22-02-2012, 10:28 (Miércoles) »
No me da ip ni responde al ping, tanto con DHCP como poniendo la ip manual.

5.1

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #3 en: 22-02-2012, 10:34 (Miércoles) »
Pues si despues del brick lo has desconectado de la corriente y al encenderlo continua igual a mi no se me ocurre ninguna manera de recuperarlo que no sea por serial console...

Todo sea que alguien exponga otra idea, pero lo veo dificil.
« Última modificación: 22-02-2012, 10:51 (Miércoles) por 5.1 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #4 en: 22-02-2012, 12:45 (Miércoles) »
Tiene mala pinta sí  :-\
Como te comentaba 5.1, los métodos para recuperarlo pasan por usar cable serie ...  ^-^
« Última modificación: 23-02-2012, 08:46 (Jueves) por jar229 »

rofear

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #5 en: 26-02-2012, 14:48 (Domingo) »
muy buenas , yo estoy igual que tu thorazine74 pase de ddwrt al original sin problema y de este a gargoley factory también sin fallos pero al pasar de factory a a sysupgrade se fue al carajo .

buscando por mis cosas de la época de los 5100 e encontrado mi programador jtag , el tema es que no encuentro nada de información de como re-programarlo por el jtag paralelo.

SERASER

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #6 en: 26-02-2012, 15:53 (Domingo) »
Mejor que el jtag tirar por serial antes, quizas el bootloader(u-boot) esta ahi intacto y solo se necesita flashear el firmware mediante el, que se puede perfectamente.

Aqui toda la informacion sobre como acceder desde el puerto serie asi como por jtag si lo veis preciso:

[spoiler=Pincha aquí para ver]http://wiki.openwrt.org/toh/tp-link/tl-wr1043nd?s[/spoiler]

Saludos.
« Última modificación: 26-02-2012, 15:58 (Domingo) por sERASEr »

rofear

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #7 en: 26-02-2012, 15:56 (Domingo) »
no tengo cable serie . solo dispongo el jtag

SERASER

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #8 en: 26-02-2012, 15:59 (Domingo) »
Pues nada jtag si te ves bien en esas lides, en ese mismo enlace tienes la informacion para ello.

Recomiendo hacerse con un adaptador serial de los baratuchos de hoy en dia, por usb, no llegan ni a los 4 euros.

Saludos.

Edito: Leo detenidamente las instrucciones para el acceso por Jtag y veo que aun no han podido acceder a la flash en modo escritura, si en modo lectura, asi pues cable serie si o si y rezando para que este el u-boot ahi.
« Última modificación: 26-02-2012, 16:03 (Domingo) por sERASEr »

rofear

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #9 en: 26-02-2012, 16:02 (Domingo) »
si estuve mirando el cable nokia , tengo un ca-54 pero no es compatible , si no me aclaro con el jtag no tendré mas remedio que pillarlo pero si me lo puedo evitar mejor.

haber ahora si me aclaro con el ingles que tan tecnico me da de leches

SERASER

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #10 en: 26-02-2012, 16:04 (Domingo) »
si estuve mirando el cable nokia , tengo un ca-54 pero no es compatible , si no me aclaro con el jtag no tendré mas remedio que pillarlo pero si me lo puedo evitar mejor.

haber ahora si me aclaro con el ingles que tan tecnico me da de leches

El Jtag descartalo, he editado el post anterior, leelo.

El ca-54 si que es compatible, solo has de buscar los hilos Rx, Tx, y GND.

Saludos.

« Última modificación: 26-02-2012, 16:07 (Domingo) por sERASEr »

rofear

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #11 en: 26-02-2012, 16:15 (Domingo) »
ufff pues menos mal que lo lo e tirado , pero segun tengo entendido este cable es directo a usb no tiene ningun tipo de integrado , sirve aun asi?

SERASER

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #12 en: 26-02-2012, 16:19 (Domingo) »
ufff pues menos mal que lo lo e tirado , pero segun tengo entendido este cable es directo a usb no tiene ningun tipo de integrado , sirve aun asi?

Va :-\, me he confundido, el que si integra el adaptador serie es el ca-42.

Asi pues lo mas que puedo hacer es linkarte uno baratito, mucho mas barato que hacerselo uno mismo:

[spoiler=Link]http://cgi.ebay.es/CP2102-USB-to-RS232-TTL-232-Converter-Module-Chip-/220812904053?pt=LH_DefaultDomain_0&hash=item3369798675[/spoiler]

rofear

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #13 en: 26-02-2012, 16:20 (Domingo) »
e estado pensando un adaptador serie-usb no viene a ser lo mismo?

es que tengo uno

SERASER

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #14 en: 26-02-2012, 16:23 (Domingo) »
e estado pensando un adaptador serie-usb no viene a ser lo mismo?

es que tengo uno

Si, es lo mismo, serial por usb.

Lo dicho, solo Rx, Tx y Gnd.

Los parametros de conexion los tienes bien definidos en la pagina que te linke.

Saludos.

rofear

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #15 en: 26-02-2012, 16:26 (Domingo) »
vale voy a ver si encuentro el pinout de esto y me pongo a ello
 ahora os digo algo haber

rofear

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #16 en: 26-02-2012, 17:36 (Domingo) »
e encontrado esto http://www.aggsoft.com/rs232-pinout-cable/images/9-pinout.gif

vendria a ser los pines 2 3 y 5

SERASER

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #17 en: 26-02-2012, 17:40 (Domingo) »
Entonces ¿en un extremo tienes usb y en el otro lo que me acabas de mostrar?

SERASER

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #18 en: 26-02-2012, 17:42 (Domingo) »
Creo que te estas liando.

Ponme una foto de tu adaptador usb y ya te indico.

Saludos.

rofear

  • Visitante
Re: TP-Link WR1043ND: reinstalo el firmware original desde DDWRT y bricked!!!
« Respuesta #19 en: 26-02-2012, 17:49 (Domingo) »