Autor Tema: Mejorando los scripts wifislax-updaters  (Leído 172505 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #460 en: 25-01-2015, 04:47 (Domingo) »
compilando esta xd

pues el unico cambio es el que te di ... algo no copiaste bien madikita.

era la linea 47 creo ...

ya ves que es code HIPERSENCILLO ...

este en concreto es que es un pelin mas avanzado que otos updaters, ya que el filezilla puede resolverse alguna dependencia el solito.  ;D

si lanzas directamente el filezilla, y no tienes la libreria, la compilaria antes de seguir con filezilla.



PD:  ERA LA LINEA 42 , LA QUE HABIA QUE TOCAR-  ;D  en el wxGTK3_updater


el de filezilla no habia que tocarlo.


« Última modificación: 25-01-2015, 04:50 (Domingo) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #461 en: 25-01-2015, 04:58 (Domingo) »

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17992
    • GNU/Linux Wifislax
Re: Mejorando los scripts wifislax-updaters
« Respuesta #462 en: 25-01-2015, 04:58 (Domingo) »
Citar
wxGTK3_updater

ese toque

en todo caso es igual ya esta rulando


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #463 en: 25-01-2015, 05:08 (Domingo) »
Citar
wxGTK3_updater

ese toque

en todo caso es igual ya esta rulando

si lo lanzaste ese ...pues depsues ya el filezilla


y si lanzast el filezilla...pues cuando acabe con esa..seguria la otra ..en escritorio te dejara los xzm , por si usas modo livecd  ;D , si no  ..los puedes borrar.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #464 en: 25-01-2015, 05:09 (Domingo) »
nos quedo pendiente el updater de java sdk ...    ^-^ ^-^ ^-^ ^-^

CristianEdgardo

  • Visitante
Re: Mejorando los scripts wifislax-updaters
« Respuesta #465 en: 25-01-2015, 05:54 (Domingo) »
la ultima joda del dia que hacemo con ese paquete gt3-va haber updater o....




perdonenmesi la solucion es facil, pero haora no me sale....  ^-^ ^-^ ^-^


 ;) >:( >:( >:( >:(

perdon, perdon ya lo vi es wx gtk3_updater   no dije nada, ni escribi ni posteeee ni puse imagen,  ;D ;D ;D ;D ;D
« Última modificación: 25-01-2015, 06:06 (Domingo) por CristianEdgardo »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #466 en: 25-01-2015, 06:01 (Domingo) »
? y si instalas wxGTK3 ?  ;D

ACTUALIZADORES --> LIBRERIAS -> WXGTK3


Es uno nuevo .. ;D
« Última modificación: 25-01-2015, 06:02 (Domingo) por USUARIONUEVO »

vk496

  • Visitante
Re: Mejorando los scripts wifislax-updaters
« Respuesta #467 en: 25-01-2015, 11:02 (Domingo) »
Joer con las librerías wx

No sabia que daba tanto follón jajajaja

Buen trabajo @USUARIONUEVO!

Salu2

CristianEdgardo

  • Visitante
Re: Mejorando los scripts wifislax-updaters
« Respuesta #468 en: 26-01-2015, 00:58 (Lunes) »
:( :( :( :( :( :( :( :( :( :(

estodebe a un error mio???

Version Script: 25/01/2015

Descargando sources de wxGTK3-3.0.2
[#1793c2 19MiB/19MiB(99%) CN:1 DL:366KiB]                                        
01/25 20:53:06 [NOTICE] Descarga completa: /tmp/build/wxGTK3/wxWidgets-3.0.2.tar.bz2

Resultados de la descarga:
gid   |stat|avg speed  |path/URI
======+====+===========+=======================================================
1793c2|OK  |   345KiB/s|/tmp/build/wxGTK3/wxWidgets-3.0.2.tar.bz2

Leyenda:
(OK):descarga completada.

Descomprimiendo ...
tar: /opt/wifislax-updaters/Librerias/wxWidgets-3.0.2.tar.?z*: Cannot open: No existe el fichero o el directorio
tar: Error is not recoverable: exiting now
 

 ???


perdon ususario nuevo, no pude poner la imagen el problema es este, no me la instala...
« Última modificación: 26-01-2015, 01:12 (Lunes) por CristianEdgardo »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #469 en: 26-01-2015, 01:04 (Lunes) »
:( :( :( :( :( :( :( :( :( :(

estodebe a un error mio???




 ???


YA TE RESPONDI ... instala wxGTK3 , categoria LIBRERIAS ....

despues ya podras instalar dvdstyler.


Bueno , acabo de ver que al final la viste e instalaste  ;D

vk se refiere a que dan guerra las librerias , por que cada paquete necesita una cosa distinta de la misma libreria ...  ;D ;D ;D
« Última modificación: 26-01-2015, 01:06 (Lunes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #470 en: 26-01-2015, 01:08 (Lunes) »
para futuras dudas ..


cuando un updater diga dependencia NO INSTALADA


buscad en los updaters que lo que necesite esta hay segurisimo.

si no seria absurdo crear updaters que no pueden instalar , ¿verdad?


cuando os diga que algo no esta instalado , mirad los updaters ... ;)

si por un casual no lo veis o no lo teneis, usad el actualizador de updaters ..por si es uno nuevo y esta en el ftp , os lo bajara e instalara.  ;)

ademas de actualizar los que tengais viejos.  >:(

CristianEdgardo

  • Visitante
Re: Mejorando los scripts wifislax-updaters
« Respuesta #471 en: 26-01-2015, 01:16 (Lunes) »


YA TE RESPONDI ... instala wxGTK3 , categoria LIBRERIAS ....

despues ya podras instalar dvdstyler.


Bueno , acabo de ver que al final la viste e instalaste  ;D

vk se refiere a que dan guerra las librerias , por que cada paquete necesita una cosa distinta de la misma libreria ...  Version Script: 25/01/2015




el problema ahora es que no instala....
 quise poner la imagen y no me dejaba....
hay abajo te puse que lo me dice...
« Última modificación: 26-01-2015, 01:17 (Lunes) por CristianEdgardo »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #472 en: 26-01-2015, 01:33 (Lunes) »
BAJATE EL PAQUETE DE UPDATERS DE NUEVO ...


ESE FALLO LO CORREGI


vuelvete a bajar e instalar el xzm de los updaters

o bien , usa el

wifislax-updaters ..  para que te lo baje del ftp , y te añada uno nuevo que escribi hoy.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #473 en: 26-01-2015, 01:34 (Lunes) »
por cierto acaba de salir version de smplayer


el updater falla en la descarga  ..


aqui lo dejo arreglado

smplayer_updater

Código: [Seleccionar]
#!/bin/sh

# Script by www.seguridadwireless.net

SCRIPT_VERSION=20150126
CATEGORIA="Reproductores multimedia"

############################################################
## Funciones comunes. Su nombre empieza por f_ ##
############################################################
f_variables(){
. /opt/wifislax-updaters/Funciones/funciones_updater
}

############################################################
## Funciones propias del script. Su nombre empieza por F_ ##
############################################################
# Definicion de variables
F_variables() {
WEB=http://smplayer.sourceforge.net/es/downloads
VERSION=`curl -s $WEB | grep .tar.bz2 | head -1 | cut -d ":" -f2 | cut -d "/" -f5 | cut -d- -f-2 |cut -d- -f2 |sed 's/.tar.bz2">smplayer//g' |sed "s/ //g"`
PRGNAM=smplayer
DOWNLOAD="http://sourceforge.net/projects/smplayer/files/latest/download?source=files"
}

# Si el paquete no existe se descargara de internet
F_download(){
if [ ! -f $PRGNAM-$VERSION.tar.bz2 ]; then
echo ""
echo "$CYAN"Descargando sources de $PRGNAM-$VERSION"$CIERRE"
sleep 3
aria2c -x 3 $DOWNLOAD
fi
}

# Descomprimimos el fichero descargado y compilamos
F_compilar(){
echo ""
echo "$VERDE"Descomprimiendo ..."$CIERRE"
sleep 3
rm -rf $PRGNAM-$VERSION
tar xvf $PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
# Configuramos paquete
echo ""
echo "$VERDE"Configurando y compilano..."$CIERRE"
sleep 3
chown -R root:root .

sed -i "/^PREFIX/s/=.*$/=\/usr/;
        /^DOC_PATH/s/\/.*$/\/doc\/$PRGNAM-$VERSION/;
        s/share\/man/man/g;
        s/^QMAKE_OPTS=/QMAKE_OPTS+=/" Makefile

QMAKE_OPTS="QMAKE_CXXFLAGS=\"$SLKCFLAGS\"" \
make
make install DESTDIR=$PKG
}

###################################
## BLOQUE PRINCIPAL DE EJECUCION ##
###################################
# Si se cierra el script inesperadamente, ejecutar la funcion de limpieza
trap f_exitmode SIGHUP SIGINT

#Inicializamos las variables globales
f_variables
#Comprobamos conexion a Internet
f_comprobarConexion
#Inicializamos las variables del script
F_variables
#Creamos directorio de trabajo
f_directorioTemporal
#Mostramos el mensaje de presentacion
f_presentacion
#Comprobamos updates del script
f_comprobarUpdates
#Asignamos o detectamos arquitectura
f_arquitectura
#Comprobamos version instalada del script
f_versionInstalada
#Si no existe el fichero se descargara
F_download
#Descomprimir fichero descargado y compilamos
F_compilar
#Hacemos strip sobre el paquete
f_strip
#Creamos xzm , instalamos y salimos
f_tareasFinales

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #474 en: 26-01-2015, 01:38 (Lunes) »
como el ftp igual esca caido os dejo un nuevo xzm ,con smplayer arreglado y el updater nuevo

http://www.mediafire.com/download/3k3l1hz5xrzny8s/wifislax_updaters-3.4-noarch-1sw.xzm

CristianEdgardo

  • Visitante
Re: Mejorando los scripts wifislax-updaters
« Respuesta #475 en: 26-01-2015, 01:55 (Lunes) »
como el ftp igual esca caido os dejo un nuevo xzm ,con smplayer arreglado y el updater nuevo

http://www.mediafire.com/download/3k3l1hz5xrzny8s/wifislax_updaters-3.4-noarch-1sw.xzm


oki, descargo de nuevo,
te cuento lo que me pase, yo baje el segundo que pusiste  y es el que esta instalado....
la cuestion que con ese me dio ese error desde elliveusb   con otros modulos...
ahora  inicie en virtualbox dees la imagen (sin changes.dat) y me lo esta isntalando...


 ??? ??? ??? que es lo que pasa nose, te digo por si hay problema con algun otra cosa....

yo baje el ultimo modulo que pusiste, y ahora pruebo cambiandolo...


JOYA JOYA  JOYA JOYA, TODO FUNCIONA BIEN!!!!
« Última modificación: 26-01-2015, 01:59 (Lunes) por CristianEdgardo »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #476 en: 26-01-2015, 02:06 (Lunes) »
estoy empezando a odiar profundamente el uso del changes ...


el changes se penso para guardar pequeños cambios, fonde pantalla y esas cosas.


pero ocurre que claro , guarda por ejemplo la config del equipo ..y si despues lo tratas de arrancar en otro ordenador, seguro que algo no funcionara.

changes.dat = acaba corrompiendo sistemas

aunque siempre puedes hacer la prueba de arrancar sin changes ..osea desde el live , arranque normal.

CristianEdgardo

  • Visitante
Re: Mejorando los scripts wifislax-updaters
« Respuesta #477 en: 26-01-2015, 02:27 (Lunes) »
estoy empezando a odiar profundamente el uso del changes ...


el changes se penso para guardar pequeños cambios, fonde pantalla y esas cosas.


pero ocurre que claro , guarda por ejemplo la config del equipo ..y si despues lo tratas de arrancar en otro ordenador, seguro que algo no funcionara.

changes.dat = acaba corrompiendo sistemas

aunque siempre puedes hacer la prueba de arrancar sin changes ..osea desde el live , arranque normal.


me gusta usarlo asi, por que te salva, hay soluciones para eso, tenes dos chages.dat uno para el equipo personal y el dsegundo para los demas...

yo igual no lo pruebo en dos equiposdiferentes, al changes.dat

espero que no lo odies, osea que yo sea quien te saque de las casillas, si lo hago lo siento...

contantas pruebas y despruebas se me confunde todo, ensima taba haciendo y probando otras cosas,
hasta que paro todo y empiezo de cero,

cuando tenga lsta pc lista o una nueva prometo instalarlo...
 
yo por hay aporto para que si encuentra un problema, capaz que no soy solo yo...
 
pero si el changes.dat  tiene sulimite, y es uso reponsabilidad de cada usuario...



CristianEdgardo

  • Visitante
Re: Mejorando los scripts wifislax-updaters
« Respuesta #478 en: 26-01-2015, 09:00 (Lunes) »
lo siento, yo de nuevo...
 
usando la live no funciona Dvd-style aparece el cuadro de seleccion de idioma y luego nada...

el modulo esta actualizado...  baje el modulo de wxGTK3... y nada... con el mod wifislax_updaters-3.4-noarch-1sw.xzm...    todo junto no pasa nada...

quise actualizar  dvdauthory ... lo desintala  lodescarga... Descomprime ... lo  configura... lo compila...

Y...

"compilación terminada.
make[2]: *** [subgen-image.o] Error 1
make[2]: *** Se espera a que terminen otras tareas....
mv -f .deps/subrender.Tpo .deps/subrender.Po
make[2]: se sale del directorio `/tmp/build/dvdauthor/dvdauthor/src'
make[1]: *** [all] Error 2
make[1]: se sale del directorio `/tmp/build/dvdauthor/dvdauthor/src'
make: *** [all-recursive] Error 1"

 :( :(


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #479 en: 26-01-2015, 11:13 (Lunes) »
si es que no se para que tocais ..


version dvdauthor de sistema

0.7.1

la mas nueva


0.7.1

aun asi vas y le das..y por lo que veo ni salvaste en xzm por si acaso  ;D


____________________________

con gslapt reinstala la libreria imagemagick

y copilara el dvdauthor.

no se por que esa libreria pierde ficheros ...  me tiene hasta el as alla .

//FINAL Y MÁS DOS RESPUESTAS