Autor Tema: Mejorando los scripts wifislax-updaters  (Leído 172503 veces)

0 Usuarios y 1 Visitante están viendo este tema.

vk496

  • Visitante
Re: Mejorando los scripts wifislax-updaters
« Respuesta #440 en: 17-01-2015, 00:33 (Sábado) »
wxHexEditor

Código: [Seleccionar]
  #!/bin/sh

# Script by www.seguridadwireless.net

SCRIPT_VERSION=20150117

############################################################
## Funciones comunes. Su nombre empieza por f_ ##
############################################################
f_variables(){
. /opt/wifislax-updaters/Funciones/funciones_updater
}

############################################################
## Funciones propias del script. Su nombre empieza por F_ ##
############################################################
# Definicion de variables
F_variables() {
WEB=http://sourceforge.net/projects/wxhexeditor/files/wxHexEditor/
VERSION_REAL=$(curl -s $WEB | grep -m1 "class=\"folder" | grep -Po 'title="\K.*(?=" )' | sed 's/ /%20/g')
PRGNAM=wxHexEditor
VERSION=$(echo $VERSION_REAL | cut -d% -f1)
}

# Creamos directorios extra
#F_extradirs(){

#}

# Comprobar dependencias
F_dependencias(){
echo
if [ -f /var/log/packages/wxPython* ]; then
EXIST=`echo "$VERDE"Instalada"$CIERRE"`
else
EXIST=`echo "$ROJO"No Instalada"$CIERRE"`
fi
echo "$ROSA"Comprobando dependencias ..."$CIERRE"
echo
sleep 3
echo "$CYAN"Dependencias de este paquete:""
echo ""
echo "$AMARILLO"wxPython"$CIERRE: $EXIST"
if [ ! -f /var/log/packages/wxPython* ]; then
echo ""
echo "$ROJO"No se cumplen los requisitos no se puede continuar"$CIERRE"
echo ""
sleep 3
exit 0
else
echo ""
echo "$VERDE"Bien ..podemos continuar"$CIERRE"
echo ""
sleep 3
fi
}

# Si el paquete no existe se descargara de internet
F_download(){
if [ ! -f $PRGNAM-$VERSION-src.tar.bz2 ]; then
echo
echo "$CYAN"Descargando sources de $PRGNAM-$VERSION"$CIERRE"
sleep 1
aria2c -x 3 $WEB/$VERSION_REAL/$PRGNAM-$VERSION-src.tar.bz2
fi
}

# Descomprimimos el fichero descargado y compilamos
F_compilar(){
echo
echo "$VERDE"Descomprimiendo ..."$CIERRE"
sleep 3
rm -rf $PRGNAM
tar xvf $PRGNAM-$VERSION-src.tar.bz2
cd $PRGNAM
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

echo
echo "$VERDE"Compilando ..."$CIERRE"
sleep 3

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \

make
make install DESTDIR=$PKG
find $PKG -type f -name *.desktop -exec sed -i 's/Categories=Utility/Categories=Development/g' {} \;
mv $PKG/usr/local/* $PKG/usr
rmdir $PKG/usr/local
}

###################################
## BLOQUE PRINCIPAL DE EJECUCION ##
###################################
# Si se cierra el script inesperadamente, ejecutar la funcion de limpieza
trap f_exitmode SIGHUP SIGINT

#Inicializamos las variables globales
f_variables
#Comprobamos conexion a Internet
f_comprobarConexion
#Inicializamos las variables del script
F_variables
#Creamos directorio de trabajo
f_directorioTemporal
#Creamos directorios extra
#F_extradirs
#Mostramos el mensaje de presentacion
f_presentacion
#Comprobamos updates del script
f_comprobarUpdates
#Compronar dependencias
F_dependencias
#Asignamos o detectamos arquitectura
f_arquitectura
#Comprobamos version instalada del paquete
f_versionInstalada
#Si no existe el fichero se descargara
F_download
#Descomprimir fichero descargado y compilamos
F_compilar
#Hacemos strip sobre el paquete
f_strip
#Creamos xzm , instalamos y salimos
f_tareasFinales

Asi que ya tienes el pack completo: WxWidgets (No es util para el wxHexEditor) y el propio wxHexEditor

Salu2



Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #441 en: 17-01-2015, 01:47 (Sábado) »
este no lo voy a poner..por que no se necesita y por que rompe el wxopython que si se usa.

Código: [Seleccionar]
WxWidgets


respecto al updater de wxhexeditro , me quito el sombrero ... por que lo estuve mirando y no fui capaz ni de grepear la versión , siempre me decía la 0.21  cuandoo en realidad va por 0.23

vk496

  • Visitante
Re: Re: Mejorando los scripts wifislax-updaters
« Respuesta #442 en: 17-01-2015, 01:56 (Sábado) »
este no lo voy a poner..por que no se necesita y por que rompe el wxopython que si se usa.

Código: [Seleccionar]
WxWidgets


respecto al updater de wxhexeditro , me quito el sombrero ... por que lo estuve mirando y no fui capaz ni de grepear la versión , siempre me decía la 0.21  cuandoo en realidad va por 0.23
Lo de las versiones es algo puñetero en este script la verdad....

Respecto a wxWidgets, una lástima... :(

Y hablando de updaters desechados... Hay que hacerle un segundo asalto a JDownloader... Es algo personal XD

Salu2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #443 en: 18-01-2015, 20:51 (Domingo) »
jajaja esto es flipante ...


cuando añadi al sistema las wxpython , el caso es que me decia que algunos ficheros ya existian , y yo flipaba ..por que ese paquete nunca habia entrado a sistema.


ahora NO ME PREGUNTES POR QUE NI COMO , por que lo he flipado  ...  resulta que estaba en el mnodulo

extra-sw  , el paquete wxGTK ...    ??? ???


en fin , no recuerdo nada que no necesitase y teniendo wxpython , el otro no vale...ademas ya esta anulado al poner encima el wxpython ...   es como los inmortales, solo puede haber uno.


voy a reiniciar el sistema ...y buscar si hay dependencias rotas.... :-\

CristianEdgardo

  • Visitante
Re: Mejorando los scripts wifislax-updaters
« Respuesta #444 en: 20-01-2015, 16:13 (Martes) »
 :D :D :D :D :D :D :D :D :D :D

el wifislax updater gui 0.6 en la version 4.10.1 version de mantenimiento...

anda de diez, en las 4.10 se quedaba tildado y no vanzaba nunca....

 >:( >:( >:( >:(

Y una pregunta???, las actualizaciones van a changes dat, en modo live usb???
« Última modificación: 20-01-2015, 16:49 (Martes) por CristianEdgardo »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #445 en: 25-01-2015, 01:47 (Domingo) »
:D :D :D :D :D :D :D :D :D :D

el wifislax updater gui 0.6 en la version 4.10.1 version de mantenimiento...

anda de diez, en las 4.10 se quedaba tildado y no vanzaba nunca....

 >:( >:( >:( >:(

Y una pregunta???, las actualizaciones van a changes dat, en modo live usb???

cualquier cambio ..va al changes.dat   --->> para eso esta y de eso se trata , de guardar los cambios.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #446 en: 25-01-2015, 01:53 (Domingo) »
Traigo buenas noticias.  ;D

He conseguido desentramar el royo de las wx  ...

hay 4 updaters dependientes de wxwidgets , ya sea la parte en python o en gtk.


wxsvg -->> a este le da igual ..compila con las dos
wxHexeEditor -->> a este tambien le da igual compila con las dos

audacity -->> este solo con wxpython 2.8
filezilla -->> las versiones nuevas con wxGTK3


Bien , ...se puede tener en el sistema a la vez wxpython2 y wxgtk3 , por que no comparten librerias son todas distintas , solo se pelean por el fichero

/usr/bin/wx-config


es un simbolico que apunta hacia version 2 o 3 ...asi que segun lo que necesitemos el updater cambiara hacia donde apuntar el wx-config     ;D ;D ;D ;D ;D ;D


filezilla ,le cambie la dependencia en vez de wxpython , ahora buscara wxgtk3 y si wx-config no apunta hacia version 3 ..lo cambiara el solito ... lo mismo hace audacity que busca la version 2 , si no apunta , lo cambia el solo tambien.



Código: [Seleccionar]
# Se requiere version 3 de wxgtk se verifica
WXCONFIG=`ls -l /usr/bin/wx-config|cut -d'>' -f2 | sed "s/ //g" |rev|cut -d "/" -f1 |rev`
if [ ! $WXCONFIG = "gtk3-unicode-3.0" ]; then
ln -sf /usr/lib/wx/config/gtk3-unicode-3.0 /usr/bin/wx-config
fi



CristianEdgardo

  • Visitante
Re: Mejorando los scripts wifislax-updaters
« Respuesta #447 en: 25-01-2015, 02:17 (Domingo) »
Traigo buenas noticias.  ;D

Código: [Seleccionar]
# Se requiere version 3 de wxgtk se verifica
WXCONFIG=`ls -l /usr/bin/wx-config|cut -d'>' -f2 | sed "s/ //g" |rev|cut -d "/" -f1 |rev`
if [ ! $WXCONFIG = "gtk3-unicode-3.0" ]; then
ln -sf /usr/lib/wx/config/gtk3-unicode-3.0 /usr/bin/wx-config
fi


y este pedacito de codigo donde iria...

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #448 en: 25-01-2015, 02:42 (Domingo) »
es mejior que bajeis el pack con todo arreglado , ese trozo de code solo es parte de uno de los afectados.

en el de audacity es otro code ..y a filezilla le meti que comprobase la existencia de wxgtk

ademas como en wifislax-4.10.1 no viene esa libreria he añadido un updater wxGTK3

http://www.mediafire.com/download/r0zl321227smvg4/wifislax_updaters-3.3-noarch-1sw.xzm

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17992
    • GNU/Linux Wifislax
Re: Mejorando los scripts wifislax-updaters
« Respuesta #449 en: 25-01-2015, 04:12 (Domingo) »
me sale esto

 ******************************
           Actualizador/Instalador   
           Paquete: wxGTK3
                                   
           www.seguridadwireless.net 
        ******************************

Version Script: 25/01/2015

Descomprimiendo ...
tar: /opt/wifislax-updaters/Librerias/wxWidgets-3.0.2.tar.?z*: Cannot open: No existe el fichero o el directorio
tar: Error is not recoverable: exiting now
wifislax Librerias # ^C
wifislax Librerias #


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17992
    • GNU/Linux Wifislax
Re: Mejorando los scripts wifislax-updaters
« Respuesta #450 en: 25-01-2015, 04:15 (Domingo) »
y para el filezilia

configure: error:
        wxWidgets must be installed on your system
        but either the wx-config script couldn't be found or
        no compatible wxWidgets configuration has been installed.

        Compatible wxWidgets configurations are the unicode builds
        of wxGTK, wxMac and wxMSW.

        Please check that wx-config is in path, the directory
        where wxWidgets libraries are installed (returned by
        'wx-config --libs' command) is in LD_LIBRARY_PATH or
        equivalent variable and wxWidgets version is 3.0.2 or above.


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #451 en: 25-01-2015, 04:27 (Domingo) »
el de filezilla es normal...hasta que no metas la otra , nanai.

aunque no deberia de haberte dejado seguir si no tienes wxGTK3


/opt/wifislax-updaters/Librerias/wxGTK3_updater


antes
tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*

despues
tar xvf $SRCNAM-$VERSION.tar.bz2

con ese cambio ya deberia funcionar.

« Última modificación: 25-01-2015, 04:29 (Domingo) por USUARIONUEVO »

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17992
    • GNU/Linux Wifislax
Re: Mejorando los scripts wifislax-updaters
« Respuesta #452 en: 25-01-2015, 04:29 (Domingo) »
el de filezilla es normal...hasta que no metas la otra , nanai.


wxGTK3

ok, en la 4.9 paso lo mismo tuve que poner ima wxwidgets que ni recuerdo, pero pense que solo hacia falta para las versiones nuevas, no la otra



antes
tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*

despues
tar xvf $SRCNAM-$VERSION.tar.bz2

con ese cambio ya deberia funcionar.




Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #453 en: 25-01-2015, 04:32 (Domingo) »
vale . ya veo que filezilla ...lleva la funcion de autoresolverse las dependencias ...y al fallar pues se quedo a medias.

 ;D

se deberia resolver todo , cambiando la line que te dije en el wxGTK3_updater

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17992
    • GNU/Linux Wifislax
Re: Mejorando los scripts wifislax-updaters
« Respuesta #454 en: 25-01-2015, 04:35 (Domingo) »
escomprimiendo ...
tar: /opt/wifislax-updaters/Librerias/wxWidgets-3.0.2.tar.bz2: Cannot open: No existe el fichero o el directorio


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17992
    • GNU/Linux Wifislax
Re: Mejorando los scripts wifislax-updaters
« Respuesta #455 en: 25-01-2015, 04:41 (Domingo) »
rm -rf /tmp/build/wxGTK3


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #456 en: 25-01-2015, 04:41 (Domingo) »
fijate mas ...

has quitado el CWD ??


EJECUTALO DESDE EL MENU ... NI SE TE OCURRA LANZARLO TU A MANO ..POR QUE NO FUNCIONARA.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14715
Re: Mejorando los scripts wifislax-updaters
« Respuesta #457 en: 25-01-2015, 04:42 (Domingo) »
wxGTK3_updater


reparado

Código: [Seleccionar]
#!/bin/sh

# Script by www.seguridadwireless.net

SCRIPT_VERSION=20150125

############################################################
## Funciones comunes. Su nombre empieza por f_ ##
############################################################
f_variables(){
. /opt/wifislax-updaters/Funciones/funciones_updater
}

############################################################
## Funciones propias del script. Su nombre empieza por F_ ##
############################################################
# Definicion de variables
F_variables() {
WEB=http://sourceforge.net/projects/wxwindows/files/
VERSION=$(curl -s $WEB | grep -m1 "class=\"folder" | grep -Po 'title="\K.*(?=" )' | sed 's/ /%20/g')
PRGNAM=wxGTK3
SRCNAM=wxWidgets
DESCARGA=http://sourceforge.net/projects/wxwindows/files/$VERSION/$SRCNAM-$VERSION.tar.bz2
}

# Si el paquete no existe se descargara de internet
F_download(){
if [ ! -f $SRCNAM-$VERSION.tar.bz2 ]; then
echo
echo "$CYAN"Descargando sources de $PRGNAM-$VERSION"$CIERRE"
sleep 1
aria2c -x 3 $DESCARGA
fi
}

# Descomprimimos el fichero descargado y compilamos
F_compilar(){
echo
echo "$VERDE"Descomprimiendo ..."$CIERRE"
sleep 1
rm -rf $SRCNAM-$VERSION
tar xvf $SRCNAM-$VERSION.tar.bz2
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
 -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --enable-shared \
  --enable-mediactrl \
  --with-opengl \
  --enable-graphics_ctx \
  --with-gtk=3 \
  --enable-unicode \
  --build=$ARCH-slackware-linux

make
make install DESTDIR=$PKG

ln -fs /usr/lib${LIBDIRSUFFIX}/wx/config/gtk3-unicode-3.0 \
       $PKG/usr/bin/wx-config
}

###################################
## BLOQUE PRINCIPAL DE EJECUCION ##
###################################
# Si se cierra el script inesperadamente, ejecutar la funcion de limpieza
trap f_exitmode SIGHUP SIGINT

#Inicializamos las variables globales
f_variables
#Comprobamos conexion a Internet
f_comprobarConexion
#Inicializamos las variables del script
F_variables
#Creamos directorio de trabajo
f_directorioTemporal
#Mostramos el mensaje de presentacion
f_presentacion
#Comprobamos updates del script
f_comprobarUpdates
#Asignamos o detectamos arquitectura
f_arquitectura
#Comprobamos version instalada del paquete
f_versionInstalada
#Si no existe el fichero se descargara
F_download
#Descomprimir fichero descargado y compilamos
F_compilar
#Hacemos strip sobre el paquete
f_strip
#Creamos xzm , instalamos y salimos
f_tareasFinales

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17992
    • GNU/Linux Wifislax
Re: Mejorando los scripts wifislax-updaters
« Respuesta #458 en: 25-01-2015, 04:43 (Domingo) »
lo hice desde el menu

esultados de la descarga:
gid   |stat|avg speed  |path/URI
======+====+===========+=======================================================
9a13ee|OK  |   896KiB/s|/tmp/build/wxGTK3/wxWidgets-3.0.2.tar.bz2

Leyenda:
(OK):descarga completada.

Descomprimiendo ...
http://sourceforge.net/projects/wxwindows/files/3.0.2/wxWidgets-3.0.2.tar.bz2
tar: /opt/wifislax-updaters/Librerias/wxWidgets-3.0.2.tar.bz2: Cannot open: No existe el fichero o el directorio
tar: Error is not recoverable: exiting now


añadi echo para ver la ruta

ahora pruebo, tu ultimo code

me gusta lo manual, pero los menus tambien xd


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17992
    • GNU/Linux Wifislax
Re: Mejorando los scripts wifislax-updaters
« Respuesta #459 en: 25-01-2015, 04:46 (Domingo) »
compilando esta xd


//FINAL Y MÁS DOS RESPUESTAS