Autor Tema: Incompatibilidad con nuevo chipset Atheros!!!  (Leído 55965 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Tom

  • Visitante
Incompatibilidad con nuevo chipset Atheros!!!
« en: 24-06-2007, 15:33 (Domingo) »
Total, lo dicho "Atheros AR5007UG" en un portatil nuevo, y ninguna versión de wifislax (1.2,, 2.0, 3.0...) detecta siquiera el dispositivo...

"interface wireless reconocidas" ------------>"no wireless extensions"  :o

¿problema del chipset, del portatil, o de la suite?

Gracias por vuestra ayuda, estupendo el trabajo que realizais.



Armenos

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #1 en: 24-06-2007, 16:36 (Domingo) »
Citar
In May 2007, Atheros rebranded the ZD1211B chip but don't appear to have made other changes. The new chip name is Atheros AR5007UG (alternatively known as AR2524/AR5524). The hardware is supported by the current driver, except all known AR5007UG devices are based on UW2453 radio which won't be supported until Linux 2.6.23.

Información de http://linuxwireless.org/en/users/Drivers/zd1211rw. Saludos.

protagoras

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #2 en: 28-08-2007, 20:49 (Martes) »
Hola, hace un tiempo estoy tratando de conectarme con debian 4.0 a internet, pero no logro dar con un controlador para Atheros AR5007UG, entonces fué que di con este foro y la live wifislax, por lo que la bajé con la esperanza de que allí hubiese un contralador, pero tampoco me la reconoce, recientement bajé la versión 3.1, y tampoco lo hace, buscando he encontrado unos controladores que dicen funcionan, pero como estoy empezando con linux no sé como instalarlos, luego agregaré el link, si logro volver a encontrarlo, o subiré estos supuestos controladores, a ver si sirven

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17749
    • GNU/Linux Wifislax
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #3 en: 29-08-2007, 01:11 (Miércoles) »
es facil instalar drivers en linux , mira de meter el enlace y lo vemos


protagoras

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #4 en: 30-08-2007, 21:18 (Jueves) »
Bueno, será facil, pero para mi que estoy empezando no se por donde encarar, he estado leyendo sobre compilar el kernel, bueno, dejo el enlace, para que lo veas http://dsd.object4.net/zd1211-vendor/releases/

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17749
    • GNU/Linux Wifislax
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #5 en: 30-08-2007, 22:49 (Jueves) »
Me he perdido, atheros ,zydas, nuevo kernel para esos drivers, el 2.6.23, no me aclaro?


protagoras

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #6 en: 31-08-2007, 20:15 (Viernes) »
Lo mas seguro es que yo esté perdido, a ese enlace que te he puesto me llevó la respuesta de una persona que en un foro dice que ha logrado hacer funcionar la tarjeta Atheros AR5007UG, que es la que tiene mi portatil, instalando la ultima versión de los archivos del enlace que te dejé, ahora te dejo el link, donde dice el que le ha funcionado http://www.bandaancha.st/foros.php?temid=1330332. Lo del nuevo kernel, como no sé como se instala un controlador en linux he estado leyendo que habría que bajarse un kernel que esté actualizado con los driver, compilarlo e instalarlo. pero he instalado debian 4.0 y pensaba que me la reconocería, dado que el kernel que lleva es reciente,pero nada, ni tampoco ubuntu, ni pclinuxos, ni el wifislax 3.1.

pmg

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #7 en: 11-09-2007, 21:57 (Martes) »
Hola.

Ese mensaje que enlazas lo escribí yo, y ahora estoy saliedo por una AR5007UG. de todas formas lo he ampliado.

http://www.bandaancha.st/foros.php?temid=1404576

Espero que ayude, y se a alguien se le ocurre como mejorarlo, se lo agradecería.

Un saludo.

protagoras

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #8 en: 20-09-2007, 12:44 (Jueves) »
Hola, mira que he venido a dar con el autor de aquel mensaje. Bueno, yo no he tenido demasiado tiempo para dedicarme, por lo pronto ya he istalado wifislax 3.1 y windows xp, pues antes tenía vista, pero al instalar xp he visto que me pone un controlador de zydas, así que lo de Atheros AR5007UG, bueno, supongo que la placa que tengo tiene varios controladores. Me pasó que al instalar PClinuxOS me pedía justamente un controlador de zydas. Por lo que he leido PClinuxos tiene buena deteccion de hardware, así que descomprimiré el archivo que has enlazado tu para ver si al instalar pclinuxos me lo instala, si no tendré que compilarlo, y tomarme tiempo, así que paciencia. Muchas gracias por responder


pmg

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #9 en: 12-10-2007, 18:39 (Viernes) »
Hola.

Salio una nueva versión del driver, concretamente el día 1/10/07. http://dsd.object4.net/zd1211-vendor/releases/

Hoy he actualizado el Kernel y me he puesto con este nuevo driver ZD1211LnxDrv_2_21_0_0.tar.gz

Todo sigue casi igual. La instalación es muy simple para mi tarjeta de red AR5007UG

Lo primero compilar e instalar el driver

make ZD1211REV_B=1

-- COMO ROOT --
make ZD1211REV_B=1 install

Si reseteamos la red o reiniciamos e ordenador ya aparece la wlan pero aun se tiene que dar la orden:

ifconfig wlan1 up (wlan1 es en mi caso, cada uno la que tenga)

ya te puedes conectar, Para no tener que hacerlo continuaente en
 /etc/init.d/boot.local
añadir
ifconfig wlan1 up
(se que no es muy lógica poner esa orden en ese fiechero, per es en donde funciona)

Con este nuevo driver y la AR5007AG funciona networkmanager y Kntworkmanager, pero unicamente para redes sin cifrar, con redes que tienen clave sigue igual SIN FUNCIONAR.

por lo que si como yo tiene la red con cave (del tipo que sea) confgurala por IFUP y funciona a la primera.

Un saludo.

Se me paso. Si te carga el zd1211rw, tiene que hacer que no cague.





Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17749
    • GNU/Linux Wifislax
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #10 en: 12-10-2007, 18:56 (Viernes) »
este post y la tematica de el, nolo acabo de entender, como es posible un drivers de zydasp ara atheros.

Y para que tarjetas exactamente?


pmg

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #11 en: 12-10-2007, 19:50 (Viernes) »
te respondo con un copy paste de la página

http://zd1211.wiki.sourceforge.net/

ZyDAS ZD1211 802.11b/g USB WLAN chipset Linux drivers

Initially contributed by ZyDAS under the GPL license, the ZD1211 Linux driver is maintained by the open source community.

ZyDAS have been very friendly towards the community in terms of providing a fully open source driver, freely distributable firmware, technical specifications under non-distribution agreement, and answering queries from developers. We hope other vendors will follow their great example, and with the inclusion of a stable in-kernel driver we certainly recommend this hardware as a worthwhile purchase for Linux users.

After being acquired by Atheros, the chipset was renamed to AR5007UG. The original drivers support the new hardware.

Legalese: This is an unofficial website that is not affiliated or endorsed by the ZyDAS corporation. Warranty disclaimer.

Un saludo

pmg

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #12 en: 12-10-2007, 23:27 (Viernes) »
Mirando hilos he visto que:

https://foro.seguridadwireless.net/index.php/topic,2724.0.html

tiene el mismito ordenador que tengo yo, cuando me lo compre he tenido mas de un cabreo.

http://forum.packardbell.com/es/viewtopic.php?t=5132

Que aun hoy no se han molestado en responder. Comentar a esta persona que almenso con SuSE y entiendo que con cualquier otra distribución lo puede hacer funcionar.

Un saludo.

protagoras

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #13 en: 03-11-2007, 18:39 (Sábado) »
Hola, demasiado tiempo he tardado en mirar el foro, bueno, aún no consigo tener los tres sistemas: xp, wifislax y pclinuxos funcionando, he instalado pclinuxos, he cambiado el lilo según un tutorial de adrianweb, pero solo me aparece al inicio xp y wifislax, ya me dedicaré a mirar que hago mal, o pondré algunas capturas en el foro. Esto que dices, pmg, de que con clave no se conecta, me ha pasado con wifislax y se soluciona ingresándola por la consola: iwconfig wlan0 key (la clave), por poner un ej. Respecto a lo que dice hwagm, que no acaba de entender, yo tampoco, es decir, ya sea atheros, o zidas, hablamos de chipset, y no de la placa, o del nombre de la placa, que querría saber yo que placa tengo y que chipset lleva, para saber que controlador se usa para ese chipset, pero la verdad es que no he logrado saberlo, tampoco me he dedicado a investigar, pero mi portatil es un Mediom, que compré en aldi, podría ver si el soporte técnico me da respuestas, pues la verdad, en vista me instaló el controlador de atheros, y funcionaba bien, y en xp me bajé los driver para xp, de la pagina, y me instala un controlador de zidas. Si que estoy confuso, pero como ahora tengo otro adaptador que si funciona en linux...  Salu2

Elcadaver

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #14 en: 27-11-2007, 17:22 (Martes) »
Hola...

Tambien hay problemas con la Atheros AR5007EG Wireless Network Adapter y no consigo soluciones...

Alguien puede ayudarme?¿

Gracias

bgomez

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #15 en: 28-01-2008, 17:14 (Lunes) »
Hola. Acabo de comprar una tarjeta zydas atheros AR5007UG. para darla de alta en wifislax 3.1, ejecuta:

zd1211rw1.sh

Funciona perfectamente, he inyectado con una velocidad de 900

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 17749
    • GNU/Linux Wifislax
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #16 en: 10-02-2008, 00:56 (Domingo) »
ya habia olvidado este post, bueno lo enlazo a esta solucion:

https://foro.seguridadwireless.net/index.php/topic,2724.msg54922.html#msg54922

¿Controladores Atheros AR5007UG para modo monitor?

https://foro.seguridadwireless.net/index.php/topic,2724.msg54922.html#msg54922

que viene a decir, a que probeis estos nuevos modulos:

-------------------------

NO se como estara el tema legal de estos drivers, pero los he metido ya compilados en un paquete y se pueden usar para wifiway-1.0 beta 2, wifislax-small y wifislax 3.1, la wifiway-0.8 ya no me acuerdo de que kernel llebaba,jejejej

como bajarlos ya compilados

http://telefonica.net/web2/wifislax/modulos-extra/atheros-special.tar.gz

Código: [Seleccionar]
wget http://telefonica.net/web2/wifislax/modulos-extra/atheros-special.tar.gz
descoprimimos

Código: [Seleccionar]
tar -zxf atheros-special.tar.gz
Borramos todos los ficheros de /lib/modules/2.6.21.5/net/ y colocamos todos los ficheros que se han descomprimido con el comando tar -zxf atheros-special.tar.gz, en esa misma tarjeta.

Luego lo tipico de siempre,
por si se cargaron algunos de los modulos anteriores de atheros, lo liberamos de la memoria

Código: [Seleccionar]
rmmod wlan_wep ath_rate_sample ath_rate_onoe ath_pci wlan ath_hal ath_rate_amrr 2>/dev/null
para que cargue los nuevos
Código: [Seleccionar]
depmod -ae
modprobe ath_pci

Lastimas que solo permitan el modo monitor, supongo que no valen los parches de siempre de la atheros y no se como esta el tema de nuevos parches para inyeccion con estos drivers.

pd: curioso que estas soluciones se deriven de post empezados en la zona de no registrados, asi se pone de manifiesto que esa zona tambien es muy importante.
« Última modificación: 10-02-2008, 00:58 (Domingo) por Hwagm »


ZaPa

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #17 en: 21-03-2008, 06:00 (Viernes) »
Hola a todos.

Puede que no funcione este dispositivo para redes encriptadas porqué faltan un par de cosas a cambiar en el kernel, probar a activar en el kernel todos los algoritmos de encriptación y demás.

Código: [Seleccionar]
[*] Cryptographic API
 <*>   AES cipher algorithms (i586)
 <*>   ARC4 cipher algorithm
 <*>   Michael MIC keyed digest algorithm

Saludos.

Nieto08

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #18 en: 27-03-2008, 17:05 (Jueves) »
Hola a todos e consultado foros y siempre e solucinado las dudas pero esta vez no la encuentro ni loco o al menos me pierden.

Es mi primera vez que lo intento hacer ;D, lo de averiguar las claves de los wifi y no tengo ni la mas remota idea, aunque no paro de probar programas y leer paginas del foro.

Cuando hago ipconfig /all en el virus Vista en el portatil nuevo, me pone que mi tarjeta es o tiene un chipset "Atheros AR5007EG wireless network adapter", y tengo el wifislax 3.1, que no me reconoce la tarjeta, ¿no vale la tarjeta?, y si funcionase,por favor diganme todo lo que necesito descargar, de donde, y los pasos para instarlos.

¿y alguien sabe como se puede hacer en el virus Vista?

¡¡¡Por favor, que me va a estallar la cabeza!!!

flacoluis

  • Visitante
Re: Incompatibilidad con nuevo chipset Atheros!!!
« Respuesta #19 en: 08-05-2008, 16:19 (Jueves) »
con VISTA el commview 6.0 me ve la tarjeta de ese modelo
la reconoce como atheros 5006
hay un programita chekcard de commview que te detecta si la tarjeta es compatible con el programa

espero te sirva
« Última modificación: 08-05-2008, 17:28 (Jueves) por flacoluis »

//FINAL Y MÁS DOS RESPUESTAS