Autor Tema: USB en Openwrt  (Leído 43640 veces)

0 Usuarios y 1 Visitante están viendo este tema.

tasseguro

  • Visitante
USB en Openwrt
« en: 21-07-2008, 00:52 (Lunes) »
Besos y abrazos para toda la peña  :-*

Antes de nada agradecer al amigo Recovero (con mucho retraso) su ayuda en el post de Jesus1981 sobre las particiones en el Asus wl-500 gp sobre DD-WRT.

Mi intención era en aquel momento intentar instalar Aircrack en DD-WRT, pero probé de 1000 formas y no tuve piltilclines a conseguir rular Airodump.

Por ahí hay alguien que dice haberlo conseguido con una V24 mini.  :-'

No se tira al rollo y no pone cómo lo ha hecho, pero si es así, le aplaudo desde aquí y veo como la envidia empieza a corroerme por entre los calcetines, joooooder.

Bueno, como mi objetivo sigue siendo la auditoría de mi red, he pasado a OpenWrt, y ahí parece que la cosa 'ta más asequible.

He conseguido en el Kamikaze 7.09 que rule Airodump (Aireplay quedaría para Atheros, ya que parece ser que la Broadcom en el wl-500 no inyecta en estos cachiruls).

Sigo estando cada día más perdido con Linux, pero siguiendo este tuto del foro del OpenWrt (traduciéndolo el Google) he podido montarle al wl-500 un HD externo de 2,5' en un enclosure USB y parece que también instalarle Samba:

http://forum.openwrt.org/viewtopic.php?id=11495

Pero hasta ahí llego. Necesito un penúltimo empujón. Ya digo que Airodump corre, también captura los datas de mi nitguorq con seguridad WEP, unos 50/segundo, pero el problema es al guardar los CAPs o los IVs

El Asus tiene 32 MB de RAM y para decir verdad no tengo ni idea del volumen de memoria que ocuparían esos 200.000 o 2.000.000 de IVs. y que rotos denotarían la inseguridad de la red de mis desmayos.

Unos 200.000 datas (también paquetes por ese número) le han proporcionado al Aircrack solamente unos 1200 IVs válidos en mis 2-3 intentos. Esos 200.000 datas han formado un archivo.ivs de apenas 1 KB o 7-8 KB (no recuerdo bien).

No sé si el motivo es la deficiencia de la Broadcom en el Asus al sniflar (o el que está sentado a los mandos de la Broadcom en el Asus), o si por el contrario el problema es que Airodump no puede escribir las capturas a disco.

Ya digo que (parece) el HD externo bien montado, y Samba instalado, Pero he intentado situarme en varios directorios para comenzar a capturar, y que los datas pasaran al HD, pero no ha habido forma.

Sale un archivo.ivs de muy pocas bytes (y aún menos IVs válidos), en una captura de 200.000 paquetes con los enrutadores viéndose hasta los pelillos de la nariz, bueno no tan cerca pero eso.

Entonces, ¿sólo habría que situarse en un directorio apropiado y desde allí rular Airodump y que pudiera grabar en el HD externo?

O ¿Habría que configurar Samba para habilitar archivos compartidos?

Necesito aunque sea una pequeña pista para mi despiste. ???

Gracias por aguantarme estos mamotretos. ^-^

Saludos a todos. :D



tasseguro

  • Visitante
Re: USB en Openwrt
« Respuesta #1 en: 22-07-2008, 07:46 (Martes) »
No hay nada como tener la solución delante de las narices para no poder dar con ella.  ;)

Tres días. Tres días enteros con sus noches. Tres días enteros con sus noches y el Domingo de Ramos próximo que ya lo se he dejado empeñado al Mal Can.

Tres días enteros con sus noches, el Domingo de Ramos próximo que ya lo se he dejado empeñado al Mal Can, más todo el remanente de la discontinuidad espacio tiempo y una medianoche en la cara parda de la luna.

Tres días enteros con sus noches y el Domingo de Ramos próximo que ya lo se he dejado empeñado al Mal Can, más todo el remanente de la discontinuidad espacio tiempo, una medianoche en la cara parda de la luna y Cuba si no llega a ser por los Yanquis, sin contar las veces que me he **** en **** y el tiemo empleado en limpiarme para al final ver que el HD EXTERNO HABILITADO SE HACE CON LA RAIZ DE TODO EL DIRECTORIO.

En fin, bien empieza lo que bien acaba. Vientooooooooooo, mal tiempo.

Saludotes
« Última modificación: 22-07-2008, 22:42 (Martes) por uNbAs »

pikomule

  • Visitante
Re: USB en Openwrt
« Respuesta #2 en: 25-05-2010, 22:51 (Martes) »
por favor, necesito los comandos para acceder al USB. tengo un Comtrend 5361, con Openwrt 10.03 instalado. Tengo el router modificado con un puerto USB, En el LOg aparece esto:


Mar 31 06:04:23 OpenWrt user.notice kernel: sd 9:0:0:0: [sda] 7827456 512-byte logical blocks: (4.00 GB/3.73 GiB)
Mar 31 06:04:23 OpenWrt user.debug kernel: usb-storage: device scan complete
Mar 31 06:04:23 OpenWrt user.notice kernel: sd 9:0:0:0: [sda] Write Protect is off
Mar 31 06:04:23 OpenWrt user.debug kernel: sd 9:0:0:0: [sda] Mode Sense: 23 00 00 00
Mar 31 06:04:23 OpenWrt user.err kernel: sd 9:0:0:0: [sda] Assuming drive cache: write through
Mar 31 06:04:23 OpenWrt user.err kernel: sd 9:0:0:0: [sda] Assuming drive cache: write through
Mar 31 06:04:23 OpenWrt user.info kernel:  sda: sda1
Mar 31 06:04:23 OpenWrt user.err kernel: sd 9:0:0:0: [sda] Assuming drive cache: write through
Mar 31 06:04:23 OpenWrt user.notice kernel: sd 9:0:0:0: [sda] Attached SCSI removable disk


Con eso creo que es reconocido, pero como accedo a él?

de estas maneras no puedo acceder:

/mnt/dev/sda

/mnt/dev/sda1

/mnt/sda

/mnt/sda1

*dudux

  • Visitante
Re: USB en Openwrt
« Respuesta #3 en: 25-05-2010, 23:01 (Martes) »
muy facil!!

Código: [Seleccionar]
mkdir /mnt/sda1
mount /dev/sda1 /mnt/sda1   
         //debe de existir mnt y sda1

asegurate con
Código: [Seleccionar]
df -h

pikomule

  • Visitante
Re: USB en Openwrt
« Respuesta #4 en: 25-05-2010, 23:04 (Martes) »
muchas gracias por responder, tiene que ser muy sencillo montar esto, pero es que no tengo mucha idea de linux.

al hacer df -h me sale esto:

root@OpenWrt:/# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 1.8M      1.8M         0 100% /rom
tmpfs                     6.6M     92.0K      6.5M   1% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock3            1.3M    776.0K    568.0K  58% /overlay
mini_fo:/overlay          1.8M      1.8M         0 100% /



Y haciendo lo otro, esto:

root@OpenWrt:/# mkdir /mnt/sda1
root@OpenWrt:/# mount /dev/sda1 /mnt/sda1
mount: you must specify the filesystem type
root@OpenWrt:/# /dev/sda
/bin/ash: /dev/sda: Permission denied
root@OpenWrt:/# mnt/sda
/bin/ash: mnt/sda: not found
root@OpenWrt:/# mnt/sda1
/bin/ash: mnt/sda1: Permission denied
« Última modificación: 25-05-2010, 23:07 (Martes) por pikomule »

berni69

  • Visitante
Re: USB en Openwrt
« Respuesta #5 en: 25-05-2010, 23:07 (Martes) »
prueba con
mount -t auto /dev/sda1 /mnt/sda1

*dudux

  • Visitante
Re: USB en Openwrt
« Respuesta #6 en: 25-05-2010, 23:08 (Martes) »
primero haz lo de arriba...


p.d.por cierto ,ahora mnismo acabo de ver sygic para iph0ne by .............xD

que formato es?¿

pikomule

  • Visitante
Re: USB en Openwrt
« Respuesta #7 en: 25-05-2010, 23:13 (Martes) »
jeje funciona muy bien el Sygic.


con este comando: mount /dev/sda1 /mnt/sda1    me dice que especifique filesystem type


Berny, lo tuyo tampoco funciona. Si alguien se ofrece le ofrezco acceso remoto a mi ordenador para que vea el tema y pruebe.

Con Showmypc el remoto es rapido y sencillo

berni69

  • Visitante
Re: USB en Openwrt
« Respuesta #8 en: 25-05-2010, 23:20 (Martes) »
pega la salida que te da lo que te puse a ver donde falla


mkdir /mnt/sda1
mount -t auto /dev/sda1 /mnt/sda1   
cd /mnt/sda1

pikomule

  • Visitante
Re: USB en Openwrt
« Respuesta #9 en: 25-05-2010, 23:25 (Martes) »
he apagago el router y vuelta a empezar, esto me sale berni:


root@OpenWrt:/# mkdir /mnt/sda1
mkdir: cannot create directory '/mnt/sda1': File exists
root@OpenWrt:/# mount -t auto /dev/sda1 /mnt/sda1
mount: you must specify the filesystem type
root@OpenWrt:/# cd /mnt/sda1
root@OpenWrt:/mnt/sda1# dir
/bin/ash: dir: not found



como listo los archivos?

*dudux

  • Visitante
Re: USB en Openwrt
« Respuesta #10 en: 25-05-2010, 23:29 (Martes) »
debes de sabeer el filesystem de ese USB
el directorio ya lo tienes creado

si es ntfs tendras problemsas,vamos no estoy seguro,pero dudo que openwrt lleve ntfs-3g ,asi que formatea a fat o ext3 y cargalo con -t ext3 o -t fat

listar con ls

berni69

  • Visitante
Re: USB en Openwrt
« Respuesta #11 en: 25-05-2010, 23:32 (Martes) »
se listan con el comando "ls"

si es ntfs deberias montarlo asi:
mount -t ntfs-3g /dev/sda1 /mnt/sda1
y si es fat
mount -t vfat /dev/sda1 /mnt/sda1

debes de sabeer el filesystem de ese USB
el directorio ya lo tienes creado

si es ntfs tendras problemsas,vamos no estoy seguro,pero dudo que openwrt lleve ntfs-3g ,asi que formatea a fat o ext3 y cargalo con -t ext3 o -t fat

listar con ls

te me adelantaste.. jeje

*dudux

  • Visitante
Re: USB en Openwrt
« Respuesta #12 en: 25-05-2010, 23:34 (Martes) »
se listan con el comando "ls"

si es ntfs deberias montarlo asi:
mount -t ntfs-3g /dev/sda1 /mnt/sda1
y si es fat
mount -t vfat /dev/sda1 /mnt/sda1

debes de sabeer el filesystem de ese USB
el directorio ya lo tienes creado

si es ntfs tendras problemsas,vamos no estoy seguro,pero dudo que openwrt lleve ntfs-3g ,asi que formatea a fat o ext3 y cargalo con -t ext3 o -t fat

listar con ls

te me adelantaste.. jeje

eso peta,no?

berni69

  • Visitante
Re: USB en Openwrt
« Respuesta #13 en: 25-05-2010, 23:38 (Martes) »
depende de si tienes el driver, no?

pikomule

  • Visitante
Re: USB en Openwrt
« Respuesta #14 en: 25-05-2010, 23:40 (Martes) »
los drivers para usb en el router estan instalados, si no en el LOG no seria reconocido.

root@OpenWrt:/# mkfs.vfat /dev/sda1
/bin/ash: mkfs.vfat: not found
root@OpenWrt:/# mount -t vfat /dev/sda1 /mnt/sda1
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

root@OpenWrt:/# mount -t vfat /dev/sda1 /mnt/sda
mount: mount point /mnt/sda does not exist
root@OpenWrt:/#

berni69

  • Visitante
Re: USB en Openwrt
« Respuesta #15 en: 25-05-2010, 23:49 (Martes) »
como esta particionado tu disco  duro?? y con que formato??

prueba quitandole la v, como xcomenta dudux, ya que quizas al ser una versio nreducida para openwrt le falten opciones/drivers
mount -t fat /dev/sda1 /mnt/sda1
« Última modificación: 25-05-2010, 23:51 (Martes) por βerni69 »

pikomule

  • Visitante
Re: USB en Openwrt
« Respuesta #16 en: 25-05-2010, 23:50 (Martes) »
es un pendrive de 4gb en FAT.

todos estos comandos estan hechos desde telnet hacia el router, por si habia dudas

lo formateo en lo que me digais si es mas facil

berni69

  • Visitante
Re: USB en Openwrt
« Respuesta #17 en: 25-05-2010, 23:53 (Martes) »
en teoria la fat te la deberia soportarm ya que las sd de la fonera son fat y funcionan, si puedes pasalo a ext3 o reformatealo para salir de dudas, prueba lo que te dije en la edicion del posta nterior

pikomule

  • Visitante
Re: USB en Openwrt
« Respuesta #18 en: 25-05-2010, 23:56 (Martes) »
root@OpenWrt:/# mount -t vfat /dev/sda1 /mnt/sda
mount: mount point /mnt/sda does not exist
root@OpenWrt:/# mount -t fat /dev/sda1 /mnt/sda1
mount: unknown filesystem type 'fat'
mount: maybe you meant 'vfat'?
root@OpenWrt:/#

berni69

  • Visitante
Re: USB en Openwrt
« Respuesta #19 en: 25-05-2010, 23:59 (Martes) »
la clave esta aqui

Citar
root@OpenWrt:/# mount -t vfat /dev/sda1 /mnt/sda1
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

reformatea el USB si puedes quita la aprticion y crealade nuevo, sino formatealo completo, no rapido como sueleahacer win2 ya que tienes un problema con la tabla de particiones