Autor Tema: problema con pcsc (lector dni electronico) en comtrend ar5387un  (Leído 6625 veces)

0 Usuarios y 1 Visitante están viendo este tema.

jarping

  • Visitante
Hola me gustaria saber si alguien ha tenido o tiene el mismo problema, el tema es que tengo este router comtrend ar5387un con openwrt 14.07 rc3 la ultima version, le he compilado la ultima version de oscam e instalado todos los paquetes necesarios para el lector usb pcsc y el oscam funciona bien se arranca perfecto pero no consigo activar el pcsc a pesar de detectar el lector por usb con el comando lsusb

alguien sabe cual puede ser el problema

Gracias y un saludo




raphik

  • Visitante
Re: problema con pcsc (lector dni electronico) en comtrend ar5387un
« Respuesta #1 en: 09-01-2015, 22:47 (Viernes) »
¿Qué paquetes has instalado exactamente? ¿Has instalado el paquete CCID?

Saludos.

jarping

  • Visitante
Re: problema con pcsc (lector dni electronico) en comtrend ar5387un
« Respuesta #2 en: 10-01-2015, 08:26 (Sábado) »
Ccid, piscis, libpcsc, libuab están pero nada a pesar de estar compilado Óscar con soporte pcsc

raphik

  • Visitante
Re: problema con pcsc (lector dni electronico) en comtrend ar5387un
« Respuesta #3 en: 10-01-2015, 10:06 (Sábado) »
Supongo que el lector SC está en la lista de dispositivos compatibles oscam.

Saludos.

jarping

  • Visitante
Re: problema con pcsc (lector dni electronico) en comtrend ar5387un
« Respuesta #4 en: 10-01-2015, 11:33 (Sábado) »
si lo está porque lo he probado en una maquina virtual con ubuntu y ahora está corriendo en una raspberry pi con oscam, pero quiero probarlo en el router y dejarlo funcionando y usar la raspberry para otros usos

xDD nose si será problema de firmware  y compilar uno con soporte pcsc que he visto que el firmware lleva la opcion

rafalci

  • Visitante
Re:
« Respuesta #5 en: 10-01-2015, 14:24 (Sábado) »
Por si te sirve de referencia lo compile con pcsc en un hg553 y funciona perfectamente con un lector dni.
Un saludo

jarping

  • Visitante
Re: problema con pcsc (lector dni electronico) en comtrend ar5387un
« Respuesta #6 en: 10-01-2015, 14:25 (Sábado) »
Pcsc y libpcsclite??


Enviado desde mi iPhone utilizando Tapatalk

raphik

  • Visitante
Re:
« Respuesta #7 en: 11-01-2015, 02:35 (Domingo) »
Por si te sirve de referencia lo compile con pcsc en un hg553 y funciona perfectamente con un lector dni.
Un saludo

¿Podrías explicar cómo lo has hecho?

Saludos.

jarping

  • Visitante
Re: problema con pcsc (lector dni electronico) en comtrend ar5387un
« Respuesta #8 en: 11-01-2015, 08:39 (Domingo) »
Lo ha compilado como parte del kernel, así lo estoy intentando yo pero hay una librería del kernel de la rama trunk que esta arrojando errores, seguiré intentandolo


Enviado desde mi iPhone utilizando Tapatalk

raphik

  • Visitante
Re: problema con pcsc (lector dni electronico) en comtrend ar5387un
« Respuesta #9 en: 11-01-2015, 12:40 (Domingo) »
Entonces igual es la compilación del trunk para el ar5387un lo que falla. Para asegurarte, podrías compilar con la rama BB. Actualmente no soporta wifi, pero al menos saldrás de dudas.

Saludos.

jarping

  • Visitante
Re: problema con pcsc (lector dni electronico) en comtrend ar5387un
« Respuesta #10 en: 11-01-2015, 14:43 (Domingo) »
acabo de compilarlo sin errores era error mio despues lo probaré que tal va y comento

rafalci

  • Visitante
Re:
« Respuesta #11 en: 11-01-2015, 20:25 (Domingo) »
Exacto,pero creo recordar que el libpcsclite lo instale como paquete al igual que oscam, luego los datos en los tres archivos de rigor y funciona....para mi sorpresa con los mismos tiempos que el deco.
Un saludo

jarping

  • Visitante
Re: problema con pcsc (lector dni electronico) en comtrend ar5387un
« Respuesta #12 en: 12-01-2015, 12:13 (Lunes) »
ahora el problema está en poder compilar oscam con soporte pcsc haciendolo con un script "simplebuild" falla por el toolchain porque compilarlo en el propio router es mas bien complicado
y la descargas de binarios precompilados no suelen llevar soporte pcsc

xDD alguien tiene experiencia en compilaciones oscam para la plataforma brcm63xx


pego el error que da a ver si alguien lo identifica

 OSCam ver: 1.20-unstable_svn rev: 10157 target: mips-openwrt-linux-uclibc
| Tools:
|  CROSS    = /opt/simplebuild/toolchains/brcm63xx/bin/mips-openwrt-linux-uclibc-
|  CC       = /opt/simplebuild/toolchains/brcm63xx/bin/mips-openwrt-linux-uclibc-gcc
| Settings:
|  CONF_DIR = /etc/config/oscam
|  CC_OPTS  = -Os -ggdb -pipe -ffunction-sections -fdata-sections
|  CC_WARN  = -w
|  CFLAGS   =
|  LDFLAGS  = -Wl,--gc-sections -Wl,-rpath,/lib -Wl,-rpath,/usr/local/lib -Wl,-rpath,/usr/lib -L/opt/simplebuild/toolchains/brcm63xx/lib
|  LIBS     = -lpthread -ldl -lrt
|  UseFlags =
| Config:
|  Addons   : WEBIF WEBIF_LIVELOG WEBIF_JQUERY TOUCH HAVE_DVBAPI IRDETO_GUESSING CS_ANTICASC WITH_DEBUG MODULE_MONITOR WITH_LB CS_CACHEEX CW_CYCLE_CHECK CLOCKFIX
|  Protocols: CAMD35 CAMD35_TCP NEWCAMD CCCAM CCCSHARE GBOX RADEGAST SCAM SERIAL CONSTCW PANDORA GHTTP
|  Readers  : NAGRA IRDETO CONAX CRYPTOWORKS SECA VIACCESS VIDEOGUARD DRE TONGFANG BULCRYPT GRIFFIN DGCRYPT
|  CardRdrs : PHOENIX INTERNAL SC8IN1 MP35 SMARGO DB2COM STAPI STINGER  
|  Compiler : mips-openwrt-linux-uclibc-gcc.bin (Linaro GCC 4.6-2012.02) 4.6.3 20120201 (prerelease)
|  Binary   : ../archiv/oscam-svn10157-brcm63xx-webif
+-------------------------------------------------------------------------------
HOSTCC   webif/pages_gen
GEN   webif/pages.c
GEN   Compressed 375664 template bytes into 157857 bytes. 217807 saved bytes (57.98%).
CC   cscrypt/aes.c
CC   cscrypt/bn_add.c
CC   cscrypt/bn_asm.c
/opt/simplebuild/toolchains/brcm63xx/bin/../lib/gcc/mips-openwrt-linux-uclibc/4.6.3/../../../../mips-openwrt-linux-uclibc/bin/as: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory
/opt/simplebuild/toolchains/brcm63xx/bin/../lib/gcc/mips-openwrt-linux-uclibc/4.6.3/../../../../mips-openwrt-linux-uclibc/bin/as: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory
CC   cscrypt/bn_ctx.c
/opt/simplebuild/toolchains/brcm63xx/bin/../lib/gcc/mips-openwrt-linux-uclibc/4.6.3/../../../../mips-openwrt-linux-uclibc/bin/as: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory
/opt/simplebuild/toolchains/brcm63xx/bin/../lib/gcc/mips-openwrt-linux-uclibc/4.6.3/../../../../mips-openwrt-linux-uclibc/bin/as: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory
Makefile:363: recipe for target 'build/mips-openwrt-linux-uclibc/cscrypt/bn_ctx.o' failed
make[1]: *** [build/mips-openwrt-linux-uclibc/cscrypt/bn_ctx.o] Error 2
make[1]: *** Se espera a que terminen otras tareas....
Makefile:363: recipe for target 'build/mips-openwrt-linux-uclibc/cscrypt/bn_add.o' failed
make[1]: *** [build/mips-openwrt-linux-uclibc/cscrypt/bn_add.o] Error 2
Makefile:363: recipe for target 'build/mips-openwrt-linux-uclibc/cscrypt/aes.o' failed
make[1]: *** [build/mips-openwrt-linux-uclibc/cscrypt/aes.o] Error 2
Makefile:363: recipe for target 'build/mips-openwrt-linux-uclibc/cscrypt/bn_asm.o' failed
make[1]: *** [build/mips-openwrt-linux-uclibc/cscrypt/bn_asm.o] Error 2
Makefile:316: recipe for target 'all' failed
make: *** [all] Error 2


XDDDD Solucionado con este paquete sudo apt-get install lib32z1
« Última modificación: 12-01-2015, 12:28 (Lunes) por jarping »

rafalci

  • Visitante
Re:
« Respuesta #13 en: 12-01-2015, 14:07 (Lunes) »
Has probado a compilarlo con los paquetes básicos y despues instalar los paquetes pscs, libpcsclite,cccid y no recuerdo si alguno más?
Creo recordar que lo hice de esta forma, aunque en el hg553.
Un saludo

jarping

  • Visitante
Re: problema con pcsc (lector dni electronico) en comtrend ar5387un
« Respuesta #14 en: 13-01-2015, 01:28 (Martes) »
Si desde el openwrt instaló los paquetes libpcsc y pcsd, compiló os cam con soporte pcsd pero luego emboscan me dice que no tiene soporte pcsc es raro y no termino de dar con el fallo


Enviado desde mi iPhone utilizando Tapatalk

lomismo1

  • Visitante
Re: problema con pcsc (lector dni electronico) en comtrend ar5387un
« Respuesta #15 en: 28-03-2015, 17:57 (Sábado) »
Por casualidad no tendreis alguno el oscam para un asl2555? He intentado compilar uno pero no me arranca y tampoco da ningun fallo. He encontrado uno que me funciona oscam-svn5574-mips-wrt54g pero si me bajo una version mas moderna no funciona.

para el hg556si lo voy actualizando regularmente a la ultima version pero en este no logro encontrar una version actual que me funcione

anatulfo

  • Visitante
Re: problema con pcsc (lector dni electronico) en comtrend ar5387un
« Respuesta #16 en: 07-10-2016, 21:52 (Viernes) »

........

XDDDD Solucionado con este paquete sudo apt-get install lib32z1


..........

Gracias por el aporte, ademas del paquete "lib32z1" he tenido que instalar " libstdc++6-mipsel-cross"  "lib32stdc++6", para poder compilarlo para un ar-5381u en Ubuntu 16.04 LTS.

Version del paquete   "oscam-svn11273-brcm63xx-webif-libusb".

//FINAL Y MÁS DOS RESPUESTAS