Autor Tema: Problema al instalar luci a Tp-link Tl-wa901nd  (Leído 8084 veces)

0 Usuarios y 1 Visitante están viendo este tema.

walindo

  • Visitante
Problema al instalar luci a Tp-link Tl-wa901nd
« en: 16-07-2013, 19:04 (Martes) »
Buenos días amigos el problema mio es el siguiente.
ayer instale openwrt sin la interfaz gráfica de luci a mi router Tp-link Tl-wa901nd, creyendo que la instalación gráfica iba a ser mas fácil. como saben este aparato solo tiene un puerto lan. para darle acceso a internet para la instalación de luci lo conecte al modem adsl billion que me dio mi isp telefonica y este lo conecte por cable al pc.
Para hacer todo el proceso de configuración desde windows utilizo puTTY pero al momento de intentar acceder al router me arroja el error ‘Network error: Connection refused’. leí a alguien que comentaba que había que configurar el módem como bridge, pero cuando lo hago se desconecta el Internet.

Por favor estaría agradecido toda la vida a quien me ayude con este problema que me esta desmotivando! Gracias de antemano.



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #1 en: 17-07-2013, 08:12 (Miércoles) »
Antes de conectarlo al router, debes modificar su IP (que por defecto es 192.168.1.1) de acuerdo al rango de tu red. Y teniendo cuidado de no usar la IP que pueda tener asignada otro dispositivo.
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

walindo

  • Visitante
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #2 en: 17-07-2013, 14:32 (Miércoles) »
Amigo jar229 muchas gracias por tu respuesta, un amigo me comento esto que acabas de exponer y la verdad creo que ese era el problema, ya que tanto el modem adsl y el router tenian la misma ip. Mas luego probare cuando llegue a casa.

walindo

  • Visitante
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #3 en: 20-07-2013, 06:50 (Sábado) »
Cambie la ip del router y nada que puedo descargar los paquetes update para instalar luci.
cabe aclarar que el router ya tiene acceso a internet, porque me he conectado por wifi y se conecta a perfectamente a internet. me han comentado que el error posiblemente es por la version trunk que tengo instalada openwrt-ar71xx-generic-tl-wa901nd-v2-squashfs-factory.bin

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #4 en: 20-07-2013, 09:54 (Sábado) »
A qué router le has cambiado la IP ?

Tienes que cambiársela al Tp-link.

Contando que el router que te da acceso a internet, así quedaría el fichero network en el Tp-link:

Código: [Seleccionar]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '8.8.8.8'
option ipaddr '192.168.1.2'
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

walindo

  • Visitante
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #5 en: 20-07-2013, 21:00 (Sábado) »
Amigo muchas gracias por su respuesta.
Esta es la configuración que hice en el tl wa901nd

uci set wireless.radio0.channel=11
uci set wireless.radio0.hwmode=11ng
uci set wireless.radio0.txpower=20
uci set wireless.radio0.country=ES
uci set wireless.radio0.disabled=0
uci set wireless.@wifi-iface[0].device=radio0
uci set wireless.@wifi-iface[0].network=lan
uci set wireless.@wifi-iface[0].mode=ap
uci set wireless.@wifi-iface[0].ssid=barcelona
uci set wireless.@wifi-iface[0].encryption=psk
uci set wireless.@wifi-iface[0].key="qatarfoundation"
uci set dhcp.lan.interface=lan
uci set dhcp.lan.ignore=1
uci set dhcp.wan.interface=wan
uci set dhcp.wan.ignore=1
uci set network.lan.gateway=192.168.1.1
uci set network.lan.ipaddr=192.168.1.2
uci set network.lan.netmask=255.255.255.0
uci set network.lan.dns="8.8.4.4 8.8.8.8"
uci commit
/etc/init.d/network restart

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #6 en: 20-07-2013, 21:37 (Sábado) »
Pues si la IP del router que te da internet es 192.168.1.1, ya deberías poder actualizar la lista de paquetes e instalar lo que quieras.
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

walindo

  • Visitante
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #7 en: 20-07-2013, 22:43 (Sábado) »
Esa es la ip del modem y nada cuando ejecuto desde ssh "opkg update" me tira un error y dice que no se puedes descargar el archivo .tgz.

Por supuesto, me he asegurado que ambos routers tienen conexión a internet. Me han comentado que podría ser un problema de los servidores.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #8 en: 21-07-2013, 11:05 (Domingo) »
Y si haces ping a www.google.com, tienes respuesta ?
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

walindo

  • Visitante
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #9 en: 09-08-2013, 03:20 (Viernes) »
Gracias por su interés en ayudarme sr jar229 le agradezco enormemente su colaboracion.
El router Si se conecta a internet de echo con la configuración que antes postie me da Internet por el wifi a los demas dispositivos, el problema radica es al intentar descargar los paquetes de luci.

Chumpy

  • Visitante
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #10 en: 09-08-2013, 11:16 (Viernes) »
walido, has vuelto a probar en otro momento? Puede ser que, como has apuntado, cuando lo hiciste hubiese algún problema en los servidores y que ahora funcione bien.

walindo

  • Visitante
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #11 en: 09-08-2013, 11:30 (Viernes) »
Eso me comento un compañero, luego haré las pruebas de nuevo para ver como me va, ojalá funcione. Gracias por su colaboración.

walindo

  • Visitante
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #12 en: 13-08-2013, 22:00 (Martes) »
He hecho todo lo humanamente posible y me ha sido imposible instalar luci  :-\
Hay alguna manera de instalar otro firmware a este router? puedo acceder a el mediante WinSCP. sera que de este modo puedo arrastrar los paquetes opkg hasta el directorio en el router?
« Última modificación: 21-08-2013, 00:56 (Miércoles) por walindo »

walindo

  • Visitante
Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #13 en: 31-08-2013, 06:51 (Sábado) »
Buenas noche amigos.
Disculpen el triple post, pero esta ves lo hago para contarles que al fin pude instalar luci a mi tp-link  >:( >:( >:( . lo que hice básicamente fue reiniciarlo y acceder a el mediante WinSCP y hacer todas las configuraciones, para mi gusto mucho mas practico que putty.
Lo que me gustaria ahora, es guardar toda la configuración que hice en el firmware, por si en algún momento por x o y motivo se tiene que reiniciar.

Gracias de antemano a esta comunidad por la ayuda que me dieron.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Re: Problema al instalar luci a Tp-link Tl-wa901nd
« Respuesta #14 en: 31-08-2013, 11:19 (Sábado) »
Puedes guardar la configuración (desde LuCi). Lo que no puedes hacer es guardar las aplicaciones que has instalado.


Enviado desde mi Cube U30GT
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka