Autor Tema: IMposible guardar la configuración de openwrt  (Leído 8603 veces)

0 Usuarios y 1 Visitante están viendo este tema.

kleiman

  • Visitante
IMposible guardar la configuración de openwrt
« en: 04-02-2015, 22:18 (Miércoles) »
Tengo instalado el openwrt en un TP-link WR841N y todo va bien hasta que lo apago, ya que no guarda ningun cambio de  los que le hago.
He visto en el FAQ que parece que es un problema conocido, pero la solucion que dais a mi no me funciona y no se porque.
Al introducir el codigo que poneis:

Código:
jffs2_scan_eraseblock(): End of filesystem marker found at 0x?????
jffs2: Cowardly refusing to erase blocks on filesystem with no valid JFFS2 nodes
jffs2: empty_blocks ??, bad_blocks ?, c->nr_blocks ??
Ejecutar el siguiente comando (si no es posible acceder por telnet/ssh hay que acceder al modo failsafe):
Código:
mtd erase -r rootfs_data

Me ejecuta bien la primera linea, pero luego me da error y no se que mas hacer. Estoy bucando por todos lados pero o encuentro una salida. Que puedo estar hacendo mal?

La version de openwrt que tengo es : openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-sysupgrade

 :(



TheMrRafus

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #1 en: 05-02-2015, 00:16 (Jueves) »
Hola

A mi también me pasaba, solo tienes que ejecutar:

mtd -r erase rootfs_data

esperas a que reinicie, ejecutas:
firstboot

y seguidamente:
reboot -f
(te devolverá al estado original del openwrt)

accedes por telnet, cambias la pass y todo eso, ya te debería guardar los cambios.

por si acaso aquí te dejo la compilación que uso yo,tienes que hacerle lo del mtd pero funciona

Trunk+LuCi incorporado
https://mega.co.nz/#!A0FWnCZQ!egLVAwuTTwpxMH1kRx8t50tnzlF7On2rhLZxZ7ZAU5s


Saludos

« Última modificación: 05-02-2015, 00:25 (Jueves) por TheMrRafus »

kleiman

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #2 en: 05-02-2015, 08:23 (Jueves) »
Hola

A mi también me pasaba, solo tienes que ejecutar:

mtd -r erase rootfs_data

esperas a que reinicie, ejecutas:
firstboot

y seguidamente:
reboot -f
(te devolverá al estado original del openwrt)

accedes por telnet, cambias la pass y todo eso, ya te debería guardar los cambios.

por si acaso aquí te dejo la compilación que uso yo,tienes que hacerle lo del mtd pero funciona

Trunk+LuCi incorporado
https://mega.co.nz/#!A0FWnCZQ!egLVAwuTTwpxMH1kRx8t50tnzlF7On2rhLZxZ7ZAU5s


Saludos



Muchas gracias, esta tarde en cuanto vuelva del trabajo lo pruebo  ;)

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1950
Re: IMposible guardar la configuración de openwrt
« Respuesta #3 en: 05-02-2015, 09:00 (Jueves) »
Código:
mtd erase -r rootfs_data

Me ejecuta bien la primera linea, pero luego me da error y no se que mas hacer. Estoy bucando por todos lados pero o encuentro una salida. Que puedo estar hacendo mal?

La version de openwrt que tengo es : openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-sysupgrade

 :(


Poner el error puede ayudar a entender qué te está pasando...
El nombre del fichero de la imagen que pones no tiene número de versión, así que no se puede saber qué versión utilizas...
Un log del arranque también ayuda...

La adivinomancia no está bien vista por aquí...  ^-^
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

kleiman

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #4 en: 05-02-2015, 13:43 (Jueves) »
Código:
mtd erase -r rootfs_data

Me ejecuta bien la primera linea, pero luego me da error y no se que mas hacer. Estoy bucando por todos lados pero o encuentro una salida. Que puedo estar hacendo mal?

La version de openwrt que tengo es : openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-sysupgrade

 :(


Poner el error puede ayudar a entender qué te está pasando...
El nombre del fichero de la imagen que pones no tiene número de versión, así que no se puede saber qué versión utilizas...
Un log del arranque también ayuda...

La adivinomancia no está bien vista por aquí...  ^-^

Perdona. Haré la prueba que me indicó el forero y si sigue sin funcionar pondré el error e incluso el log de arranque que me comentas, si consigo averiguar como sacarlo, que estoy en pañales en linux, y en openwrt ni te cuento.
Fijate que la version pensaba que era esa V9 que aparece en el nomre, y por lo que se ve no es asi.  :(
« Última modificación: 05-02-2015, 13:49 (Jueves) por kleiman »

TheMrRafus

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #5 en: 05-02-2015, 14:02 (Jueves) »
Hola

La versión de hardware y firmware del router la tienes en la etiqueta debajo del router.
Por ejemplo Ver 9.0. el 9 significa la versión del Hardware y el segundo numero(0) significa la versión  del firmware.

para ver los logs, dmesg es una buena utilidad para ver los logs.
simplemente pon eso en el telnet o shh y te devuelve un log con todos los eventos


Saludos
« Última modificación: 05-02-2015, 15:41 (Jueves) por TheMrRafus »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1950
Re: IMposible guardar la configuración de openwrt
« Respuesta #6 en: 05-02-2015, 14:45 (Jueves) »
Hola

La versión del router la tienes en la etiqueta debajo del router.
Por ejemplo Ver 9.0. el 9 significa la version del Hardware y el segundo numero(0) significa la version  del firmware.

para ver los logs, dmesg es una buena utilidad para ver los logs.
simplemente ponlo en el telnet o shh y te devuelve un log con todos los eventos


Saludos

¿Openwrt viene ahora etiquetado en los routers?  ;D
Pensaba que la versión de openwrt era algo parecido a "Barrier Breaker r34404", o algo asín...  ^-^

(Sí, lo que me faltaba por ver: "asín" está recogido en el Diccionario de la RAE: http://lema.rae.es/drae/?val=as%C3%ADn ¿Quién dijo que evolucionamos? Yo creo que INVOLUCIONAMOS...)

Perdón por el offtopic...  ;)
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

TheMrRafus

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #7 en: 05-02-2015, 15:02 (Jueves) »
Hola

La versión del router la tienes en la etiqueta debajo del router.
Por ejemplo Ver 9.0. el 9 significa la version del Hardware y el segundo numero(0) significa la version  del firmware.

para ver los logs, dmesg es una buena utilidad para ver los logs.
simplemente ponlo en el telnet o shh y te devuelve un log con todos los eventos


Saludos

¿Openwrt viene ahora etiquetado en los routers?  ;D
Pensaba que la versión de openwrt era algo parecido a "Barrier Breaker r34404", o algo asín...  ^-^

(Sí, lo que me faltaba por ver: "asín" está recogido en el Diccionario de la RAE: http://lema.rae.es/drae/?val=as%C3%ADn ¿Quién dijo que evolucionamos? Yo creo que INVOLUCIONAMOS...)

Perdón por el offtopic...  ;)

Tranquilidad, ya he editado el mensaje para mayor comprensión,que no cunda el pánico jaja


kleiman

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #8 en: 05-02-2015, 18:34 (Jueves) »
He hecho lo que me ha indicado TheMrRafus. Una cosa parece cierta, ahora debe guardar los cambios, ya que he cambiado la configuracion de red y la ha mantenido tras desconectarlo de la corriente. Pero cuando trato de instalar Luci, cosa que antes hacia sin problemas, pasa esto:
root@OpenWrt:/# opkg install luci
Installing luci (git-15.029.55606-84346cd-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages
/luci/luci_git-15.029.55606-84346cd-1_all.ipk.
Installing uhttpd (2015-01-25.2-db79faae848e9ca5ed1c5b62cdd9d01650687fff) to roo
t...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages
/base/uhttpd_2015-01-25.2-db79faae848e9ca5ed1c5b62cdd9d01650687fff_ar71xx.ipk.
Collected errors:
 * copy_file: unable to open `/etc/config/uhttpd-opkg.backup': No space left on
device.
 * file_copy: Failed to copy file /etc/config/uhttpd to /etc/config/uhttpd-opkg.
backup.
 * backup_make_backup: Failed to copy /etc/config/uhttpd to /etc/config/uhttpd-o
pkg.backup
 * opkg_install_cmd: Cannot install package luci.
 * opkg_conf_write_status_files: Can't open status file //usr/lib/opkg/status: N
o space left on device.




El dmesg me saca esto:
root@OpenWrt:/# dmesg
[    0.000000] Linux version 3.14.30 (openwrt@gb-10) (gcc version 4.8.3 (OpenWrt
/Linaro GCC 4.8-2014.04 r44235) ) #1 Sun Feb 1 22:10:52 UTC 2015
[    0.000000] MyLoader: sysp=aa2a22aa, boardp=aaaaaa22, parts=a2aaaa2a
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Qualcomm Atheros QCA9533 rev 1
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x01ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x01ffffff]
[    0.000000] On node 0 totalpages: 8192
[    0.000000] free_area_init_node: node 0, pgdat 803605e0, node_mem_map 8100000
0
[    0.000000]   Normal zone: 64 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 8192 pages, LIFO batch:0
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32
bytes
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc:
  • 0

[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pag
es: 8128
[    0.000000] Kernel command line:  board=TL-WR841N-v9 console=ttyS0,115200 roo
tfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 28456K/32768K available (2520K kernel code, 124K rwdata,
520K rodata, 220K init, 191K bss, 4312K reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Clocks: CPU:550.000MHz, DDR:399.560MHz, AHB:199.780MHz, Ref:25.00
0MHz
[    0.000000] Calibrating delay loop... 366.18 BogoMIPS (lpj=1830912)
[    0.060000] pid_max: default: 32768 minimum: 301
[    0.060000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.070000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.080000] NET: Registered protocol family 16
[    0.080000] MIPS: machine is TP-LINK TL-WR841N/ND v9
[    0.540000] bio: create slab <bio-0> at 0
[    0.550000] Switched to clocksource MIPS
[    0.550000] NET: Registered protocol family 2
[    0.560000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.570000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.570000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.580000] TCP: reno registered
[    0.580000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.590000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.590000] NET: Registered protocol family 1
[    0.600000] PCI: CLS 0 bytes, default 32
[    0.600000] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.620000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.630000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORIT
Y) (c) 2001-2006 Red Hat, Inc.
[    0.640000] msgmni has been set to 55
[    0.640000] io scheduler noop registered
[    0.650000] io scheduler deadline registered (default)
[    0.650000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.690000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 156
2500) is a 16550A
[    0.700000] console [ttyS0] enabled
[    0.700000] bootconsole [early0] disabled
[    0.720000] m25p80 spi0.0: found s25sl032p, expected m25p80
[    0.720000] m25p80 spi0.0: s25sl032p (4096 Kbytes)
[    0.730000] 5 tp-link partitions found on MTD device spi0.0
[    0.730000] Creating 5 MTD partitions on "spi0.0":
[    0.740000] 0x000000000000-0x000000020000 : "u-boot"
[    0.750000] 0x000000020000-0x00000013c108 : "kernel"
[    0.750000] mtd: partition "kernel" must either start or end on erase block b
oundary or be smaller than an erase block -- forcing read-only
[    0.770000] 0x00000013c108-0x0000003f0000 : "rootfs"
[    0.770000] mtd: partition "rootfs" must either start or end on erase block b
oundary or be smaller than an erase block -- forcing read-only
[    0.790000] mtd: device 2 (rootfs) set to be root filesystem
[    0.790000] 1 squashfs-split partitions found on MTD device rootfs
[    0.800000] 0x000000320000-0x0000003f0000 : "rootfs_data"
[    0.810000] 0x0000003f0000-0x000000400000 : "art"
[    0.810000] 0x000000020000-0x0000003f0000 : "firmware"
[    0.840000] libphy: ag71xx_mdio: probed
[    1.440000] ag71xx-mdio.1: Found an AR934X built-in switch
[    1.480000] eth0: Atheros AG71xx at 0xba000000, irq 5, mode:GMII
[    2.080000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd0
42, driver=Generic PHY]
[    2.090000] eth1: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[    2.100000] TCP: cubic registered
[    2.100000] NET: Registered protocol family 17
[    2.110000] Bridge firewalling registered
[    2.110000] 8021q: 802.1Q VLAN Support v1.8
[    2.120000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    2.130000] Freeing unused kernel memory: 220K (80379000 - 803b0000)
[    4.280000] usbcore: registered new interface driver usbfs
[    4.290000] usbcore: registered new interface driver hub
[    4.290000] usbcore: registered new device driver usb
[    4.310000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.310000] ehci-platform: EHCI generic platform driver
[    4.320000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    4.330000] ohci-platform: OHCI generic platform driver
[    5.760000] random: mktemp urandom read with 55 bits of entropy available
[    7.810000] eth0: link up (1000Mbps/Full duplex)
[    9.050000] jffs2: notice: (351) jffs2_build_xattr_subsystem: complete buildi
ng xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 12 of xref (0 dead,
0 orphan) found.
[    9.100000] eth0: link down
[   11.720000] NET: Registered protocol family 10
[   11.730000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   11.740000] Loading modules backported from Linux version master-2014-11-04-0
-gf3660a2
[   11.750000] Backport generated by backports.git backports-20141023-2-g4ff890b
[   11.760000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   11.780000] nf_conntrack version 0.5.0 (448 buckets, 1792 max)
[   11.830000] xt_time: kernel timezone is -0000
[   11.870000] cfg80211: Calling CRDA to update world regulatory domain
[   11.870000] cfg80211: World regulatory domain updated:
[   11.880000] cfg80211:  DFS Master region: unset
[   11.880000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gai
n, max_eirp), (dfs_cac_time)
[   11.890000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 m
Bm), (N/A)
[   11.900000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 m
Bm), (N/A)
[   11.910000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 m
Bm), (N/A)
[   11.920000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 m
Bm), (N/A)
[   11.930000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AU
TO), (N/A, 2000 mBm), (0 s)
[   11.940000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000
mBm), (0 s)
[   11.940000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 m
Bm), (N/A)
[   11.950000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0
mBm), (N/A)
[   12.030000] PPP generic driver version 2.4.2
[   12.040000] NET: Registered protocol family 24
[   12.090000] ath: EEPROM regdomain: 0x0
[   12.090000] ath: EEPROM indicates default country code should be used
[   12.090000] ath: doing EEPROM country->regdmn map search
[   12.090000] ath: country maps to regdmn code: 0x3a
[   12.090000] ath: Country alpha2 being used: US
[   12.090000] ath: Regpair used: 0x3a
[   12.110000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   12.120000] cfg80211: Calling CRDA for country: US
[   12.130000] ieee80211 phy0: Atheros AR9531 Rev:1 mem=0xb8100000, irq=2
[   12.150000] cfg80211: Regulatory domain changed to country: US
[   12.150000] cfg80211:  DFS Master region: FCC
[   12.160000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gai
n, max_eirp), (dfs_cac_time)
[   12.170000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 m
Bm), (N/A)
[   12.170000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AU
TO), (N/A, 1700 mBm), (N/A)
[   12.180000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AU
TO), (N/A, 2300 mBm), (0 s)
[   12.190000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 m
Bm), (N/A)
[   12.200000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 40
00 mBm), (N/A)
[   19.120000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   19.140000] device eth0 entered promiscuous mode
[   19.160000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   19.180000] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   21.220000] eth0: link up (1000Mbps/Full duplex)
[   21.230000] br-lan: port 1(eth0) entered forwarding state
[   21.230000] br-lan: port 1(eth0) entered forwarding state
[   21.240000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   21.250000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   23.230000] br-lan: port 1(eth0) entered forwarding state
[   27.230000] random: nonblocking pool is initialized

Y en esas estoy ahora, no puedo instalar luci

TheMrRafus

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #9 en: 05-02-2015, 19:05 (Jueves) »
Eso creo que  es porque no queda espacio en la memoria flash..

* opkg_conf_write_status_files: Can't open status file //usr/lib/opkg/status: N
o space left on device


Prueba a instalarle la Barrier Breaker, con esa si te deberia dejar ya que ocupa menos espacio en la flash.

Si le instalas esta si te instala bien el LuCi:

https://mega.co.nz/#!3ZMH2bKJ!n6kDYQnuT-pstNPKbJBBZBGdJhxVXH9ZW0LY2Gv2d8E

Saludos
« Última modificación: 05-02-2015, 19:06 (Jueves) por TheMrRafus »

kleiman

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #10 en: 05-02-2015, 19:31 (Jueves) »
Eso creo que  es porque no queda espacio en la memoria flash..

* opkg_conf_write_status_files: Can't open status file //usr/lib/opkg/status: N
o space left on device


Prueba a instalarle la Barrier Breaker, con esa si te deberia dejar ya que ocupa menos espacio en la flash.

Si le instalas esta si te instala bien el LuCi:

https://mega.co.nz/#!3ZMH2bKJ!n6kDYQnuT-pstNPKbJBBZBGdJhxVXH9ZW0LY2Gv2d8E

Saludos

Siento la chapa pero como puedo instalar la barrier breaker desde esta version que tengo?

Noltari

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #11 en: 05-02-2015, 19:56 (Jueves) »
1) Te era imposible guardar la configuración porque al cambiar del firmware original a OpenWrt has instalado la versión sysupgrade en lugar de factory.
2) El TL-WR841n tiene muy poca flash, por lo que si quieres disponer de luci tienes que usar un firmware que ya lo lleve integrado en la partición squashfs, de esta forma ahorras el espacio necesario para que quepa.
3) Barrier Breaker, al igual que todas las versiones finales lleva LuCI integrado:
openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-factory.bin
openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-sysupgrade.bin

Saludos.
« Última modificación: 05-02-2015, 19:57 (Jueves) por Noltari »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1950
Re: IMposible guardar la configuración de openwrt
« Respuesta #12 en: 05-02-2015, 20:02 (Jueves) »
Eso creo que  es porque no queda espacio en la memoria flash..

* opkg_conf_write_status_files: Can't open status file //usr/lib/opkg/status: N
o space left on device


Prueba a instalarle la Barrier Breaker, con esa si te deberia dejar ya que ocupa menos espacio en la flash.

Si le instalas esta si te instala bien el LuCi:

https://mega.co.nz/#!3ZMH2bKJ!n6kDYQnuT-pstNPKbJBBZBGdJhxVXH9ZW0LY2Gv2d8E

Saludos

Siento la chapa pero como puedo instalar la barrier breaker desde esta version que tengo?

Bájate la imagen sysupgrade correspondiente al PC.
Utiliza WinSCP para subir la imagen al directorio /tmp del router.
Abre una consola y teclea:
Código: [Seleccionar]
mtd -r write /tmp/nombre_del_fichero_openwrt.bin firmwarenombre_del_fichero_openwrt.bin es el nombre del fichero con openwrt. Cámbialo por el nombre del fichero real.
El router debe reiniciarse solo, y arrancar con el nuevo openwrt.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

TheMrRafus

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #13 en: 05-02-2015, 20:06 (Jueves) »
1) Te era imposible guardar la configuración porque al cambiar del firmware original a OpenWrt has instalado la versión sysupgrade en lugar de factory.
2) El TL-WR841n tiene muy poca flash, por lo que si quieres disponer de luci tienes que usar un firmware que ya lo lleve integrado en la partición squashfs, de esta forma ahorras el espacio necesario para que quepa.
3) Barrier Breaker, al igual que todas las versiones finales lleva LuCI integrado:
openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-factory.bin
openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-sysupgrade.bin

Saludos.

Mejor respuesta que esa dudo que exista...

Para instalar:
1-->Renombra a tplink.bin(para ahorrar estar escribiendo nombres largos)
2-->Lo subes por SCP al directorio /tmp
3-->Pones en telnet sysupgrade /tmp/tplink.bin

Creo que se podia hacer asi, pero que alguien lo confirme.


Saludos


Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1950
Re: IMposible guardar la configuración de openwrt
« Respuesta #14 en: 05-02-2015, 21:33 (Jueves) »
1) Te era imposible guardar la configuración porque al cambiar del firmware original a OpenWrt has instalado la versión sysupgrade en lugar de factory.
2) El TL-WR841n tiene muy poca flash, por lo que si quieres disponer de luci tienes que usar un firmware que ya lo lleve integrado en la partición squashfs, de esta forma ahorras el espacio necesario para que quepa.
3) Barrier Breaker, al igual que todas las versiones finales lleva LuCI integrado:
openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-factory.bin
openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-sysupgrade.bin

Saludos.

Mejor respuesta que esa dudo que exista...

Para instalar:
1-->Renombra a tplink.bin(para ahorrar estar escribiendo nombres largos)
2-->Lo subes por SCP al directorio /tmp
3-->Pones en telnet sysupgrade /tmp/tplink.bin

Creo que se podia hacer asi, pero que alguien lo confirme.


Saludos



Estaba confirmado en el post anterior. Sólo había que leer...
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

kleiman

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #15 en: 05-02-2015, 22:24 (Jueves) »
1) Te era imposible guardar la configuración porque al cambiar del firmware original a OpenWrt has instalado la versión sysupgrade en lugar de factory.
2) El TL-WR841n tiene muy poca flash, por lo que si quieres disponer de luci tienes que usar un firmware que ya lo lleve integrado en la partición squashfs, de esta forma ahorras el espacio necesario para que quepa.
3) Barrier Breaker, al igual que todas las versiones finales lleva LuCI integrado:
openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-factory.bin
openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-sysupgrade.bin

Saludos.


Vale ya me he descargado los archivos, supongo que le tengo que meter el factory no?
Intento pasar el fichero por winSCP y por filezilla y me da error 127 en ambos casos (no puede inicializar el protocolo sftp.
¿tengo que instalar activar algun servicio de ftp en el router?

TheMrRafus

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #16 en: 06-02-2015, 09:47 (Viernes) »
1) Te era imposible guardar la configuración porque al cambiar del firmware original a OpenWrt has instalado la versión sysupgrade en lugar de factory.
2) El TL-WR841n tiene muy poca flash, por lo que si quieres disponer de luci tienes que usar un firmware que ya lo lleve integrado en la partición squashfs, de esta forma ahorras el espacio necesario para que quepa.
3) Barrier Breaker, al igual que todas las versiones finales lleva LuCI integrado:
openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-factory.bin
openwrt-ar71xx-generic-tl-wr841n-v9-squashfs-sysupgrade.bin

Saludos.


Vale ya me he descargado los archivos, supongo que le tengo que meter el factory no?
Intento pasar el fichero por winSCP y por filezilla y me da error 127 en ambos casos (no puede inicializar el protocolo sftp.
¿tengo que instalar activar algun servicio de ftp en el router?



Eso es porque no has seleccionado el protocolo SCP en WinSCP

A la hora de conectarte tienes que seleccionar SCP en lugar de SFTP.

Saludos

kleiman

  • Visitante
Re: IMposible guardar la configuración de openwrt
« Respuesta #17 en: 06-02-2015, 18:26 (Viernes) »
Por fin. Me pude conectar con el winscp, le meti al fichero del firimware que me pusisteis y se hizo la luz. Todo configurado perfectamente y se guardan los cambios tras la desconexion de corriente.
Muchas gracias por vuestra ayuda y disculpas por el ejercicio de paciencia al que os he sometido.
Una vez solventado este tema me veo con fuerzas para intentar revivir un 3com WL-542 perjudicado por la tormenta de hace una semana. Ya los di por muerto pero quien sabe. Voy a mirar si es compatible con openwrt y a intentar hacerme con el firmware correspondinte (espero que el correcto esta vez  ;D

Desconectado Byakko

  • **
  • Mensajes: 1
Re: IMposible guardar la configuración de openwrt
« Respuesta #18 en: 16-08-2019, 17:06 (Viernes) »
Hola

A mi también me pasaba, solo tienes que ejecutar:

mtd -r erase rootfs_data

esperas a que reinicie, ejecutas:
firstboot

y seguidamente:
reboot -f
(te devolverá al estado original del openwrt)

accedes por telnet, cambias la pass y todo eso, ya te debería guardar los cambios.

por si acaso aquí te dejo la compilación que uso yo,tienes que hacerle lo del mtd pero funciona

Trunk+LuCi incorporado
https://mega.co.nz/#!A0FWnCZQ!egLVAwuTTwpxMH1kRx8t50tnzlF7On2rhLZxZ7ZAU5s


Saludos

Agradezco mucho estos comandos, fuiste el único que me dio una solución al inconveniente que no dejaba la configuración guardada.

con estos ya pude solucionar el problema y al apagar el equipo por falta de energía no se pierde la misma.