Autor Tema: HG556 con OPENWRT como punto de acceso WiFi de un router monopuesto Telefónica  (Leído 11510 veces)

0 Usuarios y 1 Visitante están viendo este tema.

jescalv

  • Visitante
Hola

Telefónica me ha instalado un acceso a Internet por satélite. Tengo un Hughes HN7740S con IP fija configurado como monopuesto, sin WiFi y con sólo un interfaz ethernet activo. Puedo conectarle ahora mismo un PC que coje una IP fija también, sin problemas.

Para conseguir crear una red WiFi en casa, he instalado OPENWRT en un HG556 que tenía y quiero conectar este equipo por LAN al Hughes, y luego conectar mis portátiles al HG556.

Puedo crear correctamente la red WiFi en el HG556, pero cuando lo conecto con LAN al Hughes y puenteo la LAN y la WLAN, no tengo conexiçon a Internet. Cualquier ping se me para en 192.168.1.1 y no pasa de ahí.

He probado también a poner el interfaz LAN en DHCP (para ver si me coje la IP fija que Telefónica me asignó) pero cuando lo hago, ya no puedo ni acceder al HG556 por WiFi.

He revisado los tutoriales del foro pero no localizo cuál es el caso exacto que estoy buscando.

¿Alguien me puede ayudar?

Muchas gracias por adelantado!! :D :D



jescalv

  • Visitante
Como no sé si me he explicado bien, resumo...

El HG556 con openwrt debe ser cliente del Hughes, a través de la interfaz LAN. Y el HG556 debe crear una red Wifi para conectar mis dispositivos a Internet a través de el.

Toda la configuración la hago con Luci.

Gracias!

tragabalas

  • Visitante
Hola,

Desconozco si con el HG556 se puede poner en modo de router neutro, si fuera posible, es la solucion.

De echo si tu le conectas un router neutro al de satelite, la toma RJ45 del de satelite conectado a la toma WAN del router neutro, y en el router neutro configurado para que la parte WAN sea cliente DHCP y activar el servidor DHCP en la parte LAN, te funcionaria.

Ahora te queda investigar si con el HG556 se puede poner en este modo, ya que creo que no tiene entrada WAN por RJ45.

A lo mejor con ciertos parámetros se puede configurar para que uno de los puertos LAN haga la función de WAN, pero aqui ya me pierdo, no se si con ese aparato es posible hacerlo.

Suerte ;)

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
En la wiki de OpenWrt tienes un ejemplo: http://wiki.openwrt.org/toh/huawei/hg556a
El puerto 4 del router actúa como WAN:

Código: [Seleccionar]


# path: /etc/config/network
# port 4 = WAN
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option type bridge
option ifname eth0.0
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
option nat 1

config interface wan
option ifname eth0.1
option macaddr 00:11:22:33:44:55
option proto dhcp
option defaultroute 1

config switch eth0
option enable 1
option reset 1
option enable_vlan 1

config switch_vlan
option device eth0
option vlan 0
option ports "0 1 2 5t"

config switch_vlan
option device eth0
option vlan 1
option ports "3 5t"

Valoraciones positivas en compra/venta:
167 en Htcmania
224 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

jescalv

  • Visitante
En la wiki de OpenWrt tienes un ejemplo: http://wiki.openwrt.org/toh/huawei/hg556a
El puerto 4 del router actúa como WAN:


OK, muchas gracias!

¿Sabemos cómo se puede hacer lo mismo con Luci?

phullock

  • Visitante
Jar, ¿y qué pones en la MAC? ¿la de eth1?

Saludos.
« Última modificación: 29-11-2012, 22:10 (Jueves) por phullock »

Elnef

  • Visitante
¿No sería más simple lo siguiente?

Desde LuCI y suponiendo que el router principal es la ip 192.168.1.1.

En el HG556a configuras en el apartado network->interfaces->LAN

IP: 192.168.1.2
Mascara: 255.255.255.0
Gateway: 192.168.1.1
DNS: 8.8.8.8 y 8.8.4.4
DHCP: Disable

Ahora en Wifi creas la red que quieras como Access Point y le marcas la casilla de LAN.

Conectas por cable el Hughes al HG556a por cualquier lan y listo. Ya tienes un punto de acceso wifi a tu red.

edudi

  • Visitante
El compañero Elnef me ha resuelto el problema q tenía con su explicación..... ya puse el HG556a como punto de acceso.

Tiene toda la pinta de que así va niquelado y que aguantará en el tiempo. De momento me conecto más rápido y mejor al WiFI del AP (HG556a) que cuando cambio al WiFi del router principal, que en mi caso es uno de ONO (modelo: CDE-30364), se queda el WiFi del PC (Win7) medio pescando y tengo que reiniciar el PC, luego ya conecta rápido y bien.

Se ve que cada router principal, sea cable o adsl, tiene sus peculiaridades a la hora de añadirle un AP...que si mirar desde donde empieza su DHCP para poner al AP una IP fuera del rango que suele asignar el DHCP y no haya un conflicto de IP´s, que si no puede coincidir con la red de invitados al intentar ponerle la IP 192.168.4.1...no encontré en todo el router donde cambiar la red de invitados ni verla tp (me pasó con otro de ONO, el NetGear CG3100Dv3 que en la web del Router pone como modelo una variación a la etiqueta externa: CG3100D-RG)

En mi caso con el de ONO (modelo: CDE-30364), empieza el DHCP por 192.168.1.10 y al AP le puse la IP fija 192.168.1.2, de este modo nunca pisará cualquier dispositivo la IP fija del AP y el AP estará siempre funcionando sin conflictos.

Sé que estos parámetros se pueden cambiar y que cada uno los pone como quiera, x ej: 192.168.4.1 la IP del Router principal, DHCP desde la 192.168.4.30 a la 192.168.4.50, etcéteras varios.


Gracias señores,,,una y otra vez este foro me salva la vida.