Autor Tema: Ayuda con VLAN  (Leído 3381 veces)

0 Usuarios y 1 Visitante están viendo este tema.

phullock

  • Visitante
Ayuda con VLAN
« en: 29-11-2012, 22:38 (Jueves) »
Hola a todos,

estoy intentando que mi Comtrend se conecte a internet mediante el primer puerto de ethernet y el resto dejarlos como switch. El problema es que no logro hacerlo funcionar y lo he probado con todos los tutoriales de internet. Os dejo los datos del archivo network:

Citar
# path: /etc/config/network
# port 4 = WAN
config interface loopback
   option ifname lo
   option proto static
   option ipaddr 127.0.0.1
   option netmask 255.0.0.0

config interface lan
   option type bridge
   option ifname eth1.0
   option proto static
   option ipaddr 192.168.4.1
   option netmask 255.255.255.0
   option nat 1

config interface wan
   option ifname eth1.1
   option macaddr 00:1D:20:D7:AF:15
   option proto dhcp
   option defaultroute 1

config switch eth0
   option enable 1
   option reset 1
   option enable_vlan 1

config switch_vlan
   option device eth1
   option vlan 0
   option ports "0 1 2 5t"

config switch_vlan
   option device eth1
   option vlan 1
   option ports "3 5t"



Gracias.



Noltari

  • Visitante
Re: Ayuda con VLAN
« Respuesta #1 en: 29-11-2012, 22:45 (Jueves) »
Siempre se os olvida dar la información más relevante... ¿Qué router es?

Si es un Comtrend 5365, prueba esta configuración:
Código: [Seleccionar]
config 'switch' 'eth0'
option 'enable' '1'
option 'enable_vlan' '1'
option 'reset' '1'

config 'switch_vlan' 'vlan0'
option 'vlan' '0'
option 'device' 'eth0'
option 'ports' '1 2 3 5t'

config 'switch_vlan' 'vlan1'
option 'vlan' '1'
option 'device' 'eth0'
option 'ports' '0t 5t'

config 'interface' 'loopback'
option 'ifname' 'lo'
option 'proto' 'static'
option 'ipaddr' '127.0.0.1'
option 'netmask' '255.0.0.0'

config 'interface' 'lan'
option 'type' 'bridge'
option 'ifname' 'eth0.0'
option 'proto' 'static'
option 'ipaddr' '192.168.1.1'
option 'netmask' '255.255.255.0'
option 'gateway' '192.168.1.1'
option 'dns' '8.8.8.8'
option 'nat' '1'
option 'defaultroute' '0'
option 'peerdns' '0'

config 'interface' 'wan'
option 'ifname' 'eth0.1'
option 'proto' 'dhcp'

Saludos.

phullock

  • Visitante
Re: Ayuda con VLAN
« Respuesta #2 en: 29-11-2012, 22:58 (Jueves) »
Disculpame, es un CT-5361. He estado viendo esa configuración y creo que se me quedaría frito por lo de eth0, ¿lo cambio por eth1?

Gracias por tu ayuda, de verdad. Llevo toda la tarde liado con esto!! Lo peor de todo es que si me equivoco tengo que empezar de cero todo, cargando un nuevo firm y todo eso.
« Última modificación: 29-11-2012, 23:01 (Jueves) por phullock »

Noltari

  • Visitante
Re: Ayuda con VLAN
« Respuesta #3 en: 29-11-2012, 23:04 (Jueves) »
Disculpame, es un CT-5361. He estado viendo esa configuración y creo que se me quedaría frito por lo de eth0, ¿lo cambio por eth1?

Gracias por tu ayuda, de verdad. Llevo toda la tarde liado con esto!! Lo peor de todo es que si me equivoco tengo que empezar de cero todo, cargando un nuevo firm y todo eso.
Sí, cambia la configuración que te he puesto por eth1.

Saludos!

phullock

  • Visitante
Re: Ayuda con VLAN
« Respuesta #4 en: 29-11-2012, 23:27 (Jueves) »
Pues sigue sin funcionar :S He puesto lo siguiente:

Citar
config 'switch' 'eth1'
   option 'enable' '1'
   option 'enable_vlan' '1'
   option 'reset' '1'

config 'switch_vlan' 'vlan0'
   option 'vlan' '0'
   option 'device' 'eth1'
   option 'ports' '1 2 3 5t'

config 'switch_vlan' 'vlan1'
   option 'vlan' '1'
   option 'device' 'eth1'
   option 'ports' '0t 5t'

config 'interface' 'loopback'
   option 'ifname' 'lo'
   option 'proto' 'static'
   option 'ipaddr' '127.0.0.1'
   option 'netmask' '255.0.0.0'

config 'interface' 'lan'
   option 'type' 'bridge'
   option 'ifname' 'eth1.0'
   option 'proto' 'static'
   option 'ipaddr' '192.168.4.1'
   option 'netmask' '255.255.255.0'
   option 'gateway' '192.168.4.1'
   option 'dns' '8.8.8.8'
   option 'nat' '1'
   option 'defaultroute' '0'
   option 'peerdns' '0'

config 'interface' 'wan'
   option 'ifname' 'eth1.1'
   option 'proto' 'dhcp'


Para que no haya confusiones, el cable WAN (el que conecta a internet) debe ser el primero, ¿no?

Saludos.

emeryth

  • Visitante
Re: Ayuda con VLAN
« Respuesta #5 en: 30-11-2012, 09:34 (Viernes) »
hola phullock, prueva con esto

Código: [Seleccionar]
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config switch 'eth1'
   option enable '1'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'eth0'
   option vlan '0'
   option ports '0 5t'

config switch_vlan
   option device 'eth0'
   option vlan '1'
   option ports '1 2 3 5t'

config interface 'lan'
   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option ifname 'eth1.1'
   option ipaddr '192.168.4.1'
   option nat '1'

config interface 'wan'
   option ifname 'eth1.0'
   option proto 'dhcp'
   option macaddr 'XX:XX:XX:XX:18:XX '

config interface 'wwan'
   option proto 'dhcp'

Las subredes de lan y wan no pueden ser la misma. En macaddr coloca la mas que quieras pero no la del router, puede ser la del router mas 2.

Debes enlazar lan y wan por medio de /etc/config/firewall

Código: [Seleccionar]
config defaults
   option syn_flood '1'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'REJECT'

config zone
   option name 'lan'
   option network 'lan'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'REJECT'

config zone
   option name 'wan'
   option input 'REJECT'
   option output 'ACCEPT'
   option forward 'REJECT'
   option masq '1'
   option mtu_fix '1'
   option network 'wan wwan'

config forwarding
   option src 'lan'
   option dest 'wan'

saludos

phullock

  • Visitante
Re: Ayuda con VLAN
« Respuesta #6 en: 30-11-2012, 10:43 (Viernes) »
Acabo de probar la configuración que has puesto y el router no responde. Estoy intentando acceder por SSH y me dice que no es posible establecer una conexión.

Noltari, ¿con el AR-5387un tendría más suerte?
« Última modificación: 30-11-2012, 11:45 (Viernes) por phullock »

emeryth

  • Visitante
Re: Ayuda con VLAN
« Respuesta #7 en: 30-11-2012, 11:51 (Viernes) »
perdona hay un error, se me colo un par de eth0.  :-[

Código: [Seleccionar]
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config switch 'eth1'
   option enable '1'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'eth1'
   option vlan '0'
   option ports '0 5t'

config switch_vlan
   option device 'eth1'
   option vlan '1'
   option ports '1 2 3 5t'

config interface 'lan'
   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option ifname 'eth1.1'
   option ipaddr '192.168.4.1'
   option nat '1'

config interface 'wan'
   option ifname 'eth1.0'
   option proto 'dhcp'
   option macaddr 'XX:XX:XX:XX:18:XX '

config interface 'wwan'
   option proto 'dhcp'

saludos

phullock

  • Visitante
Re: Ayuda con VLAN
« Respuesta #8 en: 30-11-2012, 12:03 (Viernes) »
No pasa nada, luego lo pruebo ;)

phullock

  • Visitante
Re: Ayuda con VLAN
« Respuesta #9 en: 30-11-2012, 14:12 (Viernes) »
Funciona! Muchísimas gracias!! Al principio no funcionaba porque lo tengo conectado a otro router con openwrt y no tenía activada la NAT. Vamos, que he puesto WAN en STATIC y ahora funciona perfecto. Lo que no entiendo es por qué me funciona mal el wifi. Tengo el firm con el driver oficial (wl0), ¿será por eso? El caso es que la velocidad del wifi es de risa, va mas o menos a dos megas.

Dejo el fichero wireless:


Código: [Seleccionar]
config 'wifi-device' 'wl0'
option 'type' 'broadcom'
option 'disabled' '0'
option 'hwmode' '11bg'
option 'channel' '13'
option 'txpower' '6'

config 'wifi-iface'
option 'device' 'wl0'
option 'network' 'lan'
option 'mode' 'ap'
option 'ssid' 'LAN'
option 'encryption' 'psk2'
option 'key' 'dani1234567890'


Normalmente baja a 11MB/S:

Código: [Seleccionar]
Modo: Master | SSID: LAN
BSSID: 00:1A:2B:48:0E:07 | Encriptación: WPA2 PSK (CCMP)
Canal: 11 (2.462 GHz) | Tx-Power: 5 dBm
Signal: -29 dBm | Noise: -93 dBm
Bit Rate: 36.0 MBit/s |  Country: US

¿Qué puede ser? Si me conecto por wifi me va a dos megas, si me conecto por red va bien. He puesto el canal en 13 porque aquí hay muchas wifis de vecinos, por si era eso. Pero vamos, que sigue igual.

Saludos.


________________


EDIT. Ya lo he solucionado. El problema era que no había configurado el país en el  wifi. Tenía puesto el canal 13 pero se conectaba en realidad en el 1. He cambiado lo del país y ahora sí que va en el 13 y va perfecto. El problema es que aquí hay muchas wifis, con una antena normal puedo coger como 15 wifis. Con una antena un poco más potente ya llego a casi 30 asi que os podéis hacer una idea de cómo está congestionado esto.

Saludos y gracias a todos.
« Última modificación: 30-11-2012, 16:31 (Viernes) por phullock »

//FINAL Y MÁS DOS RESPUESTAS