Autor Tema: Antenas USB RT3572 y openwrt  (Leído 6658 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1889
Antenas USB RT3572 y openwrt
« en: 06-06-2014, 22:21 (Viernes) »
     Si no te funciona bien una antena con chipset RT3x7x, ésta puede ser la solución:

Me he encontrado con problemas a la hora de echar a andar un pincho USB con chipset RT3572 y la compilación Barrier Breaker 14.04. El problema puede presentarse también en la rama trunk de openwrt, aunque no lo he probado.
No había forma de que el router pusiera la antena en modo master en las modos a y a+n. Tampoco tenía la banda de los 5GHz ni sus respectivos canales.

He conseguido solucionar todo el tema bajando el firmware de la antena directamente de la web de mediatek : http://www.mediatek.com/en/downloads/firmware-rt28xxrt30xx-usb-series-rt2870rt2770rt3572rt3070/
El firmware rt2870.bin hay que ponerlo en /lib/firmware sobreescribiendo el anterior.
El firmware que instala la compilación de openwrt por lo visto da problemas. He hecho una comparación binaria de ambos firmwares y hay multitud de diferencias, así que no son el mismo fichero.

Ahora ya reconoce la banda de los 5GHz y los modos a y a+n, y va a todo trapo.
Se la he pinchado a un router VH4032N y por ahora estoy realizando pruebas, pero parece que va bien.

Espero que si alguien se encuentra con problemas de esta clase, esto le sirva de algo.


No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

Pteridium

  • Visitante
Re: Antenas USB RT3572 y openwrt
« Respuesta #1 en: 06-06-2014, 22:51 (Viernes) »
¡Qué gran hallazgo!  >:( >:( >:(
Y fijo que se puede aplicar a otros drivers.

barriteleves

  • Visitante
Re: Antenas USB RT3572 y openwrt
« Respuesta #2 en: 09-06-2014, 15:00 (Lunes) »
saludos compañero, tan solo una consulta este problema es el que tengo en el router ARV 7519  he probado tanto 5370 y un 3070 ninguno se deja maneja como master si como cliente. se puede probar en ese router sin causar daños???

Pteridium

  • Visitante
Re: Antenas USB RT3572 y openwrt
« Respuesta #3 en: 09-06-2014, 16:18 (Lunes) »
saludos compañero, tan solo una consulta este problema es el que tengo en el router ARV 7519  he probado tanto 5370 y un 3070 ninguno se deja maneja como master si como cliente. se puede probar en ese router sin causar daños???
¿Puedes repetir la pregunta?

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1889
Re: Antenas USB RT3572 y openwrt
« Respuesta #4 en: 09-06-2014, 16:24 (Lunes) »
saludos compañero, tan solo una consulta este problema es el que tengo en el router ARV 7519  he probado tanto 5370 y un 3070 ninguno se deja maneja como master si como cliente. se puede probar en ese router sin causar daños???

Baja el firmware adecuado para los chipsets que tengas. El procedimiento es el mismo. Si no quieres sobreescribir el firmware anterior, renómbralo.
En la configuración avanzada de la wifi, pónle el código de país. Tampoco te deja escoger canales en los 5Ghz si no se lo pones.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4580
Re: Antenas USB RT3572 y openwrt
« Respuesta #5 en: 10-06-2014, 08:29 (Martes) »
Tki2000, estaría bien si lo añadieras al [Índice] Hilos relevantes de OpenWrt

 >:(
Valoraciones positivas en compra/venta:
121 en Htcmania
126 en Har2mano
18 en elchapuzasinformatico
8 en gsmspain
 ....
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1889
Re: Antenas USB RT3572 y openwrt
« Respuesta #6 en: 10-06-2014, 09:14 (Martes) »
Tki2000, estaría bien si lo añadieras al [Índice] Hilos relevantes de OpenWrt

 >:(

Ahí está...  ;D
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4580
Re: Antenas USB RT3572 y openwrt
« Respuesta #7 en: 10-06-2014, 10:01 (Martes) »
Tki2000, estaría bien si lo añadieras al [Índice] Hilos relevantes de OpenWrt

 >:(

Ahí está...  ;D

Lo podía haber hecho yo, pero ... así te estrenabas editando hilos de referencia  ;)
Valoraciones positivas en compra/venta:
121 en Htcmania
126 en Har2mano
18 en elchapuzasinformatico
8 en gsmspain
 ....
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1889
Re: Antenas USB RT3572 y openwrt
« Respuesta #8 en: 11-06-2014, 11:17 (Miércoles) »
Una cosa que he observado con las últimas versiones de LuCi es que los escaneos de wifis a veces no los hace ni queriendo. Y a veces no sólo con wifis externas, sino con wifis internas. Es un problema cuya raíz no sé cuál es, pero he estado observando el comportamiento de luci bajo ciertas circunstancias y "creo" que he conseguido dar con un procedimiento que funciona "la mayoría" de las veces:

     1.- Pinchamos el pincho USB wifi
     2.- Nos aseguramos de que la wifi del pincho ESTA DESACTIVADA
     3.- Reiniciamos el router
     4.- Escaneamos wifis con luci.

Debiera funcionar el escaneo. Si no funciona, Activamos y Desactivamos la wifi y le damos otra vez al scan.

No sé por qué pero la wifi que hace el escaneo debe estar desactivada en luci.
Sin embargo por línea de comandos sí hace escaneos aunque la wifi esté activada con : iw wlan1 scan.

Evidentemente, si tenemos que desactivar la wifi, el acceso al router debe ser por cable si es la única wifi que tenemos.

Por ahora es lo mejor que he encontrado.  :-\

Sigo pensando que es debido al nombre de los interfaces. Cuando escaneo redes en LuCi con el procedimiento anterior veo en la consola serie
Código: [Seleccionar]
[  774.400000] IPv6: ADDRCONF(NETDEV_UP): tmp.radio1: link is not readylo que me da que pensar que está buscando nombres temporales de interfaces, pero sin embargo funciona.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.

barriteleves

  • Visitante
Re: Antenas USB RT3572 y openwrt
« Respuesta #9 en: 11-06-2014, 20:36 (Miércoles) »
hola compañero dice:


Una cosa que he observado con las últimas versiones de LuCi es que los escaneos de wifis a veces no los hace ni queriendo. Y a veces no sólo con wifis externas, sino con wifis internas. Es un problema cuya raíz no sé cuál es, pero he estado observando el comportamiento de luci bajo ciertas circunstancias y "creo" que he conseguido dar con un procedimiento que funciona "la mayoría" de las veces:

     1.- Pinchamos el pincho USB wifi
     2.- Nos aseguramos de que la wifi del pincho ESTA DESACTIVADA
     3.- Reiniciamos el router
     4.- Escaneamos wifis con luci.

Debiera funcionar el escaneo. Si no funciona, Activamos y Desactivamos la wifi y le damos otra vez al scan.

No sé por qué pero la wifi que hace el escaneo debe estar desactivada en luci.
Sin embargo por línea de comandos sí hace escaneos aunque la wifi esté activada con : iw wlan1 scan.

Evidentemente, si tenemos que desactivar la wifi, el acceso al router debe ser por cable si es la única wifi que tenemos.

Por ahora es lo mejor que he encontrado.  :-\

Sigo pensando que es debido al nombre de los interfaces. Cuando escaneo redes en LuCi con el procedimiento anterior veo en la consola serie
Código: [Seleccionar]
[  774.400000] IPv6: ADDRCONF(NETDEV_UP): tmp.radio1: link is not readylo que me da que pensar que está buscando nombres temporales de interfaces, pero sin embargo funciona.

pues tengo que decir que tienes toda la razon esto es el principal problema que me he encontrado a la hora de hacer pruebas con los dos drivers tango el que trae la imagen de Pteridium ( que tengo que agradecer es con el unico que me ha funcionado la wifi externa los dos de chips ralink que tengo) y con el drivers este ultimop que a ti te funciona yo no he conseguido que ni tan siquiera realizara el  scaneo. tambien comentar que lo estoy realizando en el router arv7519 como ya comente y pregunte si habia algun incoveniente al ser de distinta cpu l que tu estas utilizando. buen intentare hacer algo con lo que acabas de exponer aqui grs un saludo